icj-citation-graph / docs /snapshot-audit.json
Chulinz's picture
Publish release-20261005T012547Z: ICJ-only citations, graph-held update progress, versioned release kit
8f03655 verified
Raw History Blame Contribute Delete
10.4 kB
{
"source_id": "release-20261005T012547Z",
"queries": {
"node_counts": "MATCH (n) UNWIND labels(n) AS label RETURN label, count(*) AS n ORDER BY label",
"case_courts": "MATCH (c:Case) RETURN coalesce(c.court, 'ICJ') AS court, count(*) AS n ORDER BY court",
"document_layers": "MATCH (d:Document) RETURN d.layer AS layer, count(*) AS n ORDER BY layer",
"document_courts": "MATCH (d:Document)-[:IN_CASE]->(c:Case) RETURN coalesce(c.court, 'ICJ') AS court, count(*) AS n ORDER BY court",
"resolution_coverage": "MATCH (r:Resolution) RETURN r.organ AS organ, count(*) AS n, sum(CASE WHEN size(coalesce(r.text, '')) > 0 THEN 1 ELSE 0 END) AS with_text ORDER BY organ",
"relationships": "MATCH (a)-[r]->(b) RETURN labels(a) AS source, type(r) AS type, labels(b) AS target, count(*) AS n ORDER BY source, type, target",
"citing_layers": "MATCH (d:Document)-[r:CITES|CITES_CASE]->() RETURN d.layer AS layer, count(r) AS n ORDER BY layer",
"backlog": "MATCH (d:Document) WHERE d.layer = 'decision' RETURN count(d.un_scanned) AS un_scanned, count(d.ilc_scanned) AS ilc_scanned, count(d.treaty_scanned) AS treaty_scanned, count(d.tribunal_scanned) AS tribunal_scanned, sum(size(coalesce(d.pending_un, []))) AS pending_un, sum(size(coalesce(d.pending_ilc, []))) AS pending_ilc, sum(size(coalesce(d.pending_treaty, []))) AS pending_treaty, sum(size(coalesce(d.pending_tribunal, []))) AS pending_tribunal",
"title_vectors": "MATCH (c:Case) WITH count(c.name_embedding) AS cases MATCH (r:Resolution) RETURN cases, count(r.title_embedding) AS resolutions",
"indexes": "SHOW INDEXES YIELD name, type, labelsOrTypes, properties RETURN name, type, labelsOrTypes, properties ORDER BY name"
},
"results": {
"node_counts": [
{
"label": "Case",
"n": 571
},
{
"label": "Chunk",
"n": 1206400
},
{
"label": "Country",
"n": 112
},
{
"label": "Document",
"n": 6901
},
{
"label": "Instrument",
"n": 370
},
{
"label": "Judge",
"n": 220
},
{
"label": "Provision",
"n": 12375
},
{
"label": "ResChunk",
"n": 169622
},
{
"label": "Resolution",
"n": 20292
}
],
"case_courts": [
{
"court": "ECtHR",
"n": 46
},
{
"court": "HRC",
"n": 17
},
{
"court": "IACtHR",
"n": 10
},
{
"court": "ICC",
"n": 10
},
{
"court": "ICJ",
"n": 200
},
{
"court": "ICTR",
"n": 23
},
{
"court": "ICTY",
"n": 40
},
{
"court": "ITLOS",
"n": 13
},
{
"court": "IUSCT",
"n": 3
},
{
"court": "OTHER",
"n": 8
},
{
"court": "PCA",
"n": 27
},
{
"court": "PCIJ",
"n": 83
},
{
"court": "RIAA",
"n": 84
},
{
"court": "WTO",
"n": 7
}
],
"document_layers": [
{
"layer": "decision",
"n": 2407
},
{
"layer": "oral",
"n": 1875
},
{
"layer": "pleadings",
"n": 2114
},
{
"layer": null,
"n": 505
}
],
"document_courts": [
{
"court": "ECtHR",
"n": 46
},
{
"court": "HRC",
"n": 17
},
{
"court": "IACtHR",
"n": 10
},
{
"court": "ICC",
"n": 10
},
{
"court": "ICJ",
"n": 6396
},
{
"court": "ICTR",
"n": 23
},
{
"court": "ICTY",
"n": 41
},
{
"court": "ITLOS",
"n": 13
},
{
"court": "IUSCT",
"n": 3
},
{
"court": "OTHER",
"n": 8
},
{
"court": "PCA",
"n": 27
},
{
"court": "PCIJ",
"n": 208
},
{
"court": "RIAA",
"n": 92
},
{
"court": "WTO",
"n": 7
}
],
"resolution_coverage": [
{
"organ": "GA",
"n": 17464,
"with_text": 17464
},
{
"organ": "SC",
"n": 2828,
"with_text": 2828
}
],
"relationships": [
{
"source": [
"Chunk"
],
"type": "PART_OF",
"target": [
"Document"
],
"n": 1206400
},
{
"source": [
"Document"
],
"type": "APPLICANT",
"target": [
"Country"
],
"n": 577
},
{
"source": [
"Document"
],
"type": "CITES",
"target": [
"Instrument"
],
"n": 14763
},
{
"source": [
"Document"
],
"type": "CITES",
"target": [
"Provision"
],
"n": 10905
},
{
"source": [
"Document"
],
"type": "CITES",
"target": [
"Resolution"
],
"n": 1748
},
{
"source": [
"Document"
],
"type": "CITES_CASE",
"target": [
"Case"
],
"n": 7450
},
{
"source": [
"Document"
],
"type": "IN_CASE",
"target": [
"Case"
],
"n": 6901
},
{
"source": [
"Document"
],
"type": "RESPONDENT",
"target": [
"Country"
],
"n": 586
},
{
"source": [
"Document"
],
"type": "SAT_ON",
"target": [
"Judge"
],
"n": 5288
},
{
"source": [
"Provision"
],
"type": "CITES",
"target": [
"Provision"
],
"n": 242
},
{
"source": [
"Provision"
],
"type": "PART_OF",
"target": [
"Instrument"
],
"n": 12375
},
{
"source": [
"ResChunk"
],
"type": "PART_OF",
"target": [
"Resolution"
],
"n": 169622
},
{
"source": [
"Resolution"
],
"type": "CITES",
"target": [
"Resolution"
],
"n": 53111
}
],
"citing_layers": [
{
"layer": "decision",
"n": 26992
},
{
"layer": "oral",
"n": 2508
},
{
"layer": "pleadings",
"n": 5366
}
],
"backlog": [
{
"un_scanned": 2407,
"ilc_scanned": 2407,
"treaty_scanned": 2407,
"tribunal_scanned": 2407,
"pending_un": 0,
"pending_ilc": 0,
"pending_treaty": 5450,
"pending_tribunal": 102
}
],
"title_vectors": [
{
"cases": 427,
"resolutions": 17650
}
],
"indexes": [
{
"name": "case_id",
"type": "RANGE",
"labelsOrTypes": [
"Case"
],
"properties": [
"case_id"
]
},
{
"name": "case_name_embedding",
"type": "VECTOR",
"labelsOrTypes": [
"Case"
],
"properties": [
"name_embedding"
]
},
{
"name": "chunk_embedding",
"type": "VECTOR",
"labelsOrTypes": [
"Chunk"
],
"properties": [
"embedding"
]
},
{
"name": "chunk_id",
"type": "RANGE",
"labelsOrTypes": [
"Chunk"
],
"properties": [
"id"
]
},
{
"name": "country_name",
"type": "RANGE",
"labelsOrTypes": [
"Country"
],
"properties": [
"name"
]
},
{
"name": "doc_id",
"type": "RANGE",
"labelsOrTypes": [
"Document"
],
"properties": [
"id"
]
},
{
"name": "index_343aff4e",
"type": "LOOKUP",
"labelsOrTypes": null,
"properties": null
},
{
"name": "index_f7700477",
"type": "LOOKUP",
"labelsOrTypes": null,
"properties": null
},
{
"name": "inst_name",
"type": "RANGE",
"labelsOrTypes": [
"Instrument"
],
"properties": [
"name"
]
},
{
"name": "instrument_key",
"type": "RANGE",
"labelsOrTypes": [
"Instrument"
],
"properties": [
"key"
]
},
{
"name": "judge_name",
"type": "RANGE",
"labelsOrTypes": [
"Judge"
],
"properties": [
"name"
]
},
{
"name": "prov_key",
"type": "RANGE",
"labelsOrTypes": [
"Provision"
],
"properties": [
"key"
]
},
{
"name": "provision_embedding",
"type": "VECTOR",
"labelsOrTypes": [
"Provision"
],
"properties": [
"embedding"
]
},
{
"name": "res_chunk_embedding",
"type": "VECTOR",
"labelsOrTypes": [
"ResChunk"
],
"properties": [
"embedding"
]
},
{
"name": "res_chunk_id",
"type": "RANGE",
"labelsOrTypes": [
"ResChunk"
],
"properties": [
"id"
]
},
{
"name": "resolution_embedding",
"type": "VECTOR",
"labelsOrTypes": [
"Resolution"
],
"properties": [
"title_embedding"
]
},
{
"name": "resolution_symbol",
"type": "RANGE",
"labelsOrTypes": [
"Resolution"
],
"properties": [
"symbol"
]
}
]
}
}