hash
stringlengths
32
32
doc_id
stringlengths
7
13
section
stringlengths
3
121
content
stringlengths
0
2.2M
6e06e68f245f2bf3bd0d4ca07b2a95d9
103 407
8.4.2 /token response
If successful, the authorization provider shall generate a new access token for the client, and shall invalidate any existing token for that client for the given service provider domain. The authorization provider shall respond with HTTP status 200 and shall include the following information in a JSON object in the res...
6e06e68f245f2bf3bd0d4ca07b2a95d9
103 407
8.5 Verification endpoint
6e06e68f245f2bf3bd0d4ca07b2a95d9
103 407
8.5.1 Verification endpoint request
In response to an HTTP GET request to the verification endpoint, the authorization provider should authenticate the user's identity and ask the user to enter the user_code. How this verification process is managed is out of scope of the present document. For a device capable of presenting a web browser to the user (suc...
6e06e68f245f2bf3bd0d4ca07b2a95d9
103 407
8.5.2 User permission request
The resource at the verification_uri shall request permission from the user prior to associating a device even if the user is already signed in. This prevents a client from associating a user's account without their explicit consent.
6e06e68f245f2bf3bd0d4ca07b2a95d9
103 407
8.5.3 Redirection response
The redirection response shall have HTTP status 302 and shall include a result query parameter as described below. result The outcome of the user authentication and user permission request. This shall be one of the following values: • success - The user has been authenticated, and the association approved. • cancelled ...
6e06e68f245f2bf3bd0d4ca07b2a95d9
103 407
9 Service Provider/Authorization Provider API
6e06e68f245f2bf3bd0d4ca07b2a95d9
103 407
9.1 Overview
This clause defines the API offered by the authorization provider to the service provider. It consists of a single endpoint: • /authorized - Verify an access token and return client and user identities The access token verification endpoint /authorized allows the service provider to verify an access token with the auth...
6e06e68f245f2bf3bd0d4ca07b2a95d9
103 407
9.3 /authorized - Access token verification endpoint
6e06e68f245f2bf3bd0d4ca07b2a95d9
103 407
9.3.1 /authorized request
The service provider makes a HTTP POST request to the authorization provider's access token verification endpoint and shall include the following parameters in a JSON object in the request body: access_token The access token to verify. domain The domain name of the service provider (which may include a port number). To...
6e06e68f245f2bf3bd0d4ca07b2a95d9
103 407
9.3.2 /authorized response
If the access token belongs to a registered client, the authorization provider shall respond with HTTP status 200 and shall include the following information in a JSON object in the response body: client_id A string containing the unique identifier of the client who owns the given access token. ETSI ETSI TS 103 407 V1....
f3c9c9f0a5d00e88420ea6902915e91c
103 389
1 Scope
The present document defines the signalling and media interface between the Network Switching Subsystem and the Fixed Terminal Subsystem in order to provide a clear set of services needed for GSM-R operations. This includes voice call service and available call-related supplementary services. In addition, requirements ...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
2 References
f3c9c9f0a5d00e88420ea6902915e91c
103 389
2.1 Normative references
References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies. Referenced documents which a...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
2.2 Informative references
References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies. NOTE: While any hyperlinks i...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
3 Definition of terms, symbols and abbreviations
f3c9c9f0a5d00e88420ea6902915e91c
103 389
3.1 Terms
For the purposes of the present document, the terms given in IETF RFC 3261 [3] and the following apply: call: SIP Dialog between two Signalling Endpoints NOTE: Established for the purpose of a voice communication and related data exchange. client: any network element that sends SIP requests and receives SIP responses N...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
3.2 Symbols
Void.
f3c9c9f0a5d00e88420ea6902915e91c
103 389
3.3 Abbreviations
For the purposes of the present document, the following abbreviations apply: 3GPP 3rd Generation Partnership Program ACK ACKnowledgement AF Assured Forwarding AoCC Advice of Charge (Charging) AoCI Advice of Charge (Information) B2BUA Back to Back User Agent BAIC Barring of All Incoming Calls BAOC Barring of All Outgoin...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
4 Reference System Architecture
The system architecture used to identify the interface that is the subject of the present document is a simplification of a GSM-R system down to a minimum of logical entities relevant to the present document. Within the context of the present document a GSM-R system is logically divided into a GSM-R Network and a Fixed...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
5 Interface Functionality
f3c9c9f0a5d00e88420ea6902915e91c
103 389
5.0 General Description
This clause specifies functional requirements of the interface. The technical details are specified in clauses 6 and 7 of the present document.
f3c9c9f0a5d00e88420ea6902915e91c
103 389
5.1 Basic Call
f3c9c9f0a5d00e88420ea6902915e91c
103 389
5.1.0 Primary Function
The primary function to be delivered by the present interface is the means to initiate and tear down full duplex audio (voice) connections between the NSS and FTS with a single, logical, SIP Endpoint involved per connection on each side of the present interface that controls the connection as well as its respective Med...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
5.1.1 Progress Indication
Progress indication shall be provided via explicit signalling. In addition a progress tone generation policy, clearly stating which party shall generate which progress tones and when, is defined.
f3c9c9f0a5d00e88420ea6902915e91c
103 389
5.1.2 Early Media
Furthermore, the basic call procedure shall provide a means for media (i.e. audio) exchange prior to call setup completion. This shall be possible in the direction callee to caller only. This functionality is needed in order to provide pre-call announcements to the user before the dialog is established.
f3c9c9f0a5d00e88420ea6902915e91c
103 389
5.2 Connected Parties Identity Information
The calling party shall provide its identity information with the connection request. The calling party shall be informed about the identity of the remote party. The identity information shall contain a routable number in the underlying network's address space and in addition - if available - an EIRENE functional numbe...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
5.3 Call Hold
Both endpoints of an established call shall be able to suspend an associated media stream and resume it at a later time. The endpoint holding the call shall inform the other party that the call is suspended and shall further inform the other party when the call is reconnected. The media stream is not just interrupted, ...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
5.4 Multi Level Precedence and Pre-emption
In order to allow differentiated/preferred treatment of calls of different/higher operational priority (e.g. emergency calls) when facing resource limits, the interface shall support signalling mechanisms and procedures to provide multi-level precedence signalling and as well as call pre-emption functionality. Addition...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
5.5 Voice Group Call and Broadcast Call Control
Voice Group Calls [i.11] and Voice Broadcast Calls [i.12] are service implementations in the NSS. The interface subject to the present document shall provide mechanisms for the FTS to control voice group calls and voice broadcast calls from the perspective of Fixed Terminal users as defined by EIRENE [1]. Control of vo...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
5.6 User-User-Information-Element Transport
User-to-User-Information-Elements (UUIE) [i.2] are used in GSM-R systems to carry EIRENE specific information and are exchanged within basic call control messages. ETSI TS 102 610 [9] specifies in detail the use and content of UUIEs in GSM-R and also distinguishes between international and national EIRENE UUIE tags. Th...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
5.7 Reason Transport
In most currently deployed GSM-R systems fixed and mobile terminals make use of end-to-end release cause signalling. The present interface shall therefore support the transparent, end-to-end transport of release and disconnect reasons between the fixed terminals and GSM-R mobile terminals and vice versa.
f3c9c9f0a5d00e88420ea6902915e91c
103 389
5.8 Call Transfer Notification
In case a call is being transferred, it is important for the user to be notified that a call transfer has happened and about the new connected party. The present interface should therefore support the notification about call transfer and about the new connected party, as well in case of attended call transfer as in the...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
5.9 Conferencing
A user can turn a point to point call into a conference, whereas it is important for the participants to be notified about being a part of a conference. The indication of the conference established event should be conveyed via SIP signalling from the conference controller side of the dialog (either NSS or FTS) towards ...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
5.10 Call Forwarding
A call can be forwarded to another destination by an entity in the FTS or by an entity in the NSS. This can happen due to several reasons, e.g. unconditional call forwarding, call forwarding on subscriber busy and so on. The initiating message in forward direction should contain the information about the history of the...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
5.11 Call Waiting
The call waiting service can be implemented for called subscribers (callees), either in FTS or in NSS. However, if the calling subscriber (caller) is located in a different subsystem than the called subscriber (either NSS or FTS), then the backward notification about the call waiting service has to be transmitted via t...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6 Signalling Interface
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.1 Network Layer Protocol
NSS and FTS shall use IPv4 [2] as the network layer protocol. Network Address Translation (NAT) is a method used for IP address translation between address realms. NAT adds complexity to higher layer protocols that is not dealt with in the present document. Therefore no form of NAT shall be implemented in the network i...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.2 Transport Layer Protocol
NSS and FTS shall use UDP IETF RFC 768 [26] as the transport layer protocol. Network Address and Port Translation (NAPT) is a form of NAT that extends to the transport layer. For the same reason as for pure network layer NAT, NAPT shall not be implemented in the network infrastructure at the signalling interface. See I...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3 Signalling Protocol
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3.0 General Provisions
NSS and FTS shall support SIP in accordance with: • IETF RFC 3261 [3]; and SDP in accordance with: • IETF RFC 4566 [6]; and • IETF RFC 3264 [4]; as signalling protocols further qualified by statements in later clauses of the present document. Requirements for support of other IETF RFCs and other standards are as stated...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3.1 SIP Entities
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3.1.0 SIP networks
A SIP network can be composed of many logical SIP entities. Each entity provides specific functions and participates in SIP communication as a client (initiates requests), as a server (responds to requests), or as both. One physical entity can implement the functionality of more than one logical SIP entity. On the inte...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3.1.1 SIP User Agent
UAs initiate and terminate sessions by exchanging requests and responses. IETF RFC 3261 [3] defines a User Agent as a logical entity that can act both as User Agent Client and as User Agent Server. User Agent Client and User Agent Server are defined in IETF RFC 3261 [3]. In a SIP environment a SIP User Agent (UA) is a ...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3.1.2 SIP Proxy
A Proxy Server is defined in IETF RFC 3261 [3]. The deployment of SIP Proxy Servers on either side of the present interface is optional and subject to the FTS/NSS design. A typical application probably requiring the use of a SIP Proxy at the present interface may be a load balancing service in front of a number of Sign...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3.2 SIP Request Methods
Table 6.1 specifies the requests that shall be, may be, or shall not be, supported by the SIP entities on the present interface in order to provide the required interface functionality. The terms and abbreviations used in table 6.1 have the following meaning: • "Sending" means "initiating the method" • "Replying" means...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3.3 SIP Responses
Upon receiving a SIP request SIP entities reply to it with an appropriate SIP response, which depends on the type of request, the type of the receiving SIP entity and the request computing logic. All SIP entities implementing the present interface shall support sending, receiving and processing of all applicable respon...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3.4 SIP Header Fields
IETF RFC 3261 [3], IETF RFC 3262 [11], IETF RFC 3326 [8], IETF RFC 4412 [12], IETF RFC 3325 [13], IETF RFC 5876 [14], IETF RFC 3323 [15], IETF RFC 4028 [16], IETF RFC 3311 [17], IETF RFC 5009 [i.21], IETF RFC 6086 [i.3], IETF RFC 3891 [34], IETF RFC 4579 [33], IETF RFC 4244 [36] and IETF RFC 4458 [37] - all of them are...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3.5 SIP Bodies
SIP messages may, depending on the application and message type, contain one or more bodies to include information that is not encoded into SIP header fields. This clause specifies the relevant body or content types to be supported by interface implementers. The Session Description Protocol (IETF RFC 4566 [6]) shall be...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3.6 SIP URI Convention
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3.6.0 General provisions
GSM-R networks and other telephony networks address their subscribers and route calls based on numeric addresses and numeric addressing schemes. EIRENE [1] specifies such an addressing scheme for GSM-R telephony. Recommendation ITU-T E.164 [23] specifies such an addressing scheme for public telephony networks. In contr...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3.6.1 Display Name
The display name is defined in IETF RFC 3261 [3] as "not standardized optional text" preceding the SIP URI. A display name may be used at the present interface, but it shall be ignored by all involved SIP entities.
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3.6.2 User Part
The user part of the SIP URI at the present interface shall either contain: • an international EIRENE [1] number if a GSM-R number is addressed; or • an international Recommendation ITU-T E.164 [23] number consisting of a "+" and one or more digits if a PSTN, PLMN or PABX number is addressed.
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3.6.3 Host Part
According to the above definition of the SIP URI scheme used at the present interface, the host part is a fully qualified domain name or an IPv4 address as defined in IETF RFC 791 [2]. IETF RFC 3261 [3] defines an optional extension of the URI's host part with a service port. As this is not allowed at the present inter...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3.6.4 URI Parameters
The user parameter is mandatory within the SIP URI at the present interface. The "user" parameter at the present interface shall either be set to: • "gsmr" if an EIRENE GSM-R number is addressed; or • "phone" if a PSTN, PLMN or PABX number is addressed (compare IETF RFC 3261 [3], section 19.1.6). All other SIP URI para...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3.6.5 Use
The specified SIP URI scheme shall be applied to the Request URI and the URIs in the following header fields: • From • To • P-Asserted-Identity • Contact The general purpose and use of the From, To, and Contact header fields is defined in IETF RFC 3261 [3] and fully applies to the present interface. The purpose and use...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3.6.6 Examples
This clause illustrates how common use cases map to valid SIP URI combinations at the present interface. Table 6.6 shows an example where a GSM-R subscriber (049212345601) calls an FTS subscriber by its EIRENE functional number (04971234501). Table 6.6: Use of SIP URIs - Example NSS to FTS Header Field Request Response...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3.6.7 Public Emergency Numbers and Private Network Short Codes
For calls which address public emergency numbers at the present interface, the following SIP URI convention shall be used. SIP-URI = "sip:" short-code-user "@" host ;"user=phone" Where: short-code-user = "+" 1*DIGIT with country code followed by public emergency number or private network short codes host = hostname / I...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3.7 Option Tags
Option tags are used to identify to SIP Endpoints the required, supported or unsupported SIP options/extensions. Table 6.9 lists the option tags which shall be used accordingly at the NSS-FTS interface by all SIP entities. Table 6.9: Option tags Option Tag List in header field Reference 100rel Require, Supported IETF R...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.3.8 Feature Parameter
Feature parameters are used to identify capabilities of SIP UAs according to IETF RFC 3840 [30]. Table 6.10: Feature Parameter Feature Parameter List in header field Reference isfocus Contact IETF RFC 3840 [30] ETSI ETSI TS 103 389 V3.4.1 (2022-09) 28
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4 Interface Functionality to Signalling Interface Mapping
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.0 General
This clause specifies in detail all signalling procedures required to support the functionalities described in clause 5. As the SIP signalling framework and well known SIP extensions provide solutions to the major part of the requirements, this is being done by referencing applicable IETF RFCs. Deviations from and/or l...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.1 Basic Call
This clause defines the signalling mechanisms applicable for basic call handling at the present interface. The basic procedures for call setup, negotiation and establishment of an associated media session and call termination are defined in IETF RFC 3261 [3] and IETF RFC 3264 [4] and fully apply to the present interfac...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.2 Connected Parties Identity Information
SIP implicitly supports identity information exchange between connected parties with the header fields From and To as specified in IETF RFC 3261 [3]. These header fields, mandatory in all requests and responses, contain URIs according to the SIP URI convention in clause 6.3.6 of the present document. According to IETF ...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.3 Media Session Renegotiation and Call Hold
Media session renegotiation using the re-INVITE method as defined in IETF RFC 3261 [3] during an established dialog is allowed on the present interface and may be initiated by either side. NSS and FTS SIP Endpoints which send changes to negotiated media capabilities via SIP re-INVITE shall support section 14 "Modifying...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.4 Early Media
Media exchange prior to final call acceptance or rejection is referred to as early media. At the present interface only uni-directional, reverse early media shall be supported for the purpose of delivery of in-band announcements to a caller when available and required. It is the responsibility of the called subsystem, ...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.5 Multi Level Precedence and Pre-emption
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.5.0 General Provisions
The MLPP [24] service in EIRENE [1] and at the present interface shall be used to give precedence to higher priority calls over lower priority calls. In order to ensure a deterministic quality of service a Signalling Endpoint at the present interface shall be able to either block further resource consumption by incomin...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.5.1 Resource Priority
The Resource-Priority header field as specified in IETF RFC 4412 [12] shall be included in all INVITE requests between NSS and FTS to inform the partner about the operational and resource call priority. IETF RFC 4412 [12] defines several resource priority namespaces. At the present interface the Q735 namespace shall be...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.5.2 Reason Indication for Precedence and Pre-emption Events
In case of a pre-emption or precedence event the partner of the dialog shall be informed about the reason why the call has been terminated. For this purpose the Reason Header Field in accordance with IETF RFC 3326 [8] and described in clause 6.4.8 of the present document shall be used. The following reasons shall be su...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.5.3 Signalling Procedure for Precedence Call Blocking
Figure 6.6 shows one example of the signalling procedure for precedence call blocking. There may be several other situations where call blocking is performed. ETSI ETSI TS 103 389 V3.4.1 (2022-09) 37 NOTE: The Signalling and Media Endpoints are shown as one entity. This representation is used to enhance the readability...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.5.4 Signalling Procedure for Pre-emption
Figure 6.7 shows the signalling procedure for call pre-emption. NOTE: The Signalling and Media Endpoints are shown as one entity. This representation is used to enhance the readability of the diagrams and does not favour any physical implementation. Figure 6.7: Pre-emption of existing session NSS Signalling/ Media Endp...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.6 Group Call and Broadcast Call Control
Fixed Terminals shall use either DTMF tones to control VGCS/VBS calls at the present interface (as specified by EIRENE [1]) or explicit signalling on the Signalling Interface. DTMF handling at the present interface is specified in clause 7.4.1, explicit signalling is specified in clause 6.4.11. Clause 7.4.1 and IETF RF...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.7 User-to-User-Information-Element Transport
Following the approach of IETF RFC 7433 [i.1] a header field shall be used to transport the User-to-User information at the present interface. If User-to-User information needs to be attached to call control messages at the present interface, the header field User-to-User, as specified in IETF RFC 7433 [i.1], but follo...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.8 Release Cause Transport
The Reason Header Field as specified in IETF RFC 3326 [8] shall be used to transport Release Causes over the present interface. Such Release Causes are sent by the FTS or by the NSS in order to provide specific information about the reason for the release to GSM-R mobile terminals and Fixed Terminals. ETSI ETSI TS 103 ...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.9 SIP Session Timer
SIP [3] does not define a keep alive mechanism for the sessions it establishes. For instance, when a Signalling Endpoint fails to send a BYE message at the end of a session or the BYE message gets lost due to network problems, the other Signalling Endpoint or possibly a dialog stateful proxy will not know that the sess...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.10 OPTIONS Processing
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.10.0 General Provisions
The SIP OPTIONS method allows SIP peers to query each other for capabilities. The syntax of the OPTIONS message is described in IETF RFC 3261 [3]. NSS Signalling/ Media Endpoint FTS Signalling/ Media Endpoint 1. INVITE 6. ACK 2. 180 Ringing 10. BYE Both way RTP media 5. 200 OK (INVITE) 8. 200 OK 7. re-INVITE or UPDATE ...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.10.1 OPTIONS Heartbeating
To enhance the efficiency and robustness of the present interface, the SIP Endpoints should have knowledge of the status of their partner entities. To prevent unnecessary delay due to timeouts and subsequent message re-transmissions, a method by which each entity may discover the operational status of its communicating...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.11 Signalling for Group Call and Broadcast Call Control
The SIP INFO method shall be utilized to control group calls and broadcast calls. The SIP INFO method shall be used to send mute, un-mute or kill commands. Table 6.12 shows the extensions of the SIP message body with specific add-ons to exchange the group call and broadcast control commands. ETSI ETSI TS 103 389 V3.4.1...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.12 Call Transfer Notification
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.12.1 Procedures for Call Transfer Notification
The specification of the call transfer notification procedure for FTS-NSS interface depends on the usage of a 3rd party call control for controlling Explicit Call Transfer. NSS Signalling/ Media Endpoint FTS Signalling/ Media Endpoint 3. INFO Method=VGCS-Control action=kill Bi-directional RTP 5. BYE 1. INFO Method=VGCS...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.12.2 Call Transfer Notification Normal Procedure
The INVITE method shall be used together with a contained P-Asserted-Identity header (IETF RFC 3325 [13]) to indicate the call transfer event and the new connected party to the peer SIP UA via the present interface. This shall be valid for confirmed dialogs (necessary for un-attended or attended call transfers). Each i...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.12.3.2 Call Transfer Notification to Transfer Target in Alerting State
The transferor establishes an early dialog with the transfer target. When the transferor performs an explicit call transfer in alerting state, the transferor triggers 3rd party call control to establish a dialog with the transfer target. This INVITE request contains a Replaces header field to request the transfer targe...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.12.3.3 Call Transfer Notification to Transfer Target in Connected State
The transferor has an active session with the transfer target. When the transferor performs an explicit call, it triggers 3rd party call control to establish a dialog with the transfer target. This INVITE request containing a Replaces header field to request the transfer target to replace the existing dialog and SDP of...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.13 Conferencing
The isfocus feature tag (defined in IETF RFC 3840 [30]) shall be used in the Contact header to indicate the conference established condition to the peer SIP UA via the present interface. The isfocus feature tag shall be included in every transmitted Contact header as long as the conference established condition is true...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.14 Call Forwarding
The History-Info header shall be used in initial INVITE requests to indicate the history of the call. This shall be done according to IETF RFC 4244 [36]. A cause-param URI parameter shall be used according to IETF RFC 4458 [37] to indicate the reasons of call forwarding in the entries of the History-Info header. The Hi...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
6.4.15 Call Waiting
The Alert-Info header (defined in IETF RFC 3261 [3]) shall be used on the present interface in the 180 Ringing response, to indicate the call waiting service has been applied downstream the call. The Alert-Info header shall be set to the fixed value "urn:alert:service:call-waiting" for this purpose (the coding shall be...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
7 Media Interface
f3c9c9f0a5d00e88420ea6902915e91c
103 389
7.1 Network Layer Protocol
NSS and FTS shall use IPv4 [2] as the network layer protocol. Network Address Translation (NAT) is a method used for IP address translation between address realms. NAT adds complexity to higher layer protocols that is not dealt with in the present document. Therefore no form of NAT shall be implemented in the network i...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
7.2 Transport Layer Protocol
NSS and FTS shall use UDP [26] as the transport layer protocol. Network Address and Port Translation (NAPT) is a form of NAT that extends to the OSI transport layer. For the same reason as for pure network layer NAT, NAPT shall not be implemented in the network infrastructure at the media interface. See IETF RFC 2663 [...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
7.3 Real-Time Transport Protocol
f3c9c9f0a5d00e88420ea6902915e91c
103 389
7.3.0 General Provisions
A Media Endpoint shall transport and receive voice samples and telephony events using the Real-Time Transport Protocol (RTP) as described in IETF RFC 3550 [7]. At the present interface only uni-cast RTP streams shall be supported. ETSI ETSI TS 103 389 V3.4.1 (2022-09) 56
f3c9c9f0a5d00e88420ea6902915e91c
103 389
7.3.1 Media inactivity detection
At the present interface the reception of RTP packets is supervised. For this purpose, a media inactivity timer shall be used. If no RTP packets are received for an established session the media inactivity timer shall be started. The media inactivity timer shall be reset if RTP packets are received again for an establi...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
7.4 Media Codecs
f3c9c9f0a5d00e88420ea6902915e91c
103 389
7.4.0 General Provisions
Recommendation ITU-T G.711 [27] µ-Law and A-Law PCM codecs with a packetization rate of 20 ms shall be supported between the Media Endpoints at the present interface as shown in table 7.1. Additional packetization rates may be negotiated by SDP offer/answer model. Table 7.1: Media codecs and recommended packetization r...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
7.4.1 DTMF
DTMF as specified in IETF RFC 4733 [5] shall be supported at the present interface. Each Media Endpoint shall use the procedures according to IETF RFC 4733 [5] to transmit DTMF tones using the RTP telephone-event payload format. NSS and FTS Signalling Endpoints shall advertise support for receiving DTMF in every SDP of...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
8 Recorder Interface
f3c9c9f0a5d00e88420ea6902915e91c
103 389
8.1 Reference Architecture
The system architecture used to identify the interface that is the subject of this clause is a simplification of a GSM-R Recording system down to a minimum of logical entities relevant to the present document. Within this context the GSM-R recording system is logically divided into a GSM-R network and a Recorder Subsys...
f3c9c9f0a5d00e88420ea6902915e91c
103 389
8.2 Interface Functionality
f3c9c9f0a5d00e88420ea6902915e91c
103 389
8.2.0 General
This clause specifies functional requirements of the recording interface. The technical details are specified in clauses 7, 8.3 and 8.4 of the present document.