hash
stringlengths
32
32
doc_id
stringlengths
7
13
section
stringlengths
3
121
content
stringlengths
0
2.2M
7adb0e514db56f2b9504192e0018f063
103 221-2
5.3.15 Source Port
If used, this conditional attribute shall contain the source TCP/UDP port related to the Payload field given as a 16-bit unsigned integer in network byte order.
7adb0e514db56f2b9504192e0018f063
103 221-2
5.3.16 Destination Port
If used, this conditional attribute shall contain the destination TCP/UDP port related to the Payload field given as a 16-bit unsigned integer in network byte order.
7adb0e514db56f2b9504192e0018f063
103 221-2
5.3.17 IP Protocol
If used, this conditional attribute shall contain the IP protocol related to the Payload field given as an 8-bit unsigned integer, as assigned by IANA [22].
7adb0e514db56f2b9504192e0018f063
103 221-2
5.3.18 Matched Target Identifier
If used, this conditional attribute shall contain a target identifier that the POI matched against the payload and lead to the interception of this Payload field. This conditional attribute shall be given as a TargetIdentifier as defined in ETSI TS 103 221-1 [1], clause 6.2.1.2, table 6.2.1.2-2, as the contents of the ...
7adb0e514db56f2b9504192e0018f063
103 221-2
5.3.19 Other Target Identifier
If used, this conditional attribute shall contain another target identifier that is known to the POI. This conditional attribute shall be given using the same format as the Matched Target Identifier conditional attribute (see clause 5.3.18). Multiple occurrences of this conditional attribute are permitted.
7adb0e514db56f2b9504192e0018f063
103 221-2
5.3.20 MIME Content Type
This conditional attribute is intended for use with the MIME Message payload format (see clause 5.4.16). If used, this conditional attribute shall contain the MIME Content-Type of the data in the Payload field according to IETF RFC 2045 [21], clause 5. ETSI ETSI TS 103 221-2 V1.10.1 (2026-03) 18
7adb0e514db56f2b9504192e0018f063
103 221-2
5.3.21 MIME Content Transfer Encoding
This conditional attribute is intended for use with the MIME Message payload format (see clause 5.4.14). If used, this conditional attribute shall contain the MIME Content-Transfer-Encoding of the data in the Payload field according to IETF RFC 2045 [21], clause 6.
7adb0e514db56f2b9504192e0018f063
103 221-2
5.3.22 Additional XID Related Information (AXRI)
The Additional XID Related Information (AXRI) conditional attribute is intended for use when the POI sends a PDU with a Payload field which is the result of data intercepted due to more than one X1 XID or X1 ProductID (if present) as result of several X1 task activations and to be sent to the same destination. This con...
7adb0e514db56f2b9504192e0018f063
103 221-2
5.3.23 SDP Session Description
If used, this conditional attribute shall contain an SDP Session Description as described in IETF RFC 4566 [25] section 5, encoded as UTF-8. The SDP Session Description shall describe the RTP media stream contained within the Payload field of this PDU, and any subsequent PDU with the same XID and CorrelationID until an...
7adb0e514db56f2b9504192e0018f063
103 221-2
5.4 Payload
7adb0e514db56f2b9504192e0018f063
103 221-2
5.4.1 Overview
The POI shall populate the Payload field with intercepted data, given in the format specified by the Payload Format field (see clause 5.2.5). Table 5.4.1-1 defines the set of permissible Payload Formats and whether each is permitted for use in X2 or X3 PDUs. ETSI ETSI TS 103 221-2 V1.10.1 (2026-03) 19 Table 5.4.1-1: Pa...
7adb0e514db56f2b9504192e0018f063
103 221-2
5.4.2 ETSI TS 102 232-1 Defined Payload
If this payload format is specified, the Payload field shall contain data specified and encoded by ETSI TS 102 232-1 [2].
7adb0e514db56f2b9504192e0018f063
103 221-2
5.4.3 3GPP TS 33.128 Defined Payload
If this payload format is specified, the Payload field shall contain data specified and encoded according to 3GPP TS 33.128 [20].
7adb0e514db56f2b9504192e0018f063
103 221-2
5.4.4 3GPP TS 33.108 Defined Payload
If this payload format is specified, the Payload field shall contain data specified and encoded according to 3GPP TS 33.108 [15].
7adb0e514db56f2b9504192e0018f063
103 221-2
5.4.5 Proprietary Payload
If this payload format is specified, the Payload field shall contain data encoded as described in table 5.4.5-1. Table 5.4.5-1: Proprietary Payload Structure Field Name Description Format Payload Owner Length Indicates the length of the Payload Owner field. 8-bit unsigned integer Payload Owner FQDN indicating the organ...
7adb0e514db56f2b9504192e0018f063
103 221-2
5.4.6 IPv4 Packet
If this payload format is specified, the Payload field shall contain an IPv4 packet encoded as per IETF RFC 791 [4].
7adb0e514db56f2b9504192e0018f063
103 221-2
5.4.7 IPv6 Packet
If this payload format is specified, the Payload field shall contain an IPv6 packet encoded as per IETF RFC 8200 [5].
7adb0e514db56f2b9504192e0018f063
103 221-2
5.4.8 Ethernet Frame
If this payload format is specified, the Payload field shall contain an ethernet frame encoded as per IEEE 802.3 [6].
7adb0e514db56f2b9504192e0018f063
103 221-2
5.4.9 RTP Packet
If this payload format is specified, the Payload field shall contain an RTP packet encoded as per "RTP packet" definition in clause 3 of IETF RFC 3550 [7], without any IP/UDP encapsulation. Use of this payload format is discouraged for new implementations - handing over RTP with IP encapsulation using the IPv4 Packet o...
7adb0e514db56f2b9504192e0018f063
103 221-2
5.4.10 SIP Message
If this payload format is specified, the Payload field shall contain a SIP message encoded as per clause 7 in IETF RFC 3261 [8], without any IP/UDP encapsulation. NOTE: For implementations intending to support compliance with ETSI TS 102 232-5 [i.2], appropriate use of the Source IPv4 Address, Source IPv6 Address, Dest...
7adb0e514db56f2b9504192e0018f063
103 221-2
5.4.11 DHCP Message
If this payload format is specified, the Payload field shall contain a DHCP message encoded as per clause 5, figure 1 in IETF RFC 2131 [9], without any IP/UDP encapsulation.
7adb0e514db56f2b9504192e0018f063
103 221-2
5.4.12 RADIUS Packet
If this payload format is specified, the Payload field shall contain a RADIUS packet encoded as per IETF RFC 2865 [10], without any IP/UDP encapsulation.
7adb0e514db56f2b9504192e0018f063
103 221-2
5.4.13 GTP-U Message
If this payload format is specified, the Payload field shall contain a GTP Message encoded as per clause 7 in 3GPP TS 29.281 [11], without any IP/UDP encapsulation.
7adb0e514db56f2b9504192e0018f063
103 221-2
5.4.14 MSRP Message
If this payload format is specified, the Payload field shall contain an MSRP Message encoded as per IETF RFC 4975 [17], clause 5.1, without any IP/UDP/SIP encapsulation.
7adb0e514db56f2b9504192e0018f063
103 221-2
5.4.15 3GPP TS 33.108 EpsIRIContent
If this payload format is specified, the Payload field shall contain a BER-encoded EpsHI2Operations.EpsIRIContent structure as defined in 3GPP TS 33.108 [15], clauses 10.5 and B.9. Depending on the details of the implementation, compliance with 3GPP TS 33.128 [20], clauses 6.3.2.2 and 6.3.3.2 may also be required. ETSI...
7adb0e514db56f2b9504192e0018f063
103 221-2
5.4.16 MIME Message
If this payload format is specified, the Payload field shall contain a message encoded as per IETF RFC 2045 [21], clause 2.3. Unless otherwise specified by the relevant LI architecture, it is recommended that the MIME Content Type attribute (see clause 5.3.20) and, if appropriate, the MIME Content Transfer Encoding att...
7adb0e514db56f2b9504192e0018f063
103 221-2
5.4.17 3GPP Unstructured PDU
If this payload format is specified, the Payload field shall contain the octets of a PDU from either: • a PDU session of type "unstructured" as defined in 3GPP TS 23.501 [23], clauses 5.6.1 and 5.6.10.3; or • a PDN type of "non-IP" as defined in 3GPP TS 23.401 [24], clause 4.3.17.8.
7adb0e514db56f2b9504192e0018f063
103 221-2
5.4.18 ETSI TS 102 232-1 PS-PDU.Payload
If this payload format is specified, the Payload field shall contain a Payload structure as defined in the LI-PS-PDU ASN.1 module specified and encoded by ETSI TS 102 232-1 [2].
7adb0e514db56f2b9504192e0018f063
103 221-2
6 Transport
7adb0e514db56f2b9504192e0018f063
103 221-2
6.1 Summary
This clause provides transport profiles that may be used to transport encoded X2/X3 PDUs. The present document specifies a default profile, but further profiles may be defined in future or by the relevant LI architecture or SDO. Implementations shall support at least the default profile.
7adb0e514db56f2b9504192e0018f063
103 221-2
6.2 TLS Transport Profile
7adb0e514db56f2b9504192e0018f063
103 221-2
6.2.1 General
If using this profile to send X2/X3 PDUs to the MDF, the POI opens a TLS over TCP connection. TLS is used to perform mutual authentication and identification between the POI and MDF, and to provide confidentiality and integrity protection for X2/X3 PDUs. NOTE: Multiple TLS connections may be used subject to local agree...
7adb0e514db56f2b9504192e0018f063
103 221-2
6.2.2 Profile
POIs and MDFs shall support TLS, using at least version 1.2 as defined in IETF RFC 5246 [12], supporting the recommendations given in IETF RFC 7525 [13]. Implementations are encouraged to support best practice e.g. the guidance given in OWASP TLS Cheat Sheet [i.1], section 2.6. New implementations should support TLS 1....
7adb0e514db56f2b9504192e0018f063
103 221-2
6.2.3 Authentication
Implementations shall perform mutual authentication using client and server X.509 certificates following IETF RFC 6125 [14]. ETSI ETSI TS 103 221-2 V1.10.1 (2026-03) 22
7adb0e514db56f2b9504192e0018f063
103 221-2
6.2.4 Keepalive mechanism for reliability
The Keepalive and Keepalive Acknowledgement PDU type shall be supported by POIs and MDFs. This profile enables the use of this mechanism. It is intended as a means for the POI application to verify that the MDF application is still operational, and to disconnect the connection if the MDF is not. The POI shall send out ...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
1 Scope
The present document defines an electronic interface for the exchange of information relating to the establishment and management of Lawful Interception. Typically, this interface would be used between a central LI administration function and the network internal interception points. Typical reference models for LI def...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
2 References
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
2.1 Normative references
References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies. Referenced documents which a...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
2.2 Informative references
References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies. NOTE: While any hyperlinks i...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
3 Definition of terms, symbols and abbreviations
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
3.1 Terms
For the purposes of the present document, the following terms apply: destination: point to which xIRI and/or xCC is delivered by the NE Destination IDentifier (DID): identifier to uniquely identify a Destination internally to the X1 interface Destination Set: collection of DIDs and their associated preference of use De...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
3.2 Symbols
Void.
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
3.3 Abbreviations
For the purposes of the present document, the following abbreviations apply: ADMF ADMinistration Function AVP Attribute-Value Pair AXRI Additional XID Related Information CC Content of Communication CIDR Classless Inter Domain Routing CIN Communication Identity Number CSP Communication Service Provider DID Destination ...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
4 Overview
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
4.1 Reference model
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
4.1.1 Overview
The X1 interface is based on communication between two entities; the controlling function (e.g. a CSP ADMinistration Function (ADMF)), and the controlled function (e.g. a Network Element performing interception or mediation and delivery). The X1 reference model is shown in figure 4.1.1-1. Figure 4.1.1-1: X1 reference m...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
4.1.2 ADMF deployment model
Figure 4.1.2-1 shows a deployment model for X1 where a CSP ADMF uses X1 to provision a number of NEs to perform interception. ETSI ETSI TS 103 221-1 V1.23.1 (2026-03) 13 Figure 4.1.2-1: X1 Model for CSP ADMF Deployment Onward delivery of information from the NE is called X2 (for xIRI) and X3 (for xCC). X2 and X3 are de...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
4.1.3 Triggering deployment model
Figure 4.1.3-1 shows another possible deployment model for X1, where the X1 protocol is used to trigger interception in an NE present in a different network function. In this deployment model, the "Triggering Function" (TF) takes on the role of the ADMF in the previous deployment model, while the "Triggered Function" t...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
4.1.4 Mediation and delivery function deployment model
Figure 4.1.4-1 shows another possible deployment model for X1, where the X1 protocol is used to manage a CSP mediation and delivery function. In this deployment model, the MDF takes on the role of the NE in the previous deployment model. Figure 4.1.4-1: X1 deployment model for Mediation and Delivery Functions If this d...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
4.2 Reference model for X1: requesting and responding
X1 transactions consist of a request followed by a response. Requests may be sent in either direction i.e. with the ADMF or NE initiating the request. The side initiating the request is called the "Requester"; this term is used when it is not specified whether it is the ADMF or NE making the request. The other side is ...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
4.3 Overview of security
Security is based on creating public/private keys for the ADMF and each NE for which it is responsible. All transactions over X1 are performed using the security procedures in clause 8, which provide assurance that communication only takes place between an NE and ADMF which have been populated with the relevant key mat...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
4.4 Relationship to other standards
The present document forms part of a family of internal interface documents covering all of X0, X1, X2 and X3 which are handled as separate standards. Some models of LI (e.g. 3GPP TS 33.107 [1] and 3GPP TS 33.127 [22]) define interfaces for the purposes described in clause 4.1 (e.g. X1_1, X1_2 and X1_3 defined by 3GPP ...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
4.5 Release management
This clause describes the release management requirements. The requirements are: • The version of the present document is defined as <major>.<minor>.<patch>. • The major version should be incremented when making a backwards incompatible change. • The minor version should be incremented when adding backwards compatible ...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
5 Basic concepts
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
5.1 The lifecycle of a Task
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
5.1.1 Start and end of a Task
A Task relates to a single target identifier, and goes from the point an ActivateTask Request is sent by the ADMF to the time a DeactivateTask Request is sent by the ADMF, a "terminating fault" occurs, or (for Tasks with the "ImplicitDeactivationAllowed" flag set) the NE determines that it has completed. The present do...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
5.1.2 Identification of a Task
Each Task on X1 is uniquely identified by an X1 Identifier (XID) and it is handled independently of all others. The ADMF shall assign the XID as a version 4 UUID as per IETF RFC 4122 [2]. The ADMF is responsible for correlating the XID to any LI instance identifiers used to communicate with Law Enforcement. When used b...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
5.1.3 Destinations
Intercepted traffic is delivered by the NE to a Destination. Each Destination is uniquely identified by a Destination Identifier (DID), and is handled independently from details of the Task. DIDs can optionally be grouped with individual DID preference weightings as part of a Destination Set. Destination Sets specify a...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
5.1.4 Generic Objects
The NE may require supplementary information which is not described within the Task or Destination objects. Such information is contained within structures derived from a Generic Object, which may be managed via the messages defined in clause 6.8. Generic Object are defined in clause 6.8.1.2. This mechanism shall only ...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
5.2 The lifecycle of an X1 request/response
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
5.2.1 Identification of X1 request/response
Each request and response shall be identified by an X1TransactionID. The requester (may be ADMF or NE) shall assign an X1TransactionID as a version 4 UUID as per IETF RFC 4122 [2].
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
5.2.2 Responding to the request
The response shall be sent without undue delay and shall be sent within TIME1 of receiving the request. TIME1 shall be configurable and by default TIME1 shall be five seconds. TIME2, the time a requester waits for a response, shall be configurable, it shall be at least twice TIME1 and by default shall be fifteen second...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
5.2.3 Behaviour if a response is not received
If the requester has not received a response after TIME2 (as defined in clause 5.2.2), or if a status report on the completion of the whole request following an "OK - Acknowledge" has not been received in a timely fashion, the requester may assume that either the request or response failed to get through. For example, ...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
5.3 Warnings and Faults
The present document uses the term "error" to mean a protocol error within the X1 protocol as defined in clause 6.7. All other problems are categorized as warnings, alerts or faults: • Warnings are one-off problems i.e. sent by the NE and then not referred to again over X1. Warnings shall not be used for issues which a...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6 Message Structure and Data Definitions
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.1 X1 Message details
X1 messages contain information as defined in table 6.1-1 (the information is Mandatory, Optional or Conditional as shown in the last column). ETSI ETSI TS 103 221-1 V1.23.1 (2026-03) 18 Table 6.1-1: Message details Field Description Format Mandatory (M), Optional (O) or Conditional (C) ADMF Identifier Identifies the A...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.2 Message definitions: starting, modifying and stopping tasks
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.2.1 ActivateTask
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.2.1.1 Summary
DIRECTION: ADMF to NE. USAGE: Used by the ADMF to add a new Task to an NE. ETSI ETSI TS 103 221-1 V1.23.1 (2026-03) 19 Table 6.2.1.1-1: ActivateTaskRequest Field Description Format M/C/O TaskDetails Target and interception details See clause 6.2.1.2. M Table 6.2.1.1-2: ActivateTaskResponse Field Description Format M/C/...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.2.1.2 TaskDetails
The TaskDetails structure shall include the following. Table 6.2.1.2-1: TaskDetails Field Description Format M/C/O XID Uniquely identifies the Task. There may be more than one different Task relating to the same target identifier (two distinct XIDs). The X1 interface supports delivery for this situation (i.e. it is not...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.2.2 ModifyTask
DIRECTION: ADMF to NE. USAGE: Used by the ADMF to modify an existing Task on the NE. All details for the Task shall be given (i.e. the modified details and the information that is unchanged) to totally replace the previous Task details. Depending on the NE implementation, it may not be possible to modify some or all of...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.2.3 DeactivateTask
DIRECTION: ADMF to NE. USAGE: Used by the ADMF to deactivate (permanently stop and remove) a Task on the NE. There is no concept of suspension or temporary deactivation. To stop a Task "temporarily", ADMFs shall deactivate the Task and then activate a new Task. Table 6.2.3-1: DeactivateTaskRequest Field Description For...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.2.4 DeactivateAllTasks
DIRECTION: ADMF to NE. USAGE: If enabled, the DeactivateAllTasks command shall perform a "DeactivateTask" command for all Tasks on the NE. Table 6.2.4-1: DeactivateAllTasksRequest Field Description Format M/C/O There shall be no request parameters. Table 6.2.4-2: DeactivateAllTasksResponse Field Description Format M/C/...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.3.1 CreateDestination
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.3.1.1 Summary
DIRECTION: ADMF to NE. USAGE: Used by the ADMF to add a new Destination to the NE. Table 6.3.1.1-1: CreateDestinationRequest Field Description Format M/C/O Destination details Details of the new destination. See clause 6.3.1.2. M Table 6.3.1.1-2: CreateDestinationResponse Field Description Format M/C/O OK or Error The ...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.3.1.2 DestinationDetails
DestinationDetails relate to the delivery of information from the NE to a Destination. The DestinationDetails structure is defined as follows. Table 6.3.1.2-1: DestinationDetails Field Description Format M/C/O DID Destination Identifier which uniquely identifies the destination. UUIDv4 (see clause 5.1). M FriendlyName ...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.3.2 ModifyDestination
DIRECTION: ADMF to NE. USAGE: Used by the ADMF to modify an existing Destination on the NE. All details for the Destination shall be given (i.e. the modified details and the information that is unchanged) to totally replace the previous Destination details. Depending on the NE implementation, it may not be possible to ...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.3.3 RemoveDestination
DIRECTION: ADMF to NE. USAGE: Used by the ADMF to remove a Destination from the NE. A Destination may only be removed if it is not referenced by any Tasks or Destination Sets. An NE shall respond with an appropriate error if the ADMF attempts to remove a Destination that is referenced by a Task or Destination Set. Tabl...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.3.4 RemoveAllDestinations
DIRECTION: ADMF to NE. USAGE: To completely and permanently remove all Destinations on the NE. Table 6.3.4-1: RemoveAllDestinationsRequest Field Description Format M/C/O There shall be no message parameters. Table 6.3.4-2: RemoveAllDestinationsResponse Field Description Format M/C/O OK or Error The general errors in cl...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.4 Message details: getting information from NE
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.4.1 Overview
This clause defines messages for the ADMF to request status information from the NE. This is distinct from "Reporting Issues" where the NE pushes information to the ADMF (see clause 6.5). The following requests and responses shall be supported: • GetTaskDetails: to request details of a single Task. • GetDestinationDeta...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.4.2 GetTaskDetails
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.4.2.1 Summary
DIRECTION: ADMF to NE. USAGE: Used by the ADMF to retrieve the details of a particular Task. Table 6.4.2.1-1: GetTaskDetailsRequest Field Description Format M/C/O XID See clause 5.1. See clause 5.1. M Table 6.4.2.1-2: GetTaskDetailsResponse Field Description Format M/C/O TaskResponseDetails The Task details are as per ...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.4.2.2 TaskStatus
The TaskStatus contains information about a Task as collected internally by the NE. Table 6.4.2.2-1: TaskStatus Field Description Format M/C/O ProvisioningStatus Indicates whether the Task has been provisioned ("complete"), has failed to provision ("failed") or whether it is awaiting provisioning ("awaitingProvisioning...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.4.3 GetDestinationDetails
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.4.3.1 Summary
DIRECTION: ADMF to NE. USAGE: Used by the ADMF to retrieve the details of a particular Destination. Table 6.4.3.1-1: GetDestinationRequest Field Description Format M/C/O DID See clause 5.1. See clause 5.1. M Table 6.4.3.1-2: GetDestinationResponse Field Description Format M/C/O DestinationResponseDetails The destinatio...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.4.3.2 DestinationStatus
The DestinationStatus relates only to the status of the delivery Destination as seen by the NE. Table 6.4.3.2-1: DestinationStatus Field Description Format M/C/O DestinationStatus Status of Destination. Indicating whether the destination is active and working, or whether there is a delivery fault and traffic being lost...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.4.4 GetNEStatus
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.4.4.1 Summary
DIRECTION: ADMF to NE. USAGE: Used by the ADMF to determine the status of the NE. Table 6.4.4.1-1: GetNEStatusRequest Field Description Format M/C/O There shall be no request parameters. Table 6.4.4.1-2: GetNEStatusResponse Field Description Format M/C/O NEStatusDetails The NEStatusDetails for the NE. The NE Status sha...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.4.5 GetAllDetails
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.4.5.1 Summary
DIRECTION: The GetAllDetails command goes from ADMF to NE. USAGE: For the ADMF to determine the details of all Tasks, Destinations and the status of the NE itself. Table 6.4.5.1-1: GetAllDetailsRequest Field Description Format M/C/O There shall be no request parameters. ETSI ETSI TS 103 221-1 V1.23.1 (2026-03) 29 Table...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.4.6 ListAllDetails
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.4.6.1 Summary
DIRECTION: ADMF to NE. USAGE: Used by the ADMF to retrieve the list of all XIDs and DIDs (i.e. a list of identifiers) but no details. Table 6.4.6.1-1: ListAllDetailsRequest Field Description Format M/C/O There shall be no request parameters. Table 6.4.6.1-2: ListAllDetailsResponse Field Description Format M/C/O ListOfX...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.4.7 GetAllTaskDetails
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.4.7.1 Summary
DIRECTION: The GetAllTaskDetails command goes from ADMF to NE. USAGE: For the ADMF to determine the details of all Tasks. ETSI ETSI TS 103 221-1 V1.23.1 (2026-03) 30 Table 6.4.7.1-1: GetAllTaskDetailsRequest Field Description Format M/C/O There shall be no request parameters. Table 6.4.7.1-2: GetAllTaskDetailsResponse ...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.4.8 GetAllDestinationDetails
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.4.8.1 Summary
DIRECTION: The GetAllDestinationDetails command goes from ADMF to NE. USAGE: For the ADMF to determine the details of all Destinations. Table 6.4.8.1-1: GetAllDestinationDetailsRequest Field Description Format M/C/O There shall be no request parameters. Table 6.4.8.1-2: GetAllDestinationDetailsResponse Field Descriptio...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.4.9 GetAllGenericObjectDetails
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.4.9.1 Summary
DIRECTION: The GetAllGenericObjectDetails command goes from ADMF to NE. USAGE: For the ADMF to determine the details of all Generic Objects. Table 6.4.9.1-1: GetAllGenericObjectDetailsRequest Field Description Format M/C/O ObjectType If present, only the specific XSD type is required rather than the whole Generic Objec...
110c3f54a6d6c21aa1b5ed12398734d0
103 221-1
6.5 Message details: reporting issues from the NE