hash stringlengths 32 32 | doc_id stringlengths 7 13 | section stringlengths 3 121 | content stringlengths 0 2.2M |
|---|---|---|---|
f0c592daf024022db4705a3d366b0a5f | 103 158 | 6 Portable Part Test specification | This clause includes lists of the test groups relevant for a NG-DECT portable part. Test cases are ordered with network features followed by application features (ETSI TS 102 527-5 [6], clauses 6.4 and 6.9). Descriptions of new portable part tests specific to NG-DECT part 5 [6] start at clause 6.40. This leaves room fo... |
f0c592daf024022db4705a3d366b0a5f | 103 158 | 6.1 DPRS PT Procedures | TC_PT_DPRS.N.11_ BV_101 Terminal capability indication during location registration TC_PT_DPRS.N.11_ BV_101 Terminal capability indication during location registration Test purpose - Reference: ETSI TS 102 527-4 [5], clause 7.5.7, ETSI EN 300 175-5 [1], clause 7.7.41 Initial condition: T-00 IUT is registered to TS_1 Ti... |
f0c592daf024022db4705a3d366b0a5f | 103 158 | 6.2 NGLDS-N.1 General Light Data Service Procedures | TC_PT_NGLDS.N.1_BV_101 TC incoming voice call during preliminary exchanges of the SUOTA process TC_PT_NGLDS.N.1_BV_101 TC incoming voice call during preliminary exchanges of the SUOTA process Main test purpose: Test that PP can accept or ignore an incoming voice call during SUOTA C-plane commands exchange Reference: ET... |
f0c592daf024022db4705a3d366b0a5f | 103 158 | 6.3 NGLDS-N.2 Software upgrade over the air, C-plane | TC_PT_NGLDS.N.2_BV_101 C-Plane SUOTA exchange - new version is available-user interaction TC_PT_NGLDS.N.2_BV_101 C-Plane SUOTA exchange - new version is available - user interaction Test purpose Check C-plane exchange when a new software version is available. 1-User initiates the SUOTA connection 2-IUT sends Handset ve... |
f0c592daf024022db4705a3d366b0a5f | 103 158 | 6.4 NGLDS-A.1 Binary content download | TC_PT_NGLDS.A.1_BV_101 Simple BCD with Simplified single-context Interworking procedure (DPRS/B.8.4.3) - Connection setup with limited N.34 support TC_PT_NGLDS.A.1_BV_101 Simple BCD with Simplified single-context Interworking procedure (DPRS/B.8.4.3) - Connection setup with limited N.34 support Test purpose IUT initiat... |
f0c592daf024022db4705a3d366b0a5f | 103 158 | 6.5 NGLDS-A.2 Software upgrade over the air | TC_PT_NGLDS.A.2_BV_101(SWV, UI) Basic SUOTA - Single upgrade SUOTA - with or without user interaction (UI) TC_PT_NGLDS.A.2_BV_101(S WV, UI) Basic SUOTA - Single upgrade SUOTA with initial software version (SWV) - with or without user interaction (UI boolean) (parameterized test) Test purpose IUT performs a software upg... |
f0c592daf024022db4705a3d366b0a5f | 103 158 | 6.6 NGLDS-A.3 HTTP based applications | TC_PT_NGLDS.A.3_BV_108 (URLP) PP browses a simple test site using the Simple XHTML profile TC_PT_NGLDS.A.3_BV_108 (URLP) HTTP based application - PP browses a test site (at url URLP) using a DECT specific XHTML profile Main test purpose: Check IUT ability to access and display a XHTML site. Depending on the site pointe... |
f0c592daf024022db4705a3d366b0a5f | 103 158 | 7 Fixed Part Test specification | This clause includes lists of the test groups relevant for a NG-DECT fixed part. Test cases are ordered so that network features are followed by application features (ETSI TS 102 527-5 [6], clauses 6.4 and 6.9). The NG-DECT fixed part under test shall be connected to a network when running the tests suite. Descriptions... |
f0c592daf024022db4705a3d366b0a5f | 103 158 | 7.1 DPRS FT Procedures | TC_FT_DPRS.N.36_BV_101 Management - Broadcast attributes TC_FT_DPRS.N36_ BV_101 Management - Broadcast attributes Test purpose Verify mandatory capability bits set on the IUT Reference: ETSI TS 102 527-4 [5], clause 7.5.10 ETSI EN 300 175-5 [1], clause F.3 Initial condition: F-00 Time sequence: s1 [USR >> IUT] Open IUT... |
f0c592daf024022db4705a3d366b0a5f | 103 158 | 7.2 NGLDS-N.1 General Light Data Service Procedures | TC_FT_NGLDS.N.1_BV_101 TC incoming voice call during preliminary exchanges of the SUOTA process TC_FT_NGLDS.N.1_BV_101 TC incoming voice call during preliminary exchanges of the SUOTA process Main test purpose: Test that FP can present an incoming voice call to PP during SUOTA C-plane commands exchange 1- TS_1 initiate... |
f0c592daf024022db4705a3d366b0a5f | 103 158 | 7.3 NGLDS-N.2 Software upgrade over the air, C-plane | TC_FT_NGLDS.N2_BV_101(MSO, SUF) C Plane SUOTA exchange - New firmware is available TC_FT_NGLDS.N2_BV_101(MS O, SUF) C Plane SUOTA exchange - New firmware is available Test purpose Test that existing and new Handset versions are transmitted correctly. Test may be used either with tester supplier MS, or manufacturer MS, ... |
f0c592daf024022db4705a3d366b0a5f | 103 158 | 7.4 NGLDS-A.1 Binary content download | TC_FT_NGLDS.A.1_BV_101 Simple BCD with Simplified single-context Interworking procedure (DPRS/B.8.4.3) - Connection setup with limited N.34 support TC_FT_NGLDS.A.1_BV_10 1 Simple BCD with Simplified single-context Interworking procedure (DPRS/B.8.4.3) - Connection setup with limited N.34 support Test purpose Test the p... |
f0c592daf024022db4705a3d366b0a5f | 103 158 | 7.5 NGLDS-A.2 Software upgrade over the air | TC_FT_NGLDS.A.2_BV_103 Basic or enhanced SUOTA - Single upgrade SUOTA - Multiple file upgrade TC_FT_NGLDS.A.2_BV_10 3(MSO) Basic or enhanced SUOTA with MS from MSO origin - Single upgrade SUOTA - Multiple file upgrade (parameterized test) Test purpose Hypotheses: TS_1 simulates a single software upgrade (with no multip... |
f0c592daf024022db4705a3d366b0a5f | 103 158 | 7.6 NGLDS-A.3 HTTP based applications | TC_FT_NGLDS.A.3_BV_104(URLP) HTTP based application - TS_1 browses a test site (at url URLP) using a DECT specific XHTML profile TC_FT_NGLDS.A.3_BV_104 (URLP) HTTP based application - TS_1 browses a test site (at url URLP) using a DECT specific XHTML profile Main test purpose: Check IUT ability to forward requests to t... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 1 Scope | The present document is part of the IPCablecom suite of specifications. The document is based on MGCP 1.0 [1] an IETF Informational RFC. |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 2 References | References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the reference document (including any amendments) applies. Referenced documents which ar... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 2.1 Normative references | The following referenced documents are necessary for the application of the present document. [1] IETF RFC 3435: "Media Gateway Control Protocol (MGCP) Version 1.0", January 2003. [2] IETF RFC 1889: "RTP: A Transport Protocol for Real-Time Applications", January 1996. [3] IETF RFC 1890: "RTP Profile for Audio and Video... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 2.2 Informative references | The following referenced documents are not necessary for the application of the present document but they assist the user with regard to a particular subject area. [i.1] ETSI TS 102 836-1 (V1.1.1): "Access, Terminals, Transmission and Multiplexing (ATTM); Lawful Interception (LI); Part 1: Interception of IP Telephony S... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 3 Definitions and abbreviations | |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 3.1 Definitions | For the purposes of the present document, the following terms and definitions apply: authentication: process of verifying the claimed identity of an entity to another entity endpoint: terminal, gateway or Multipoint Conference Unit (MCU) gateway: devices bridging between the IPCablecom IP Voice Communication world and ... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 3.2 Abbreviations | For the purposes of the present document, the following abbreviations apply: AAD Average Acknowledgement Delay ABNF Augmented Backus-Naur Form AC Access Code ACM Accumulated Call Meter ANI Access Network Interface ANM Answer Message ANS Answer Tone API Application Program Interface AT Access Tandem ATM Asynchronous Tra... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 4 Void | |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 5 Technical Overview | The present document describes an IPCablecom profile of an application programming interface called a Media Gateway Control Interface (MGCI) and a corresponding protocol (MGCP) for controlling voice-over-IP (VoIP) PSTN Gateways from external call control elements. The MGCP assumes a call control architecture where the ... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 6 Introduction | The present document describes the TGCP profile of an application programming interface (MGCI) and a corresponding protocol (MGCP) for controlling trunking gateways from external call control elements. A trunking gateway is a network element that provides analogue, emulated analogue, or digital bearer and channel- asso... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 6.1 Relation with Other IPCablecom Standards | An IPCablecom PSTN Gateway consists of three functional components: • Media Gateway Controller (MGC), which contains the call intelligence and terminates call signalling. This component is also referred to as a Call Agent. • Media Gateway (MG), which terminates the bearer channels under the instruction and control of t... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 6.2 Relation to RFC 3435 and ABNF Grammar | RFC 3435 [1] includes a formal description of the MGCP protocol syntax following the "Augmented BNF for Syntax Specifications" [15]. This formal description is referenced by developers for the creation of interoperable devices. A copy of the MGCP protocol syntax, annotated and edited to indicate its applicability to IP... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7 Media Gateway Control Interface (MGCI) | MGCI functions provide for connection control, endpoint control, auditing, and status reporting. They each use the same system model and the same naming conventions. |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.1 Model and Naming Conventions | MGCP assumes a connection model where the basic constructs are endpoints and connections. Connections are grouped in calls. One or more connections can belong to one call. Connections and calls are set up at the initiative of one or several Media Gateway Controllers. It should be recognized that in none of these cases ... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.1.1 Endpoint Names | Endpoint names, also known as endpoint identifiers, have two components, both of which are defined to be case insensitive here: • the domain name of the gateway managing the endpoint, • a local endpoint name within that gateway. Endpoint names will be of the form: local-endpoint-name@domain-name where domain-name is an... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.1.1.1 Trunking Gateway Endpoint Names | Endpoints in trunking gateways must support the additional naming conventions specified in this clause. Trunking gateways will support the following basic endpoint-type: ds A DS-0 trunk The basic endpoint type is expected to be provisioned with additional information about the type of signalling supported on the trunk ... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.1.1.1.1 Trunk Circuit Endpoints | In addition to the naming conventions specified above, local endpoint names for PSTN trunking gateway endpoints of type "ds" must adhere to the following: • Local endpoint names will consist of a series of terms each separated by a slash ("/") that describe the physical hierarchy within the gateway: ds/<unit-type1>-<un... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.1.2 Call Names | Calls are identified by unique identifiers, independent of the underlying platforms or agents. Call identifiers are hexadecimal strings, which are created by the Media Gateway Controller. Call identifiers with a maximum length of 32 characters must be supported. At a minimum, call identifiers must be unique within the ... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.1.3 Connection Names | Connection identifiers are created by the gateway when it is requested to create a connection. They identify the connection within the context of an endpoint. Connection identifiers are treated in MGCP as hexadecimal strings. The gateway must ensure that a proper waiting period, at least three minutes, elapses between ... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.1.4 Names of Media Gateway Controllers and Other Entities | The Media Gateway Control Protocol has been designed for enhanced network reliability to allow implementation of redundant Media Gateway Controllers. This means that there is no fixed binding between entities and hardware platforms or network interfaces. Media Gateway Controller names consist of two parts, similar to e... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.1.5 Digit Maps | In MGCP, the Media Gateway Controller can ask the gateway to collect digits dialled by a user. This facility is typically used by analogue access lines with residential gateways to collect the numbers that a user dials, or it can be used for CAS PBX interfaces. Rather than sending each digit to the Media Gateway Contro... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.1.6 Events and Signals | The concept of events and signals is central to MGCP. A Media Gateway Controller may ask to be notified about certain events occurring in an endpoint, e.g. off-hook events. A Media Gateway Controller also may request certain signals to be applied to an endpoint, e.g. ringback. Events and signals are grouped in packages... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.2 SDP Use | The Media Gateway Controller uses the MGCP to provide the gateways with the description of connection parameters such as IP addresses, UDP port, and RTP profiles. Except where otherwise noted or implied in the present document, SDP descriptions must follow the conventions delineated in the session description protocol ... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.3 Gateway Control Functions | This clause describes the commands of the MGCP in the form of a remote procedure call (RPC) like API, which we will refer to as the media gateway control interface (MGCI). An MGCI function is defined for each MGCP command, where the MGCI function takes and returns the same parameters as the corresponding MGCP command. ... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.3.1 NotificationRequest | The NotificationRequest command is used to request the gateway to send a notification upon the occurrence of specified events in an endpoint. For example, a notification may be requested when tones associated with fax communication are detected on the endpoint. The entity receiving this notification, usually the Media ... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.3.2 Notifications | Notifications are sent via the Notify command by the gateway when an observed event is to be notified: ReturnCode ← Notify(EndpointId [, NotifiedEntity] , RequestIdentifier , ObservedEvents) EndpointId is the name for the endpoint in the gateway, which is issuing the Notify command, as defined in clause 7.1.1. The iden... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.3.3 CreateConnection | This command is used to create a connection. ReturnCode [, ConnectionId] [, SpecificEndPointId] [, LocalConnectionDescriptor] ← CreateConnection(CallId , EndpointId [, NotifiedEntity] [, LocalConnectionOptions] , Mode [, RemoteConnectionDescriptor] [, RequestedEvents] [, RequestIdentifier] [, SignalRequests] [, Quarant... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.3.4 ModifyConnection | This command is used to modify the characteristics of a gateway's "view" of a connection. This "view" of the call includes both the local connection descriptor, as well as the remote connection descriptor. [, LocalConnectionDescriptor] ← ModifyConnection(CallId , EndpointId , ConnectionId [, NotifiedEntity] [, LocalCon... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.3.5 DeleteConnection (From the Media Gateway Controller) | This command is used to terminate a connection. As a side effect, it collects statistics on the execution of the connection. ReturnCode [, Connection-parameters ] ← DeleteConnection(CallId , EndpointId , ConnectionId [, NotifiedEntity] [, RequestedEvents] [, RequestIdentifier] [, SignalRequests] [, QuarantineHandling] ... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.3.6 DeleteConnection (From the Trunking gateway) | In some circumstances, a gateway may have to clear a connection, for example, because it has lost the resource associated with the connection. The gateway can terminate the connection by using a variant of the DeleteConnection command: ReturnCode ← DeleteConnection(CallId, EndpointId, ConnectionId, Reason-code, Connect... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.3.8 Auditing | The MGCP is based upon a centralized call control architecture where a Media Gateway Controller acts as the remote controller of client devices that provide voice communications interfaces to users and networks. In order to achieve the same or higher levels of availability as the current PSTN, some protocols have imple... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.3.8.1 AuditEndPoint | The AuditEndPoint command can be used by the Media Gateway Controller to find out the status of a given endpoint. { ReturnCode [, EndPointIdList] [, NumEndPoints] } | { ReturnCode [, RequestedEvents] [, SignalRequests] [, RequestIdentifier] [, NotifiedEntity] [, ConnectionIdentifiers] [, DetectEvents] [, ObservedEvents... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.3.8.2 AuditConnection | Auditing of individual connections on an endpoint can be achieved using the AuditConnection command. ReturnCode [, CallId] [, NotifiedEntity] [, LocalConnectionOptions] [, Mode] [, RemoteConnectionDescriptor] [, LocalConnectionDescriptor] [, ConnectionParameters] ← AuditConnection(EndpointId , ConnectionId [, Requested... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.3.9 Restart in Progress | The RestartInProgress command is used by the gateway to signal that an endpoint, or a group of endpoints, is taken out of service or is being placed back in service. ReturnCode [, NotifiedEntity] [, VersionSupported] ← RestartInProgress(EndpointId , RestartMethod [, RestartDelay]) The EndpointId identifies the endpoint... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.4 States, Failover and Race Conditions | In order to implement proper call signalling, the Media Gateway Controller must keep track of the state of the endpoint, and the gateway must make sure that events are properly notified to the Media Gateway Controller. Special conditions may exist when the gateway or the Media Gateway Controller are restarted: the gate... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.4.1 Recaps and Highlights | As mentioned in clause 7.1.4, Media Gateway Controllers are identified by their domain name, and each endpoint has one, and only one, "notified entity" associated with it at any given point in time. In this clause the areas of special importance to reliability and failover in MGCP are recapped and highlighted: • A Medi... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.4.2 Retransmission and Detection of Lost Associations | The MGCP protocol is organized as a set of transactions, each of which is composed of a command and a response. The MGCP messages, being carried over UDP, may be subject to losses. In the absence of a timely response (see clause 8.4.4), commands are repeated. Gateways and Media Gateway Controllers must keep in memory a... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.4.3 Race Conditions | This clause describes how MGCP deals with race conditions. First of all, MGCP deals with race conditions through the notion of a "quarantine list" that quarantines events and through explicit detection of desynchronization, e.g. for mismatched seizure-state due to glare for an endpoint. Secondly, MGCP does not assume t... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.4.3.1 Quarantine list | MGCP controlled gateways will receive notification requests that ask them to watch for a list of events. The protocol elements that determine the handling of these events are the "Requested Events" list, and the "Detect Events" list. When the endpoint is initialized, the requested events list only consists of persisten... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.4.3.2 Explicit detection | A key element of the state of several endpoints is the seizure state of a circuit. Although seizure-state changing events are persistent in TGCP, race conditions and state mismatch may still occur, for example when a circuit is seized while the Media Gateway Controller is in the process of requesting the gateway to loo... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.4.3.3 Transactional Semantics | As the potential transaction completion times increases, e.g. due to external resource reservations, a careful definition of the transactional semantics becomes increasingly important. In particular the issue of race conditions, specifically as it relates to seizure-state must be defined carefully. ETSI ETSI TS 103 161... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.4.3.4 Ordering of commands and treatment of disorder | MGCP does not mandate that the underlying transport protocol guarantees the sequencing of commands sent to a gateway or an endpoint. This property tends to maximize the timeliness of actions, but it has a few drawbacks. For example: • Notify commands may be delayed and arrive to the Media Gateway Controller after the t... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.4.3.5 Fighting the restart avalanche | Suppose that a large number of gateways are powered on simultaneously. If they were to all initiate a RestartInProgress transaction, the Media Gateway Controller would very likely be swamped, leading to message losses and network congestion during the critical period of service restoration. In order to prevent such ava... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.4.3.6 Disconnected Endpoints | In addition to the restart procedure, trunking gateways also have a "disconnected" procedure, which is initiated when an endpoint becomes "disconnected" as described in clause 7.4.2. It should here be noted, that endpoints can only become disconnected when they attempt to communicate with the Media Gateway Controller. ... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.4.3.7 Call Agent Handling of Disconnected Endpoints | When an endpoint is in the "disconnected" state it may accumulate a large number of events in the quarantine buffer. Also, a "disconnected" endpoint may autonomously delete established connections (say the gateway reboots). Therefore, when connectivity between a "disconnected" endpoint and its Call Agent is subsequentl... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.5 Return Codes and Error Codes | All MGCP commands receive a response. The response carries a return code that indicates the status of the command. The return code is an integer number, for which five value ranges have been defined: • value 000 indicates a response acknowledgement, NOTE: Response acknowledgement is used for provisional responses (see ... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.6 Reason Codes | Reason-codes are used by the gateway when deleting a connection to inform the Media Gateway Controller about the reason for deleting the connection. The reason code is an integer number. Table 4 below lists the values that have been defined for the reason code. Table 4: Reason Codes Code Meaning 900 Endpoint malfunctio... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.7.1 RFC 2833 Negotiation | The internal list of supported codecs must include the telephone-event codec with events 0 to 15. This will ensure that RFC 2833 [22] DTMF relay will be used for the connection when authorized by the LCO (via inclusion or an empty a: parameter) and allowed by the RCD. An example of an LCO that authorizes RFC 2833 [22] ... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.7.2 Remote IP and Port Negotiation | The remote IP and port are provided via the Remote Connection Descriptor. Once obtained in a successful connection handling command (for example, a Modify Connection command), the endpoint must continue to use them until either a new Remote Connection Descriptor is provided which specifies a new remote IP or port, or t... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.7.3 LCO use when the FXR package is used without the VBD package | The FXR package enables fax calls to be supported in two different ways. The first one utilizes ITU-T Recommendation T.38 [24] using either UDPTL or TCP for fax relay under the control of the MGC. IPCablecom only supports UDPTL T38 and does not support TCP T38. The second way lets the gateway negotiate a method for fax... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.7.3.1 fxr/fx:gw | This results in image/t38 via udptl t38 not being used on the call. Other ways that should not be used by the MGC to request the same behaviour if the VBD package is not being used are: • fxr/fx:off • no fxr/fx in the LCO (this provides the default of gw) or any fxr/fx format where off is first followed by one or more ... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.7.3.2 fxr/fx:t38;off | This results in udptl t38 via image/t38 being used if the rcd has RFC 3407 [26] indication of udptl t38 capability, otherwise the fax is carried via audio codecs. Other ways that should not be used by the MGC to request the same behaviour if the VBD package is not being used are: • fxr/fx:t38;gw • fxr/fx:gw;t38 • fxr/f... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.7.3.3 fxr/fx:t38 | This results in udptl t38 via image/t38 being used if the rcd has RFC 3407 [26] indication of image/t38 capability and fax is detected. If rcd does not have an RFC 3407 [26] indication of image/t38, the connection request is to be nacked. |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.7.3.4 fxr/fx:t38-loose | This results in udptl t38 via image/t38 being used if fax is detected. Other ways that should not be used by the MGC to request the same behaviour if the VBD package is not being used are: • fxr/fx:gw;t38-loose • fxr/fx:t38-loose;off • fxr/fx:t38-loose;gw • fxr/fx:t38-loose;t38;off • fxr/fx:t38-loose;t38;gw;off • fxr/f... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.7.3.5 Other Options | Events used for fax/mode/text handling with FXR package that are permissible when the VBD package is not being used are: R: fxr/t38,L/ft,L/mt,L/tdd or R: fxr/t38,L/mt,L/tdd or R:L/ft,L/mt,L/tdd Table 4a couples the Recommended RequestedEvents with the fxr/fx LocalConnectionOption recommendations above. Table 4a fxr/fx ... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.7.4 LCO with FXR and VBD being used by MGC at same time | If the MGC uses both the VBD package and the FXR package, the use of V.152 for fax handling is being requested via the LCO. This means that if the FXR package is also used, the MGC can specify the following: • that fax/modem/text handling can be done via V.152 • that the use of udptl t38 is allowed (either strict or lo... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 7.7.5 LCO format for V.152 and 2198 Redundancy use | The MGC will specify in the LCO the payload to be used as V.152, the level of redundancy to be used with V.152 and the preference of the use of redundancy vs. non-redundant use of V.152. The MGC must map V.152 to either PCMU or PCMA. If the MGC wishes to authorize the use of PCMU or PCMA as voice and as V.152, it must ... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8 Media Gateway Control Protocol | The MGCP implements the media gateway control interface as a set of transactions. The transactions are composed of a command and a mandatory response. There are eight types of commands: • CreateConnection • ModifyConnection • DeleteConnection • NotificationRequest • Notify • AuditEndpoint • AuditConnection • RestartInP... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.1 General Description | All commands are composed of a Command header, which for some commands may be followed by a session description. All responses are composed of a Response header, which for some commands may be followed by a session description. Headers and session descriptions are encoded as a set of text lines, separated by a carriage... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2 Command Header | The command header is composed of: • A command line identifying the requested action or verb, the transaction identifier, the endpoint towards which the action is requested, and the MGCP protocol version. • A set of parameter lines composed of a parameter name followed by a parameter value. Unless otherwise noted or di... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.1 Command Line | The command line is composed of: • The name of the requested verb • The identification of the transaction • The name of the endpoint(s) that should execute the command (in notifications or restarts, the name of the endpoint(s) that is issuing the command) • The protocol version These four items are encoded as strings o... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.1.1 Requested Verb Coding | Requested verbs are encoded as four letter upper- and/or lower-case ASCII codes (comparisons must be case insensitive) as defined in table 5. Table 5: Requested Verbs Verb Code CreateConnection CRCX ModifyConnection MDCX DeleteConnection DLCX NotificationRequest RQNT Notify NTFY AuditEndpoint AUEP AuditConnection AUCX ... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.1.2 Transaction Identifiers | Transaction identifiers are used to correlate commands and responses. A trunking gateway supports two separate transaction identifier name spaces: • a transaction identifier name space for sending transactions; and ETSI ETSI TS 103 161-13 V1.1.1 (2011-10) 67 • a transaction identifier name space for receiving transacti... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.1.3 Endpoint, Media Gateway Controller and NotifiedEntity Name Coding | The endpoint names and Media Gateway Controller names are encoded as e-mail addresses, as defined in RFC 2821 [14]. In these addresses, the domain name identifies the system where the endpoint is attached, while the left side identifies a specific endpoint on that system. Both components must be case insensitive. Examp... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.1.4 Protocol Version Coding | The protocol version is coded as the keyword "MGCP" followed by a white space and the version number, which again is followed by the profile name "TGCP" and a profile version number. The version numbers are composed of a major version number, a dot, and a minor version number. The major and minor version numbers are co... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2 Parameter Lines | Parameter lines are composed of a parameter name, which in most cases is composed of a single upper-case character, followed by a colon, a white space, and the parameter value. Parameter names and values are still case-insensitive though. The parameters that can be present in commands are defined in table 7. Table 7: P... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2.1 Response Acknowledgement | The response acknowledgement parameter is used to support the three-way handshake described in clause 8.7. It contains a comma separated list of "confirmed transaction-id ranges". Each "confirmed transaction-id range" is composed of either one decimal number, when the range includes exactly one transaction, or two deci... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2.2 RequestIdentifier | The request identifier correlates a Notify command with the NotificationRequest (includes notification request embedded in connection handling primitives) that triggered it. A RequestIdentifier is a hexadecimal string; length must not exceed 32 characters. RequestIdentifiers are compared as strings rather than numerica... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2.3 Local Connection Options | The local connection options describe the operational parameters that the Media Gateway Controllers instructs the gateway to use for a connection. These parameters are: • The packetization period in milliseconds, encoded as the keyword "p" followed by a colon and a decimal number. • The multiple packetization period in... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2.4 Capabilities | Capabilities inform the Media Gateway Controller about its capabilities when audited. The encoding of capabilities is based on the Local Connection Options encoding for the parameters that are common to both. In addition, capabilities can also contain a list of supported packages, and a list of supported modes. The par... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2.5 Connection Parameters | Connection parameters are encoded as a string of type and value pairs, where the type is one of the codes in the table below, and the value a decimal integer. Types are separated from values by an "=" sign. Parameters are separated from each other by a comma. The connection parameter types are specified in table 9: Tab... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2.6 Reason Codes | Reason codes are three-digit numeric values. The reason code is optionally followed by a white space and commentary, e.g.: E: 900 Endpoint malfunctioning A list of reason-codes can be found in clause 7.6. ETSI ETSI TS 103 161-13 V1.1.1 (2011-10) 73 |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2.7 Connection Mode | The connection mode describes the connection's operation mode. The possible values are shown in table 10. Table 10: Connection Mode Values Mode Meaning M: sendonly The gateway should only send packets. M: recvonly The gateway should only receive packets. M: sendrecv The gateway should send and receive packets. M: inact... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2.8 Event/Signal Name Coding | Event/signal names are composed of an optional package name, separated by a slash (/) from the name of the actual event. The event name can optionally be followed by an at sign (@) and the identifier of a connection on which the event should be observed. Event names are used in the RequestedEvents, SignalRequests, Dete... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2.9 RequestedEvents | The RequestedEvents parameter provides the list of events that have been requested. The currently defined event codes are described in annex A. Each event can be qualified by a requested action, or by a list of actions. Not all actions can be combined - please refer to clause 7.3.1 for valid combinations. The actions, ... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2.10 SignalRequests | The SignalRequests parameter provides the name of the signals that have been requested. The currently defined signals can be found in annex A. A given signal can only appear once in the list, and all signals will, by definition, be applied at the same time. The MG must support, at a minimum, a single signal on each end... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2.11 ObservedEvents | The observed events parameters provide the list of events that have been observed. The event codes are the same as those used in the NotificationRequest. When an event is detected on a connection, the observed event will identify the connection the event was detected on using the "@<connection>" syntax. Examples of obs... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2.12 RequestedInfo | The RequestedInfo parameter contains a comma separated list of parameter codes, as defined in the "Parameter lines" section - clause 7.3.8. That clause lists auditable parameters. Table 15 provides additional parameter codes. Table 15: Non-auditable Parameter codes for the RequestedInfo Parameter RequestedInfo Paramete... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2.13 QuarantineHandling | The quarantine handling parameter contains a list of comma separated keywords: • The keyword "process" or "discard" to indicate the treatment of quarantined and observed events. If neither process nor discard is present, process is assumed. • The keyword "step" or "loop" to indicate whether, at most, one notification i... |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2.14 DetectEvents | The DetectEvents parameter is encoded as a comma separated list of events, such as for example: T: ft, mt It should be noted, that no actions can be associated with the events. |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2.15 EventStates | The EventStates parameter is encoded as a comma separated list of events, such as for example: ES: MO/rlc It should be noted, that no actions can be associated with the events. |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2.16 RestartMethod | The RestartMethod parameter is encoded as one of the keywords "graceful", "cancel-graceful," "forced", "restart", or "disconnected", as for example: RM: restart |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2.17 VersionSupported | The VersionSupported parameter is encoded as a comma separated list of versions supported, such as for example: VS: MGCP 1.0, MGCP 1.0 TGCP 1.0 |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2.18 Call Identifier | The Call Identifier is encoded as a hexadecimal string, at most 32 characters. Call Identifiers are compared as strings rather than numerical values. |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2.19 Connection Identifier | The Connection Identifier is encoded as a hexadecimal string, at most 32 characters. Connection Identifiers are compared as strings rather than numerical values. ETSI ETSI TS 103 161-13 V1.1.1 (2011-10) 77 |
e24dc05fc9943606cbfab85caeca5aef | 103 161-13 | 8.2.2.20 MaxMGCPDatagram | The MaxMGCPDatagram parameter is encoded as a string of up to nine decimal digits - leading zeroes are not permitted. The following example illustrates the use of this parameter: MD: 8100 |
Subsets and Splits
No community queries yet
The top public SQL queries from the community will appear here once available.