hash stringlengths 32 32 | doc_id stringlengths 7 13 | section stringlengths 3 121 | content stringlengths 0 2.2M |
|---|---|---|---|
238e580d718f360a78b094505f1c62e3 | 102 728 | 3.2 Abbreviations | For the purposes of the present document, the following abbreviations apply: (Java) SE Java Standard Edition ADF Application Description File AES Advanced Encryption Standard AFD Active Format Definition AGTS A GEM Terminal Specification AID Application Identifier AIT Application Information Table API Application Progr... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4 General considerations and conventions | |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.1 General considerations | |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.1.1 Purpose | The GEM document is not intended, and should not be used, as a complete terminal specification. It is a framework upon which a GEM terminal specification can be created. A GEM-based specification, the Multimedia Home Platform (MHP) middleware standard, defines a comprehensive platform that enables interactive televisio... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.1.2 Format | The present document does not state how the receiver has to be built or what network infrastructure has to underlie the implementation; it is limited to specifying the behaviour and interfaces that globally interoperable applications may rely on. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.1.3 Inclusion of GEM features | |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.1.3.1 Subsetting prohibited | Specifications that reference GEM shall include it in its entirety. It is prohibited to base any specification on GEM if the referencing document does not require all normative requirements of the present document. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.1.3.2 Supersetting permitted | If a GEM terminal specification wishes to include APIs, signalling or behaviours defined in MHP [1] that are not required by GEM, it may do so as described in clause 15.6, "Functional equivalents". |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.1.4 Addition of non-GEM interfaces | Specifications based on GEM may add public interfaces, provided that they are added in a namespace that does not conflict with GEM. For example, OCAP [5] defines extensions in the Java package org.ocap. GEM terminal specifications and GEM terminals shall not require that such extension interfaces be called by GEM appli... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.1.4.1 DVB-J enumerations | A GEM terminal specification shall not add new values to an enumeration that is returned from a method defined by the present document. NOTE: For example, the interface org.dvb.net.rc.RCInterface defined in Annex R introduces an enumeration that is returned by the method getType(). This enumeration includes the values ... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.1.4.2 Competitive APIs | A GEM terminal specification may include functionality that is functionally equivalent to functionality required by GEM, and thus could reasonably be mapped to a GEM API. This functionality (e.g. signalling) might be in addition to functionality that satisfies the GEM requirement that a functional equivalent be defined... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.1.4.2.1 Illustration of Complementary Functional equivalents | org.xxx.yyy org.dvb.yyy non-GEM app GEM app API -> A API -> A API -> B Protocol “A” Protocol “B” Figure 1: Complementary Functional equivalents Figure 1, showing complementary functional equivalents A and B, both mapped to the GEM API org.dvb.yyy. Mechanism A includes additional features, which are exposed to non-GEM a... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.1.4.2.2 Illustration of Competitive APIs | org.xxx.yyy org.dvb.yyy non-GEM app GEM app API -> A API -> B Protocol “A” Protocol “B” Figure 2: Competitive APIs Figure 2, showing complementary functional equivalents A and B. Only mechanism B is mapped to the GEM API; A is only exposed via the non-GEM API org.xxx.yyy. In this case, org.xxx.yyy is a competitive API,... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.1.5 Application areas | GEM defines four targets: Broadcast, Packaged Media and IPTV and OTT. The first two of these, Broadcast and Packaged Media, are further subdivided into two application areas: Enhanced Broadcasting and Interactive Broadcasting. Enhanced Broadcasting combines digital broadcast of audio/video services with downloaded appl... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.1.5.1 Broadcast target | The broadcast target is available since GEM 1.0.x and is defined for broadcast TV using cable, terrestrial or satellite. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.1.5.2 Packaged Media target | The packaged media target allows to combine audio/video content and application into a self contained medium, such as an optical disc. The GEM packaged media target is the basis of the BD-J Blu-ray execution environment. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.1.5.3 IPTV target | The GEM-IPTV target is defined to enable audio/video services over managed broadband networks. These networks allow management of the broadband bandwith and can maintain a guaranteed QoS. Since these networks can provide both unicast and multicast network services, typical services can include LMB (based on multicast) ... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.1.5.4 OTT target | According to the service profiles defined in [79] for delivery of media contents over IP networks, OTT is restricted to Content on Demand (CoD) type of services and LMB over unicast connections. NOTE: Multicast based LMB is typically not possible within OTT, even if live (unicast) contents can be enjoyed via OTT. Conte... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.1.5.5 Typical Hybrid profiles | The following combined targets are most useful for certain markets: • OTT+Broadcast: a combination of OTT with the Broadcast Interactive Profile used in hybrid broadcast/broadband receivers. • OTT+Packaged: a combination of OTT with the Packaged Media Interactive Profile. ETSI ETSI TS 102 728 V1.2.1 (2011-09) 48 • OTT+... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.1.6 Profiles | As not all GEM implementations will be able to support all application areas and as there is a further evolution expected over time, different profiles of GEM are considered. For this release of the GEM specification, profiles are mapped to the above mentioned application areas, yielding five profiles. Figure 3 shows t... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.1.7 Full conformance with the present document | To be fully conformant with the present document, GEM terminals shall conform to at least one of the profiles defined in clause 15, "Detailed platform profile definitions". Further, GEM terminals shall be conformant with any one of the following specifications: • MHP 1.0., MHP 1.1, MHP 1.2, MHP 1.2.2. [1] or later. • O... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.2 Conventions | Unless otherwise specified, the BNF notation in the present document shall follow the definitions of section 2.1 of RFC 2616 [44]. The text "Void" in a clause title or in a reference designates a clause or reference that existed in a previous version of the present document that has been removed and replaced with "Void... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.2.1 Void | |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.2.2 Void | |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.2.3 Void | |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.2.4 Conventions within the present document | |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.2.4.1 GEM | Use of the term "GEM" within a normative clause of the present document shall be interpreted as referring to the present document. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.2.4.2 Resident navigator | The present document uses the terms "navigator" and "resident navigator". It is noted that in GEM terminal specifications, it is permissible for some of the functions of the navigator to be delegated to an entity that is not part of the resident software of the terminal, e.g. the OCAP [5] monitor application. Downloade... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.2.4.3 DVB service | For the purposes of the present document, references within the present document to DVB services shall be interpreted as meaning any services that may carry GEM applications. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 4.2.5 References to OCAP | Where the words "shall be supported" or "may be supported" are used referring to a clause from OCAP [5], the following terms in the referenced clause shall be re-defined as follows: • References to OCAP-J applications or application instances shall be interpreted as references to GEM applications. • In the case of broa... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 5 Basic architecture (informative) | GEM does not mandate a basic architecture. The clause below describes an informative example of one possible architecture for GEM terminal specifications. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 5.1 Context | At its simplest level, GEM is set in the following context (see figure 4). The software of GEM has access to flows of streams and data, and may write some data to storage. The platform may be able to route streams and data outwards to a sink or store. Figure 4: GEM context The platform will receive inputs from Viewer i... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 5.2 Architecture | The Architecture describes how the GEM software elements are organized. The GEM model considers 3 layers (figure 6): • Resources. • System software. • Applications. The API lies between the Applications and the System Software seen from the perspective of an application. Figure 6: Basic architecture |
238e580d718f360a78b094505f1c62e3 | 102 728 | 5.2.1 Resources | The hardware entities in the platform include a number of functions. They are represented by hardware or software resources. There is no assumption about how they are grouped. The model considers that there can be more than one hardware entity in the total Platform. From an abstract point of view it makes no difference... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 5.2.2 System software | Applications will not directly address resources. The system software brings an abstract view of such resources. This middle layer isolates the application from the hardware, enabling portability of the application. The implementations of the Resources and System software are not specified in the present document. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 5.2.2.1 Application Manager | The system software includes an application management function, which is responsible for managing the lifecycle of all applications, including Interoperable ones. ETSI ETSI TS 102 728 V1.2.1 (2011-09) 53 |
238e580d718f360a78b094505f1c62e3 | 102 728 | 5.2.3 Application | Applications implement interactive services as software running in one or more hardware entities. The interface for GEM applications is a top view from application to the system software. Figure 6 illustrates an idealized architecture model of the processes which will occur in a GEM terminal. A hierarchy of control is ... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 5.4 Plug-ins | A "plug-in" is a set of functionality that can be added to a generic platform in order to provide interpretation of application and content formats not specified by the present document to be included in GEM terminals. NOTE: Those organizations concerned with interoperation between the standard GEM platform and other p... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 5.4.1 Security Model | Plug-ins must have sufficient access to the resources in the platform to implement the specification concerned. An implementation-specific plug-in may have access to many of the resources of the platform irrespective of the GEM security model. All plug-ins are responsible for managing the security of the applications t... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6 Transport protocols | |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.1 Introduction | For broadcast targets, in order to be able to talk to the external world, a GEM terminal has to communicate through different network types. Broadcast only services are provided on systems consisting of a downstream channel from the Service Providers to Service consumers. Interactive services are provided on systems co... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.2 Broadcast channel protocols | For broadcast targets, this clause deals with DVB defined or referenced broadcast channel protocols. This clause does not consider other protocols and the APIs that would provide access to them. Other protocols and their APIs are considered as extensions to the present document, see Annex H. Figure 10 shows the broadca... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.2.1 MPEG-2 transport stream | MPEG-2 Transport Stream is defined in ISO/IEC 13818-1 [35]. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.2.2 MPEG-2 sections | MPEG-2 private sections as defined in ISO/IEC 13818-1 [35] is based on the MPEG-2 Transport Stream protocol in clause 6.2.1. ETSI ETSI TS 102 728 V1.2.1 (2011-09) 58 |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.2.3 DSM-CC private data | DSM-CC Private Data protocol as defined in ISO/IEC 13818-6 [37]. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.2.4 DSM-CC data carousel | DSM-CC Data Carousel as defined in ISO/IEC 13818-6 [37]. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.2.5 Object carousel | DSM-CC User-to-User Object Carousel protocols as defined in ISO/IEC 13818-6 [37] with the restrictions and extensions as defined in EN 301 192 [31], TR 101 202 [i.9] and Annex B, "Broadcast filesystem and trigger transport". Use of the Object Carousel protocol is not required for GEM terminal specifications. GEM termin... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.2.5.1 Void | |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.2.5.2 Void | |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.2.5.3 Loss of carousel behaviour | Under some conditions, carousel data streams servicing broadcast file systems may become unavailable. The conditions for temporary disconnection and reconnection of carousel are defined in clause 9.1.5, "Persistence of Applications Across Service Boundaries". DSM-CC User-to-User Object Carousels as described in clause ... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.2.6 Protocol for delivery of IP multicast over the broadcast channel | DVB Multiprotocol Encapsulation as defined in EN 301 192 [31] provides support for IP and is based on the DSM-CC Private Data protocol. EN 301 192 [31] only defines support for carriage of multicast IP in MPE and not support for carriage of unicast IP. Use of the DVB Multiprotocol Encapsulation protocol is not required... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.2.7 Internet Protocol (IP) | Internet Protocol as defined in RFC 791 [47]. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.2.8 User Datagram Protocol (UDP) | User Datagram Protocol as defined in RFC 768 [46]. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.2.9 Service information | Use of DVB service information is not required for GEM terminal specifications, however some mechanism for delivery of service information that is sufficient for the SI access mechanisms required by GEM shall be specified. DVB Service Information as defined in EN 300 468 [14] and TS 101 211 [i.5] may be taken as an inf... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.2.10 IP signalling | IP Notification Table (INT) as defined in EN 301 192 [31]. Use of this signalling is not required for GEM terminal specifications, however a functional equivalent that satisfies the requirements of clause 11.5.2, "Support for Multicast IP over the Broadcast Channel" is required if IP over the broadcast channel is suppo... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.3 Interaction channel protocols | This clause deals with the DVB defined or referenced interaction channel protocols. This clause does not consider other protocols and the APIs that would provide access to them. Other private protocols and possibly APIs are not precluded and are outside of the scope of GEM. Figure 11 illustrates the set of DVB defined ... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.3.1 Network Dependent Protocols | As defined in ES 200 800 [19], ETS 300 801 [20], EN 301 193 [i.2], EN 301 195 [i.3], EN 301 199 [i.4], TR 101 201 [i.8], EN 301 790 [i.11] respectively for CATV, PSTN/ISDN, DECT, GSM, LMDS SMATV and satellite networks. For connections based interaction channels, the PPP protocol is used as defined in RFC 1332 [i.13], R... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.3.2 Internet Protocol (IP) | Internet Protocol as defined in RFC 791 [47]. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.3.3 Transmission Control Protocol (TCP) | Transmission Control Protocol as defined in RFC 793 [48]. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.3.4 UNO-RPC | The UNO-RPC consists of the Internet Inter-ORB Protocol (IIOP) as specified in CORBA/IIOP [30]. ETSI ETSI TS 102 728 V1.2.1 (2011-09) 61 |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.3.5 UNO-CDR | The UNO-CDR as defined in CORBA/IIOP [30]. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.3.6 DSM-CC User to User | DSM-CC User-to-user as defined in ISO/IEC 13818-6 [37] with the restrictions and extensions as defined in EN 301 192 [31] and TR 101 202 [i.9]. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.3.7 Hypertext Transfer Protocol (HTTP) | |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.3.7.1 HTTP 1.1 | Hypertext Transfer Protocol as defined in RFC 2616 [44]. NOTE: HTTP 1.1 support as specified is not required in the broadcast, packaged media and IPTV target of GEM. This does not preclude a GEM terminal specification using a different profile of HTTP. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.3.7.2 GEM profile of HTTP 1.0 | HTTP 1.0 is defined in RFC 1945 [67]. GEM terminals supporting HTTP 1.0 are required to support persistent connections as defined below. GEM terminals implementing profiles where HTTP 1.0 is required are also allowed to implement subsequent versions of the HTTP specification (e.g. HTTP 1.1, RFC 2616 [44]) as long as th... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.3.7.2.1 HTTP 1.0 persistent connections | When connecting to a server, a GEM terminal shall send the Keep-Alive connection-token: Connection: Keep-Alive An HTTP server (1.0 or 1.1) would then respond with the Keep-Alive connection token and the client may proceed with an HTTP 1.0 (Keep-Alive) persistent connection. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.3.7.2.2 The Keep-Alive Header | When the Keep-Alive connection-token has been transmitted with a request or a response, a Keep-Alive header field may also be included. The Keep-Alive header field takes the following form: Keep-Alive-header = "Keep-Alive" ":" 0# keepalive-param keepalive-param = param-name "=" value where the "0#" notation means that ... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.3.7.2.3 GEM and proxies | A GEM terminal must not send the Keep-Alive connection token to a HTTP 1.0 proxy server, as HTTP 1.0 proxy servers do not obey the rules of HTTP 1.1 for parsing the Connection header field. If a GEM terminal sends Keep-Alive to a proxy server that does not understand Connection, which would then erroneously forward it ... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.3.7.2.4 Version compatibility | An HTTP 1.1 server may also establish persistent connections with a GEM terminal upon receipt of a Keep-Alive connection token. However, a persistent connection with a GEM terminal cannot make use of the chunked transfer coding, and therefore must use a content-length for marking the ending boundary of each message. Fo... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.3.7.3 HTTPS | This is described in RFC 2818 [72]. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.3.8 User Datagram Protocol (UDP) | User Datagram Protocol as defined in RFC 768 [46]. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.3.9 DNS | GEM terminals shall implement at least the DNS resolver protocols that enable forward translation of fully qualified domain names to IP addresses as defined by RFC 1034 [63] and RFC 1035 [61] and clarified by RFC 1982 [64] and RFC 2181 [65]. In connection based return channels, where DNS server addresses are provided b... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.3.10 Additional Transport Protocols | Additional transport protocols that are proprietary and/or specific to a network service provider may be supported through the registration of interaction channel service providers (see org.dvb.spi.ict.InteractionChannelTransportProvider). 6.4 Transport protocols for application loading over the interaction channel Thr... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.4.1 File system implemented only by the interaction channel | This clause addresses the case where the interaction channel presents the only file system, e.g. in MHP [1], where the protocol ID is 0x0003. ETSI ETSI TS 102 728 V1.2.1 (2011-09) 63 GEM terminal specifications may define other protocol ID values that use this mechanism. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.4.1.1 File system logical structure | The list of items signalled in the transport protocol descriptor(s) (see clause 15.6.1.2.1, "Transport protocol descriptor") are considered to form a single name space. The GEM terminal when trying to locate a file specified by an incomplete (relative) filename, shall attempt to fetch a file from each of the items in t... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.4.1.2 File transfer | Files to be transferred from an "http" URL shall be transferred using either HTTP 1.1 as defined in clause 6.3.7.1, "HTTP 1.1" or the profile of HTTP specified under clause 6.3.7.2, "GEM profile of HTTP 1.0". Files to be transferred from an "https" URL shall be transferred as defined in clause 6.3.7.3, "HTTPS". For oth... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.4.1.3 Class encoding | The classes of DVB-J applications can be delivered either as discrete class files or within ZIP files (see ZIP [66]). NOTE 1: This contrasts to the broadcast case where object carousel files are simply class files. The classes of DVB-J applications shall be delivered as discrete class files at the level of the file sys... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.4.1.4 Directory listing in this file system | For the authentication (see clause 12.4.1.5, "Special authentication rules"), this file system shall be considered to be one not supporting directory listing. For listing the files in a directory (see clause 14.7, "Files and file names"), this file system shall be considered to be one where the MHP terminal is never ce... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.4.2 Hybrid between broadcast stream and interaction channel | In the hybrid case all directory information is provided in the broadcast stream but some, or possibly all, of the file contents are provided via the interaction channel. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.4.2.1 File transfer | |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.4.2.1.1 Broadcast file delivery | In GEM terminals that use the DSM-CC User-to-User Object Carousel, the file contents are carried via a BIOP::File as is the normal case for a DSM-CC User-to-User Object Carousel as described in clause 6.2.5, "Object carousel". The IOR from the file binding to the file contents uses either a BIOPProfileBody or a LiteOpt... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.4.2.1.2 Interaction channel delivery | In GEM terminals that use the DSM-CC User-to-User Object Carousel, the IOR from the file binding to the file contents uses the HTTPProfileBody (see table 2) to identify the location of the file contents on the interaction channel. This form of IOR shall only be used for BIOP::File objects. See clause 6.3.7.2, "GEM prof... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.4.2.1.3 HTTPProfileBody | The HTTP Profile body specifies host, port and path_segments. In HTTP requests these are concatenated to form a URL of the form: http://host:port/path_segments Table 2: HTTP Profile Body syntax Syntax bits Type Value Comment HTTPProfileBody { profileId_tag 32 uimsbf 0x44564200 profile_data_length 32 uimsbf * profile_da... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.5 IPTV protocols | GEM terminal specifications supporting the IPTV target shall define protocols for the delivery of GEM services and service information. GEM terminal specifications may mandate support for any of the protocols specified by the following subclauses. NOTE: GEM-IPTV protocols may rely on the provider interfaces, defined in... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.5.1 Transport protocols | |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.5.1.1 Service Discovery and Selection | The protocols for unicast and multicast delivery of service discovery and selection information are defined in clause 5.4 of TS 102 034 [79]. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.5.1.2 Broadband Content Guide | The protocols for unicast and multicast delivery of broadband content guide information are defined in clause 4 of TS 102 539 [80]. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.5.1.3 Real Time Protocol (RTP) | The use of RTP is defined in clause 7 of TS 102 034 [79]. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.5.1.4 Real Time Streaming Protocol (RTSP) | The use of RTSP is defined in clause 6 of TS 102 034 [79]. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.5.1.5 Internet Group Management Protocol (IGMP) | The use of IGMP is defined in clause 7 of TS 102 034 [79]. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.5.2 Service information and metadata protocols | |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.5.2.1 IP service discovery | This is defined by clause 5.2 of TS 102 034 [79] excluding clause 5.2.6.6. GEM terminals shall monitor and detect changes in this signalling however there is no requirement to do this more frequently than once per day. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.5.2.2 Broadband content guide | This is defined by clauses 5, 6 and 7 of TS 102 539 [80] and clause 5.2.6.6 of TS 102 034 [79]. ETSI ETSI TS 102 728 V1.2.1 (2011-09) 67 |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.6 OTT Protocols | |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.6.1 Protocols for streaming | Unicast streaming using HTTP 1.1 [44] shall be supported for the OTT target. NOTE: HTTP 1.1 support the range header in a GET request, which allows partial retrieval for use in cases such as trick play or seek operations to reduce unnecessary network usage. To optimize the streaming user experience over best-effort bro... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.6.1.1 Adaptive Streaming | The user experience with Streamed CoD based on a single instance (single coding rate) of a given content may be adversely affected by the different and varying conditions of each customer’s unmanaged broadband access. Different because of possible different access line profiles (either commercial or technical); varying... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 6.6.2 Protocols for download | If content download is supported, HTTP 1.1 [44] shall be supported. The content download mechanism is agnostic to the file formats that are transferred. NOTE: HTTP 1.1 supports the range header in a GET request, which allows partial retrieval for continuing failed or interrupted download requests. ETSI ETSI TS 102 728 ... |
238e580d718f360a78b094505f1c62e3 | 102 728 | 7 Content formats | NOTE: This clause contains definitions referenced from other parts of the present document. Use of these formats may be optional, or it may be possible to replace them with a functional equivalent. |
238e580d718f360a78b094505f1c62e3 | 102 728 | 7.1 Static formats | |
238e580d718f360a78b094505f1c62e3 | 102 728 | 7.1.1 Bitmap image formats |
Subsets and Splits
No community queries yet
The top public SQL queries from the community will appear here once available.