message
stringlengths
13
484
diff
stringlengths
38
4.63k
more cryptocurrency apis * crypto apis * tick fixes * ICObench data api Zloader API Voltaire API Coin Ranking API * remove spacing in coin rank * remove voltaire
@@ -185,15 +185,18 @@ API | Description | Auth | HTTPS | CORS | | [CoinLayer](https://coinlayer.com) | Real-time Crypto Currency Exchange Rates | `apiKey` | Yes | Unknown | | [CoinMarketCap](https://coinmarketcap.com/api/) | Cryptocurrencies Prices | No | Yes | Unknown | | [Coinpaprika](https://api.coinpaprika.com) | C...
tests: don't fail when `convert` is missing ...instead, just skip as if the version is too old. Closes
@@ -19,6 +19,7 @@ from libqtile import images def get_imagemagick_version(): "Get the installed imagemagick version from the convert utility" + try: p = sp.Popen(['convert', '-version'], stdout=sp.PIPE, stderr=sp.PIPE) stdout, stderr = p.communicate() lines = stdout.decode().splitlines() @@ -28,6 +29,9 @@ def get_image...
llvm/execution: Drop redundant frozenset contructors Rename additional_tags -> tags.
@@ -235,7 +235,7 @@ class CompExecution(CUDAExecution): self.__bin_run_multi_func = None self.__debug_env = debug_env self.__frozen_vals = None - self.__additional_tags = frozenset(additional_tags) + self.__tags = frozenset(additional_tags) # TODO: Consolidate these if len(execution_ids) > 1: @@ -269,8 +269,8 @@ class ...
revent: Add add_listener() This is a non-backwards compatible replacement for addListener(). Its big new trick is that if you give it a function without an event, it will attempt to infer the event name from the function name.
@@ -387,6 +387,24 @@ class EventMixin (object): kw['byName'] = True return self.addListener(*args,**kw) + def add_listener (self, handler, event_type=None, event_name=None, + once=False, weak=False, priority=None): + """ + Add an event handler for an event triggered by this object (subscribe). + + This is a replacement...
Update visual.py Typo
@@ -192,7 +192,7 @@ def get_vert_ngrams( lower: bool = True, from_sentence: bool = True, ) -> Iterator[str]: - """Return all ngrams which are visually vertivally aligned with the Mention. + """Return all ngrams which are visually vertically aligned with the Mention. Note that if a candidate is passed in, all of its Men...
Ignore "unsubscriptable-object" This code has been tested, points is subscriptable.
@@ -2554,7 +2554,7 @@ class PDPlotter: if self._dim == 2: error = stable_marker_plot.error_y["array"] points = np.append(x, [y, error]).reshape(3, -1).T - points = points[points[:, 0].argsort()] # sort by composition + points = points[points[:, 0].argsort()] # sort by composition # pylint: disable=E1136 # these steps t...
Add missing expected_regex parameter to TestCase.assertRaisesRegexp(). This makes it match the signature of assertRaisesRegex() which is the modern name for the same function.
@@ -197,11 +197,13 @@ class TestCase: @overload def assertRaisesRegexp(self, # type: ignore exception: Union[Type[BaseException], Tuple[Type[BaseException], ...]], + expected_regex: Union[str, bytes, Pattern[str], Pattern[bytes]], callable: Callable[..., Any] = ..., *args: Any, **kwargs: Any) -> None: ... @overload def...
Update 'stock' icons for part table Display on-order and building quantity as icons Simplified display logic Do not hide information in certain circumstances.
@@ -1460,46 +1460,42 @@ function loadPartTable(table, url, options={}) { title: '{% trans "Stock" %}', searchable: false, formatter: function(value, row) { - var link = '?display=part-stock'; - if (row.in_stock) { - // There IS stock available for this part + var text = ''; - // Is stock "low" (below the 'minimum_stock...
Always set the child index Fix
@@ -451,10 +451,6 @@ def _in_flow_layout(context, box, index, child, new_children, page_is_empty, fixed_boxes, adjoining_margins, discard) if new_child is not None: - # index in its non-laid-out parent, not in future new parent - # May be used in find_earlier_page_break() - new_child.index = index - # We need to do thi...
Update parser.h update parser.h for larger apps
#include "common/tiny-json.h" -#define MAX_NUM_IO 4 -#define MAX_NUM_IO_TILES 8 +#define MAX_NUM_IO 16 +#define MAX_NUM_IO_TILES 16 #define BUFFER_SIZE 1024 #define MAX_NUM_KERNEL 16 -#define MAX_JSON_FIELDS 512 +#define MAX_JSON_FIELDS 2048 #define MAX_CONFIG 40 #define MAX_ADDR_GEN_LOOP 5
[Stress Tester XFails] Update XFails has been fixed on `Dollar.swift` was listed by mistake on `Dollar.swift` was previously shadowed by on `SceneDelegate.swift` is now shadowing on `Model.swift`
"issueUrl" : "https://bugs.swift.org/browse/SR-14545" }, { - "path" : "*\/DNS\/Sources\/DNS\/Integer+Data.swift", + "path" : "*\/Dollar\/Sources\/Dollar.swift", + "modification" : "concurrent-2318", "issueDetail" : { - "kind" : "codeComplete", - "offset" : 194 + "kind" : "conformingMethodList", + "offset" : 2320 }, "ap...
Fix episode termination reward in highway environment Otherwise the agent just slows down in the end to prevent the episode termination and keep earning rewards.
@@ -17,8 +17,9 @@ class HighwayEnv(AbstractEnv): COLLISION_COST = 10 LANE_CHANGE_COST = 0.0 - RIGHT_LANE_REWARD = 0.5 + RIGHT_LANE_REWARD = 0.4 HIGH_VELOCITY_REWARD = 1.0 + EPISODE_SUCCESS = 10.0 def __init__(self): road = Road.create_random_road(lanes_count=4, lane_width=4.0, vehicles_count=20, vehicles_type=IDMVehicl...
Removed filtering of directories that contain _X_ This is a strange undocumented hack that breaks experiments that contain X in their name.
@@ -222,9 +222,9 @@ def data_from_time(timestamp, folder=None): def measurement_filename(directory=os.getcwd(), file_id=None, ext='hdf5'): dirname = os.path.split(directory)[1] if file_id is None: - if dirname[6:9] == '_X_': - fn = dirname[0:7] + dirname[9:] + '.' + ext - else: + # if dirname[6:9] == '_X_': + # fn = di...
Update README.md Added Configure Indicator Threshold Parameters under Configure Anomali ThreatStream v3 on Cortex XSOAR to clarify how the DBotScore is generated from the thresholds (based on customer request)
@@ -26,6 +26,21 @@ If you are upgrading from a previous version of this integration, see [Breaking | Create relationships | Create relationships between indicators as part of enrichment. | False | 4. Click **Test** to validate the URLs, token, and connection. + +### Configure Indicator Threshold Parameters +Each indica...
Don't assume that each item in "pkgs" is a dict (as packed by pkg.installed state). Fixes Also, corrects an issue where a trailing space was added to package names when pkgs was passed as a dict (i.e. pkg.installed state)
@@ -46,6 +46,7 @@ import salt.utils.data import salt.utils.functools import salt.utils.path import salt.utils.pkg +from salt.ext.six import string_types from salt.exceptions import CommandExecutionError # Define the module's virtual name @@ -332,7 +333,6 @@ def latest_version(name, **kwargs): return ret return '' - # a...
Make import sorting tool work on Windows too. * Due to it changing the line endings of all files, it won't work though.
@@ -41,7 +41,7 @@ sys.path.insert( ) ) -from nuitka.tools.Basics import goHome, addPYTHONPATH # isort:skip +from nuitka.tools.Basics import goHome, addPYTHONPATH, setupPATH # isort:skip from nuitka.tools.ScanSources import scanTargets # isort:skip @@ -57,6 +57,7 @@ def main(): target_files.append("nuitka/build/SingleEx...
descriptors: Add function to clear pypsa output series data Meant to be run before solving lopf to temporarily free up data for the solver.
@@ -284,6 +284,17 @@ def allocate_series_dataframes(network, series): pnl[attr] = pnl[attr].reindex(columns=df.index, fill_value=network.components[component]["attrs"].at[attr,"default"]) +def free_output_series_dataframes(network, components=None): + if components is None: + components = network.all_components + + for...
Point users to logs when running 'mlflow ui' fails The change attempts to address by pointing users to the logs of trying to start the mlflow server instead of printing an exception that does not explain the cause for failure and is slightly noisy.
@@ -14,6 +14,7 @@ import mlflow.sagemaker.cli import mlflow.server from mlflow.entities.experiment import Experiment +from mlflow.utils.process import ShellCommandException from mlflow import tracking @@ -128,7 +129,12 @@ def ui(file_store, host, port): The UI will be visible at http://localhost:5000 by default. """ # ...
PIN: jinja2 < 3.1 See sphinx-doc/sphinx#10291
@@ -27,7 +27,7 @@ url = https://github.com/nipreps/mriqc [options] python_requires = >= 3.7 install_requires = - jinja2 + jinja2 < 3.1 markupsafe ~= 2.0.1 # jinja2 imports deprecated function removed in 2.1 matplotlib mriqc-learn
Continue the job even if linters fail. Current linter has many false positives and it seems not justify blocking PRs. Please see also
@@ -65,6 +65,7 @@ jobs: [ ! -s "py_test_files.txt" ] || cat py_test_files.txt | xargs -I {} python {} - name: Lint with protolint + continue-on-error: true env: PROTOLINT_VERSION: 0.25.1 shell: bash @@ -77,6 +78,7 @@ jobs: [ ! -s "proto_files.txt" ] || cat proto_files.txt | xargs -I {} ./protolint {} - name: Lint with ...
use capitalize in currentUser in App.vue Fixes: ```TypeError: Cannot read properties of undefined (reading 'charAt') at Proxy.render (VM25715 App.vue:71:37) at Vue._render (vue.runtime.esm.js?2b0e:2654:1) at VueComponent.updateComponent (vue.runtime.esm.js?2b0e:3844:1)```
@@ -49,7 +49,7 @@ limitations under the License. Share </v-btn> <v-avatar color="grey lighten-1" size="25" class="ml-3"> - <span class="white--text">{{ currentUser.charAt(0).toUpperCase() }}</span> + <span class="white--text">{{ currentUser | capitalize }}</span> </v-avatar> <v-menu v-if="!isRootPage" offset-y> <templa...
Allow kwargs in _log_console_output As a part of the scenario/manager.py stabilization tracked by the below BP the patch adds kwargs argument for _log_console_output method so that the consumers are able to pass additional parameters if needed. Implements: blueprint tempest-scenario-manager-stable
@@ -625,7 +625,7 @@ class ScenarioTest(tempest.test.BaseTestCase): LOG.debug("image:%s", image['id']) return image['id'] - def _log_console_output(self, servers=None, client=None): + def _log_console_output(self, servers=None, client=None, **kwargs): """Console log output""" if not CONF.compute_feature_enabled.console_...
Replaced the Documentation Link The original Documentation link to MDA no longer exists. A new link has been provided to a Government of Canada page.
Name: RADARSAT-1 Description: Developed and operated by the Canadian Space Agency, it is Canada's first commercial Earth observation satellite. -Documentation: https://mdacorporation.com/geospatial/international/satellites/RADARSAT-1/ +Documentation: https://www.asc-csa.gc.ca/eng/satellites/radarsat1/what-is-radarsat1....
be stricter on broadcast message area validation even if there is a json struct, make sure it actually contains polygons, or we'll send to the entire country.
@@ -56,7 +56,7 @@ def _update_broadcast_message(broadcast_message, new_status, updating_user): f'User {updating_user.id} cannot approve their own broadcast_message {broadcast_message.id}', status_code=400 ) - elif not broadcast_message.areas: + elif len(broadcast_message.areas['simple_polygons']) == 0: raise InvalidReq...
Make host backward compatible with transmissionrpc Code adapted from
@@ -55,10 +55,22 @@ class TransmissionBase: def create_rpc_client(self, config): user, password = config.get('username'), config.get('password') + urlo = urlparse(config['host']) + + if urlo.scheme == '': + urlo = urlparse('http://' + config['host']) + + protocol = urlo.scheme if urlo.scheme else 'http' + port = str(ur...
Skip flaky test See
@@ -227,6 +227,7 @@ class TestPantsDaemonIntegration(PantsDaemonIntegrationTestBase): for run_pairs in zip(non_daemon_runs, daemon_runs): self.assertEqual(*(run.stdout_data for run in run_pairs)) + @unittest.skip('Flaky as described in: https://github.com/pantsbuild/pants/issues/7622') def test_pantsd_filesystem_invali...
Update listeners.py fix typo
@@ -35,7 +35,7 @@ class ListenerMixin: """ Create a listener from a decorated function. - To be used as a deocrator: + To be used as a decorator: .. code-block:: python
Changed to check if brcmEGL and brcmGLESv2 library files exists in /opt/vc/lib instead of checking distribution version for rpi platform.
@@ -598,12 +598,20 @@ def determine_gl_flags(): '/opt/vc/include/interface/vcos/pthreads', '/opt/vc/include/interface/vmcs_host/linux'] flags['library_dirs'] = ['/opt/vc/lib'] - from platform import linux_distribution - dist = linux_distribution() - if dist[0] == 'debian' and float(dist[1]) >= 9.1: - flags['libraries']...
Fix bib file Author name was duplicated, causing the sphinx build to fail.
-@Book{2007:ritto, - author = {Ritto, Thiago G.}, - author = {Sampaio, Rubens.}, +@Book{2007ritto, + author = {Ritto, Thiago G. and Sampaio, Rubens.}, title = {Rotor Dynamics with MATLAB - Finite Element Analysis}, publisher = {PUC-Rio}, year = {2007}
fix: 2FA qrcode generation error Fixed decoding issues so as to facilitate proper comparison of strings durin qrcode generation for 2FA.
@@ -5,7 +5,7 @@ from __future__ import unicode_literals import frappe from frappe import _ -from six.moves.urllib.parse import parse_qs +from six.moves.urllib.parse import parse_qsl from frappe.twofactor import get_qr_svg_code def get_context(context): @@ -15,10 +15,11 @@ def get_context(context): def get_query_key(): ...
Couple fewer Telnet colons "Telnet server started" already lost its colon to match the GDB server. Drop two more colons for internal consistency.
@@ -330,7 +330,7 @@ class TelnetSemihostIOHandler(SemihostIOHandler): while not self._shutdown_event.is_set(): self.connected = self._abstract_socket.connect() if self.connected is not None: - logging.debug("Telnet: client connected") + logging.debug("Telnet client connected") break if self._shutdown_event.is_set(): @@...
chore: update OKD to latest 4.7 This commit updates the OKD version to the current latest.
@@ -64,7 +64,7 @@ kubeinit_okd_registry_repository: "{{ kubeinit_okd_registry_repository_aux | rep kubeinit_okd_registry_release_tag_aux: "{% if ( kubeinit_okd_openshift_deploy | default(False) ) %} 4.7.18 {% else %} - 4.7.0-0.okd-2021-06-19-191547 + 4.7.0-0.okd-2021-08-07-063045 {% endif %}" kubeinit_okd_registry_rele...
Skip flaky test on Python 3 Even with the flaky decorator, this test sometimes passes and sometimes fails. Let's skip it for now.
@@ -93,7 +93,7 @@ class TestSerializers(TestCase): @skipIf(not yaml.available, SKIP_MESSAGE % 'yaml') @skipIf(not yamlex.available, SKIP_MESSAGE % 'sls') - @flaky + @skipIf(six.PY3, 'Flaky on Python 3.') def test_compare_sls_vs_yaml_with_jinja(self): tpl = '{{ data }}' env = jinja2.Environment()
sql: Explain cop capabilities Explain cop capabilities
@@ -97,7 +97,9 @@ mysql> EXPLAIN ANALYZE SELECT count(*) FROM trips WHERE start_date BETWEEN '2017 ### Introduction to task -Currently, the calculation task of TiDB contains two different tasks: cop task and root task. The cop task refers to the computing task that is pushed to the KV side and executed distributedly. T...
Update tests.py Update for tests for rgb2gray
@@ -3146,12 +3146,6 @@ def test_plantcv_rgb2gray(): pcv.params.debug_outdir = cache_dir # Read in test data img = cv2.imread(os.path.join(TEST_DATA, TEST_INPUT_COLOR)) - # Test with debug = "print" - pcv.params.debug = "print" - _ = pcv.rgb2gray(rgb_img=img) - # Test with debug = "plot" - pcv.params.debug = "plot" - _ ...
Fix dbus-next notification bug Some notification clients run "GetServerInformation" as part of the notification process. The old code returned a tuple whereas dbus requires an array (i.e. list).
@@ -79,7 +79,7 @@ if has_dbus: @method() def GetServerInformation(self) -> 'ssss': # type:ignore # noqa: N802, F821 - return ("qtile-notify-daemon", "qtile", "1.0", "1") + return ["qtile-notify-daemon", "qtile", "1.0", "1"] class Notification: def __init__(self, summary, body='', timeout=-1, hints=None, app_name='',
Update test_command_line_client.py delete command line cp test
@@ -559,66 +559,6 @@ def test_command_get_recursive_and_query(): schedule_for_cleanup(new_paths[0]) -def test_command_copy(): - """Tests the 'synapse cp' function""" - - # Create a Project - project_entity = syn.store(Project(name=str(uuid.uuid4()))) - schedule_for_cleanup(project_entity.id) - - # Create a Folder in Pr...
soft-deactivation/management: Rename variable to make more sense. We rename variable user_ids_to_deactivate to users_to_deactivate since it was storing UserProfiles anyway.
@@ -57,14 +57,14 @@ class Command(ZulipBaseCommand): elif deactivate: if user_emails: print('Soft deactivating forcefully...') - user_ids_to_deactivate = list(UserProfile.objects.filter( + users_to_deactivate = list(UserProfile.objects.filter( realm=realm, email__in=user_emails)) else: - user_ids_to_deactivate = get_us...
Cleans Up Voice Sync Tests Cleans up the tests related to the voice sync/kick functions by adding a helper method to simplify mocking.
@@ -291,6 +291,17 @@ class RescheduleTests(unittest.IsolatedAsyncioTestCase): self.cog.notifier.add_channel.assert_not_called() +def voice_sync_helper(function): + """Helper wrapper to test the sync and kick functions for voice channels.""" + @autospec(silence.Silence, "_force_voice_sync", "_kick_voice_members", "_set_...
Add basic path for image AutoML * Add basic path for image AutoML * [pre-commit.ci] auto fixes from pre-commit.com hooks for more information, see
@@ -38,6 +38,9 @@ except ImportError: OUTPUT_DIR = "." +AUTOML_DEFAULT_TABULAR_MODEL = "tabnet" +AUTOML_DEFAULT_TEXT_ENCODER = "bert" +AUTOML_DEFAULT_IMAGE_ENCODER = "stacked_cnn" class AutoTrainResults: @@ -217,7 +220,7 @@ def _model_select( # tabular dataset heuristics if len(fields) > 3: - base_config = merge_dict(b...
mmctl heading formatting fixes * mmctl heading formatting fixes Documentation task: Updated: Self-Managed Admin Guide > Administration > mmctl Command Line Tool (Beta) > mmctl export - Fixed formatting for child command links * Heading formatting fixes for mmctl export
@@ -25,6 +25,8 @@ This feature was developed to a large extent by community contributions and we'd - `mmctl docs`_ - Generates mmctl documentation - `mmctl export`_ - Exports management - `mmctl group`_ - Group management + - `mmctl group channel`_ - Channel group management + - `mmctl group team`_ - Team group managem...
dplay: check per episode if its premium or not fixes
@@ -43,7 +43,7 @@ class Dplay(Service): yield ServiceError("Wrong username or password") return - what = self._playable(dataj, premium) + what = self._playable(dataj["data"][0], premium) if what == 1: yield ServiceError("Premium content") return @@ -137,13 +137,13 @@ class Dplay(Service): return "sv" def _playable(self...
Clarify Query Store naming Clarify that Query Stores can be named and referenced individually. There can be multiple Query Stores.
@@ -18,11 +18,11 @@ Steps A SqlAlchemy Query Store acts as a bridge that can query a SqlAlchemy-connected database and return the result of the query to be available for an evaluation parameter. - Find the ``stores`` section in your ``great_expectations.yml`` file, and add the following configuration for a new store ca...
Fix for issue * Check for None to fix issue * Update tenable/reports/nessusv2.py This makes sense to me
@@ -54,6 +54,7 @@ class NessusReportv2(object): elif name in ['cvss_base_score', 'cvss_temporal_score']: # CVSS scores are floats, so lets return them as such. + if value: return float(value) elif name in ['first_found', 'last_found', 'plugin_modification_date',
Uninspired label, remaping to routing_instance man_facepalming:
@@ -112,7 +112,7 @@ class PrometheusTransport(TransportBase): self.metrics[error] = Counter( 'napalm_logs_{error}'.format(error=error.lower()), 'Counter for {error} notifications'.format(error=error), - ['host', 'instance', 'neighbor', 'peer_as'] + ['host', 'routing_instance', 'neighbor', 'peer_as'] ) instance_name = l...
Make http staging test run with different configs, rather than fixed one This is already the case for the FTP test.
-import pytest - import parsl from parsl.app.app import App from parsl.data_provider.files import File -from parsl.tests.configs.local_threads import config - -parsl.clear() -parsl.load(config) @App('python') @@ -19,7 +13,6 @@ def sort_strings(inputs=[], outputs=[]): s.write(e) -@pytest.mark.local def test_implicit_sta...
Fixed typo in Python setup (calling virtualenv binary directly) and added needs: validate- content as a dependency.
@@ -103,6 +103,7 @@ jobs: build-sources: runs-on: ubuntu-latest + needs: validate-content steps: - name: Checkout Repo uses: actions/checkout@v2 @@ -116,7 +117,7 @@ jobs: run: | rm -rf venv - virtualenv --clear venv + python3 -m pip --clear venv source venv/bin/activate python3 -m pip install -q -r requirements.txt --i...
update spacing in readme Addresses
@@ -24,7 +24,7 @@ Each instance is at least composed of: |------------------|------------------------------------------------------------------------------------------------------------------| | `prometheus_url` | A URL that points to the metric route (**Note:** must be unique) | | `namespace` | This namespace is prepe...
(airline-use-dsl-1) Use DSL for process_on_time_data Summary: Behold the glory Test Plan: Buildkite Reviewers: max, natekupp, alangenfeld
PresetDefinition, SolidInstance, String, + composite_solid, file_relative_path, ) }, ) -process_on_time_data = CompositeSolidDefinition( - name='process_on_time_data', - solids=[s3_to_df, join_q2_data, load_data_to_database_from_spark], - dependencies={ - SolidInstance('s3_to_df', alias='april_on_time_s3_to_df'): {}, -...
Duplicate entries One entry removed for being a duplicate. Links copied to other entry. Date verified because there were conflicting dates attached.
@@ -13,11 +13,14 @@ A peaceful protest was dispersed with tear gas and flash bangs, with police shoo ### Congresswoman Joyce Beatty reportedly sprayed with "mace or pepper spray" | May 30th -CNN reports that Joyce Beatty, an African American congresswoman from Ohio, was sprayed with mace or pepper spray at a protest in...
Removed a line that did nothing It was not necessary to reduce the loop index. The supposed fix did not even do this.
@@ -359,9 +359,6 @@ class BlackrockRawIO(BaseRawIO): if length < 2: nb_empty_segments += 1 self.nsx_data.pop(data_bl) - # TODO: CHECK WHAT HAPPENS HERE AND IF -1 IS CORRECT - # Is this even needed? It should be - data_bl -= 1 continue if self.__nsx_data_header[self.nsx_to_load] is None: t_start = 0.
Must detect/set js parser (when applicable) Per Prettier v1.13, the default parser (babylon) is no longer set. See <https://prettier.io/blog/2018/05/27/1.13.0.html#don-t-default-to-the-javascript-parser-4528-by-duailibe>
@@ -471,6 +471,11 @@ class JsPrettierCommand(sublime_plugin.TextCommand): prettier_options.append('vue') continue + if self.is_source_js(view): + prettier_options.append(cli_option_name) + prettier_options.append('babylon') + continue + if self.is_html(view): prettier_options.append(cli_option_name) prettier_options.ap...
Refresh README documentation Refer to the new `Dockerfile.tmpl` Remove outdated documentation about GPU layers/ Remove link to outdated external documentation.
[Kaggle Notebooks](https://www.kaggle.com/notebooks) allow users to run a Python Notebook in the cloud against our competitions and datasets without having to download data or set up their environment. -This repository includes our Dockerfiles for building the [CPU-only](Dockerfile) and [GPU](gpu.Dockerfile) image that...
Change to XPath using button label text for Click Modal Button to cover modals opened by a Quick Action which don't set a title on the button element
@@ -10,7 +10,7 @@ lex_locators = { "loading_box": "css: div.auraLoadingBox.oneLoadingBox", "modal": { "is_open": "css: div.DESKTOP.uiModal.forceModal.open.active", - "button": "css: div.uiModal div.modal-footer button[title='{}']", + "button": "//div[contains(@class,'uiModal')]//div[contains(@class,'modal-footer')]//bu...
[Snippets/interpolatable] Use Hungarian algorithm from munkres or scipy when available Fixes
@@ -77,8 +77,28 @@ def _matching_cost(G, matching): def min_cost_perfect_bipartite_matching(G): n = len(G) - if n <= 8: - # brute-force + try: + from scipy.optimize import linear_sum_assignment + rows, cols = linear_sum_assignment(G) + # This branch untested + assert rows == list(range(n)) + return cols, _matching_cost...
Update test_reopt_url.py correct expected error message for outage hours
@@ -143,7 +143,7 @@ class EntryResourceTest(ResourceTestCaseMixin, TestCase): data['Scenario']['Site']['LoadProfile']['outage_end_hour'] = 0 response = self.get_response(data) err_msg = str(json.loads(response.content)['messages']['input_errors']) - self.assertTrue("LoadProfile outage_start_hour and outage_end_hour can...
util.commandline: StoreTarget: add separator kwarg to allow splitting input Via a specified separator to enable things like splitting a comma-separated string of args.
@@ -71,9 +71,12 @@ class StoreTarget(argparse._AppendAction): def __init__(self, *args, **kwargs): self.allow_sets = kwargs.pop('allow_sets', False) self.allow_ebuild_paths = kwargs.pop('allow_ebuild_paths', False) + self.separator = kwargs.pop('separator', None) super(StoreTarget, self).__init__(*args, **kwargs) def _...
remove error handling for exception that does not happen no point complicating Repeater payload with error handling targetting ResourceNotFound when that has only ever happened once in 2015
@@ -168,17 +168,9 @@ class Repeater(QuickCachedDocumentMixin, Document, UnicodeMixIn): generator = self.get_payload_generator(self.format_or_default_format()) return generator.get_payload(repeat_record, self.payload_doc(repeat_record)) - def get_payload_or_none(self, repeat_record): - try: - return self.get_payload(rep...
CI: try to cache android apk builds and build qml arm64 on every commit
@@ -174,39 +174,52 @@ task: CIRRUS_DOCKER_CONTEXT: contrib/build-wine task: - name: Android build (Kivy arm64) + name: Android build (Kivy $APK_ARCH) container: dockerfile: contrib/android/Dockerfile cpu: 2 memory: 2G + env: + APK_ARCH: arm64-v8a + p4a_cache: + folders: + - ".buildozer/android/platform/build-$APK_ARCH/...
wmt should actually use specified tfds eval set also remove redundant license and add a tokenizer comment.
-# Copyright 2020 The Flax Authors. -# -# Licensed under the Apache License, Version 2.0 (the "License"); -# you may not use this file except in compliance with the License. -# You may obtain a copy of the License at -# -# http://www.apache.org/licenses/LICENSE-2.0 -# -# Unless required by applicable law or agreed to i...
Add function `htmlEntities` `htmlentities()` is a function which converts special characters. This allows you to show to display the string without the browser reading it as HTML.
return "{% url 'helpdesk:view' 1234 %}".replace(/1234/, row.id.toString()); } + function htmlEntities(str) { + return String(str).replace(/&/g, '&amp;').replace(/</g, '&lt;').replace(/>/g, '&gt;').replace(/"/g, '&quot;'); + } + $(document).ready(function () { // Ticket DataTable Initialization $('#ticketTable').DataTab...
Add documentation about how to run the tests. Improve documentation about the location of the installation output, especially with respect to the example programs. Most importantly, make installation actually build everything.
# Example programs +After running ``source install.sh``, the executable versions of the +example programs can be located in ``bazel-bin/nucleus/examples/``. +For example, to run ``ascii_pileup``, you would actually run a command +like + +```shell +bazel-bin/nucleus/examples/ascii_pileup input.sam chr3:99393 +``` + +If ...
fix poor implementation append caused the original list to be updated each time this was done
@@ -44,8 +44,7 @@ class UploadedTranslationsValidator(object): :param for_type: type of sheet, module_and_forms, module, form :return: list of errors messages if any """ - columns_to_compare = COLUMNS_TO_COMPARE[for_type] - columns_to_compare.append(self.default_language_column) + columns_to_compare = COLUMNS_TO_COMPAR...
fix proforma wind and BESS tax incentives wind and BESS bonus fraction cell references were switched with each other
@@ -1030,10 +1030,10 @@ def generate_proforma(scenariomodel, output_file_path): col_idx += 1 ws['{}{}'.format(upper_case_letters[col_idx], current_row)] = batt.macrs_bonus_pct - wind_bonus_fraction_cell = "\'{}\'!{}{}".format(inandout_sheet_name, upper_case_letters[col_idx], current_row) + batt_bonus_fraction_cell = "\...
Clarify docs on IAM role configuration Closes
@@ -82,6 +82,8 @@ value is ``true``. If this value is ``false`` then chalice will try to load an IAM policy from disk at ``.chalice/policy-<stage-name>.json`` instead of auto-generating a policy from source code analysis. You can change the filename by providing the ``iam_policy_file`` config option. +See :ref:`iam-rol...
Move iter_subtrees_topdown into standalone Move the definition of `iter_subtrees_topdown` into the standalone template section, so it will be included in standalone parsers.
@@ -142,6 +142,20 @@ class Tree(Generic[_Leaf_T]): del queue return reversed(list(subtrees.values())) + def iter_subtrees_topdown(self): + """Breadth-first iteration. + + Iterates over all the subtrees, return nodes in order like pretty() does. + """ + stack = [self] + while stack: + node = stack.pop() + if not isinsta...
Fix for a broken method method had moved to the renderer
@@ -46,7 +46,7 @@ class ImageViewAgg(ImageView.ImageViewBase): def get_rgb_image_as_bytes(self, format='png', quality=90): # TO BE DEPRECATED: DO NOT USE - return self.get_surface_as_rgb_format_bytes(format=format, + return self.renderer.get_surface_as_rgb_format_bytes(format=format, quality=quality) def save_rgb_image...
Bug when determine if all rows have same length Should be the length of each row in all rows (len(row)), but not the number of rows (nrow).
@@ -117,7 +117,7 @@ def csv2st(csvfile, headers=False, stubs=False, title=None): stubs = () nrows = len(rows) ncols = len(rows[0]) - if any(nrows != ncols for row in rows): + if any(len(row) != ncols for row in rows): raise IOError('All rows of CSV file must have same length.') return SimpleTable(data=rows, headers=hea...
Adds initialization of self.gates_on_qubits to ProcessorSpec Since this is needed for RB calculations - currently a little rough.
@@ -84,6 +84,21 @@ class ProcessorSpec(object): if len(self.compilations) > 0: self.construct_compiler_costs() + if len(construct_models) > 0: + # Compute the gate labels that act on an entire set of qubits + self.gates_on_qubits = _collections.defaultdict(list) + + model_to_use = construct_models[0] + if model_to_use ...
Remove typo in echo partion -> partition
@@ -497,23 +497,23 @@ if [ "$1" = "format" ]; then sudo parted /dev/${hdd} mkpart primary ext4 0% 100% 1>&2 sleep 6 sync - # loop until the partion gets available + # loop until the partition gets available loopdone=0 loopcount=0 while [ ${loopdone} -eq 0 ] do - >&2 echo "# waiting until the partion gets available" + >...
Update heart_anomaly_detection.py * Update heart_anomaly_detection.py Fix wrong initialized node name and comment, organize imports * Update heart_anomaly_detection.py Fix indentations * Fix style
# See the License for the specific language governing permissions and # limitations under the License. -import rospy +import argparse import torch + +import rospy from vision_msgs.msg import Classification2D -import argparse from std_msgs.msg import Float32MultiArray + from opendr_bridge import ROSBridge from opendr.pe...
update epochs_create() to account for the problem of having insufficient number of samples in the first epoch or the last epoch
@@ -26,8 +26,7 @@ def epochs_create(data, events, sampling_rate=1000, epochs_duration=1, epochs_st A list containing unique event identifiers. If `None`, will use the event index number. event_conditions : list An optional list containing, for each event, for example the trial category, group or experimental conditions...
input-pill: Add copy override functionality for input pills. When a pill is selected and you press copy, it will by default return the value, but it can be overridden with the `onCopyReturn` function.
@@ -15,6 +15,7 @@ var input_pill = function ($parent) { pills: [], $parent: $parent, $input: $parent.find(".input"), + copyReturnFunction: function (data) { return data.value; }, getKeyFunction: function () {}, validation: function () {}, lastUpdated: null, @@ -110,6 +111,7 @@ var input_pill = function ($parent) { if (...
Fix doc for solver in LogisticRegression Answers Authors: - Victor Lafargue (https://github.com/viclafargue) Approvers: - Dante Gama Dessavre (https://github.com/dantegd) URL:
@@ -142,12 +142,11 @@ class LogisticRegression(UniversalBase, See :ref:`verbosity-levels` for more info. l1_ratio : float or None, optional (default=None) The Elastic-Net mixing parameter, with `0 <= l1_ratio <= 1` - solver : 'qn', 'lbfgs', 'owl' (default='qn'). + solver : 'qn' (default='qn') Algorithm to use in the op...
subtitle: stpp support this is used in dash
@@ -54,6 +54,8 @@ class subtitle: data = self.wrstsegment(subdata) if self.subtype == "raw": data = self.raw(subdata) + if self.subtype == "stpp": + data = self.stpp(subdata) if self.subfix: if self.config.get("get_all_subtitles"): @@ -80,9 +82,11 @@ class subtitle: def tt(self, subdata): i = 1 - data = "" subs = subda...
Remove prefetch_related query when fetching folder children metadata [#PLAT-1116]
@@ -432,7 +432,7 @@ class OsfStorageFolder(OsfStorageFileNode, Folder): @property def is_preprint_primary(self): if hasattr(self.target, 'preprint_file') and self.target.preprint_file: - for child in self.children.all().prefetch_related('target'): + for child in self.children.all(): if getattr(child.target, 'preprint_f...
docs: fix Python extraction script I needed to import `tarfile` rather than `tar`. Closes
@@ -29,7 +29,7 @@ If you want to extract the distribution with Python, use the .. code-block:: python - import tar + import tarfile import zstandard with open("path/to/distribution.tar.zstd", "rb") as ifh:
[honggfuzz] version update New day, new code updates - they improve coverage in some benchmarks
@@ -23,14 +23,14 @@ RUN apt-get update -y && \ libblocksruntime-dev \ liblzma-dev -# Download honggfuz version 2.1 + 7c34b297d365d1f9fbfc230db7504c8aca384608 +# Download honggfuz version 2.1 + e0d47db4d0d775a3dc42120351a17c646b198beb # Set CFLAGS use honggfuzz's defaults except for -mnative which can build CPU # depend...
axis_pseudolandmarks added small arrays with 0's into both x and y_axis_pseudolandmarks to cover if statement where len(value) == 0
@@ -2072,6 +2072,7 @@ def test_plantcv_x_axis_pseudolandmarks(): # Test with debug = "plot" pcv.params.debug = "plot" _ = pcv.x_axis_pseudolandmarks(obj=obj_contour, mask=mask, img=img) + _ = pcv.x_axis_pseudolandmarks(obj=np.array([[0, 0], [0, 0]]), mask=mask, img=img) # Test with debug = None pcv.params.debug = None ...
Fix Nested field root method Makes root method in Nested field not return itself but None if the field isn't a schema
@@ -325,7 +325,7 @@ class Field(FieldABC): ret = self while hasattr(ret, 'parent') and ret.parent: ret = ret.parent - return ret + return ret if isinstance(ret, SchemaABC) else None class Raw(Field): """Field that applies no formatting or validation."""
Add repeat option for Alerters. Thanks for the patch. Closes
@@ -12,6 +12,7 @@ class Alerter: hostname = gethostname() available = False limit = 1 + repeat = 0 days = range(0, 7) times_type = "always" @@ -34,6 +35,8 @@ class Alerter: self.set_dependencies([x.strip() for x in config_options["depend"].split(",")]) if 'limit' in config_options: self.limit = int(config_options["limi...
Add me to code owners Add me to code owners.
# Generic rule for the repository. This pattern is actually the one that will # apply unless specialized by a later rule -* @ajavadia @ewinston @atilag @delapuente @diego-plan9 +* @ajavadia @ewinston @atilag @delapuente @diego-plan9 @nonhermitian # Individual folders on root directory /cmake @ajavadia @atilag @diego-pl...
Added unit tests for blacklist and whitelist Closes-Bug:
# under the License. import argparse +import atexit import os import shutil import subprocess @@ -25,6 +26,7 @@ from tempest.cmd import run from tempest.tests import base DEVNULL = open(os.devnull, 'wb') +atexit.register(DEVNULL.close) class TestTempestRun(base.TestCase): @@ -68,6 +70,34 @@ class TestTempestRun(base.Te...
Update CovidCast Fixes 3 & 4 mentioned in
@@ -6,8 +6,7 @@ nav_order: 1 # COVIDcast Epidata API -This is the documentation for accessing the Delphi's COVID-19 Surveillance -Streams (`covidcast`) endpoint of [Delphi](https://delphi.cmu.edu/)'s +This is the documentation for accessing Delphi's COVID-19 indicators, an (`covidcast`) endpoint of [Delphi](https://del...
provision: Bump provision version after clipboard package update. The provision wasn't bumped in which caused some js exceptions.
@@ -8,4 +8,4 @@ ZULIP_VERSION = "1.7.1+git" # Typically, adding a dependency only requires a minor version bump, and # removing a dependency requires a major version bump. -PROVISION_VERSION = '17.10' +PROVISION_VERSION = '17.11'
Use the version.json file generated by CircleCI Remove the logic that pull the version tag from local git repo. This is no longer needed now that the build pipeline is moved to pipeline v2.
@@ -36,13 +36,9 @@ RUN localedef -i en_US -f UTF-8 en_US.UTF-8 ENV LANG en_US.UTF-8 ENV LC_ALL en_US.UTF-8 +# version.json is overwritten by CircleCI (see circle.yml). # The pipeline v2 standard requires the existence of /app/version.json -# inside the docker image, although the content of the file comes from -# circle...
Import and Export buttons grouped with Add and Remove buttons Fixed issue where path was added after canceling "Select directory" dialog Disable Remove button when editable rows is length 0 Remove Python 2.x consideration
# Local imports from spyder.config.base import _ -from spyder.py3compat import PY2 from spyder.utils.icon_manager import ima from spyder.utils.misc import getcwd_or_home from spyder.utils.qthelpers import create_toolbutton @@ -53,6 +52,7 @@ def __init__(self, parent, path=None, read_only_path=None, self.moveup_button =...
email report enhancement move summary (passed, failed, skipped...) to the top of the email report add passed percentage to the subject of email report fixes:
@@ -1024,7 +1024,7 @@ def add_squad_analysis_to_email(session, soup): skipped_message = "--unknown--" skipped["UNASSIGNED"].append((result.nodeid, skipped_message)) - # no failed or skipped tests - exist the function + # no failed or skipped tests - exit the function if not failed and not skipped: return @@ -1044,6 +10...
you flaky piece of shit Got pwned by logging in to zhe test server.
@@ -101,7 +101,7 @@ def test_video_Movie_attrs(movies): assert [i.tag for i in movie.directors] == ['Nina Paley'] assert movie.duration >= 160000 assert movie.fields == [] - assert sorted([i.tag for i in movie.genres]) == ['Animation', 'Comedy', 'Fantasy', 'Musical'] + assert sorted([i.tag for i in movie.genres]) == ['...
Fix Add parser argument "--no-daemonize"
@@ -69,10 +69,14 @@ def abort(message, colour=RED, stream=sys.stderr): sys.exit(1) -def start(configfile): +def start(configfile, daemonize = True): write("Starting ...") args = SYNAPSE + + if daemonize: args.extend(["--daemonize", "-c", configfile]) + else: + args.extend(["-c", configfile]) try: subprocess.check_call(...
[GTK] Implement web-inspector debug support Based on the latest multi-window feature.
@@ -93,7 +93,13 @@ class BrowserView: self.webview.connect('notify::visible', self.on_webview_ready) self.webview.connect('document-load-finished', self.on_load_finish) self.webview.connect('status-bar-text-changed', self.on_status_change) + + if debug: + self.webview.props.settings.props.enable_developer_extras = True...
SceneInspector : Fix transform decomposition This was broken by the move to the imath module.
@@ -1498,7 +1498,8 @@ class __TransformSection( LocationSection ) : return matrix try : - components = dict( zip( "shrt", matrix.extractSHRT() ) ) + components = { x : imath.V3f() for x in "shrt" } + matrix.extractSHRT( components["s"], components["h"], components["r"], components["t"] ) except : # decomposition can fa...
Fix bug on participant roles table qtip Qtip is now re-initialized every time a participant is edited
$('.js-reset-role-filter').toggleClass('disabled', isInitialState); } + function initTooltip() { + $('.js-show-regforms').qtip({ + content: { + text: function() { + return $(this).data('title'); + } + }, + hide: { + delay: 100, + fixed: true + } + }); + } + global.setupEventPersonsList = function setupEventPersonsList(...
Fixes some bugs in build_crosstalk_free_model. Bugs that caused the use of float and tuples (instead of error-dicts) to not work correctly for describing the errors of the gates in a crosstalk-free model.
@@ -1070,11 +1070,12 @@ def build_crosstalk_free_model(nQubits, gate_names, error_rates, nonstd_gate_uni #tuple should have length 4^k-1 for a k-qubit gate (with dimension 4^k) assert(len(errs) + 1 == gateMx.shape[0]), \ "Invalid number of Pauli stochastic rates: got %d but expected %d" % (len(errs), gateMx.shape[0] - ...
Start network thread when actually running not loading config Closes
@@ -117,8 +117,6 @@ class SimpleMonitor: raise RuntimeError("Broken dependency configuration") if not self.verify_alerting(): module_logger.critical("No alerters defined and no remote logger found") - if self._network: - self._start_network_thread() def _start_network_thread(self) -> None: if self._remote_listening_thr...
Bug fix: backup role does not provide the listShards privilege Fixes
@@ -365,9 +365,10 @@ class Connector(threading.Thread): else: # sharded cluster while self.can_run: - - for shard_doc in retry_until_ok(self.main_conn.admin.command, - 'listShards')['shards']: + # The backup role does not provide the listShards privilege, + # so use the config.shards collection instead. + for shard_doc...
Fix for .gro file output with too many atoms. Addresses issue
@@ -100,7 +100,7 @@ class GromacsGroParser(object): atom.name = "LMP_{0}".format(atom.name) # .gro wraps at 100,0000, which is why the field is 5 width. gro.write('{0:5d}{1:<5s}{2:5s}{3:5d}'.format( - atom.residue_index, atom.residue_name, atom.name, (n + 1)%100000)) + atom.residue_index%100000, atom.residue_name, atom...
gatherkeys: ensure decoded strings are used when writing to a file Resolves: rm#39489
@@ -9,6 +9,7 @@ import time from ceph_deploy import hosts from ceph_deploy.cliutil import priority from ceph_deploy.lib import remoto +from ceph_deploy.util import as_string import ceph_deploy.util.paths.mon LOG = logging.getLogger(__name__) @@ -143,7 +144,7 @@ def gatherkeys_missing(args, distro, rlogger, keypath, key...
dark-mode: Make language settings modal compatible. This makes the language settings modal compatible with dark mode by making the background color dark.
-<div id="default_language_modal" class="modal hide" tabindex="-1" role="dialog" +<div id="default_language_modal" class="modal hide modal-bg" tabindex="-1" role="dialog" aria-labelledby="default_language_modal_label" aria-hidden="true"> <div class="modal-header"> <button type="button" class="close" data-dismiss="modal...
Update attrib_to_hide_files.yml Adding dest
@@ -39,7 +39,7 @@ detect: search: '| tstats `security_content_summariesonly` count min(_time) values(Processes.process) as process max(_time) as lastTime from datamodel=Endpoint.Processes where Processes.process_name=attrib.exe (Processes.process=*+h*) by Processes.parent_process - Processes.process_name Processes.user...