code stringlengths 122 4.99k | label int64 0 14 |
|---|---|
diff --git a/src/components/Main/PlotAgeAndParams.tsx b/src/components/Main/PlotAgeAndParams.tsx @@ -18,13 +18,14 @@ export default function AgePlot( {data, rates}: SimProps ) {
const ages = Object.keys(params.ageDistribution).map(x => x);
const agesFrac = ages.map(x => params.ageDistribution[x]);
- var probSevere = ra... | 1 |
diff --git a/webaverse.js b/webaverse.js @@ -573,56 +573,7 @@ const _startHacks = () => {
}
}; */
window.addEventListener('keydown', e => {
- if (e.which === 219) { // [
- if (localPlayer.avatar) {
- (async () => {
- const audioUrl = '/sounds/pissbaby.mp3';
- // const audioUrl2 = '/sounds/music.mp3';
-
- const _loadAud... | 2 |
diff --git a/articles/appliance/extensions.md b/articles/appliance/extensions.md @@ -6,7 +6,7 @@ description: Explains implementation details for Extensions specific to the Auth
# Auth0 Appliance: Extensions
-In many ways, using [Extensions](/extensions) in the Appliance requires the same configuration steps as in the ... | 0 |
diff --git a/environment/core/Halite.cpp b/environment/core/Halite.cpp @@ -573,7 +573,21 @@ auto collision_time(
const auto disc = std::pow(b, 2) - 4 * a * c;
- if (disc == 0) {
+ if (a == 0.0) {
+ if (b == 0.0) {
+ if (c <= 0.0) {
+ // Implies r^2 >= dx^2 + dy^2 and the two are already colliding
+ return { true, 0.0 }... | 9 |
diff --git a/src/Output.js b/src/Output.js @@ -323,8 +323,8 @@ export class Output extends EventEmitter {
* [Manufacturer ID Numbers](https://www.midi.org/specifications-old/item/manufacturer-id-numbers)
* .
*
- * @param [data=number[]] {number[]|Uint8Array} A Uint8Array or an array of unsigned integers
- * between 0 a... | 11 |
diff --git a/docs/introduction/javascript-events-dom-apis.md b/docs/introduction/javascript-events-dom-apis.md @@ -70,7 +70,7 @@ Components encapsulate all of our code to be reusable, declarative, and
shareable. Though if we're just poking around at runtime, we can use our
browser's Developer Tools Console to run JavaS... | 1 |
diff --git a/test/functional/specs/C14407.js b/test/functional/specs/C14407.js import { t, ClientFunction } from "testcafe";
import createNetworkLogger from "../helpers/networkLogger";
-import getResponseBody from "../helpers/networkLogger/getResponseBody";
import fixtureFactory from "../helpers/fixtureFactory";
import... | 3 |
diff --git a/tests/2_alerting.js b/tests/2_alerting.js @@ -35,7 +35,7 @@ var chaiSubset = require('chai-subset');
chai.use(chaiSubset);
var expect = chai.expect;
-let asyncTimeout = 2000000;
+let asyncTimeout = 20000;
global.EXTERNAL_VERSION_FOR_TEST = "0.0.1";
global.EXTERNAL_CONFIG_FILE = "tests/config.test.yml";
| 12 |
diff --git a/packages/gatsby-source-shopify/src/gatsby-node.ts b/packages/gatsby-source-shopify/src/gatsby-node.ts @@ -43,7 +43,7 @@ export function pluginOptionsSchema({
.default([])
.items(Joi.string().valid(`orders`, `collections`)),
salesChannel: Joi.string().default(
- process.env.GATSBY_SHOPIFY_SALES_CHANNEL
+ pr... | 12 |
diff --git a/src/og/input/KeyboardHandler.js b/src/og/input/KeyboardHandler.js @@ -20,8 +20,8 @@ const KeyboardHandler = function () {
} else {
KeyboardHandler.prototype._instance = this;
- document.onkeydown = function (event) { _event = event; _active && _that.handleKeyDown.call(_that) };
- document.onkeyup = functio... | 0 |
diff --git a/token-metadata/0x554FFc77F4251a9fB3c0E3590a6a205f8d4e067D/metadata.json b/token-metadata/0x554FFc77F4251a9fB3c0E3590a6a205f8d4e067D/metadata.json "symbol": "ZMN",
"address": "0x554FFc77F4251a9fB3c0E3590a6a205f8d4e067D",
"decimals": 18,
- "dharmaVerificationStatus": {
"dharmaVerificationStatus": "VERIFIED"
... | 3 |
diff --git a/src/resources/views/crud/fields/repeatable.blade.php b/src/resources/views/crud/fields/repeatable.blade.php if (values != null) {
// set the value on field inputs, based on the JSON in the hidden input
new_field_group.find('input, select, textarea').each(function () {
- if ($(this).data('repeatable-input-n... | 9 |
diff --git a/generators/database-changelog-liquibase/index.js b/generators/database-changelog-liquibase/index.js @@ -233,32 +233,18 @@ module.exports = class extends BaseGenerator {
_loadColumnType(entity, field) {
const columnType = field.columnType;
- if (
- columnType === 'integer' ||
- columnType === 'bigint' ||
- ... | 7 |
diff --git a/node-red-viseo-storage-plugin/projects/Project.js b/node-red-viseo-storage-plugin/projects/Project.js @@ -59,7 +59,7 @@ function getGitUser(user) {
function Project(path) {
this.flowPath = path;
- this.packageDir = settings.packageDir || '';
+ this.packageDir = settings.editorTheme.projects.packageDir || '... | 12 |
diff --git a/lib/keyboard_utils.coffee b/lib/keyboard_utils.coffee @@ -23,7 +23,6 @@ KeyboardUtils =
key = event.code
# Strip some standard prefixes.
key = key[3..] if key[...3] == "Key"
- key = key[5..] if key[...5] == "Digit"
key = key[6..] if key[...6] == "Numpad"
# Translate some special keys to event.key-like stri... | 9 |
diff --git a/src/traces/funnel/plot.js b/src/traces/funnel/plot.js @@ -89,8 +89,6 @@ function plotConnectorLines(gd, plotinfo, cdModule, traceLayer) {
var isHorizontal = (trace.orientation === 'h');
- if(!plotinfo.isRangePlot) cd0.node3 = plotGroup;
-
var connectors = group.selectAll('g.line').data(Lib.identity);
conne... | 2 |
diff --git a/tests/test_IssuanceController.py b/tests/test_IssuanceController.py @@ -31,10 +31,6 @@ class TestIssuanceController(HavvenTestCase):
@classmethod
def deployContracts(cls):
sources = [
- "contracts/Owned.sol",
- "contracts/SelfDestructible.sol",
- "contracts/Pausable.sol",
- "contracts/SafeDecimalMath.sol",... | 2 |
diff --git a/templates/winter.svelte b/templates/winter.svelte </script>
<style>
+ :global(html) {
+ height: 100%;
+ }
+
+ :global(body) {
+ min-height: 100%;
+ }
+
.sidenav {
padding: 1rem 0 1rem 0.75rem;
}
}
.body-inner {
+ min-height: 100vh;
background-color: #fafafa;
}
| 12 |
diff --git a/packages/saltcorn-markup/helpers.js b/packages/saltcorn-markup/helpers.js @@ -65,14 +65,16 @@ const pagination = ({
const search_bar = (
name,
v,
- { placeHolder, has_dropdown, contents, badges, stateField } = {}
+ { placeHolder, has_dropdown, contents, badges, stateField, onClick } = {}
) => {
const rndid... | 11 |
diff --git a/package.json b/package.json "lint": "eslint --ignore-path .gitignore .",
"test:unit": "jest -c test/lib/unit.config.js",
"test:e2e": "jest -c test/lib/integration.config.js --testRegex 'e2e.js' --runInBand",
- "test:current": "jest test-results.e2e.js -c test/lib/integration.config.js --testRegex 'e2e.js'"... | 2 |
diff --git a/packages/node_modules/@node-red/editor-client/src/js/ui/editors/code-editors/monaco.js b/packages/node_modules/@node-red/editor-client/src/js/ui/editors/code-editors/monaco.js @@ -148,6 +148,20 @@ RED.editor.codeEditor.monaco = (function() {
function init(options) {
+
+ //Handles "Uncaught (in promise) Can... | 9 |
diff --git a/articles/protocols/saml/saml-apps/index.md b/articles/protocols/saml/saml-apps/index.md @@ -16,17 +16,17 @@ classes: topic-page
## SAML Configuration Tutorials
<%= include('../../../_includes/_topic-links', { links: [
- '/protocols/saml/saml-apps/cisco-webex',
- '/protocols/saml/saml-apps/datadog',
- '/pro... | 2 |
diff --git a/server/game/cards/02.1-TtB/BastardDaughter.js b/server/game/cards/02.1-TtB/BastardDaughter.js @@ -4,10 +4,7 @@ class BastardDaughter extends DrawCard {
setupCardAbilities() {
this.interrupt({
when: {
- onCharacterKilled: event => (
- this.controller === event.card.controller &&
- (event.card === this || ev... | 11 |
diff --git a/nodejs/lib/util/http.ts b/nodejs/lib/util/http.ts @@ -94,14 +94,14 @@ const Http: typeof IHttp = class {
if(currentFallback) {
if(currentFallback.validUntil > Date.now()) {
/* Use stored fallback */
- Http.doUri(method, rest, uriFromHost(currentFallback.host), headers, body, params, (err?: ErrnoException |... | 1 |
diff --git a/voicer.js b/voicer.js +import Avatar from './avatars/avatars.js';
+
function weightedRandom(weights) {
var totalWeight = 0,
i, random;
@@ -20,7 +22,7 @@ function weightedRandom(weights) {
}
class Voicer {
- constructor(audios) {
+ constructor(audios, player) {
this.voices = audios.map(audio => {
return {
a... | 0 |
diff --git a/data.js b/data.js @@ -1139,6 +1139,14 @@ module.exports = [{
url: "http://agnostic.github.io/LocalDB.js",
source: "https://raw.githubusercontent.com/Agnostic/LocalDB.js/master/src/LocalDB.js"
},
+ {
+ name: "mess-js",
+ github: "graciano/mess",
+ tags: ["message", "toast", "toasts", "android", "dialog", "i... | 0 |
diff --git a/layouts/_default/single.html b/layouts/_default/single.html footer fragment, the local one is rendered.
*/}}
{{ $global := .Site.GetPage "page" "global" }}
- {{ $global_fragments := $global.Resources.ByType "page" }}
+ {{ $.Scratch.Delete "global_fragments" }}
+ {{ if $global }}
+ {{ $.Scratch.Set "global_... | 0 |
diff --git a/src/components/Card/Card.styles.js b/src/components/Card/Card.styles.js @@ -8,6 +8,7 @@ import type { ComponentType } from 'react';
export const HalfCard: ComponentType<*> =
styled
.div`
+ display: grid;
flex: 1 1 43%;
padding: 20px 20px 0 20px;
border: 1px #f3f2f1 solid;
@@ -78,6 +79,7 @@ export const Hal... | 7 |
diff --git a/js/keybindings.js b/js/keybindings.js @@ -113,20 +113,36 @@ ipc.on('goForward', function () {
} catch (e) { }
})
+function defineShortcut (keyMapName, fn) {
+ Mousetrap.bind(keyMap[keyMapName], function (e, combo) {
+ // mod+left and mod+right are also text editing shortcuts, so they should not run when an... | 8 |
diff --git a/extras/build/utils/index.js b/extras/build/utils/index.js @@ -118,6 +118,19 @@ const decoders = {
}
}
+function getAttributesAsStyle (el) {
+ const exceptions = ['d', 'style', 'width', 'height', 'rx', 'ry', 'r', 'x', 'y', 'x1', 'y1', 'x2', 'y2', 'cx', 'cy', 'points', 'class', 'xmlns', 'viewBox', 'id', 'nam... | 1 |
diff --git a/edit.js b/edit.js @@ -1015,6 +1015,7 @@ const [
marchingCubes: methodIndex++,
bakeGeometry: methodIndex++,
chunk: methodIndex++,
+ releaseUpdate: methodIndex++,
};
let messageIndex = 0;
const MESSAGES = {
@@ -1169,7 +1170,11 @@ const [
indicesCount,
skyLightsCount,
torchLightsCount,
- })
+ });
+ }
+ {
+ co... | 0 |
diff --git a/src/core/viewports/viewport.js b/src/core/viewports/viewport.js @@ -132,16 +132,13 @@ export default class Viewport {
this.meterOffset = modelMatrix ? modelMatrix.transformVector(position) : position;
}
+ this.viewMatrixUncentered = viewMatrix;
+
+ if (this.isGeospatial) {
// Determine camera center
- this... | 2 |
diff --git a/token-metadata/0x37E808F084101F75783612407e7C3f5F92d8ee3F/metadata.json b/token-metadata/0x37E808F084101F75783612407e7C3f5F92d8ee3F/metadata.json "symbol": "RI",
"address": "0x37E808F084101F75783612407e7C3f5F92d8ee3F",
"decimals": 18,
- "dharmaVerificationStatus": {
"dharmaVerificationStatus": "VERIFIED"
}... | 3 |
diff --git a/README.md b/README.md @@ -22,18 +22,18 @@ Installation
## Prerequisites
-- Python. Kotlinlang is [Flask](http://flask.pocoo.org/)-based site, so you'll need python 3 to get it working.
-- ruby + [kramdown](http://kramdown.gettalong.org/installation.html). Python has a very poor support for markdown, so kra... | 7 |
diff --git a/src/components/colorbar/draw.js b/src/components/colorbar/draw.js @@ -224,15 +224,15 @@ function drawColorBar(g, opts, gd) {
var uFrac = optsX - thickFrac * ({center: 0.5, right: 1}[xanchor] || 0);
// y positioning we can do correctly from the start
- var yBottomFrac = optsY + lenFrac * (({top: -0.5, botto... | 10 |
diff --git a/app/src/components/MeetingDrawer/Chat/List/List.js b/app/src/components/MeetingDrawer/Chat/List/List.js @@ -19,7 +19,24 @@ const styles = (theme) =>
alignItems : 'center',
overflowY : 'auto',
padding : theme.spacing(1)
+ },
+ '@global' : {
+ '*' : {
+ 'scrollbar-width' : 'thin'
+ },
+ '*::-webkit-scrollbar... | 7 |
diff --git a/src/components/nodes/task/setupCompensationMarker.js b/src/components/nodes/task/setupCompensationMarker.js @@ -3,5 +3,7 @@ import compensationIcon from '@/assets/compensation.svg';
export default function setupCompensationMarker(nodeDefinition, markers, $set) {
if (nodeDefinition.isForCompensation) {
$set... | 2 |
diff --git a/generators/ci-cd/templates/_.gitlab-ci.yml b/generators/ci-cd/templates/_.gitlab-ci.yml @@ -59,7 +59,7 @@ gradle-build:
stage: build
script:
- ./gradlew compileJava -x test -PnodeInstall --no-daemon
-gradle-check:
+gradle-test:
stage: test
script:
- ./gradlew test -PnodeInstall --no-daemon
| 4 |
diff --git a/sirepo/package_data/static/js/radia.js b/sirepo/package_data/static/js/radia.js @@ -1261,7 +1261,7 @@ SIREPO.app.directive('dmpImportDialog', function(appState, fileManager, fileUplo
let a = inputFile.name.split('.');
let t = `${a[a.length - 1]}`;
if (RADIA_IMPORT_FORMATS.indexOf(`.${t}`) >= 0) {
- data = ... | 10 |
diff --git a/app/models/carto/visualization.rb b/app/models/carto/visualization.rb @@ -519,7 +519,6 @@ class Carto::Visualization < ActiveRecord::Base
# deal with all the different the cases internally.
# See https://github.com/CartoDB/cartodb/pull/9678
def non_mapcapped
- return self if id.blank?
persisted? ? self : C... | 2 |
diff --git a/src/electron.js b/src/electron.js @@ -1401,7 +1401,7 @@ function checkForUpdates() {
}
-function getLatestUpdate(version) {
+getLatestUpdate = async (version) => {
try {
console.log("Downloading update from: " + version.downloadURL)
const fs = require('fs');
@@ -1416,32 +1416,36 @@ function getLatestUpdate... | 7 |
diff --git a/util.js b/util.js @@ -1019,6 +1019,37 @@ export const loadImage = u => new Promise((resolve, reject) => {
img.crossOrigin = 'Anonymous';
img.src = u;
});
+export const drawImageContain = (ctx, img) => {
+ const imgWidth = img.width;
+ const imgHeight = img.height;
+ const canvasWidth = ctx.canvas.width;
+ ... | 0 |
diff --git a/stories/module-pagespeed-insights-settings.stories.js b/stories/module-pagespeed-insights-settings.stories.js @@ -32,8 +32,6 @@ import { removeAllFilters, addFilter } from '@wordpress/hooks';
import SettingsModule from '../assets/js/components/settings/settings-module';
import { SettingsMain as PageSpeedIn... | 2 |
diff --git a/shows/250 - scott teaches wes.md b/shows/250 - scott teaches wes.md @@ -26,8 +26,8 @@ Build modern JAMStack websites in minutes. Stackbit lets you combine any theme,
07:57 - Svelte 101
* .svelte files
-* Files can include <script>, <style>, and straight-up CSS
-* Variables are used in templates via {var} -... | 3 |
diff --git a/package.json b/package.json {
"name": "prettier-atom",
"main": "./dist/main.js",
- "version": "0.60.0",
+ "version": "0.60.1",
"description": "Atom plugin for formatting JavaScript using prettier with (optional) prettier-eslint integration",
"keywords": [
"atom",
| 6 |
diff --git a/light.js b/light.js @@ -467,6 +467,8 @@ function prepareLinkProofs(arrUnits, callbacks){
return callbacks.ifError("no units array");
if (arrUnits.length === 1)
return callbacks.ifError("chain of one element");
+ mutex.lock(['prepareLinkProofs'], function(unlock){
+ var start_ts = Date.now();
var arrChain =... | 6 |
diff --git a/src/components/bio.js b/src/components/bio.js @@ -12,7 +12,11 @@ const Bio = () => {
>
<p>
Learn JavaScript fundamentals through fun and
- challenging quizzes!
+ challenging quizzes!{' '}
+ <a href="https://github.com/nas5w/typeofnan-javascript-quizzes">
+ Star this repo on Github
+ </a>{' '}
+ to follow a... | 0 |
diff --git a/CHANGELOG.md b/CHANGELOG.md @@ -116,6 +116,8 @@ What we need to do to release Uppy 1.0
- [ ] tus: add `filename` and `filetype`, so that tus servers knows what headers to set https://github.com/tus/tus-js-client/commit/ebc5189eac35956c9f975ead26de90c896dbe360
- [ ] core: look into utilizing https://github.... | 0 |
diff --git a/src/libs/NetworkConnection.js b/src/libs/NetworkConnection.js @@ -13,6 +13,7 @@ import CONST from '../CONST';
let unsubscribeFromNetInfo;
let unsubscribeFromAppState;
let isOffline = false;
+let hasPendingNetworkCheck = true;
// Holds all of the callbacks that need to be triggered when the network reconnec... | 14 |
diff --git a/tests/app-launcher/app-launcher.test.jsx b/tests/app-launcher/app-launcher.test.jsx @@ -158,29 +158,29 @@ describe('SLDS APP LAUNCHER *******************************************', () =>
it('renders all App Launcher dots', () => {
expect(handles.appLauncherIcon.find('.slds-icon-waffle').containsAllMatchingE... | 1 |
diff --git a/src/components/Deployments.jsx b/src/components/Deployments.jsx @@ -46,18 +46,7 @@ export default function Deployments({ data, location }) {
setLoading(false)
}, [])
- const getAquariusVersion = async (url) => {
- if (!url) return
- try {
- const data = await fetch(url)
- const { version } = await data.jso... | 7 |
diff --git a/lib/shared/addon/components/cluster-driver/driver-googlegke/template.hbs b/lib/shared/addon/components/cluster-driver/driver-googlegke/template.hbs <div class="form-control-static">
<label class="hand">
{{radio-button
- selection=config.noStackdriverLogging
- value=false
+ selection=config.enableStackdrive... | 10 |
diff --git a/src/components/profile/ProfileDataTable.js b/src/components/profile/ProfileDataTable.js @@ -32,17 +32,17 @@ const ProfileDataTable = ({
const phoneMeta = showCustomFlag && profile.mobile && parsePhoneNumberFromString(profile.mobile)
const countryFlagUrl = useCountryFlagUrl(phoneMeta && phoneMeta.country)
-... | 0 |
diff --git a/src/server/views/widget/page_alerts.html b/src/server/views/widget/page_alerts.html {% endif %}
{% if redirectFrom or req.query.renamed or req.query.redirectFrom %}
+ <div class="alert alert-info py-3 px-4 d-flex align-items-center justify-content-between">
<span>
{% set fromPath = req.query.renamed or req... | 14 |
diff --git a/core/server/api/canary/posts.js b/core/server/api/canary/posts.js const models = require('../../models');
-const i18n = require('../../../shared/i18n');
+const tpl = require('@tryghost/tpl');
const errors = require('@tryghost/errors');
const getPostServiceInstance = require('../../services/posts/posts-serv... | 14 |
diff --git a/edit.js b/edit.js @@ -5336,41 +5336,21 @@ const _makeInventoryContentsMesh = () => {
return mesh;
};
const _makeInventoryBuildsMesh = () => {
- return new THREE.Object3D();
- /* const boxMesh = new THREE.BoxBufferGeometry()
- const coneMesh = new THREE.ConeBufferGeometry();
- const cylinderMesh = new THREE... | 0 |
diff --git a/src/encoded/tests/data/inserts/user.json b/src/encoded/tests/data/inserts/user.json "ENCORE"
],
"uuid": "473a72c0-6f20-4f81-9093-198e92fee470"
+ },
+ {
+ "email": "emmao@stanford.edu",
+ "first_name": "Emma",
+ "groups": [
+ "admin"
+ ],
+ "job_title": "Software Developer",
+ "lab": "/labs/j-michael-cherry... | 0 |
diff --git a/lib/interceptor.js b/lib/interceptor.js @@ -318,10 +318,11 @@ Interceptor.prototype.match = function match(options, body, hostNameOnly) {
// special logger for query()
if (queryIndex !== -1) {
- this.scope.logger('matching ' + matchKey + '?' + queryString + ' to ' + this._key +
- ' with query(' + stringify... | 7 |
diff --git a/src/effects/transcripts/fetch.js b/src/effects/transcripts/fetch.js -import { get, last, find, isNumber } from 'lodash'
+import { get, last, find, isNumber, endsWith } from 'lodash'
import { compose, map, concat, orderBy, reduce } from 'lodash/fp'
import request from 'utils/request'
@@ -17,7 +17,7 @@ const... | 1 |
diff --git a/docs/data_preparation.rst b/docs/data_preparation.rst @@ -589,8 +589,8 @@ HiGlass expects each zoom level to be stored at a location named ``resolutions/{
Multivec Files
--------------
-Multivec files store arrays of arrays organized by chromosome. To aggregate this
-data, we need an input file where chrom... | 3 |
diff --git a/src/components/LiveStrategyExecutor/LiveStrategyExecutor.container.js b/src/components/LiveStrategyExecutor/LiveStrategyExecutor.container.js @@ -5,6 +5,7 @@ import { getMarkets } from '../../redux/selectors/meta'
const mapStateToProps = (state = {}) => ({
allMarkets: getMarkets(state),
+ strategyContent: ... | 3 |
diff --git a/packages/node_modules/@node-red/editor-client/src/js/ui/subflow.js b/packages/node_modules/@node-red/editor-client/src/js/ui/subflow.js @@ -1381,7 +1381,8 @@ RED.subflow = (function() {
}
}
if (ui.type !== "checkbox") {
- $('<span>').css({"padding-left":"5px"}).text(labelText).appendTo(label);
+ var css = ... | 2 |
diff --git a/src/transactions/views/NFTTimeline.vue b/src/transactions/views/NFTTimeline.vue @@ -159,7 +159,7 @@ export default {
)
},
fromAddress() {
- return this.item.tx.from
+ return this.accountItem(this.accountId)?.addresses[0]
},
accountId() {
return this.item.nft.accountId || this.item.accountId
| 3 |
diff --git a/tests/e2e/specs/modules/pagespeed-insights/activation.test.js b/tests/e2e/specs/modules/pagespeed-insights/activation.test.js @@ -38,11 +38,27 @@ describe( 'PageSpeed Insights Activation', () => {
await resetSiteKit();
} );
- it( 'leads you to the Site Kit dashboard after activation', async () => {
+ it( '... | 3 |
diff --git a/js/monogatari.js b/js/monogatari.js @@ -2292,7 +2292,11 @@ $_ready(function () {
// The typeof check, is to see if the character actually exists, if it does not, then it is
// treated as a normal work and the narrator is used to show the dialog
if (character.length > 1 && typeof characters[character[0]] !=... | 11 |
diff --git a/app.rb b/app.rb @@ -103,7 +103,7 @@ get '/launches/latest' do
content_type :json
collection = client[:launch]
hash = collection.find({}, projection: {_id: 0}).sort({"flight_number": -1}).limit(1)
- JSON.pretty_generate(hash.to_a[0])
+ JSON.pretty_generate(hash.to_a)
end
####################################... | 13 |
diff --git a/src/Select.js b/src/Select.js @@ -15,23 +15,20 @@ class Select extends Component {
handleChange(event) {
const { onChange } = this.props;
- if (onChange) onChange(event);
+ let value = event.target.value;
- this.setState({ value: event.target.value });
+ if (this.props.multiple) {
+ value = this.instance.g... | 1 |
diff --git a/src/live_view/live_view_server.js b/src/live_view/live_view_server.js @@ -14,6 +14,9 @@ const writeFile = promisify(fs.writeFile);
const unlink = promisify(fs.unlink);
const ensureDir = promisify(fs.ensureDir);
+const LOCAL_STORAGE_DIR = process.env[ENV_VARS.LOCAL_STORAGE_DIR] || '';
+const DEFAULT_SCREENS... | 5 |
diff --git a/bot/src/discord_commands/quiz.js b/bot/src/discord_commands/quiz.js @@ -328,8 +328,8 @@ function getTimeString(timestamp) {
function sendSaveMementos(msg, currentSaveMementos, recyclingBinMementos, extraContent) {
const prefix = msg.prefix;
const embed = {
- title: 'Available Saves',
- footer: { icon_url: ... | 7 |
diff --git a/packages/component-library/src/Header/FullNav.js b/packages/component-library/src/Header/FullNav.js @@ -82,10 +82,6 @@ const menuButton = css`
padding: 0;
color: inherit;
cursor: pointer;
-
- :focus {
- outline: none;
- }
`;
const buttonText = css`
@@ -153,7 +149,7 @@ const FullNav = props => {
return (
<d... | 7 |
diff --git a/app/src/scripts/upload/upload.js b/app/src/scripts/upload/upload.js @@ -156,7 +156,7 @@ export default {
metadata.authors.push({ name: author, ORCIDID: '' })
}
}
- scitran.updateProject(projectId, { metadata }, () => {
+ scitran.updateProject(projectId, { metadata }).then(() => {
let file = new File(
[JSON... | 1 |
diff --git a/packages/app/src/components/PageEditor.tsx b/packages/app/src/components/PageEditor.tsx @@ -85,35 +85,29 @@ const PageEditor = React.memo((props: Props): JSX.Element => {
// pageContainer, editorContainer,
// } = props;
+ const { data: pageId } = useCurrentPageId();
+ const { data: currentPagePath } = useC... | 7 |
diff --git a/404.html b/404.html @@ -5,10 +5,10 @@ layout: default
<div class="ui two column centered grid xo margin top bottom fivefold">
<div class="center aligned column">
- <img class="ui centered medium image xo padding top bottom" src="/assets/img/diybio-octocat.png"></a>
+ <img class="ui centered medium image xo... | 0 |
diff --git a/app/features/flex.js b/app/features/flex.js @@ -35,7 +35,10 @@ export function Flex({selection}) {
let selectedNodes = selection()
, keys = handler.key.split('+')
- changeDirection(selectedNodes, keys.includes('left') ? 'row' : 'column')
+ if (keys.includes('left') || keys.includes('right'))
+ changeDirect... | 7 |
diff --git a/articles/email/providers.md b/articles/email/providers.md @@ -129,10 +129,11 @@ The [Email Activity](https://sendgrid.com/logs/index) page in SendGrid will now
## Configure a Custom SMTP Server for Sending Email
-You can use your own SMTP server to send email. There are two requirements for the SMTP server... | 0 |
diff --git a/templates/osaka/index.html b/templates/osaka/index.html name="viewport"
content="width=device-width, initial-scale=1.0, maximum-scale=1.0"
/>
+ <style>
+ body {
+ height: 100%;
+ min-height: 100%;
+ }
+ </style>
</head>
<body>
<div id="root"></div>
| 12 |
diff --git a/generators/server/templates/pom.xml.ejs b/generators/server/templates/pom.xml.ejs <goals>
<goal>yarn</goal>
</goals>
- <configuration>
- <arguments>install</arguments>
- </configuration>
</execution>
<%_ } else if (clientPackageManager === 'npm') { _%>
<execution>
<goals>
<goal>npm</goal>
</goals>
- <confi... | 2 |
diff --git a/docs/src/pages/vue-components/table.md b/docs/src/pages/vue-components/table.md @@ -99,7 +99,7 @@ columns: [ // array of Objects
<doc-example title="Dense" file="QTable/Dense" />
::: tip
-You can use the `dense` prop along with `$q.screen` to create a responsive behavior. Example: `:dense="$q.screen.lt.md`... | 1 |
diff --git a/public/javascripts/LabelMap.js b/public/javascripts/LabelMap.js @@ -112,8 +112,6 @@ function LabelMap(_, $, map, params) {
});
}
-
-
/**
* This function queries the streets that the user audited and visualize them as segments on the map.
*/
@@ -298,7 +296,7 @@ function LabelMap(_, $, map, params) {
}
}
-
+... | 3 |
diff --git a/source/shaders/ibl_filtering.frag b/source/shaders/ibl_filtering.frag @@ -179,16 +179,27 @@ float D_Charlie(float sheenRoughness, float NdotH)
return (2.0 + invR) * pow(sin2h, invR * 0.5) / (2.0 * MATH_PI);
}
-float PDF(vec3 H, vec3 N, float roughness)
+// GGX microfacet distribution
+// https://www.cs.cor... | 4 |
diff --git a/src/core/operations/GenerateRSAKeyPair.mjs b/src/core/operations/GenerateRSAKeyPair.mjs /**
* @author gchq77703 []
* @copyright Crown Copyright 2018
- ` * @license Apache-2.0
+ * @license Apache-2.0
*/
import Operation from "../Operation";
import forge from "node-forge/dist/forge.min.js";
-import PrimeWork... | 1 |
diff --git a/app/models/audit/AuditTaskTable.scala b/app/models/audit/AuditTaskTable.scala @@ -517,14 +517,19 @@ object AuditTaskTable {
| street.x2,
| street.y2,
| street.timestamp,
- | street_count.completion_count,
+ | COALESCE(task.completion_count, 0),
| audit_task.completed
| FROM sidewalk.region
|INNER JOIN side... | 14 |
diff --git a/generators/entity-client/templates/common/src/test/javascript/cypress/integration/entity/entity.spec.ts.ejs b/generators/entity-client/templates/common/src/test/javascript/cypress/integration/entity/entity.spec.ts.ejs @@ -166,10 +166,7 @@ describe('<%= entityClass %> e2e test', () => {
<%_ } else if (field... | 1 |
diff --git a/public/javascripts/InitializeSubmittedLabels.js b/public/javascripts/InitializeSubmittedLabels.js function InitializeSubmittedLabels(map, self, url, params) {
$.getJSON(url, function (data) {
- var auditedStreetColor = params.choroplethType === 'labelMap' ? 'black' : 'rgba(128, 128, 128, 1.0)';
+ var audit... | 11 |
diff --git a/lib/hooks/helpers/private/load-helpers.js b/lib/hooks/helpers/private/load-helpers.js @@ -63,6 +63,7 @@ module.exports = function loadHelpers(sails, done) {
throw flaverr({
code: 'E_FAILED_TO_BUILD_CALLABLE',
identity: helperDef.identity,
+ loadedFrom: identity,
raw: err
}, err);
}
@@ -74,7 +75,7 @@ module... | 7 |
diff --git a/lib/plugins/output-filter/docker-log-enrichment.js b/lib/plugins/output-filter/docker-log-enrichment.js @@ -63,7 +63,7 @@ module.exports = function enrichDockerLogs (context, config, eventEmitter, data,
name: context.container_name,
image: {
name: imageName,
- version: imageVersion
+ tag: imageVersion
},
h... | 10 |
diff --git a/articles/connections/index.md b/articles/connections/index.md @@ -3,62 +3,6 @@ url: /identityproviders
description: Auth0 is an identity hub that supports the many authentication providers listed here.
---
-<style>
-.connections-container {
- display: flex;
- justify-content: space-between;
- flex-wrap: wr... | 2 |
diff --git a/lib/windshaft/renderers/pg_mvt/factory.js b/lib/windshaft/renderers/pg_mvt/factory.js @@ -97,143 +97,9 @@ PgMvtFactory.prototype = {
_.extend(dbParams, mapConfig.getLayerDatasource(layer));
var pgSQL = sql(dbParams, this.sqlClass);
- // TODO we don't really need such params
- fetchMapConfigAttributes(pgSQL... | 8 |
diff --git a/public/javascripts/SVValidate/mobile/mobileValidate.css b/public/javascripts/SVValidate/mobile/mobileValidate.css .validation-button {
height: 70px;
background-color: white;
- margin-right: 2px;
- border-radius: 5px;
- border-width: 2px;
- border-color: lightgrey;
- width: 243px;
+ border-radius: 25px;
+ b... | 7 |
diff --git a/articles/appliance/cli/configure-cli.md b/articles/appliance/cli/configure-cli.md @@ -36,6 +36,37 @@ Usage: a0cli [options] <command>
-p, --port <number> Port number of appliance instance. Default port: 10121
```
+However, if you have keys defined and you've run `update-commands`, you will see an extended ... | 0 |
diff --git a/core/worker/lib/subpipeline/subpipeline.js b/core/worker/lib/subpipeline/subpipeline.js @@ -154,7 +154,8 @@ class SubPipelineHandler {
algoRunnerCommunication.send({
command: messages.outgoing.subPipelineStopped,
data: {
- subPipelineId
+ subPipelineId,
+ reason: result.reason
}
});
}
| 7 |
diff --git a/app/core/router.js b/app/core/router.js @@ -18,6 +18,7 @@ var beforeUnloads = {};
export default Backbone.Router.extend({
routes: {},
+ originalPageTitle: window.document.title,
beforeUnload: function (name, fn) {
beforeUnloads[name] = fn;
@@ -44,6 +45,17 @@ export default Backbone.Router.extend({
if (cont... | 3 |
diff --git a/runtime.js b/runtime.js @@ -7,6 +7,7 @@ import {VOXLoader} from './VOXLoader.js';
// import {GLTFExporter} from './GLTFExporter.js';
import {getExt, mergeMeshes} from './util.js';
// import {bake} from './bakeUtils.js';
+// import geometryManager from './geometry-manager.js';
import {rigManager} from './ri... | 0 |
diff --git a/src/modules/auth/actions/login-with-metamask.js b/src/modules/auth/actions/login-with-metamask.js @@ -12,15 +12,32 @@ export const loginWithMetaMask = (callback = logError) => dispatch => {
dispatch(useUnlockedAccount(account));
callback(null, account);
};
+
+ if (!windowRef.ethereum || !windowRef.ethereum... | 4 |
diff --git a/sparta_main.go b/sparta_main.go @@ -423,10 +423,12 @@ func MainEx(serviceName string,
return validateErr
}
// Format?
+ prettyHeader := false
var formatter logrus.Formatter
switch OptionsGlobal.LogFormat {
case "text", "txt":
formatter = &logrus.TextFormatter{}
+ prettyHeader = true
case "json":
formatter ... | 0 |
diff --git a/kamu/common_settings.py b/kamu/common_settings.py @@ -76,7 +76,6 @@ STATICFILES_DIRS = [
WEBPACK_LOADER = {
'DEFAULT': {
'BUNDLE_DIR_NAME': 'bundles/',
- 'STATS_FILE': os.path.join(BASE_DIR, 'webpack-stats.json'),
'IGNORE': []
}
}
| 2 |
diff --git a/backend/columnar.js b/backend/columnar.js @@ -734,6 +734,7 @@ function encodeChange(changeObj) {
}
function decodeChangeColumns(buffer) {
+ if (buffer[8] === CHUNK_TYPE_DEFLATE) buffer = inflateChange(buffer)
const decoder = new Decoder(buffer)
const header = decodeContainerHeader(decoder, true)
const chun... | 11 |
diff --git a/test/functional/localConfig.json b/test/functional/localConfig.json "desktop": {
"testsFolder": "test/functional/specs/desktop/",
"browser": [
- "chrome"
+ "chrome", "safari"
],
"saucelabs": [
"saucelabs:Chrome@74.0:OS X 10.10"
"testClass": "",
"testName": "",
"skipCriticalConsoleJsErrors": true,
- "quaran... | 13 |
diff --git a/web-stories.php b/web-stories.php * Plugin URI: https://wp.stories.google/
* Author: Google
* Author URI: https://opensource.google.com/
- * Version: 1.5.0-alpha
+ * Version: 1.5.0-rc.1
* Requires at least: 5.3
* Requires PHP: 5.6
* Text Domain: web-stories
@@ -40,7 +40,7 @@ if ( ! defined( 'ABSPATH' ) ) {... | 6 |
diff --git a/assets/src/edit-story/components/panels/link/index.js b/assets/src/edit-story/components/panels/link/index.js @@ -30,7 +30,7 @@ import { __ } from '@wordpress/i18n';
* Internal dependencies
*/
import { useDebouncedCallback } from 'use-debounce';
-import { Media, Row, Button, LinkInput } from '../../form';
... | 9 |
Subsets and Splits
No community queries yet
The top public SQL queries from the community will appear here once available.