text
stringlengths
59
1.12k
scheduled to run one or more times. For example, you can use a job queue to schedule a long-running update in the background. Given a start date and a time interval, the job queue processes attempt to run the job
at the next occurrence of the interval. Oracle Database manages job queue processes dynamically, thereby enabling job queue clients to use more job queue processes when required. The database releases resources used by the new processes when they are idle.
Dynamic job queue processes can run a large number of jobs concurrently at a given interval. The sequence of events is as follows: The job coordinator process (CJQ0) is automatically started and stopped as needed by Oracle Scheduler (see "Oracle
Scheduler"). The coordinator process periodically selects jobs that need to be run from the system JOB$ table. New jobs selected are ordered by time. The coordinator process dynamically spawns job queue slave processes (Jnnn) to run the jobs. The job
queue process runs one of the jobs that was selected by the CJQ0 process for execution. Each job queue process runs one job at a time to completion. After the process finishes execution of a single job, it polls for
more jobs. If no jobs are scheduled for execution, then it enters a sleep state, from which it wakes up at periodic intervals and polls for more jobs. If the process does not find any new jobs, then it terminates
after a preset interval. The initialization parameter JOB_QUEUE_PROCESSES represents the maximum number of job queue processes that can concurrently run on an instance. However, clients should not assume that all job queue processes are available for job execution. Note:The coordinator
process is not started if the initialization parameter JOB_QUEUE_PROCESSESis set to 0. The flashback data archiver process (FBDA) archives historical rows of tracked tables into Flashback Data Archives. When a transaction containing DML on a tracked table commits, this process
stores the pre-image of the rows into the Flashback Data Archive. It also keeps metadata on the current rows. FBDA automatically manages the flashback data archive for space, organization, and retention. Additionally, the process keeps track of how far the
archiving of tracked transactions has occurred. The SMCO process coordinates the execution of various space management related tasks, such as proactive space allocation and space reclamation. SMCO dynamically spawns slave processes (Wnnn) to implement the task. See Also:Oracle Database Advanced
Application Developer's Guide to learn about Flashback Data Archive Slave processes are background processes that perform work on behalf of other processes. This section describes some slave processes used by Oracle Database. See Also:Oracle Database Reference for descriptions of Oracle
Database slave processes I/O slave processes (Innn) simulate asynchronous I/O for systems and devices that do not support it. In asynchronous I/O, there is no timing requirement for transmission, enabling other processes to start before the transmission has finished. For
example, assume that an application writes 1000 blocks to a disk on an operating system that does not support asynchronous I/O. Each write occurs sequentially and waits for a confirmation that the write was successful. With asynchronous disk, the application
can write the blocks in bulk and perform other work while waiting for a response from the operating system that all blocks were written. To simulate asynchronous I/O, one process oversees several slave processes. The invoker process assigns work to
each of the slave processes, who wait for each write to complete and report back to the invoker when done. In true asynchronous I/O the operating system waits for the I/O to complete and reports back to the process, while
in simulated asynchronous I/O the slaves wait and report back to the invoker. The database supports different types of I/O slaves, including the following: I/O slaves for Recovery Manager (RMAN) When using RMAN to back up or restore data, you
can make use of I/O slaves for both disk and tape devices. Database writer slaves If it is not practical to use multiple database writer processes, such as when the computer has one CPU, then the database can distribute I/O
over multiple slave processes. DBWR is the only process that scans the buffer cache LRU list for blocks to be written to disk. However, I/O slaves perform the I/O for these blocks. In parallel execution or parallel processing, multiple processes
work together simultaneously to run a single SQL statement. By dividing the work among multiple processes, Oracle Database can run the statement more quickly. For example, four processes handle four different quarters in a year instead of one process handling
all four quarters by itself. Parallel execution reduces response time for data-intensive operations on large databases such as data warehouses. Symmetric multiprocessing (SMP) and clustered system gain the largest performance benefits from parallel execution because statement processing can be split
up among multiple CPUs. Parallel execution can also benefit certain types of OLTP and hybrid systems. In Oracle RAC systems, the service placement of a particular service controls parallel execution. Specifically, parallel processes run on the nodes on which you
have configured the service. By default, Oracle Database runs the parallel process only on the instance that offers the service used to connect to the database. This does not affect other parallel operations such as parallel recovery or the processing
of Oracle Real Application Clusters Administration and Deployment Guide for considerations regarding parallel execution in Oracle RAC environments In serial execution, a single server process performs all necessary processing for the sequential execution of a SQL statement. For example, to
perform a full table scan such as FROM employees, one server process performs all of the work, as shown in Figure 15-5. In parallel execution, the server process acts as the parallel execution coordinator responsible for parsing the query, allocating
and controlling the slave processes, and sending output to the user. Given a query plan for a SQL query, the coordinator breaks down each operator in a SQL query into parallel pieces, runs them in the order specified in the
query, and integrates the partial results produced by the slave processes executing the operators. Figure 15-6 shows a parallel scan of the employees table. The table is divided dynamically (dynamic partitioning) into load units called granules. Each granule is a
range of data blocks of the table read by a single slave process, called a parallel execution server, which uses nnn as a name format. The database maps granules to execution servers at execution time. When an execution server finishes
reading the rows corresponding to a granule, and when granules remain, it obtains another granule from the coordinator. This operation continues until the table has been read. The execution servers send results back to the coordinator, which assembles the pieces
into the desired full table scan. The number of parallel execution servers assigned to a single operation is the degree of parallelism for an operation. Multiple operations within the same SQL statement all have the same degree of parallelism.
*result, char *buffer, int buflen); int setnetent(int stayopen); These functions are used to obtain entries for networks. An entry may come from any of the sources for networks specified in the /etc/nsswitch.conf file. See nsswitch.conf(4). getnetbyname() searches for a network
entry with the network name specified by the character string parameter name. getnetbyaddr() searches for a network entry with the network address specified by net. The parameter type specifies the family of the address. This should be one of the
address families defined in <sys/socket.h>. See the NOTES section below for more information. Network numbers and local address parts are returned as machine format integer values, that is, in host byte order. See also inet(3SOCKET). The netent.n_net member in the
netent structure pointed to by the return value of the above functions is calculated by inet_network(). The inet_network() function returns a value in host byte order that is aligned based upon the input string. For example: Commonly, the alignment of
RFC 1519, Classless Inter-Domain Routing (CIDR): an Address Assignment and Aggregation Strategy. Network Working Group. September 1993. The functions setnetent(), getnetent(), and endnetent() are used to enumerate network entries from the database. setnetent() sets (or resets) the enumeration to the
beginning of the set of network entries. This function should be called before the first call to getnetent(). Calls to getnetbyname() and getnetbyaddr() leave the enumeration position in an indeterminate state. If the stayopen flag is non-zero, the system may
keep allocated resources such as open file descriptors until a subsequent call to endnetent(). Successive calls to getnetent() return either successive entries or NULL, indicating the end of the enumeration. endnetent() may be called to indicate that the caller expects
to do no further network entry retrieval operations; the system may then deallocate resources it was using. It is still allowed, but possibly less efficient, for the process to call more network entry retrieval functions after calling endnetent(). The functions
getnetbyname(), getnetbyaddr(), and getnetent() use static storage that is reused in each call, making these routines unsafe for use in multi-threaded applications. The functions getnetbyname_r(), getnetbyaddr_r(), and getnetent_r() provide reentrant interfaces for these operations. Each reentrant interface performs th...
operation as its non-reentrant counterpart, named by removing the ``_r'' suffix. The reentrant interfaces, however, use buffers supplied by the caller to store returned results, and are safe for use in both single-threaded and multi-threaded applications. Each reentrant interface takes
the same parameters as its non-reentrant counterpart, as well as the following additional parameters. The parameter result must be a pointer to a struct netent structure allocated by the caller. On successful completion, the function returns the network entry in
this structure. The parameter buffer must be a pointer to a buffer supplied by the caller. This buffer is used as storage space for the network entry data. All of the pointers within the returned struct netent result point to
data stored within this buffer. See RETURN VALUES. The buffer must be large enough to hold all of the data associated with the network entry. The parameter buflen should give the size in bytes of the buffer indicated by buffer.
For enumeration in multi-threaded applications, the position within the enumeration is a process-wide property shared by all threads. setnetent() may be used in a multi-threaded application but resets the enumeration position for all threads. If multiple threads interleave calls to
getnetent_r(), the threads will enumerate disjointed subsets of the network database. Like their non-reentrant counterparts, getnetbyname_r() and getnetbyaddr_r() leave the enumeration position in an indeterminate state. Network entries are represented by the struct netent structure defined in <netdb.h>. The functions
getnetbyname(), getnetbyname_r, getnetbyaddr, and getnetbyaddr_r() each return a pointer to a struct netent if they successfully locate the requested entry; otherwise they return NULL. The functions getnetent() and getnetent_r() each return a pointer to a struct netent if they successfully
enumerate an entry; otherwise they return NULL, indicating the end of the enumeration. The functions getnetbyname(), getnetbyaddr(), and getnetent() use static storage, so returned data must be copied before a subsequent call to any of these functions if the data
is to be saved. When the pointer returned by the reentrant functions getnetbyname_r(), getnetbyaddr_r(), and getnetent_r() is non-NULL, it is always equal to the result pointer that was supplied by the caller. The functions setnetent() and endnetent() return 0 on
success. The reentrant functions getnetbyname_r(), getnetbyaddr_r and getnetent_r() will return NULL and set errno to ERANGE if the length of the buffer supplied by caller is not large enough to store the result. See Intro(2) for the proper usage and
interpretation of errno in multi-threaded applications. network name database configuration file for the name service switch See attributes(5) for descriptions of the following attributes: Fuller, V., Li, T., Yu, J., and Varadhan, K. RFC 1519, Classless Inter-Domain Routing (CIDR): an
Address Assignment and Aggregation Strategy. Network Working Group. September 1993. The reentrant interfaces getnetbyname_r(), getnetbyaddr_r(), and getnetent_r() are included in this release on an uncommitted basis only, and are subject to change or removal in future minor releases. The current
implementation of these functions only return or accept network numbers for the Internet address family (type AF_INET). The functions described in inet(3SOCKET) may be helpful in constructing and manipulating addresses and network numbers in this form. When compiling multi-threaded applications,
see Intro(3), Notes On Multithread Applications, for information about the use of the _REENTRANT flag. Use of the enumeration interfaces getnetent() and getnetent_r() is discouraged; enumeration may not be supported for all database sources. The semantics of enumeration are discussed
cookie protocol and the protocol defined by RFC 2965 are handled. RFC 2965 handling is switched off by default. RFC 2109 cookies are parsed as Netscape cookies and subsequently treated
either as Netscape or RFC 2965 cookies according to the 'policy' in effect. Note that the great majority of cookies on the Internet are Netscape cookies. cookielib attempts to follow
the de-facto Netscape cookie protocol (which differs substantially from that set out in the original Netscape specification), including taking note of the introduced with RFC 2965. Note: The various named
parameters found in Set-Cookie: and Set-Cookie2: headers expires) are conventionally referred to as attributes. To distinguish them from Python attributes, the documentation for this module uses the term cookie-attribute The
automatically expire contained cookies when necessary. Subclasses are also responsible for storing and retrieving cookies from a file or database. |filename, delayload=None, policy=None)| A CookieJar which can load cookies from,
and perhaps save cookies to, a file on disk. Cookies are NOT loaded from the named file until either the load() or revert() method is called. Subclasses of this class
sequence of domain names that we never accept cookies from, nor return cookies to. allowed_domains if not None, this is a sequence of the only domains for which we accept
and return cookies. For all other arguments, see the documentation for CookiePolicy and DefaultCookiePolicy objects. DefaultCookiePolicy implements the standard accept / reject rules for Netscape and RFC 2965 cookies. By
default, RFC 2109 cookies (ie. cookies received in a Set-Cookie: header with a version cookie-attribute of 1) are treated according to the RFC 2965 rules. However, if RFC 2965 handling
is turned off or rfc2109_as_netscape is True, RFC 2109 cookies are 'downgraded' by the CookieJar instance to Netscape cookies, by setting the version attribute of the Cookie instance to 0.
OLYMPIA, Wash., January 9, 2008—The Department of Revenue has released Tax Exemptions 2008, a compendium of state and local tax exemptions. The legislatively mandated tax exemption study is updated every
four years. It is available online. The 567 exemptions enacted since territorial days in 1854 represent an estimated $98.5 billion in state and local tax savings during the 2007 –
2009 biennium. Of this, about 54 percent, or $53.5 billion, involves state taxes and the remaining $45 billion are local taxes. The largest single exemption is the property tax exemption
for intangibles, enacted in 1931. It accounts for 36.7 percent, or $36.2 billion, of the total. Intangibles include assets such as money, stocks, bonds, bank deposits, and the value of
corporate trademarks. Were it not for this exemption, businesses and individuals would have to pay property taxes on their financial assets as well as their real estate. The second-largest is
a use tax exemption on personal property owned by nonresidents who visit Washington and new residents who bring used household goods and vehicles with them. That one totals $24.8 billion,
or 25.2 percent of the total. In third place is no sales tax on most services, at $5.2 billion or 5.3 percent. Sales tax on services was excluded from the
tax base when the current tax code was enacted in 1935, when services were a relative small component of the economy. Fourth is exemption of employee income from taxation (no
personal income tax) at $2.6 billion or 2.6 percent. Fifth largest is the voter-approved sales tax exemption on food, saving $2.2 billion or 2.3 percent over a two-year period. While
business incentives receive a lot of public attention, they comprise a fairly small percentage of the total value of exemptions and preferential rates, $3.9 billion or 4 percent of the
total. The report emphasizes that the revenue impacts reflect estimated savings to taxpayers but do not necessarily indicate the potential tax revenue that might generated in the absence of the
exemptions. The report assesses whether or not a tax actually could be collected if the exemption were repealed. Because many of the exemptions are mandated by federal law or the
state constitution, and other taxes would not be collected due to changes in taxpayer behavior if the exemptions were repealed, the report concludes that only about $14.8 billion in additional
state or local government revenue could potentially be generated through repeal of exemptions. Most of this – $11.9 billion – would be generated by repealing sales and use tax exemptions,
Black cap; black throat and lower neck (like a bib); white cheek patches; white chest and belly; gray back, wings, and tail; buffy patches on the flanks. 12 cm (4.75 in) in length. The Carolina Chickadee's call is chick-a-dee-dee-dee or
a shortened version of the same. The song of this species is usually four whistled notes, fee-bee fee-bay. The breeding season begins in early April, peaks later that month until early May, and extends through mid-June. Breeding habitat includes a
variety of wooded and forested areas. This species is a cavity nester and will nest in snags, trees, rotten fenceposts, or nest boxes. It will excavate its own cavity, use an old woodpecker cavity, or find a natural cavity. The
cavity is lined with moss, plant material, down, and feathers. The female lays 5-8 (usually 6) eggs that both adults incubate for 11-12 days. The young are altricial and fledge 13-17 days after hatching. The Carolina Chickadee prefers forested or
wooded habitats. It eats primarily insects and also spiders, fruits, and seeds. It forages by searching among tree branches, trunks, pine cones, and dead leaf clusters. It also frequents bird feeders. This species is a year-round resident, and does not
migrate. The Carolina Chickadee is found mostly in the Southeast, but its range extends as far north as Delaware, central Ohio, Indiana, and Illinois and as far west as Oklahoma and central Texas. In the Southeast, this species is common
to very common throughout except for extreme southern Florida. This species is common in the Southeast, and is not targeted for any special attention. The species most similar to the Carolina Chickadee is the Black-capped Chickadee. The Black-capped Chickadee is
slightly larger and has a lower pitch to the chick-a-dee-dee-dee call. The Black-capped Chickadee also has a shorter song, being 2 or 3 whistled notes, fee-bee or fee-bee-bee. The song is the most reliable identifier, because their appearances are very
In a victory for the gray wolves of the northern Rockies, a federal judge in Montana on Friday July 18 reinstated federal Endangered Species Act protections for wolves, thus preventing Idaho, Montana and Wyoming from implementing fall wolf hunts. The court ruled that conservation groups are likely to succeed on the maj...
endangered species was unlawful. The decision notes that, while the U.S. Fish and Wildlife Service had stated that genetic exchange between wolf populations in Idaho, Montana and Wyoming was necessary for the wolf's survival, Yellowstone's wolves remain genetically isolated. Further, hunting and state predator-control ...
that the conservation groups are likely to succeed in their argument that Wyoming law (which allows unregulated wolf killing in nearly 90 percent of the state and fails to commit to maintaining sufficient wolf numbers) is inadequate. The U.S. Fish and Wildlife Service had long maintained that these aspects of Wyoming l...
it approved Wyoming's wolf management scheme with "the same deficiencies" in 2007. Since wolves were delisted on March 28, states have assumed management authority for wolves, leading to the killing of at least 106 wolves. All three states had plans to allow hunts this fall. Those hunts would have permitted more than 5...
lawsuit brought by Earthjustice on behalf of 12 conservation groups. Earthjustice filed suit on behalf of Defenders of Wildlife, Natural Resources Defense Council, Sierra Club, Center for Biological Diversity, The Humane Society of the United States, Jackson Hole Conservation Alliance, Friends of the Clearwater, Allian...
and illegal in large part because existing state management plans are inadequate to ensure the long term conservation of wolves in the region, allowing far too many wolves to be unnecessarily killed. Responsible, balanced management by the states would benefit wolves, ranchers, hunters and all northern Rockies resident...
work to improve the current state plans so that they maintain a healthy wolf population," said Suzanne Asha Stone, northern Rockies wolf conservation specialist for Defenders of Wildlife. "Recovery requires allowing wolves in different populations to reach each other in order to mate and raise their pups," said Michael...
endangered species list, the government was gunning down so many wolves that the Yellowstone population was reproductively isolated, a recipe for extinction. This injunction will give the wolves a fighting chance." "This injunction is necessary to prevent the states from implementing management schemes that have the pr...
the Wild Rockies. "The federal court just offered a badly needed lifeline to wolves in the northern Rockies," said Louisa Willcox of the Natural Resources Defense Council. "Wolves have been getting killed at a rate of about one per day since the federal government stripped them of Endangered Species Act protections. Th...
a long process towards improving wolf management. The ruling puts an immediate stop to the wolf-killing that has taken place in the northern Rockies since delisting. The states lack responsible, science-based management plans that ensure the wolf's recovery into the future and the judge's ruling reflects this. We appla...
to prosper and will benefit ranchers, hunters, the public and our local economies," said Melanie Stein, a Sierra Club representative. "We consider this as one important step toward developing state management plans that will focus on wolf conservation, not wolf control," said Franz Camenzind, Executive Director of the ...
a single management plan that will treat the wolves in Idaho, Montana and Wyoming as a single population, not as discrete populations. With these guidelines, each state should bring together all the interests and shape individual plans that will ensure long-term sustainability of this important wildlife population." "T...
message that the administration cannot circumvent the protections of the ESA through the use of unlawful delisting schemes," said Jonathan R. Lovvorn, vice president of animal protection litigation for The Humane Society of the United States. "This ruling is not just great news for wolves in the Rocky Mountains, it is ...
of the Oregon-based Cascadia Wildlands Project. "Wolves are returning to Oregon now for the first time in sixty years, and the Rocky Mountain wolves are our source population. The plan to kill the Rocky Mountain wolves is the single greatest threat to the recovery of wolves here in the Pacific Northwest." "Wolves are o...
for the wolves. All three states had plans to allow hunts this fall. 500 wolves were scheduled to be killed and now those plans are halted," said Earthjustice attorney Doug Honnold. Doug Honnold, Earthjustice, (406) 586-9699 Suzanne Asha Stone, Defenders of Wildlife, (208) 424-0932 Louisa Willcox, Natural Resources Def...
What a busy two weeks! Happy to be back to the blogging world and so ready for Spring Break. I wanted to share with you all some of the fun things we did last week. I bought DeAnna's St. Patrick's Day unit and my kinders had a blast. Here's a glimpse at a few of our Math Workstations. These printables