hash
stringlengths
32
32
doc_id
stringlengths
7
13
section
stringlengths
3
121
content
stringlengths
0
2.2M
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.3 ECRF
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.3.1 LoST
TP Id TP_ECRF_LOST_BV_01 Test Objective IUT successfully responds with a service URI for a Point in the service boundary Reference ETSI TS 103 479 [1], clause 6.4.1 EENA Next Generation 112 LTD [i.3], clause 4.4 IETF RFC 5222 [5] PICS Selection PICS_ECRF_FIND_SERVICE and PICS_ECRF_GEOMETRY_POINT Initial Conditions with...
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.3.2 Errors
TP Id TP_ECRF_LOST_BI_01 Test Objective IUT responds to a findServiceRequest with an loop error response Reference ETSI TS 103 479 [1], clause 6.4.1 EENA Next Generation 112 LTD [i.3], clause 4.4 IETF RFC 5222 [5] PICS Selection PICS_ECRF_FIND_SERVICE and PICS_ECRF_LOOP_DETECTION Expected Behaviour ensure that { when {...
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.3.3 Subscriptions/Notifications
TP Id TP_ECRF_SIP_BV_01 Test Objective IUT responds to SIP Subscribe for Element State with an 200 OK Reference ETSI TS 103 479 [1], clause 6.3.4 EENA Next Generation 112 LTD [i.3], clause 4.10 IETF RFC 5985 [3] PICS Selection PICS_SIP_SUBSCRIPTION_ELEMENT_STATE Expected Behaviour ensure that { when { the IUT receives ...
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.3.4 Security
TP Id TP_ECRF_TLS_BI_01 Test Objective IUT rejects requests without a certificate Reference ETSI TS 103 479 [1], clause 6.4.1.4 EENA Next Generation 112 LTD [i.32], clause 4.10 IETF RFC 5985 [3] PICS Selection PICS_ECRF_TLS_AUTHENTICATION Expected Behaviour ensure that { when { the IUT receives any FindServiceRequest c...
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.4 PSAP
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.4.1 Invite
TP Id TP_PSAP_SIP_INVITE_BV_01 Test Objective IUT successfully handles SIP INVITE with different service urn and ULAW via UDP, with no SIP registration Reference ETSI TS 103 479 [1], clauses 5.4, 6.1.1 and 6.1.2.2 Next Generation 112 LTD [i.3], clause 4.7 IETF RFC 3261 [6] IETF RFC 5301 [7] Configuration CFG_PSAP_01 PI...
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.4.2 Ack
TP Id TP_PSAP_SIP_ACK_BV_01 Test Objective IUT after sending 200 OK INVITE successfully handles an incoming SIP ACK to accept the emergency call Reference ETSI TS 103 479 [1], clauses 5.4, 6.1.1 and 6.1.2.2 Next Generation 112 LTD [i.3], clause 4.7 IETF RFC 3261 [6] IETF RFC 5301 [7] Configuration CFG_PSAP_01 PICS Sele...
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.4.3 Bye
TP Id TP_PSAP_SIP_BYE_BV_01 Test Objective IUT successfully handles an incoming SIP BYE Reference ETSI TS 103 479 [1], clauses 5.4 and 6.1.2.2 ETSI TS 103 698 Next Generation 112 LTD [i.3], clause 4.7 IETF RFC 3261 [6] IETF RFC 5301 [7] Configuration CFG_PSAP_01 PICS Selection PICS_PSAP_S_SIP_BYE1 and PICS_PSAP_S_SIP_T...
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.4.4 Message
TP Id TP_PSAP_SIP_MESSAGE_BV_01 Test Objective IUT successfully handles an incoming SIP MESSAGE Reference ETSI TS 103 479 [1], clauses 5.4 and 6.1.2.2 Next Generation 112 LTD [i.3], clause 4.7 IETF RFC 3261 [6] Configuration CFG_PSAP_01 PICS Selection PICS_PSAP_M_SIP_URN1 and PICS_PSAP_S_SIP_REGISTRATION Initial Condit...
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.4.5 Options
TP Id TP_PSAP_SIP_OPTIONS_BV_01 Test Objective IUT successfully handles an incoming SIP OPTIONS Reference ETSI TS 103 479 [1], clauses 5.4 and 6.1.2.2 Next Generation 112 LTD [i.3], clause 4.7 IETF RFC 3261 [6] Configuration CFG_PSAP_01 PICS Selection PICS_PSAP_S_SIP_OPT1 and PICS_PSAP_S_SIP_NO_REGISTRATION Initial Con...
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.4.6 Cancel
TP Id TP_PSAP_SIP_CANCEL_BV_01 Test Objective Check that IUT successfully handles an incoming SIP CANCEL, release the call with 200 OK CANCEL and 487 Reference ETSI TS 103 479 [1], clauses 5.4 and 6.1.2.2 Next Generation 112 LTD [i.3], clause 4.7 IETF RFC 3261 [6] Configuration CFG_PSAP_01 PICS Selection PICS_PSAP_S_SI...
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.4.7 Info
TP Id TP_PSAP_SIP_INFO_BV_01 Test Objective IUT successfully handles an incoming SIP INFO Reference ETSI TS 103 479 [1], clauses 5.4 and 6.1.2.2 Next Generation 112 LTD [i.3], clause 4.7 IETF RFC 3261 [6] IETF RFC 5301 [7] Configuration CFG_PSAP_01 PICS Selection PICS_PSAP_S_SIP_TCP1 and PICS_PSAP_E_SIP_URN1 and PICS_P...
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.4.8 Dequeue registration/deregistration
TP Id TP_PSAP_HTTP_DEQUEUE_REGISTRATION_BV_01 Test Objective Check that the IUT registers properly to an ESRP Dequeue Reference ETSI TS 103 479 [1], clauses 5.2.4 and 6.2.1 ETSI TS 103 698 [11] Next Generation 112 LTD [i.3], clause 4.7 IETF RFC 3261 [6] IETF RFC 5301 [7] Configuration CFG_PSAP_03 PICS Selection PICS_PS...
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.4.9 HELD
TP Id TP_PSAP_HELD_BV_01 Test Objective Check that the IUT sends an HTTP/HELD request when the IUT is requested to get location information Reference ETSI TS 103 479 [1], clause 6.5 ETSI TS 103 698 [11] Next Generation 112 LTD [i.3], clause 4.7.3 IETF RFC 3261 [6] IETF RFC 5301 [7] Configuration CFG_PSAP_03 PICS Select...
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.4.10 LoST
TP Id TP_PSAP_LOST_BV_01 Test Objective Check that the IUT sends an HTTP/LOST request when the IUT is requested to get route emergency call Reference ETSI TS 103 479 [1], clause 6.4 ETSI TS 103 698 [11] Next Generation 112 LTD [i.3], clause 4.7.2 IETF RFC 3261 [6] IETF RFC 5301 [7] Configuration CFG_PSAP_03 PICS Select...
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.4.11 Security
TP Id TP_PSAP_TLS_BI_01 Test Objective IUT rejects requests without a certificate Reference ETSI TS 103 479 [1], clause 6.1.1 EENA Next Generation 112 LTD [i.3], clause 4.10 IETF RFC 5985 [3] PICS Selection PICS_PSAP_TLS_AUTHENTICATION Initial Conditions with { the IUT isDisconnected } Expected Behaviour ensure that { ...
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.5 BCF
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.5.1 Invite
TP Id TP_BCF_SIP_INVITE_BV_01 Test Objective IUT forwards well-formated INVITE to PSAP Reference ETSI TS 103 479 [1], clause 5.1 ETSI TS 103 698 [11], clause 5.1.1 EENA Next Generation 112 LTD [i.3], clause 4.2 Configuration CFG_BCF_01 PICS Selection PICS_BCF_S_SIP_TCP1 Initial Conditions with { the IUT acceptingIncomi...
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.5.2 Message
TP Id TP_BCF_SIP_MESSAGE_BV_01 Test Objective IUT forwards well-formated MESSAGE to PSAP Reference ETSI TS 103 479 [1], clause 5.1 ETSI TS 103 698 [11], clause 5.1.1 EENA Next Generation 112 LTD [i.3], clause 4.2 Configuration CFG_BCF_01 PICS Selection PICS_BCF_S_SIP_TCP1 Initial Conditions with { the IUT acceptingIM }...
2a069fefc04515aead3e2d17a95eab6a
103 650-1
7.2.5.3 Security
TP Id TP_BCF_TLS_BI_01 Test Objective IUT rejects requests without a certificate Reference ETSI TS 103 479 [1], clause 6.1.1 EENA Next Generation 112 LTD [i.3], clause 4.10 IETF RFC 5985 [3] PICS Selection PICS_BCF_TLS_AUTHENTICATION Initial Conditions with { the IUT isDisconnected } Expected Behaviour ensure that { wh...
35b37a7e06f88527e75b50d0d84f437a
103 695
1 Scope
The present document specifies Release 2 C-ITS access layer MCO extensions based on Release 1 backward compatibility.
35b37a7e06f88527e75b50d0d84f437a
103 695
2 References
35b37a7e06f88527e75b50d0d84f437a
103 695
2.1 Normative references
References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies. Referenced documents which a...
35b37a7e06f88527e75b50d0d84f437a
103 695
2.2 Informative references
References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies. NOTE: While any hyperlinks i...
35b37a7e06f88527e75b50d0d84f437a
103 695
3 Definition of terms, symbols and abbreviations
35b37a7e06f88527e75b50d0d84f437a
103 695
3.1 Terms
For the purposes of the present document, the following terms apply: access layer instance: fully parametrized (service channel, technology, TX power, …) transceiver entity in the access layer access layer instance ID: Unique Identifier for an access layer instance access layer instance group: set of access layer insta...
35b37a7e06f88527e75b50d0d84f437a
103 695
3.2 Symbols
Void.
35b37a7e06f88527e75b50d0d84f437a
103 695
3.3 Abbreviations
For the purposes of the present document, the following abbreviations apply: ALI Access Layer Instance AliGroupID Access layer instance Group IDentifier NOTE: The abbreviation AliGroupID is compliant with an ASN.1 representation of an identifier. ETSI ETSI TS 103 695 V2.1.1 (2022-11) 7 AliID Access layer instance IDent...
35b37a7e06f88527e75b50d0d84f437a
103 695
4 Background
An access layer implementation of a C-ITS-S capable of handling more than a single channel simultaneously requires specific multi-channel functionalities. These functionalities are needed to allow the higher layers to take efficiently advantage of the available resources to transmit and receive packets over the air. An...
35b37a7e06f88527e75b50d0d84f437a
103 695
5 Access layer MCO operation
35b37a7e06f88527e75b50d0d84f437a
103 695
5.1 Introduction
The access layer of an MCO capable C-ITS-S implements and operates more than a single transceiver active simultaneously. This set of transceivers may be capable of implementing different access layer technologies (e.g. ITS-G5, LTE-V2X, etc.). Each of which may be parametrized to be adapted to the requirements of the ap...
35b37a7e06f88527e75b50d0d84f437a
103 695
5.2 Access layer data flow
The access layer data plane as depicted in Figure 1 provides all functionalities required to transmit a PPDU over the physical channel defined as part of the AliID. In the presented figure it is assumed that the set of transceivers may be flexibly parametrized to provide different access layer technology functionalitie...
35b37a7e06f88527e75b50d0d84f437a
103 695
5.3 Access layer management flow
As identified in the ETSI TS 103 697 [i.3] at the management plane there are two Access layer entities as part of MCO_ACC depicted in Figure 3. Figure 3: MCO Access layer Management Plane, combined and separate TRXs ALI Operations: In case higher layers provide an AliID to the ALI Operations, this entity shall configur...
35b37a7e06f88527e75b50d0d84f437a
103 695
6 MCO Access layer extension
35b37a7e06f88527e75b50d0d84f437a
103 695
6.1 Introduction
An MCO enabled access layer needs to support certain functionalities to permit the distribution of the C-ITS traffic onto the available physical channels with a specific set of parameters as defined by the AliID. These extensions shall be fully backward compatible with the Release 1 devices. MCO_NET_ACC_DATA MCO_NET_AC...
35b37a7e06f88527e75b50d0d84f437a
103 695
6.2 Access layer instance IDentifier (AliID)
The Access layer instance IDentifier (AliID) shall represent a unique identifier for the access layer instance. Based on the AliID it shall be possible to set all relevant parameters of a transceiver. A specific transceiver might not be capable of supporting all possible parameter combinations. The AliID may consist of...
35b37a7e06f88527e75b50d0d84f437a
103 695
6.3 ALI groups
An ALI group represent the access layer technology and the used channel. An ALI group shall be identified by a locally unique identifier called AliGroupID. The AliGroupID is composed of the first letter of the AliID and the two following digits of the AliID. A transceiver may be switched between the different ALI group...
35b37a7e06f88527e75b50d0d84f437a
103 695
6.4 MCO_ACC Interfaces
35b37a7e06f88527e75b50d0d84f437a
103 695
6.4.1 Overview
The MCO_ACC entity shall support the MCO related interfaces illustrated in Figure 1 to Figure 3. All MCO related specified interfaces in the present document are station internal only. The detailed format of the parameters to be exchanged are implementation specific and need not to be specified in the present document.
35b37a7e06f88527e75b50d0d84f437a
103 695
6.4.2 Input parameters from higher layers
Table 1: List of M-Param for the ACC_NET_MMT interface M-Param.No Name of M-Param Access Format Description 0 AliID R not relevant (internal parameter, see Annex B) AliID per message to be transmitted to ALI operation entity 1 AliGroupStatus R not relevant (internal parameter, see Annex B) Set the status of the availab...
35b37a7e06f88527e75b50d0d84f437a
103 695
6.4.3 Output parameter to higher layers
Table 2: List of M-Param for the ACC_NET_MMT interface M-Param.No Name of M-Param Access Format Description 2 CLR W not relevant (internal parameter, see Annex B) Channel load ratio per ALI group, to "higher layers every [100] ms: Channel Load Ratio as value 0 to 1 with a resolution of 0,01 The parameter shall contain ...
52b5432891de1f9b8351cb32118ddf59
103 556
1 Scope
The present document provides the level of detail that will enable manufacturers of telecommunications equipment incorporating Telephony Events described in IETF RFC 4733 [1] for the transport of DTMF signalling to design the equipment. The present document specifies the signal receiver and transmitter requirements of ...
52b5432891de1f9b8351cb32118ddf59
103 556
2 References
52b5432891de1f9b8351cb32118ddf59
103 556
2.1 Normative references
References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies. Referenced documents which a...
52b5432891de1f9b8351cb32118ddf59
103 556
2.2 Informative references
References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies. NOTE: While any hyperlinks i...
52b5432891de1f9b8351cb32118ddf59
103 556
3 Definitions and abbreviations
52b5432891de1f9b8351cb32118ddf59
103 556
3.1 Definitions
For the purposes of the present document, the terms and definitions apply: telephony events: transmission method to carry Dual-Tone Multi Frequency (DTMF) signalling and other tone signals in RTP packets described in IETF RFC 4733 [1]
52b5432891de1f9b8351cb32118ddf59
103 556
3.2 Abbreviations
For the purposes of the present document, the following abbreviations apply: DTMF Dual-Tone Multi Frequency MGW Media GateWay PSTN Public Switched Telephone Network RTP Real-time Transport Protocol SBC Session Border Controller SDP Session Description Protocol 4 Telephone Events for the transmission of DTMF Signals
52b5432891de1f9b8351cb32118ddf59
103 556
4.1 Introduction
The telephone events are suitable for transmission of DTMF Signals between media gateways and for end-to-end scenarios. In the gateway scenario, an Internet telephony media gateway connecting to a packet voice network, the PSTN recreates the DTMF tones or other telephony events and injects them into the PSTN. The RTP P...
52b5432891de1f9b8351cb32118ddf59
103 556
4.4 Telephony Event Procedures
52b5432891de1f9b8351cb32118ddf59
103 556
4.4.1 Introduction
This clause defines the procedures associated with the tone telephony event procedures described in IETF RFC 4733 [1]. In the gateway scenario, a telephony media gateway connecting to a packet voice network creates telephony events. In the end system scenario, the DTMF events are consumed by the receiving entity itself...
52b5432891de1f9b8351cb32118ddf59
103 556
4.4.2 Sending procedures
The telephone-event payload shall not be inherently redundant with the RTP packets (DTMF in audio), as described in section 4.4.1 of IETF RFC 4733 [1]. The maximal DTMF audio Signal leakage shall be lower than 5 ms. If in the media gateway scenario RTP events are not offered in SDP, DTMF shall be transmitted in Audio t...
52b5432891de1f9b8351cb32118ddf59
103 556
4.4.3 Receiving procedures
Receiving implementations play out the tones as received, typically with a playout delay to allow for lost packets. In the case when telephony events and RTP packets received are inherently redundant, only DTMF from the telephony events should be played out. The maximal DTMF Signal leakage shall be lower than 15 ms. Fi...
bdaffd30e1afdcb3119e6349ffcd341d
103 555
1 Scope
The present document describes how IPTV Terminals can make use of HbbTV features. It does not, in any way, describe an IPTV delivery system itself. As such, technologies like fast channel change, retransmission and forward error correction are out-of-scope. Instead it defines how several technologies may be used in com...
bdaffd30e1afdcb3119e6349ffcd341d
103 555
2 References
bdaffd30e1afdcb3119e6349ffcd341d
103 555
2.1 Normative references
References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies. Referenced documents which a...
bdaffd30e1afdcb3119e6349ffcd341d
103 555
2.2 Informative references
References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies. NOTE: While any hyperlinks i...
bdaffd30e1afdcb3119e6349ffcd341d
103 555
3 Definitions and abbreviations
bdaffd30e1afdcb3119e6349ffcd341d
103 555
3.1 Definitions
For the purposes of the present document, the terms and definitions given in ETSI TS 102 796 [1] and the following apply: broadcast: uni-directional MPEG-2 transport stream based on delivery systems such as DVB-T, DVB-S, DVB-C or DVB-IPTV hybrid IPTV terminal: terminal that has both an IP connection and a classical RF-...
bdaffd30e1afdcb3119e6349ffcd341d
103 555
3.2 Abbreviations
For the purposes of the present document, the following abbreviations apply: AIT Application Information Table A/V Audio/Visual DAE Declarative Application Environment DASH Dynamic Adaptive Streaming over HTTP DHCP Dynamic Host Configuration Protocol DNS Domain Name System DSM-CC Digital Storage Media - Command and Con...
bdaffd30e1afdcb3119e6349ffcd341d
103 555
4 IPTV as the "broadcast"
bdaffd30e1afdcb3119e6349ffcd341d
103 555
4.1 General principles
All definitions and requirements of the Hybrid Broadcast Broadband TV specification [1] shall also apply for usage in an IPTV service except for the changes explicitly listed in this clause. Specifically, unless explicitly stated otherwise below: • All relevant signalling and transport (PMT entries, AITs, DSM-CC carous...
bdaffd30e1afdcb3119e6349ffcd341d
103 555
4.2 Application Lifecycle
The exceptional rules for the application lifecycle related to services without an SDT entry (in clause 6.2.2.2 of ETSI TS 102 796 [1]) shall also apply for IPTV streams without an entry in the Service Discovery Mechanism (SD&S, OSDT or other). ETSI ETSI TS 103 555 V1.1.1 (2017-08) 9
bdaffd30e1afdcb3119e6349ffcd341d
103 555
4.3 OIPF DAE Specification Profile
For the following clauses of annex A of ETSI TS 102 796 [1] the changes in table 1 shall apply. Table 1: Changed sections in the profile of the OIPF DAE specification Section, sub-section Reference in DAE (see clause A.1 of [1]) Status in Hybrid Broadcast Broadband TV Notes Security Metadata APIs The application/oipfSe...
bdaffd30e1afdcb3119e6349ffcd341d
103 555
4.4 Terminal Capabilities
The requirement in clause 10.2.4 of ETSI TS 102 796 [1] for terminals to include the client metadata element with type "dvb-si" set to true in their xmlCapabilities does not apply for pure IPTV terminals.
bdaffd30e1afdcb3119e6349ffcd341d
103 555
4.5 Access to EIT Schedule Information
The requirement in clause A.2.9 of ETSI TS 102 796 [1] to allow access to DVB-SI EIT event schedule information does not apply at all for pure IPTV terminals. For hybrid IPTV terminals, it is not required to access DVB-SI EIT event schedule information of services delivered via IPTV. 5 Integration of HbbTV and Service ...
bdaffd30e1afdcb3119e6349ffcd341d
103 555
5.1 Overview
The present document defines how HbbTV can be integrated with three different mechanisms for service discovery. Table 2 lists these three mechanisms and indicates how support for each mechanism shall be indicated in the XML device capabilities of the HbbTV terminal. ETSI ETSI TS 103 555 V1.1.1 (2017-08) 10 Table 2: Ser...
bdaffd30e1afdcb3119e6349ffcd341d
103 555
5.2 Service Discovery by HbbTV Application
The following shall apply when an HbbTV terminal indicates support for IPTV service discovery by the mechanism of an HbbTV application providing the URLs for the service as defined in table 2: • The terminal shall support creation of Channel objects with the idType argument being ID_IPTV_URI and the ipBroadcastID argum...
bdaffd30e1afdcb3119e6349ffcd341d
103 555
5.3 Service Discovery & Selection via SD&S
bdaffd30e1afdcb3119e6349ffcd341d
103 555
5.3.1 General
The following three consecutive steps shall be applied when an HbbTV terminal indicates support for IPTV service discovery via DVB SD&S as defined in table 2: 1) The terminal shall determine the service discovery location as defined in clause 5.3.2. 2) The terminal shall request information for discovering Service Prov...
bdaffd30e1afdcb3119e6349ffcd341d
103 555
5.3.2 Determining the service discovery location
Whenever the terminal wants to provide an IPTV service it has to find an entry point for obtaining the appropriate information about the location of that service. NOTE: This step partly picks up the procedural steps for discovering a service as described in clause 5.2.4 of ETSI TS 102 034 [2]. 1) When the terminal conn...
bdaffd30e1afdcb3119e6349ffcd341d
103 555
5.3.3 Selecting a Service Provider
For selecting service providers the terminal shall apply the following requirements: • HTTP over TLS shall be used for all communication between the terminal and the SD&S server. • The communication process shall follow the description given in clause 5.4.2.0 of ETSI TS 102 034 [2]. • The request for a service provider...
bdaffd30e1afdcb3119e6349ffcd341d
103 555
5.3.4 Obtaining Service Offerings
When the selection of service providers has completed, the service offerings of each selected service provider shall be obtained by the terminal. During this process the following requirements shall apply: • For all communication between the terminal and the SD&S server the protocol and the transport method shall be us...
bdaffd30e1afdcb3119e6349ffcd341d
103 555
5.4 DVB OSDT
The following shall apply when a terminal indicates support for IPTV service discovery by DVB OSDT as defined in table 2: • The changes to the methods createChannelObject(Integer idType, Integer onid, Integer tsid, Integer sid, Integer sourceID, String ipBroadcastID), setChannel(Channel channel, Boolean trickplay, Stri...
bdaffd30e1afdcb3119e6349ffcd341d
103 555
5.5 Others (informative)
If other service discovery mechanisms are used, clause 5.1 of the present document should be used as the reference for mapping the metadata of the service discovery mechanism to the relevant APIs. ETSI ETSI TS 103 555 V1.1.1 (2017-08) 12
bdaffd30e1afdcb3119e6349ffcd341d
103 555
6 Integration of HbbTV and Content Delivery Protocols
bdaffd30e1afdcb3119e6349ffcd341d
103 555
6.1 Multicast IP
The following shall apply when a terminal indicates support for multicast streaming by including a video_broadcast element in the XML device capabilities with a transport attribute including either "igmp-rtp-udp" or "igmp-udp" as defined in clause 9.3.1 of the OIPF DAE specification [6]. NOTE 1: Due to an editorial err...
bdaffd30e1afdcb3119e6349ffcd341d
103 555
6.2 MPEG DASH
This clause applies to a TV channel or service regardless of whether the presentation of that channel or service is started by a terminal UI, an HbbTV application using a video/broadcast object or something else. It does not apply to on-demand MPEG DASH content presented by an HbbTV application using either the A/V con...
bdaffd30e1afdcb3119e6349ffcd341d
103 555
6.3 Other Transport Protocols for Delivery of Linear Channels
In the case other IP based transport protocols (such as RTSP) are used for the distribution of linear broadcast streams based on MPEG-2 transport stream, an integration with Hybrid Broadcast Broadband TV shall be done as follows: • The rules of clause 4 of the present document are applied. • The channelType of the vide...
bdaffd30e1afdcb3119e6349ffcd341d
103 555
7 Content protection (informative)
The protection, by technical means, of IPTV content is outside the scope of the present document except as follows: • Protected content delivered in an MPEG-2 transport stream may be decrypted using a DVB Common Interface module as defined in ETSI TS 103 205 [3]. Support for this will be indicated in the XML capabiliti...
57c6d0080ccc3fac90d906664d16a8b7
103 596-2
1 Scope
The present document provides general security considerations and guidelines about the Constrained Application Protocol (CoAP). The collective ideas presented in the present document are enriched with example Test Purposes (TPs) to outline possible implementations.
57c6d0080ccc3fac90d906664d16a8b7
103 596-2
2 References
57c6d0080ccc3fac90d906664d16a8b7
103 596-2
2.1 Normative references
References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies. Referenced documents which a...
57c6d0080ccc3fac90d906664d16a8b7
103 596-2
2.2 Informative references
References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies. NOTE: While any hyperlinks i...
57c6d0080ccc3fac90d906664d16a8b7
103 596-2
3 Definition of terms, symbols and abbreviations
57c6d0080ccc3fac90d906664d16a8b7
103 596-2
3.1 Terms
For the purposes of the present document, the following terms apply: black-box testing: testing activity conducted without knowledge of the internal structure of the system under test grey-box testing: testing activity conducted with a partial knowledge of the internal structure of a system under test System Under Test...
57c6d0080ccc3fac90d906664d16a8b7
103 596-2
3.2 Symbols
Void.
57c6d0080ccc3fac90d906664d16a8b7
103 596-2
3.3 Abbreviations
For the purposes of the present document, the following abbreviations apply: AUT Authentication/Authorization CoAP Constraint Application Protocol CON CoAP Confirmable message CVE Common Vulnerabilities and Exposures DoS Denial of Service IP Internet Protocol IUT Implementation Under Test JSON Java Script Object Notati...
57c6d0080ccc3fac90d906664d16a8b7
103 596-2
4 Security Test Objectives
When talking about security test objectives it is meant that assets are worth protecting. This clause does not focus on how to protect those assets but raising awareness when it comes to implementing the protocol, especially within an IoT environment. Of course, the following list does not claim to be complete. Prior t...
57c6d0080ccc3fac90d906664d16a8b7
103 596-2
5.1 Fuzz Testing
57c6d0080ccc3fac90d906664d16a8b7
103 596-2
5.1.1 General Description
Fuzzing is an effective negative black box testing method of finding unknown vulnerabilities in software. A System Under Test (SUT) is exposed via its interfaces to unexpected data. The idea is to send partially invalid data to get the system into an unexpected state. Inputs are generated randomly or systematically by ...
57c6d0080ccc3fac90d906664d16a8b7
103 596-2
5.1.2 Example Approach
Figure 1: Fuzzing configuration One possible application of the fuzzing approach can be found in the Eclipse IoT-Testware project [i.1] that implement a fuzzing proxy. The Fuzzing Proxy is a MITM (Man-In-The-Middle) Fuzzer which is capable of proxying the network traffic between two systems and altering this traffic on...
57c6d0080ccc3fac90d906664d16a8b7
103 596-2
5.1.3 CoAP-specific Considerations
Regarding CoAP, different message fields can be considered for the fuzzing approach. The fixed-size 4-byte header can be started with. Most of its fields are defined with fixed values or ranges. Exhausting non-defined or reserved values within the possible range opens various possibilities to expose potential vulnerabi...
57c6d0080ccc3fac90d906664d16a8b7
103 596-2
5.2 Penetration Testing
A penetration test is a special kind of test where an attack on a system or network is simulated by an attacker or attacker team. The attacker attempts to break into the system and take control. In contrast to testing during development, no parts or artifacts of the system to be tested are checked and there are no func...
57c6d0080ccc3fac90d906664d16a8b7
103 596-2
5.3 Testing for vulnerabilities
Testing for vulnerabilities is an approach, where already known vulnerabilities from other systems are used to check the SUT. These vulnerabilities can be found in databases and bug reports in the internet, e.g. in CVE databases. There is always a good chance, that common mistakes can be found in different implementati...
57c6d0080ccc3fac90d906664d16a8b7
103 596-2
5.4 Further approaches
The security testing methods and techniques continuously grow and evolve following new attack strategies and pattern. Basic security techniques as presented above are well-known e.g. from ETSI TR 101 583 [i.7]. New security testing approaches e.g. address spoofing and amplification attacks. For example, IP Address Spoo...
57c6d0080ccc3fac90d906664d16a8b7
103 596-2
6 Test Configurations
The test configurations are derived from the SUT access points and functional test configurations. For all test configurations presented in this clause, a sniffing tool like Wireshark is recommended, but not shown in figure 3. Figure 3: CoAP test configurations
57c6d0080ccc3fac90d906664d16a8b7
103 596-2
7 CoAP Security Test Purposes
57c6d0080ccc3fac90d906664d16a8b7
103 596-2
7.0 Introduction
Several TPs can be derived from the security test objectives and testing techniques mentioned in clauses 4 and 5. Some important aspects for CoAP security testing include: • Robustness (coverage criteria, test suite execution time, number of test cases to be executed, number of test data): - data level: malformed token...