hash stringlengths 32 32 | doc_id stringlengths 7 13 | section stringlengths 3 121 | content stringlengths 0 2.2M |
|---|---|---|---|
6e25bf9319de604515be87f207fb2d40 | 103 481 | 6.5.7.1.2 Test Procedure | Step Description Expected Result RQ 1 Send Secured Data to the ISD, which contains: - GET DATA with P1P2 = '0066' (Card Data) Response with Secured Data is returned, last or only additional data includes tag '66' and starts with '01 90 00' RQ05_0109 RQ05_0301 RQ05_3401 RQ05_3402 2 Send Secured Data to the ISD, which co... |
6e25bf9319de604515be87f207fb2d40 | 103 481 | 6.5.7.2.1 Initial Conditions | • An Application Provider SD with AID40 is installed. |
6e25bf9319de604515be87f207fb2d40 | 103 481 | 6.5.7.2.2 Test Procedure | Step Description Expected Result RQ 1 Send Secured Data to the Application Provider SD with AID40, which contains: - GET DATA with P1P2 = '00E0' (Key Information Template) Response with Secured Data is returned, last or only additional data includes tag 'E0' and starts with '01 90 00' RQ05_0109 RQ05_0301 RQ05_3401 RQ05... |
6e25bf9319de604515be87f207fb2d40 | 103 481 | 6.5.8 STORE DATA | 6.5.8.1 Test case 1: STORE DATA |
6e25bf9319de604515be87f207fb2d40 | 103 481 | 6.5.8.1.1 Initial Conditions | FFS. |
6e25bf9319de604515be87f207fb2d40 | 103 481 | 6.5.8.1.2 Test Procedure | FFS. 6.5.8.2 Test case 2: STORE DATA with a Forbidden Load File List |
6e25bf9319de604515be87f207fb2d40 | 103 481 | 6.5.8.2.1 Initial Conditions | FFS. ETSI ETSI TS 103 481 V16.5.0 (2026-03) 110 Release 16 |
6e25bf9319de604515be87f207fb2d40 | 103 481 | 6.5.8.2.2 Test Procedure | FFS. |
6e25bf9319de604515be87f207fb2d40 | 103 481 | 6.5.9 RAM implementation over HTTPS | The content of this clause is FFS. |
6e25bf9319de604515be87f207fb2d40 | 103 481 | 6.6 Additional command for push | |
6e25bf9319de604515be87f207fb2d40 | 103 481 | 6.6.1 BIP | See test case definition in clause 6.6.2. |
6e25bf9319de604515be87f207fb2d40 | 103 481 | 6.6.2 CAT_TP | 6.6.2.1 Test case 1: Send Secured Data (READ BINARY) using Expanded and Compact format with the different TAR value |
6e25bf9319de604515be87f207fb2d40 | 103 481 | 6.6.2.1.1 Initial Conditions | • None. |
6e25bf9319de604515be87f207fb2d40 | 103 481 | 6.6.2.1.2 Test Procedure | Step Description Expected Result RQ 1 Send Command with Secured Data coded as: [Compact Remote command structure] to the Exercising RFM application [TAR value for Compact format], which contains: - SELECT: MF - SELECT: DFTEST - SELECT: EFTARU - READ BINARY with P3/Le = '00' Response with Secured Data is returned, last ... |
6e25bf9319de604515be87f207fb2d40 | 103 481 | 6.6.2.2.1 Initial Conditions | • None. ETSI ETSI TS 103 481 V16.5.0 (2026-03) 111 Release 16 |
6e25bf9319de604515be87f207fb2d40 | 103 481 | 6.6.2.2.2 Test Procedure | Step Description Expected Result RQ 1 Send Command with Secured Data coded as: [Expanded Remote command structure] to the Exercising RFM application [TAR value for Compact format], which contains: - SELECT: MF - SELECT: DFTEST - SELECT: EFTARU - READ BINARY TLV Structure: C-APDU TLV Definite length coding SW = '6X XX' ... |
6e25bf9319de604515be87f207fb2d40 | 103 481 | 6.6.2.3.1 Initial Conditions | • None. |
6e25bf9319de604515be87f207fb2d40 | 103 481 | 6.6.2.3.2 Test Procedure | Step Description Expected result RQ 1 Send ENVELOPE_SMS_PP to the ISD with SPI = '02 21', and Secured Data which contains: - PUSH command for BIP channel opening - PUSH command for CAT_TP link establishment i.e. Data = '80 EC 01 01 25 35 07 02 00 00 03 00 00 02 3C 03 01 1F 40 39 02 05 78 0A 09 47 53 4D 41 65 55 49 43 4... |
6e25bf9319de604515be87f207fb2d40 | 103 481 | 6.7 Confidential application management | FFS. ETSI ETSI TS 103 481 V16.5.0 (2026-03) 113 Release 16 Annex A (normative): BER-TLV tags A.1 BER-TLV tags Table A.1: BER-TLV tags Description Length of tag Value Command Scripting template tag for definite length coding 1 Defined in ETSI TS 101 220 [6] Response Scripting template tag for definite length coding 1 De... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 1 Scope | The purpose of the present document is to describe the architecture, the core elements and corresponding technical interfaces for network independent access to emergency services. Elements are: Border Control Function (BCF), Emergency Service Routing Proxy (ESRP), Emergency Call Routing Function (ECRF), Public Safety A... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 2 References | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 2.1 Normative references | References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies. Referenced documents which a... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 2.2 Informative references | References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies. NOTE: While any hyperlinks i... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 3 Definition of terms, symbols and abbreviations | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 3.1 Terms | Void. |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 3.2 Symbols | Void. |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 3.3 Abbreviations | For the purposes of the present document, the following abbreviations apply: AML Advanced Mobile Location AMR Adaptive Multi-Rate ANP Access Network Provider BCF Border Control Function ETSI ETSI TS 103 479 V1.1.1 (2019-12) 13 CA Certification Authority CAP Common Alerting Protocol CERT Computer Emergency Response Team... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 4 General | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 4.1 Overview | Per ETSI ES 203 178 [1], emergency calls originating in an ANP infrastructure are forwarded via a VSP to an ECSP where the appropriate PSAP or, in general terms, the Point-of-Interconnect to a PSP infrastructure is determined. In general, emergency calls are routed by the ESRF to the ESRP via a BCF utilizing interface ... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 4.2 Architecture | The definition of core elements for network independent access to emergency services is based on the core concept of the NG112 architecture as introduced in [i.1], the Emergency Services IP Network (ESInet). The ESInet is an emergency services network of networks that utilizes IP technology. ESInets are private, manage... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 4.3 Mandatory Interfaces | Mandatory interfaces are introduced by the present document to define media and signalling capabilities of an ESInet in addition to ETSI ES 203 283 [2]. Figure 3 shows interfaces as listed in the following: SIP-1, SIP-2: Interface between BCF, ESRP and PSAP elements that defines SIP transport and signalling capabilitie... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 4.4 Optional Interfaces | Optional interfaces are introduced by the present document to define location conveyance via AML (ETSI TS 103 625 [3]) in addition to ETSI ES 203 283 [2]. Figure 4 shows interfaces as listed in the following: AML-1: Interface between SMSC and LIS that defines AML via SMS, as in ETSI TS 103 625 [3]. AML-2: Interface bet... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5 Entities | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.1 Border Control Function (BCF) | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.1.1 Overview | A BCF provides application specific functions at the SIP/SDP [25] protocol layer to perform interconnection between two operator domains at the entrance of the ESInet where all traffic from external networks transits a BCF. A BCF is the entry point (point-of-interconnect) to the ESInet infrastructure where all traffic ... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.1.2 Mandatory Interfaces | To be compliant with the procedures in the present document, a BCF shall support: 1) the ih interface as specified in ETSI ES 203 283 [2]; 2) the SIP-1 interface as specified in clause 6.1.1; 3) the SIP-2 interface as specified in clause 6.1.2; 4) the HTTP-2 interface as specified in clause 6.2.2; 5) the RTP-1 interfac... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.1.3 Optional Interfaces | In addition to all mandatory interfaces, a BCF may support: 1) the HELD-1 interface as specified in clause 6.5.1; 2) the HELD-2 interface as specified in clause 6.5.2. Figure 6 shows the optional interface and Neighboring Entity (NE). Figure 6: BCF optional interfaces ETSI ETSI TS 103 479 V1.1.1 (2019-12) 19 |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.2 Emergency Service Routing Proxy (ESRP) | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.2.1 Overview | The Emergency Service Routing Proxy (ESRP) is the base routing function for emergency calls. ESRPs may operate in a chain (originating, intermediate, or terminating) within the ESInet with the basic function to route a call to the next hop until it reaches the appropriate PSAP. ESRPs typically receive calls from upstre... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.2.2 Mandatory Interfaces | To be compliant with the procedures in the present document, an ESRP shall support: 1) the SIP-1 interface as specified in clause 6.1.1; 2) the SIP-2 interface as specified in clause 6.1.2; 3) the HTTP-1 interface as specified in clause 6.2.1; 4) the SIP-E1 interface as specified in clause 6.3.1; ETSI ETSI TS 103 479 V... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.2.3 Optional Interfaces | In addition to all mandatory interfaces, an ESRP may support: 1) the ih, ij interface as specified in ETSI ES 203 283 [2]; 2) the SIP-3 interface as specified in clause 6.1.3; 3) the SIP-E3 interface as specified in clause 6.3.3; 4) the SIP-E4 interface as specified in clause 6.3.4; 5) the SIP-E5 interface as specified... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.2.4 Call Queueing | The destination of every routing decision is conceptually a queue of calls. The queue can be large or small, it can have one or many sources entering calls on the queue, and it can have one or many sources taking calls off the queue. All queues defined in the present document are normally First-In First-Out. A unique S... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.2.5 Policy Routing | Policy routing refers to the determination of the next hop a call or event is forwarded to by an ESRP. An ESRP shall support basic routing capabilities for calls directed to a specific queue URI. They are: 1) query the ECRF with the location included in the request to determine the normal next hop URI; 2) evaluate a po... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.3 Emergency Call Routing Function (ECRF) | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.3.1 Overview | Emergency calls will be routed to the appropriate PSAP by ESRPs based on the location of the caller. In addition, PSAPs may utilize the same routing functionality to determine how to route emergency calls to the correct responder. The functional element responsible for providing routing information to the various query... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.3.2 Mandatory Interfaces | To be compliant with the procedures in the present document, an ECRF shall support: 1) the LOST-1 interface as specified in clause 6.4.1; 2) the LOST-2 interface as specified in clause 6.4.2; 3) the LOST-3 interface as specified in clause 6.4.3; 4) the LOST-4 interface as specified in clause 6.4.4. Figure 9 shows manda... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.3.3 Optional Interfaces | In addition to all mandatory interfaces, an ECRF may support: 1) the SIP-E3 interface as specified in clause 6.3.3; 2) the SIP-E4 interface as specified in clause 6.3.4; 3) the SIP-E5 interface as specified in clause 6.3.5. Figure 10 shows the optional interface and Neighboring Entity (NE). Figure 10: ECRF optional int... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.3.4 Routing Query | When an ECRF receives a LoST query (as defined in IETF RFC 5222 [39]), it determines whether the query was received from an authenticated entity (e.g. an ESRP) and the type of service requested (i.e. emergency services). Authentication shall apply to all entities that initiate queries to the ECRF within the ESInet. TLS... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.3.5 Service Boundary | Location represented by geodetic coordinates provides data that corresponds to a specific geographic location shape. A service boundary is represented by a polygon set. More than one polygon may occur in the set, for example, when the service area has holes or non-contiguous regions. ETSI ETSI TS 103 479 V1.1.1 (2019-1... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.4 Public Safety Answering Point (PSAP) | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.4.1 Overview | A PSAP is a service, typically composed of more than one functional element. The functional elements that make up a PSAP are out of scope of the present document. The PSAP deploys the SIP call interface including the multimedia capability, and the non-human-initiated call (emergency event) capability. SIP transactions ... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.4.2 Mandatory Interfaces | To be compliant with the procedures in the present document, a PSAP shall support: 1) the SIP-1 interface as specified in clause 6.1.1; 2) the SIP-2 interface as specified in clause 6.1.2; 3) the HTTP-1 interface as specified in clause 6.2.1; 4) the HTTP-2 interface as specified in clause 6.2.2; 5) the SIP-E1 interface... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.4.3 Optional Interfaces | In addition to all mandatory interfaces, a PSAP may support: 1) the SIP-3 interface as specified in clause 6.1.3; 2) the SIP-E3 interface as specified in clause 6.3.3; 3) the SIP-E4 interface as specified in clause 6.3.4; 4) the SIP-E5 interface as specified in clause 6.3.5; 5) the HELD-3 interface as specified in clau... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.5 Location Information Server (LIS) | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.5.1 Overview | Location is fundamental to the operation of the emergency services, and the generic functional entity that provides location is a Location Information Server (LIS). For the purposes of the present document, the only capabilities a LIS provides that are relevant are: a) a dereference function defined for location by ref... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.5.2 Mandatory Interfaces | To be compliant with the procedures in the present document, a LIS shall support: 1) the HELD-1 interface as specified in clause 6.5.1; 2) the HELD-2 interface as specified in clause 6.5.2. Figure 13 shows mandatory interfaces and neighboring entities. Figure 13: LIS mandatory interfaces |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.5.3 Optional Interfaces | In addition to all mandatory interfaces, a LIS may support: 1) the AML-1 interface as specified in ETSI TS 103 625 [3]; 2) the AML-2 interface as specified in ETSI TS 103 625 [3]; 3) the HELD-3 interface as specified in clause 6.5.3. Figure 14 shows optional interfaces and neighboring entities. Figure 14: LIS optional ... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.5.4 Location Representation | Location is represented by content in a PIDF-LO document as described in IETF RFC 4119 [22], and updated by IETF RFC 5139 [59] and IETF RFC 5491 [60]. All geodetic data shall WGS84 as the datum. The representation of the location object within the PIDF document shall utilize the <tuple> element as defined in IETF RFC 4... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.6 Call Transfer Bridge (BRIDGE) | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.6.1 Overview | Bridging is used to transfer calls and conduct conferences. Bridges have a SIP signalling interface to create and maintain conferences and media mixing capability for voice, video, and text. A bridge is necessary to transfer a call because IP-based devices normally cannot mix media and transferring always adds the new ... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.6.2 Mandatory Interfaces | To be compliant with the procedures in the present document, a BRIDGE shall support: 1) the SIP-1 interface as specified in clause 6.1.1; 2) the SIP-2 interface as specified in clause 6.1.2; 3) the RTP-1 interface as specified in clause 6.6.1; 4) the RTP-2 interface as specified in clause 6.6.2. Figure 15 shows mandato... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 5.6.3 Optional Interfaces | In addition to all mandatory interfaces, a BRIDGE may support: 1) the SIP-E3 interface as specified in clause 6.3.3; 2) the SIP-E4 interface as specified in clause 6.3.4; 3) the SIP-E5 interface as specified in clause 6.3.5. Figure 16 shows the optional interface and Neighboring Entity (NE). ETSI ETSI TS 103 479 V1.1.1... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6 Interfaces | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.1 Signalling | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.1.1 SIP Transport (SIP-1) | SIP signalling within the ESInet shall be TCP with TLS as defined in IETF RFC 8446 [57]. Fallback to UDP is allowed. However emergency call messages have many large elements, for example a PIDF-LO, and are more likely to be fragmented when carried in UDP. Fragmentation and reassembly shall be supported by all ESInet el... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.1.2 SIP Session (SIP-2) | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.1.2.1 Overview | The call interface is SIP (as defined in IETF RFC 3261 [5]). All calls presented to the ESInet shall be SIP signalled. Calls are potentially multimedia, and can include one or more forms of media (audio, video and/or text). SIP is also the protocol used to call an emergency caller back, and for calls between agents wit... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.1.2.2 SIP Methods | INVITE: The INVITE method is used to initiate a call. The standard INVITE/OK/ACK sequence is to be followed, with allowance for intermediate (1XX) responses. It is generally unacceptable to refuse an INVITE request unless a SIP entity is under active attack and cannot respond. Location is either included by value in th... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.1.2.3 Required SIP Headers | Table 2 shows the SIP header fields required in the INVITE and MESSAGE methods, recalling that the Request-URI will contain urn:service:sos or a sub-service of it as defined in IETF RFC 6881 [54], section 5. Table 2 Header Field/Request Defined In See Section (or IETF RFC 6881 [54]) Notes Request-URI IETF RFC 3261 [5] ... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.1.2.4 Accepted SIP Headers | Table 3 shows the SIP header fields accepted in SIP methods. Table 3 Header Field Defined In Notes Max-Forwards IETF RFC 3261 [5], section 20.22 Specifies the maximum number of SIP elements that may be traversed before assuming a routing loop has occurred Accept-Contact IETF RFC 3841 [16] Accept IETF RFC 3261 [5], sect... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.1.2.5 Resource Priority | The Resource-Priority header (as defined in IETF RFC 4412 [24]) is used on SIP calls to indicate priority that proxy servers give to specific calls. All SIP user agents that place calls within the ESInet shall be able to set Resource-Priority. All SIP proxy servers in the ESInet shall implement Resource-Priority and pr... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.1.2.6 History-Info and Reason | When a call is retargeted by any routing element, the receiving entity shall have the ability to know why it got the call. For this reason, SIP elements in the ESInet shall support the History-Info header (as defined in IETF RFC 7044 [23]) and the associated Reason header (IETF RFC 3326 [10]). Elements which retarget a... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.1.2.7 Call-Info | SIP INVITE or MESSAGE transactions may contain a Call-Info header field with a URI referencing one or more Additional Data blocks. The transaction to dereference the Additional Data shall be protected with TLS. The dereferencing entity, which may be a PSAP, uses its credentials to dereference the Additional Data URI an... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.1.2.8 SIP Message Bodies | All SIP elements in an ESInet shall support multipart MIME types as defined in IETF RFC 2046 [4] and shall support multipart message handling as specified in IETF RFC 5621 [42]. For example, location and session description may be present in a message body. All SIP elements shall allow additional body content (for exam... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.1.2.9 SIP Element Overload | Any SIP element may encounter a condition in which it is asked to process more calls than it can handle. Elements shall not return 503 Busy Here unless it is certain, by design and configuration that the upstream element can reliably cope with the error. The present document specifies specific methods to avoid overload... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.1.2.10 Test Call | Elements in the SIP signalling path shall implement the test function described in IETF RFC 6881 [54]. As the function is designed to test if an emergency call was placed from the test-initiating device, the test mechanism should mimic the entire actual call path as closely as practical. Further the test mechanism shal... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.1.3 SIP Registration (SIP-3) | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.1.3.1 Overview | The SIP Registration interface provides means to register a PSAP call handling equipment with a terminating ESRP. This interface may be used in ESInet deployments that do not require extended policy routing capabilities as specified in clause 5.2.5. |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.1.3.2 SIP Methods | REGISTER REGISTER is a SIP method for adding, removing, or querying bindings. A REGISTER request can add a new binding between an address-of-record and one or more contact addresses. When a client sends a REGISTER request, it may suggest an expiration interval that indicates how long the client would like the registrat... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.1.3.3 Required SIP Headers | Table 4 shows the SIP header fields required in the REGISTER methods. Table 4 Header Field/Request Defined In Notes To IETF RFC 3261 [5], sections 8.1.1.2 & 20.39 The To header field contains the address of record whose registration is to be created. Usually the name of the call queue configured for the PSAP From IETF ... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.2 Web Services | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.2.1 Dequeue Registration (HTTP-1) | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.2.1.1 Overview | Dequeue Registration is a web service whereby the registering entity becomes one of the dequeuing entities, and the ESRP managing the queue will begin to send calls to it. Often, an ESRP will manage a queue where it is the only dequeuer, and this web service will not be needed. When there is more than one dequeuer, the... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.2.1.2 Parameter | Table 5: DequeueRegistrationRequest Parameter Condition Description DequeueRegistrationQueueUri MANDATORY SIP URI of queue to register on DequeueRegistrationDequeuer MANDATORY SIP URI of dequeuer (where to send calls) DequeueRegistrationExpirationTime MANDATORY Requested time in seconds this registration will expire De... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.2.2 Bad Actor (HTTP-2) | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.2.2.1 Overview | When the downstream element identifies a source as a bad actor, it signals the BCF as to which source is misbehaving by sending it a <BadActorRequest> that contains the sourceid from the source parameter that was included in the incoming SIP message. The BCF responds by returning a <BadActorResponse> message that indic... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.2.2.2 Parameter | Table 7: BadActorRequest Parameter Condition Description BadActorSourceId MANDATORY sourceid ETSI ETSI TS 103 479 V1.1.1 (2019-12) 39 Table 8: BadActorResponse Parameter Condition Description BadActorStatusCode MANDATORY Status Code • Status Codes: - 101 Already reported. - 200 OK. - 513 No such sourceId. - 514 Unautho... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.3 Event Notification | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.3.1 Queue State (SIP-E1) | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.3.1.1 Overview | QueueState is an event that indicates to an upstream entity the state of a queue. The SIP NOTIFY mechanism defined in IETF RFC 6665 [51] is used to report QueueState. The event includes the URI of the queue, the current queue length, allowed maximum length and a state enumeration. ETSI Protocol Naming and Numbering Ser... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.3.1.2 Parameter | Event Package Name: emergency-QueueState Event Package Parameters: None SUBSCRIBE Bodies: Standard IETF RFC 4661 [30] + extensions filter specification may be present Subscription Duration: Default 1 hour. One (1) minute to 24 hours is reasonable NOTIFY Bodies: MIME type application/vnd.emergency.queuestate+json Table ... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.3.2 Abandoned Call (SIP-E2) | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.3.2.1 Overview | The ESRP uses the AbandonedCallEvent to notify a PSAP that a call was started, but then cancelled prior to the PSAP knowing the call occurred. ETSI ETSI TS 103 479 V1.1.1 (2019-12) 41 |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.3.2.2 Parameter | Event Package Name: emergency-AbandonedCall Event Package Parameters: None SUBSCRIBE Bodies: Standard IETF RFC 4661 [30] + extensions filter specification may be present Subscription Duration: Default one (1) hour. One (1) minute to twenty-four (24) hours is reasonable NOTIFY Bodies: MIME type application/vnd.emergency... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.3.3 Security Posture (SIP-E3) | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.3.3.1 Overview | SecurityPosture is an event that represents a downstream entity's current security state. ETSI Protocol Naming and Numbering Service (PNNS) has created a registry (SecurityPosture) of allowed values with initial defined states of: • Green - The entity is operating normally. • Yellow - The entity is receiving suspicious... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.3.3.2 Parameter | Event Package Name: emergency-SecurityPosture Event Package Parameters: None SUBSCRIBE Bodies: Standard IETF RFC 4661 [30] + extensions filter specification may be present Subscription Duration: Default 1 hour. One (1) minute to 24 hours is reasonable NOTIFY Bodies: MIME type application/vnd.emergency.securityposture+j... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.3.4 Element State (SIP-E4) | |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.3.4.1 Overview | ElementState is an event that indicates the state of an element either automatically determined, or as determined by management. ETSI Protocol Naming and Numbering Service (PNNS) has created a registry (ElementState) of allowed values with initial defined states of: • Normal: The element is operating normally. • Schedu... |
79f44e7c40710e7c1f42553822becd68 | 103 479 | 6.3.4.2 Parameter | Event Package Name: emergency-ElementState Event Package Parameters: None SUBSCRIBE Bodies: standard IETF RFC 4661 [30] + extensions filter specification may be present Subscription Duration: Default 1 hour. One (1) minute to 24 hours is reasonable NOTIFY Bodies: MIME type application/vnd.emergency.elementstate+json Ta... |
Subsets and Splits
No community queries yet
The top public SQL queries from the community will appear here once available.