hash
stringlengths
32
32
doc_id
stringlengths
7
13
section
stringlengths
3
121
content
stringlengths
0
2.2M
79f44e7c40710e7c1f42553822becd68
103 479
6.3.5 Service State (SIP-E5)
79f44e7c40710e7c1f42553822becd68
103 479
6.3.5.1 Overview
ServiceState is an event that indicates the state of service either automatically determined, or as determined by management. ETSI Protocol Naming and Numbering Service (PNNS) has created a registry (ServiceState) of allowed values with initial defined states of: • Normal: The service is operating normally. • Unmanned:...
79f44e7c40710e7c1f42553822becd68
103 479
6.3.5.2 Parameter
Event Package Name: emergency-ServiceState Event Package Parameters: None SUBSCRIBE Bodies: standard EITF RFC 4661 [30] + extensions filter specification may be present Subscription Duration: Default 1 hour. One (1) minute to 24 hours is reasonable. NOTIFY Bodies: MIME type application/vnd.emergency.servicestate+json T...
79f44e7c40710e7c1f42553822becd68
103 479
6.4 Mapping Services
79f44e7c40710e7c1f42553822becd68
103 479
6.4.1 Find Service (LOST-1)
79f44e7c40710e7c1f42553822becd68
103 479
6.4.1.1 Overview
All SIP-based emergency calls pass location information either by value (PIDF-LO) or by reference (Location URI) plus a Service URN to an Emergency Service Routing Proxy (ESRP) to support routing of emergency calls. The ESRP passes the Service URN and location information via the LoST interface (as defined in IETF RFC ...
79f44e7c40710e7c1f42553822becd68
103 479
6.4.1.2 findService Request
The "civic" and "geodetic-2d" profiles are baseline profiles defined in IETF RFC 5222 [39] and emergency calls are expected to use only these profiles. Conformant LoST servers need not support any location profiles beyond these baseline profiles. The LoST interface allows a geo-location to be expressed as a point or on...
79f44e7c40710e7c1f42553822becd68
103 479
6.4.1.3 findService Response
An ECRF servers may operate in recursive mode or iterative mode if the server being queried is not authoritative for the location supplied. The use of recursion by the ECRF initiates a query on behalf of the requestor that propagates through other ECRFs to an authoritative ECRF that returns the PSAP URI back through th...
79f44e7c40710e7c1f42553822becd68
103 479
6.4.2 Service Boundary (LOST-2)
79f44e7c40710e7c1f42553822becd68
103 479
6.4.2.1 Overview
A <findServiceResponse> can return a globally unique identifier in the 'serviceBoundary' attribute that can be used to retrieve the service boundary, rather than returning the boundary by value.
79f44e7c40710e7c1f42553822becd68
103 479
6.4.2.2 getServiceBoundary Request
If an element returns a service boundary by reference, it shall handle <getServiceBoundary> requests as defined in IETF RFC 5222 [39].
79f44e7c40710e7c1f42553822becd68
103 479
6.4.2.3 getServiceBoundary Response
The response to a <getServiceBoundary> response shall be constructed as defined in IETF RFC 5222 [39]. If an element is unable to provide information based on the received request message, it shall return an error message as defined in clause 6.4.5.
79f44e7c40710e7c1f42553822becd68
103 479
6.4.3 List Services (LOST-3)
79f44e7c40710e7c1f42553822becd68
103 479
6.4.3.1 Overview
A client can ask a LoST server for the list of services that it understands, primarily for diagnostic purposes. The query does not contain location information, as it simply provides an indication of which services the server can look up, not whether a particular service is offered for a particular area.
79f44e7c40710e7c1f42553822becd68
103 479
6.4.3.2 listServices Request
The response to a <listServices> request may depend on the credentials of the querier. A query with no <service> element in the request should result in all top level services being returned in the response (e.g. urn:service:sos). A query with <service> specified as urn:service:sos should result in all the subservices ...
79f44e7c40710e7c1f42553822becd68
103 479
6.4.3.3 listServices Response
The response to a <listServices> response shall be constructed as defined in IETF RFC 5222 [39]. If an element is unable to provide information based on the received request message, it shall return an error message as defined in clause 6.4.5.
79f44e7c40710e7c1f42553822becd68
103 479
6.4.4 List Services by Location (LOST-4)
79f44e7c40710e7c1f42553822becd68
103 479
6.4.4.1 Overview
A client can ask a LoST server for the list of services it knows about for a particular area. The query contains one or more <location> elements and may contain the <service> element. ETSI ETSI TS 103 479 V1.1.1 (2019-12) 48
79f44e7c40710e7c1f42553822becd68
103 479
6.4.4.2 listServicesByLocation Request
The response to a <listServicesByLocation> request may depend on the credentials of the querier. A query with no <service> element in the request should result in all top level services being returned in the response (e.g. urn:service:sos). A query with <service> specified as urn:service:sos should result in all the su...
79f44e7c40710e7c1f42553822becd68
103 479
6.4.4.3 listServicesByLocation Response
The response to a <listServicesByLocation> response shall be constructed as defined in IETF RFC 5222 [39]. If an element is unable to provide information based on the received request message, it shall return an error message as defined in clause 6.4.5.
79f44e7c40710e7c1f42553822becd68
103 479
6.4.5 Error Responses
• <badRequest> Element: This element indicates the ECRF could not parse or otherwise understand the request sent by the requesting entity (e.g. the XML is malformed). • <forbidden> Element: This element indicates an ECRF refused to send an answer. This generally only occurs for recursive queries, namely, if the client ...
79f44e7c40710e7c1f42553822becd68
103 479
6.5 Location Services
79f44e7c40710e7c1f42553822becd68
103 479
6.5.1 HTTP Enabled Location Delivery (HELD-1)
79f44e7c40710e7c1f42553822becd68
103 479
6.5.1.1 Overview
All elements in an ESInet that use location by reference implement HTTP Enabled Location Delivery (HELD) dereferencing protocols as defined in IETF RFC 5985 [45].
79f44e7c40710e7c1f42553822becd68
103 479
6.5.1.2 Location Request
Location requests may be used for location configuration, where a device may identify itself by a specific identity parameter, or a third-party element (BCF, ESRP or PSAP), if authorized, requests location information. Entities that request location shall support the use of device identity in HELD as defined in IETF RF...
79f44e7c40710e7c1f42553822becd68
103 479
6.5.1.3 Location Response
Location in a response shall be represented by content in a PIDF-LO document (as defined in IETF RFC 4119 [22]). All geodetic data shall use WGS84 as the datum. The representation of the location object within the PIDF document shall utilize the 'tuple' element as defined in IETF RFC 4119 [22].
79f44e7c40710e7c1f42553822becd68
103 479
6.5.1.4 Error Responses
If an element is unable to provide location information based on the received request message, it shall return an error message as defined in IETF RFC 5985 [45].
79f44e7c40710e7c1f42553822becd68
103 479
6.5.2 Location Dereference (HELD-2)
An element needing location that has a HELD URI shall dereference per IETF RFC 6753 [52].
79f44e7c40710e7c1f42553822becd68
103 479
6.5.3 Location URI (HELD-3)
79f44e7c40710e7c1f42553822becd68
103 479
6.5.3.1 Overview
The SIP Presence Event Package IETF RFC 3856 [17] implementing the SIP Presence SUBSCRIBE/NOTIFY mechanism can control repeated dereferencing, especially when tracking of the caller is needed.
79f44e7c40710e7c1f42553822becd68
103 479
6.5.3.2 Subscription
Using SIP Presence, the entity desiring location shall subscribe to the SIP Presence Event Package (IETF RFC 3856 [17]) at the location URI provided. The SUBSCRIBE shall contain an Expires header (IETF RFC 3261 [5]) which represents the subscribers requested expiration, and the 2XX response contains one that represents...
79f44e7c40710e7c1f42553822becd68
103 479
6.5.3.3 Notification
Location updates shall trigger NOTIFY transactions (IETF RFC 6665 [51]) containing a PIDF document that will include the location in the Location Object (LO) part, forming the PIDF-LO. An immediate NOTIFY shall be generated upon acceptance of a subscription request. An Expires of zero indicates a request for exactly on...
79f44e7c40710e7c1f42553822becd68
103 479
6.6 Media
79f44e7c40710e7c1f42553822becd68
103 479
6.6.1 RTP Transport (RTP-1)
All media processing elements shall support media using RTP as defined in IETF RFC 3550 [13]. Each SIP session initiation message or response should describe the media the User Agent can support using the Session Description Protocol (SDP) in the body of the message as defined in IETF RFC 4566 [25]. Support of any type...
79f44e7c40710e7c1f42553822becd68
103 479
6.6.2 RTP Types (RTP-2)
79f44e7c40710e7c1f42553822becd68
103 479
6.6.2.1 General
Besides the definitions in the following clauses, the media included in the emergency call may be varied according to the description 3GPP TS 26.114 [i.4].
79f44e7c40710e7c1f42553822becd68
103 479
6.6.2.2 Audio
All audio processing entities in the ESInet shall support g.711 µ-law and a-law (IETF RFC 5139 [59]). AMR, AMR- WB, EVRC (IETF RFC 3558 [14]), EVRC-B (IETF RFC 4788 [31]), EVRC-WB [IETF RFC 5188 [37]), and EVRC-NW (IETF RFC 6884 [55] should be supported.
79f44e7c40710e7c1f42553822becd68
103 479
6.6.2.3 Video
All video processing entities in the ESInet shall support video compression format H.264/MPEG-4 Version 10 baseline profile including levels 1-3. Further, such entities shall support both IETF RFC 5104 [35] and IETF RFC 5168 [36] for full frame refresh requests utilizing the Real-time Transport Control Protocol (RTCP) ...
79f44e7c40710e7c1f42553822becd68
103 479
6.6.2.4 Real-time Text
All call handling elements in the ESInet shall support the framework for Real-time Text over IP using the Session Initiation Protocol (SIP), as in IETF RFC 5194 [38], specifying the use of IETF RFC 4103 [21] for the packetization of real-time text. This medium may be used simultaneously with voice and/or video in calls...
79f44e7c40710e7c1f42553822becd68
103 479
6.7 Instant Messaging (IM-1)
PSAPs shall be able to receive IM as a series of individual MESSAGE transactions within and out of a SIP dialog (non- session-mode). Location shall be included in a geolocation header in the MESSAGE method as with any other emergency call. Out of dialog MESSAGEs received from the same caller within a configurable time ...
79f44e7c40710e7c1f42553822becd68
103 479
6.8 Common Alerting Protocol (CAP-1)
Non-human-associated calls are non-interactive calls originated by an automated sensor-based device. Such calls contain data (e.g. sensor data). There may be streaming media (e.g. video or audio feeds) and a capability to control the device or another device. In general, there is no assumption of a human presence. Comm...
137a7880a1e68c67f795309695071409
103 544-2
1 Scope
The present document is part of the MirrorLink® specification which specifies an interface for enabling remote user interaction of a mobile device via another device. The present document is written having a vehicle head-unit to interact with the mobile device in mind, but it will similarly apply for other devices, whi...
137a7880a1e68c67f795309695071409
103 544-2
2 References
137a7880a1e68c67f795309695071409
103 544-2
2.1 Normative references
References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies. Referenced documents which a...
137a7880a1e68c67f795309695071409
103 544-2
2.2 Informative references
References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies. NOTE: While any hyperlinks i...
137a7880a1e68c67f795309695071409
103 544-2
3 Definition of terms, symbols and abbreviations
137a7880a1e68c67f795309695071409
103 544-2
3.1 Terms
For the purposes of the present document, the following terms apply: pointer event: touch screen action in which the user touches the screen with one (virtual) finger only at a single location touch event: touch screen action in which the user touches the screen with two or more separate fingers at different locations ...
137a7880a1e68c67f795309695071409
103 544-2
3.2 Symbols
Void.
137a7880a1e68c67f795309695071409
103 544-2
3.3 Abbreviations
For the purposes of the present document, the following abbreviations apply: A2DP Bluetooth Advanced Audio Distribution Profile API Application Programming Interface ARGB Alpha-Red-Green-Blue BT Bluetooth BVRA Bluetooth Voice Recognition Activation ETSI ETSI TS 103 544-2 V1.3.1 (2019-10) 8 DAP Device Attestation Protoc...
137a7880a1e68c67f795309695071409
103 544-2
4 Introduction
The Virtual Networking Computing (VNC) uses the Remote Framebuffer Protocol (RFB) as a simple protocol for remote access to any sort of framebuffer-based user interface. The remote endpoint is called the VNC Client, whereas the endpoint driving the framebuffer is called the VNC Server. In the MirrorLink context, the VN...
137a7880a1e68c67f795309695071409
103 544-2
5 Managing a VNC session
137a7880a1e68c67f795309695071409
103 544-2
5.1 Identifying Remote Applications and the VNC Server
The identification of remote VNC based applications and of the VNC Server is described in [4].
137a7880a1e68c67f795309695071409
103 544-2
5.2 Launching the VNC Session
The VNC Server start-up is automatically facilitated via UPnP. The MirrorLink Server's VNC Server shall be running, when launching any application in response to a UPnP TmApplicationServer:1 service LaunchApplication action, as defined in [4]. The LaunchApplication action shall return with a URL to the VNC Server, host...
137a7880a1e68c67f795309695071409
103 544-2
5.3 Intentionally Terminating the VNC Session
A VNC session can be terminated any time from both the VNC Server and Client. This mechanism is not meant to handle error situations, which require immediate action from both the VNC Server and Client (use the unintentional termination mechanisms instead). In particular, intentional termination shall be used, if the VN...
137a7880a1e68c67f795309695071409
103 544-2
5.4 Unintentionally Terminating the VNC Session
Unintentional termination of the VNC session may happen any time due to error conditions. In case of unintentional termination of the VNC session, the respective VNC Server or Client will disconnect the TCP connection. The respective counterpart should disconnect as well. If the MirrorLink Client decides to re-establis...
137a7880a1e68c67f795309695071409
103 544-2
5.5 Testing Considerations
If the MirrorLink Client is in a dedicated testing state (as part of the MirrorLink Certification), it shall launch a new VNC session (either initiated automatically or manually from the user), whenever the VNC Server has intentionally terminated the VNC session. If the MirrorLink Client is in a dedicated testing state...
137a7880a1e68c67f795309695071409
103 544-2
6 Traditional VNC Protocol Phases
137a7880a1e68c67f795309695071409
103 544-2
6.1 General
After the connection between the VNC Server and Client has been established, the VNC protocol processing will start according to the VNC specification. The VNC protocol consists of three main steps: 1) Exchange of handshaking messages. After the handshaking phase, the VNC connection parameters are negotiated and the co...
137a7880a1e68c67f795309695071409
103 544-2
6.2 Handshaking Phase
The handshaking phase defines a couple of messages, which are exchanged between the VNC Client and the VNC Server, as shown in the Figure 2. In general, the VNC Server presents its capabilities and the VNC Client selects the best option with regard to its own capabilities. Figure 2: VNC Handshaking Phase The Table 1 pa...
137a7880a1e68c67f795309695071409
103 544-2
6.3 Initialization Phase
The initialization phase defines a couple of messages, which are exchanged between the VNC Client and the VNC Server, as shown in the Figure 3. In general, the VNC Server presents its capabilities and the VNC Client selects the best option with regard to its own capabilities. Figure 3: Initialization Phase The Table 2 ...
137a7880a1e68c67f795309695071409
103 544-2
6.4 Framebuffer Update and Event Phase
The update and event phase defines a couple of messages, which are exchanged between the VNC Client and the VNC Server. The VNC Server only responds to framebuffer update requests, as shown in Figure 4. No response message is sent to any of the other messages. Figure 4: Framebuffer Update Phase The Table 3 parameters s...
137a7880a1e68c67f795309695071409
103 544-2
7 VNC MirrorLink Extension Messages
137a7880a1e68c67f795309695071409
103 544-2
7.1 General
The existing RFB protocol specification is not sufficient to cover the mobile device - remote car display configuration space. Therefore, extensions to the current protocol are specified in this clause. Extensions are made in compliance with the RFB protocol, introducing a new MirrorLink message type (128). Under the M...
137a7880a1e68c67f795309695071409
103 544-2
7.2 ByeBye Message
The VNC ByeBye message can be sent from both, the VNC Server and VNC Client to inform the other side that the VNC session is going to be terminated intentionally. The receiving side shall stop sending any further VNC message: • If the VNC Server wants to terminate the VNC session, it shall send a VNC ByeBye message. Th...
137a7880a1e68c67f795309695071409
103 544-2
7.3 Display Configuration Messages
137a7880a1e68c67f795309695071409
103 544-2
7.3.1 General
The ServerDisplayConfiguration and ClientDisplayConfiguration message pair exchanges additional display information between the VNC Client and the Server. Based on the received information the VNC Client may change the pixel format, sending a SetPixelFormat message. The VNC Server will use this information to optionall...
137a7880a1e68c67f795309695071409
103 544-2
7.3.2 Framebuffer Scaling (VNC Server)
The MirrorLink VNC Server shall down-scale its framebuffer to fit into the framebuffer resolution provided from the MirrorLink Client in the ClientDisplayConfiguration message. NOTE: A framebuffer resolution fits e.g. within 800 x 480, if its width is equal to or smaller than 800 pixels and its height is equal to or sm...
137a7880a1e68c67f795309695071409
103 544-2
7.3.3 Framebuffer Scaling (VNC Client)
The MirrorLink Client shall support up-scaling to the framebuffer resolution provided in ClientDisplayConfiguration message. The MirrorLink Client shall provide valid VNC Client display width and height [pixel] within the ClientDisplayConfiguration message. The MirrorLink Client may request a smaller framebuffer resolu...
137a7880a1e68c67f795309695071409
103 544-2
7.3.4 Handling of Different Framebuffer Aspect Ratios
The Framebuffer Aspect Ratio (FAR) is defined as the horizontal display resolution [pixel] divided by the vertical display resolution [pixel]. The FAR is also referred to as the storage aspect ratio, as those pixels are stored in memory. The MirrorLink Server and MirrorLink Client displays can have different Framebuffe...
137a7880a1e68c67f795309695071409
103 544-2
7.3.5 Handling of Server Pixel Aspect Ratios
The Pixel Aspect Ratio (PAR) is defined as the width of a 1 (one) pixel divided by the height of 1 (one) pixel. If the PAR of the MirrorLink Server Display does not match the PAR of the MirrorLink Client display, the MirrorLink Server's display content will look distorted on the MirrorLink Client's display (e.g. a squa...
137a7880a1e68c67f795309695071409
103 544-2
7.3.6 Handling of Application, Framebuffer and Display Orientation
The application's user interface (UI) can be in Landscape or Portrait orientation. The MirrorLink Server will always send a landscape-oriented framebuffer to the MirrorLink Client, which will display it on its display in a landscape- oriented view as well. To embed a portrait-oriented application UI into a landscape-or...
137a7880a1e68c67f795309695071409
103 544-2
7.4 Event Configuration Messages
The ServerEventConfiguration and ClientEventConfiguration message pair provides additional information about event handling, i.e. which key and pointer events are natively supported on the VNC Server and Client. This information helps the Server to map specific incoming VNC Client events to Server events. The message f...
137a7880a1e68c67f795309695071409
103 544-2
7.5 Event Mapping Messages
The EventMapping and EventMappingRequest message pair provide MirrorLink 1.0 to 1.2 VNC Clients with information about the VNC Server mapping of high key symbol values, as listed in Annex B. The VNC Client can send an EventMappingRequest message at any time, requesting a specific mapping within the VNC Server. The VNC ...
137a7880a1e68c67f795309695071409
103 544-2
7.6 Device Status Messages
The DeviceStatus and DeviceStatusRequest message pair provides the VNC Client with status information of specific device settings at the VNC Server and the ability to set them. The VNC Server shall inform the VNC Client about any status change. The message flow is shown in Figure 10. Figure 10: Example DeviceStatusMess...
137a7880a1e68c67f795309695071409
103 544-2
7.7 Content Attestation Messages
The ContentAttestationRequest and ContentAttestationResponse message pair allows the MirrorLink Client to securely verify the content stream received from the MirrorLink Server. This message pair allows the MirrorLink Client to detect the following security risks originating from a man-in-the-middle attack: 1) Modifica...
137a7880a1e68c67f795309695071409
103 544-2
7.8 Framebuffer Blocking Notification
The FramebufferBlockingNotification message allows the MirrorLink Client to notify the MirrorLink Server, that certain framebuffer content delivered to it (as part of a FramebufferUpdate message) has been blocked. The original VNC protocol does not provide a mechanism to inform the MirrorLink Server about the blocking....
137a7880a1e68c67f795309695071409
103 544-2
7.9 Audio Blocking Notification
The AudioBlockingNotification message allows the MirrorLink Client to notify the MirrorLink Server, that certain audio content delivered to it (as part of a RTP stream) has been blocked. In addition, the message can be used to resume the audio streaming of a previously blocked audio stream. These mechanisms do not appl...
137a7880a1e68c67f795309695071409
103 544-2
7.10 Touch Event
The support for the TouchEvent message is optional. The MirrorLink Client should not send TouchEvent messages, if it has disabled Bit [1] of the Pointer related configuration vector in the ClientEventConfiguration message. The MirrorLink Server shall ignore TouchEvent messages, if the MirrorLink Server or Client has di...
137a7880a1e68c67f795309695071409
103 544-2
8 Additional Encodings and Pseudo Encodings
137a7880a1e68c67f795309695071409
103 544-2
8.1 General
Extensions to the VNC protocols include additional encodings and pseudo encodings. All new encodings are made in compliance with the RFB protocol. The additional encodings are summarized in Table 25. Table 25: Additional VNC Encodings Type Value Description Functionality Support Pseudo Encoding -523 MirrorLink Encoding...
137a7880a1e68c67f795309695071409
103 544-2
8.2 MirrorLink Pseudo Encoding
The MirrorLinkPseudoEncoding is used within the SetEncodings message to inform the VNC Server about the Client support of the MirrorLink extension messages. The Client shall use MirrorLinkPseudoEncoding only within the SetEncoding message to indicate support for the MirrorLink extension messages. This Pseudo Encoding s...
137a7880a1e68c67f795309695071409
103 544-2
8.3 Context Information Pseudo Encoding
The ContextInformationPseudoEncoding is added to the framebuffer encoding types to provide the Client additional meta-information about the applications and content, copied via the Framebuffer Update messages. The context information can originate from different sources, giving different levels of trust in its correctn...
137a7880a1e68c67f795309695071409
103 544-2
8.4 Desktop Size Pseudo Encoding
The DesktopSizePseudoEncoding rectangle within a FramebufferUpdate message indicates to the VNC Client, that the VNC Server has changed its framebuffer resolution. The format of DesktopSizePseudoEncoding is specified in the RFB specification [1]. A FramebufferUpdate message, containing a DesktopSizePseudoEncoding recta...
137a7880a1e68c67f795309695071409
103 544-2
8.5 Scan Line based Run-Length Encoding
Scan line based run-length encoding scans the identified rectangular framebuffer update area for a run of identical pixel values. Scanning shall be done for each row individually from the top row to the bottom row and from left-to-right within each row. Each run describes a number of pixels having the same colour value...
137a7880a1e68c67f795309695071409
103 544-2
8.6 VA H.264 Encoding
137a7880a1e68c67f795309695071409
103 544-2
8.6.1 Overview
VA H.264 is an H.264 RFB encoding registered with the 0x48323634 encoding number at the IANA [i.3], which features H.264 compression of framebuffers that are sent from an RFB server to an RFB client. Using H.264 offers significant advantages like being able to leverage hardware based encoding and decoding, and being su...
137a7880a1e68c67f795309695071409
103 544-2
8.6.2 Theory of operation
A VNC FramebufferUpdate message may contain multiple rectangles. If multiple rectangles are generated for a single server framebuffer update using the VA H.264 encoding, the H.264 Access Unit shall be sent only in the first rectangle of the FramebufferUpdate message. Subsequent rectangles shall contain only the coordin...
75b50e2cbde107ac7a189dd27bd62bc2
103 466
1 Scope
The present document defines the method to code and transmit audio services using the MPEG Layer II audio coder for Digital Audio Broadcasting (DAB) (ETSI EN 300 401 [1]) and details the necessary mandatory requirements for decoders. The permitted audio modes and the data protection and encapsulation are detailed. This...
75b50e2cbde107ac7a189dd27bd62bc2
103 466
2 References
75b50e2cbde107ac7a189dd27bd62bc2
103 466
2.1 Normative references
References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies. Referenced documents which a...
75b50e2cbde107ac7a189dd27bd62bc2
103 466
2.2 Informative references
References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies. NOTE: While any hyperlinks i...
75b50e2cbde107ac7a189dd27bd62bc2
103 466
3.1 Definitions
For the purposes of the present document, the terms and definitions given in ETSI EN 300 401 [1] and the following apply: alias component: mirrored signal component resulting from sub-Nyquist sampling ETSI ETSI TS 103 466 V1.1.1 (2016-10) 7 audio bit stream: sequence of consecutive audio frames audio frame: frame of a ...
75b50e2cbde107ac7a189dd27bd62bc2
103 466
3.2 Abbreviations
For the purposes of the present document, the abbreviations given in ETSI EN 300 401 [1] and the following apply: AES Audio Engineering Society ASCTy Audio Service Component Type CIF Common Interleaved Frame CRC Cyclic Redundancy Check DAB Digital Audio Broadcasting DRC Dynamic Range Control EBU European Broadcasting U...
75b50e2cbde107ac7a189dd27bd62bc2
103 466
3.3 Mathematical symbols
75b50e2cbde107ac7a189dd27bd62bc2
103 466
3.3.1 Arithmetic operators
For the purposes of the present document, the following mathematical symbols apply: ^ Power / Integer division with truncation of the result toward zero; for example, 7/4 and -7/-4 are truncated to 1 and -7/4 and 7/-4 are truncated to -1 Q(a/b) Q(a/b) is the quotient part of the division of a by b (a and b positive int...
75b50e2cbde107ac7a189dd27bd62bc2
103 466
3.3.2 Logical and set operators
For the purposes of the present document, the following mathematical symbols apply: max [,...,] The maximum value in the argument list min [,...,] The minimum value in the argument list ⊕ Exclusive or ∩ Set intersection ∪ Set union \ Set exclusion: {-3, -2, ..., 3} \ {0} is the set of integers {-3, -2, -1, 1, 2, 3}
75b50e2cbde107ac7a189dd27bd62bc2
103 466
3.3.3 Functions
For the purposes of the present document, the following mathematical symbols apply: sin Sine cos Cosine exp Exponential e(.) Exponential function Square root log10 Logarithm to base 10 j Imaginary unit, j2 = -1 Rect ⎩ ⎨ ⎧ < ≤ = elsewhere 0 1 0 if 1 ) ( Rect x x δ Kronecker symbol ⎩ ⎨ ⎧ ≠ = = j i j i if 0 if 1 j) δ(i,
75b50e2cbde107ac7a189dd27bd62bc2
103 466
3.3.4 Constants
For the purposes of the present document, the following mathematical symbols apply: π 3,14159265359... e 2,71828182846...
75b50e2cbde107ac7a189dd27bd62bc2
103 466
3.4 C-language mathematical symbols
75b50e2cbde107ac7a189dd27bd62bc2
103 466
3.4.1 Arithmetic operators
For the purposes of the present document, the following C-language mathematical symbols apply: + Addition - Subtraction (as a binary operator) or negation (as a unary operator) ++ Increment - - Decrement * Multiplication DIV Integer division with truncation of the result toward -∞ % Modulo operator. Defined only for po...