hash
stringlengths
32
32
doc_id
stringlengths
7
13
section
stringlengths
3
121
content
stringlengths
0
2.2M
4edb75e6f4ad78671fe7cead6bdeed6f
103 192-3
6.3 Naming conventions
4edb75e6f4ad78671fe7cead6bdeed6f
103 192-3
6.3.1 Introduction
This test suite follows the naming convention guidelines provided in ETSI EG 202 798 [i.1].
4edb75e6f4ad78671fe7cead6bdeed6f
103 192-3
6.3.2 General guidelines
The naming convention is based on the following underlying principles: • in most cases, identifiers should be prefixed with a short alphabetic string (specified in table 2) indicating the type of TTCN-3 element it represents; • suffixes should not be used except in those specific cases identified in table 2; • prefixes...
4edb75e6f4ad78671fe7cead6bdeed6f
103 192-3
6.3.3 ITS specific TTCN-3 naming conventions
Next to such general naming conventions, table 3 shows specific naming conventions that apply to the ITS TTCN-3 test suite. Table 3: ITS specific TTCN-3 naming conventions Language element Naming convention Prefix Example identifier ITS Module Use upper-case initial letter Its"IUTname"_ ItsGeoNetworking_ Module contain...
4edb75e6f4ad78671fe7cead6bdeed6f
103 192-3
6.3.4 Usage of Log statements
All TTCN-3 log statements use the following format using the same order: • Three asterisks ETSI ETSI TS 103 192-3 V1.2.1 (2022-02) 13 • The TTCN-3 test case or function identifier in which the log statement is defined • One of the categories of log: INFO, WARNING, ERROR, PASS, FAIL, INCONC, TIMEOUT • Free text • Three ...
4edb75e6f4ad78671fe7cead6bdeed6f
103 192-3
6.3.5 Test Case (TC) identifier
Table 4 shows the test case naming convention, which follows the same naming convention as the test purposes. Table 4: TC naming convention Identifier: TC_<root>_<gr>_<x>_<nn> <root> = root AUTO_IOT ITS interoperability testing <gr> = group CAM CAM messages testing DENM DENM message testing <sgr> = sub-group MFW Messag...
3edb29da43389eb31b5e000bd695f3ba
103 161-7
1 Scope
The present document describes the IPCablecom 1.5 MTA MIB requirement.
3edb29da43389eb31b5e000bd695f3ba
103 161-7
2 References
References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the reference document (including any amendments) applies. Referenced documents which ar...
3edb29da43389eb31b5e000bd695f3ba
103 161-7
2.1 Normative references
The following referenced documents are not necessary for the application of the present document but they assist the user with regard to a particular subject area. [1] IETF RFC 2132 (1997): "DHCP Options and BOOTP Vendor Extensions". [2] IETF RFC 2616 (1999): "Hypertext Transfer Protocol -- HTTP/1.1". [3] IETF RFC 3617...
3edb29da43389eb31b5e000bd695f3ba
103 161-7
2.2 Informative references
The following referenced documents are not necessary for the application of the present document but they assist the user with regard to a particular subject area. Not applicable. ETSI ETSI TS 103 161-7 V1.1.1 (2011-10) 7
3edb29da43389eb31b5e000bd695f3ba
103 161-7
3 Definitions, symbols and abbreviations
Void.
3edb29da43389eb31b5e000bd695f3ba
103 161-7
4 Void
3edb29da43389eb31b5e000bd695f3ba
103 161-7
5 Requirements
The IPCablecom MTA MIB must be implemented as defined below, using these references, [1], [2], [3], [4], [5], [6], and [7]. PKTC-MTA-MIB DEFINITIONS ::= BEGIN IMPORTS MODULE-IDENTITY, OBJECT-TYPE, Integer32, Counter32, BITS,IpAddress, NOTIFICATION-TYPE FROM SNMPv2-SMI TruthValue, RowStatus, DisplayString, MacAddress, T...
84fc120568778702982fac9319e1b55a
103 161-21
1 Scope
84fc120568778702982fac9319e1b55a
103 161-21
1.1 Purpose of the document
New objects that are being introduced beyond IPCablecom 1.0 for Signalling MIBS are being grouped in the present document so that the additional changes made can be tracked easily.
84fc120568778702982fac9319e1b55a
103 161-21
2 References
References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the reference document (including any amendments) applies. Referenced documents which ar...
84fc120568778702982fac9319e1b55a
103 161-21
2.1 Normative references
The following referenced documents are necessary for the application of the present document. [1] ETSI TS 103 161-11: "Access, Terminals, Transmission and Multiplexing (ATTM) Integrated Broadband Cable and Television Networks; IPCablecom 1.5 Part 11: Media Terminal Adapter (MTA) device provisioning". [2] IETF RFC 2833 ...
84fc120568778702982fac9319e1b55a
103 161-21
2.2 Informative references
The following referenced documents are not necessary for the application of the present document but they assist the user with regard to a particular subject area. Not applicable.
84fc120568778702982fac9319e1b55a
103 161-21
3 Definitions, symbols and abbreviations
Void. ETSI ETSI TS 103 161-21 V1.1.1 (2011-10) 7
84fc120568778702982fac9319e1b55a
103 161-21
4 Void
84fc120568778702982fac9319e1b55a
103 161-21
5 Requirements
The IPCablecom Extension Signalling MIB shall be implemented as defined below, using these references [1], [2], [3] and [4]. PKTC-EN-SIG-MIB DEFINITIONS ::= BEGIN IMPORTS MODULE-IDENTITY, OBJECT-TYPE, Unsigned32, BITS FROM SNMPv2-SMI ifIndex FROM IF-MIB SnmpAdminString FROM SNMP-FRAMEWORK-MIB TruthValue FROM SNMPv2-TC ...
b8da260ea3ef9b88649480c95f11c6d3
103 161-20
1 Scope
The Management Event MIB provides a common data and format definition for events (informative, alarm, etc.). It also specifies by what means events are transmitted. Use of a common event mechanism facilitates management of the MTA in a multi-vendor environment and provides a standard means to implement IPCablecom speci...
b8da260ea3ef9b88649480c95f11c6d3
103 161-20
1.1 Organization of document
The Management Event MIB defined in the present document provides a set of objects required for the management of IPCablecom-compliant Multimedia Terminal Adapter (MTA) devices. The mechanisms to control the event reporting are defined in the present document. This MIB itself is structured as six groups: • Management i...
b8da260ea3ef9b88649480c95f11c6d3
103 161-20
2 References
References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the reference document (including any amendments) applies. Referenced documents which ar...
b8da260ea3ef9b88649480c95f11c6d3
103 161-20
2.1 Normative references
The following referenced documents are necessary for the application of the present document. [1] PacketCable 1.5 PKT-SP-MEM1.5-I02-050812: "Management Event Mechanism", August 12, 2005, Cable Television Laboratories, Inc. [2] Void. [3] Void. [4] Void. ETSI ETSI TS 103 161-20 V1.1.1 (2011-04) 7 [5] Void. [6] Void. [7] ...
b8da260ea3ef9b88649480c95f11c6d3
103 161-20
2.2 Informative references
The following referenced documents are not necessary for the application of the present document but they assist the user with regard to a particular subject area. [i.1] ETSI TR 102 473: "Digital Video Broadcasting (DVB); IP Datacast over DVB-H: Use Cases and Services". [i.2] ETSI TR 102 469: "Digital Video Broadcastin...
b8da260ea3ef9b88649480c95f11c6d3
103 161-20
3 Definitions and abbreviations
b8da260ea3ef9b88649480c95f11c6d3
103 161-20
3.1 Definitions
For the purposes of the present document, the following terms and definitions apply: endpoint: Terminal, Gateway or MCU
b8da260ea3ef9b88649480c95f11c6d3
103 161-20
3.2 Abbreviations
For the purposes of the present document, the following abbreviations apply: FQDN Fully Qualified Domain Name IANA Internet Assigned Numbers Authority IP Internet Protocol MIB Management Information Base MTA Media Terminal Adapter SNMP Simple Network Management Protocol
b8da260ea3ef9b88649480c95f11c6d3
103 161-20
4 Void
ETSI ETSI TS 103 161-20 V1.1.1 (2011-04) 8
b8da260ea3ef9b88649480c95f11c6d3
103 161-20
5 IPCablecom Management Event MIB
The IPCablecom 1.5 Management Event MIB MUST be implemented as defined below. PKTC-EVENT-MIB DEFINITIONS ::= BEGIN IMPORTS MODULE-IDENTITY, OBJECT-TYPE, Unsigned32, NOTIFICATION-TYPE, BITS FROM SNMPv2-SMI DateAndTime FROM SNMPv2-TC clabProjPacketCable FROM CLAB-DEF-MIB SnmpAdminString FROM SNMP-FRAMEWORK-MIB OBJECT-GRO...
a013481e544daf33cdc470586dede914
103 161-4
1 Scope
The present document specifies a profile of the Media Gateway Controller Protocol (MGCP) for IPCablecom 1.5 embedded clients. MGCP is a call signalling protocol for use in a centralized call control architecture, and assumes relatively simple client devices. The call signalling protocol is one layer of the overall IPCa...
a013481e544daf33cdc470586dede914
103 161-4
2 References
References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the reference document (including any amendments) applies. Referenced documents which ar...
a013481e544daf33cdc470586dede914
103 161-4
2.1 Normative references
The following referenced documents are necessary for the application of the present document. [1] IETF RFC 3435 (January 2003): "Media Gateway Control Protocol (MGCP)" Version 1.0. [2] IETF RFC 1890 (January 1996): "RTP Profile for Audio and Video Conferences with Minimal Control". [3] IETF RFC 2327 (April 1998): "Sess...
a013481e544daf33cdc470586dede914
103 161-4
2.2 Informative references
The following referenced documents are not necessary for the application of the present document but they assist the user with regard to a particular subject area. [i.1] IETF RFC 1889: "RTP: A Transport Protocol for Real-Time Applications", January 1996. [i.2] IETF RFC 2974: "SAP - Session Announcement Protocol", Octob...
a013481e544daf33cdc470586dede914
103 161-4
3 Definitions and abbreviations
a013481e544daf33cdc470586dede914
103 161-4
3.1 Definitions
For the purposes of the present document, the following terms and definitions apply: authentication: process of verifying the claimed identity of an entity to another entity authorization: act of giving access to a service or device if one has permission to have the access ciphersuite: set which contains both an encryp...
a013481e544daf33cdc470586dede914
103 161-4
3.2 Abbreviations
For the purposes of the present document, the following abbreviations apply: AAD Average Acknowledgement Delay API Application Program Interface ATM Asynchronous Transfer Mode AV Audio Video BNR Backus-Naur form CA Call Agent CM DOCSIS® Cable Modem CMS Call Management Server CMTS Cable Modem Termination System COdec CO...
a013481e544daf33cdc470586dede914
103 161-4
4 Void
a013481e544daf33cdc470586dede914
103 161-4
5 Technical Overview
The present document describes a profile of the Media Gateway Control Protocol (MGCP) for IPCablecom embedded clients, which we will refer to as the IPCablecom Network-based Call Signalling (NCS) protocol. MGCP is a call signalling protocol for use in a centralized call control architecture, and assumes relatively simp...
a013481e544daf33cdc470586dede914
103 161-4
6 Introduction
The present document describes the NCS profile of an application programming interface (MGCI) and a corresponding protocol (MGCP) for controlling embedded clients from external call control elements. An embedded client is a network element that provides: • Two or more traditional analogue (RJ11) access lines to a voice...
a013481e544daf33cdc470586dede914
103 161-4
6.1 Relation With H.323 Standards
The MGCP is designed as an internal protocol within a distributed system that appears to the outside as a single VoIP gateway. This system is composed of a Call Agent, which may or may not be distributed over several computer platforms, and a set of gateways. In an H.323 configuration, this distributed gateway system m...
a013481e544daf33cdc470586dede914
103 161-4
6.2 Relation With IETF Standards
While H.323 used to be the recognized standard for VoIP terminals, the IETF also has produced documents for other types of multi-media applications. These other documents include: • the session description protocol (SDP) [3], • the session announcement protocol (SAP) [i.2], • the session initiation protocol (SIP) [i.17...
a013481e544daf33cdc470586dede914
103 161-4
6.3 Relation to RFC 3435 and ABNF Grammar
RFC 3435 [1] includes a formal description of the MGCP protocol syntax following the "Augmented BNF for Syntax Specifications". This formal description is referenced by developers for the creation of interoperable devices. A copy of the MGCP protocol syntax, annotated and edited to indicate its applicability to IPCable...
a013481e544daf33cdc470586dede914
103 161-4
7 Media Gateway Control Interface (MGCI)
MGCI functions provide for connection control, endpoint control, auditing, and status reporting. They each use the same system model and the same naming conventions.
a013481e544daf33cdc470586dede914
103 161-4
7.1 Model and Naming Conventions
The MGCP assumes a connection model where the basic constructs are endpoints and connections. Connections are grouped in calls. One or more connections can belong to one call. Connections and calls are set up at the initiative of one or several Call Agents.
a013481e544daf33cdc470586dede914
103 161-4
7.1.1 Endpoint Names
Endpoint names, also known as also known as, endpoint identifiers, have two components, both of which are defined to be case insensitive here: • the domain-name of the gateway managing the endpoint; • a local endpoint name within that gateway. Endpoint names will be of the form local-endpoint-name@domain-name where dom...
a013481e544daf33cdc470586dede914
103 161-4
7.1.1.1 Embedded Client Endpoint Names
Endpoints in embedded clients shall support the additional naming conventions specified in this clause. Embedded clients will support the following two endpoint-types: • Analogue telephone: The Analogue Telephone is represented as an analogue access line (aaln). This is basically the equivalent of an analogue telephone...
a013481e544daf33cdc470586dede914
103 161-4
7.1.1.1.1 Analog Access Line Endpoints
In addition to the naming conventions specified above, local endpoint names for endpoints of type "analogue access line" (aaln) for embedded clients shall adhere to the following: • Local endpoint names contain at least one and, at most, two terms. • Term1 shall be the term "aaln" or a wildcard character. It should be ...
a013481e544daf33cdc470586dede914
103 161-4
7.1.1.1.2 Video Endpoints
Details on video endpoints will be provided in a future version of the present document.
a013481e544daf33cdc470586dede914
103 161-4
7.1.2 Call Names
Calls are identified by unique identifiers, independent of the underlying platforms or agents. Call identifiers are hexadecimal strings, which are created by the Call Agent. Call identifiers with a maximum length of 32 characters shall be supported. At a minimum, call identifiers shall be unique within the collection o...
a013481e544daf33cdc470586dede914
103 161-4
7.1.3 Connection Names
Connection identifiers are created by the gateway when it is requested to create a connection. They identify the connection within the context of an endpoint. Connection identifiers are treated in MGCP as hexadecimal strings. The gateway shall ensure that a proper waiting period, at least three minutes, elapses between...
a013481e544daf33cdc470586dede914
103 161-4
7.1.4 Names of Call Agents and Other Entities
The Media Gateway Control Protocol has been designed for enhanced network reliability to allow implementation of redundant Call Agents. This means that there is no fixed binding between entities and hardware platforms or network interfaces. Call Agent names consist of two parts, similar to endpoint names. The local por...
a013481e544daf33cdc470586dede914
103 161-4
7.1.5 Digit Maps
The Call Agent can ask the gateway to collect digits dialled by the user. This facility is intended to be used for analogue access lines with residential gateways to collect the numbers that a user dials; it may also be used to collect access codes, credit card numbers, and other numbers requested by call control servi...
a013481e544daf33cdc470586dede914
103 161-4
7.1.6 Events and Signals
The concept of events and signals is central to MGCP. A Call Agent may ask to be notified about certain events occurring in an endpoint, e.g. off-hook events. A Call Agent also may request certain signals to be applied to an endpoint, e.g. dial-tone. Events and signals are grouped in packages within which they share th...
a013481e544daf33cdc470586dede914
103 161-4
7.2 SDP Use
The Call Agent uses the MGCP to provide the gateways with the description of connection parameters such as IP addresses, UDP port, and RTP profiles. Except where otherwise noted or implied in the present document, SDP descriptions shall follow the conventions delineated in the session description protocol (SDP), which ...
a013481e544daf33cdc470586dede914
103 161-4
7.3 Gateway Control Functions
This clause describes the commands of the MGCP in the form of a remote procedure call (RPC) like API, which we will refer to as the media gateway control interface (MGCI). An MGCI function is defined for each MGCP command, where the MGCI function takes and returns the same parameters as the corresponding MGCP command. ...
a013481e544daf33cdc470586dede914
103 161-4
7.3.1 NotificationRequest
The NotificationRequest command is used to request the gateway to send a notification upon the occurrence of specified events in an endpoint. For example, a notification may be requested when tones associated with fax communication are detected on the endpoint. The entity receiving this notification, usually the Call A...
a013481e544daf33cdc470586dede914
103 161-4
7.3.2 Notifications
Notifications are sent via the Notify command by the gateway when an observed event is to be notified: ReturnCode ← Notify(EndpointId [, NotifiedEntity] , RequestIdentifier , ObservedEvents) EndpointId is the name for the endpoint in the gateway, which is issuing the Notify command, as defined in clause 7.1.1. The iden...
a013481e544daf33cdc470586dede914
103 161-4
7.3.3 CreateConnection
This command is used to create a connection. ReturnCode [, ConnectionId] [, SpecificEndPointId] [, LocalConnectionDescriptor] [, ResourceID] ← CreateConnection(CallId , EndpointId [, NotifiedEntity] [, LocalConnectionOptions] , Mode [, RemoteConnectionDescriptor] [, RequestedEvents] [, RequestIdentifier] [, DigitMap] [...
a013481e544daf33cdc470586dede914
103 161-4
7.3.4 ModifyConnection
This command is used to modify the characteristics of a gateway's "view" of a connection. This "view" of the call includes both the local connection descriptor, as well as the remote connection descriptor. ReturnCode [, LocalConnectionDescriptor] [, ResourceID] ← ModifyConnection(CallId , EndpointId , ConnectionId [, N...
a013481e544daf33cdc470586dede914
103 161-4
7.3.5 DeleteConnection (From the Call Agent)
This command is used to terminate a connection. As a side effect, it collects statistics on the execution of the connection. ReturnCode [, Connection-parameters] ← DeleteConnection(CallId , EndpointId , ConnectionId [, NotifiedEntity] [, RequestedEvents] [, RequestIdentifier] [, DigitMap] [, SignalRequests] [, Quaranti...
a013481e544daf33cdc470586dede914
103 161-4
7.3.6 DeleteConnection (From the Embedded Client)
In some circumstances, a gateway may have to clear a connection, for example, because it has lost the resource associated with the connection. The gateway can terminate the connection by using a variant of the DeleteConnection command: ReturnCode ← DeleteConnection(CallId, EndpointId, ConnectionId, Reason-code, Connect...
a013481e544daf33cdc470586dede914
103 161-4
7.3.7 DeleteConnection (Multiple Connections From the Call Agent)
A variation of the DeleteConnection function can be used by the Call Agent to delete multiple connections at the same time. The command can be used to delete all connections that relate to a call for an endpoint: ReturnCode ← DeleteConnection(CallId, EndpointId) The EndpointId, in this form of the DeleteConnection comm...
a013481e544daf33cdc470586dede914
103 161-4
7.3.8 Auditing
The MGCP is based upon a centralized call control architecture where a Call Agent acts as the remote controller of client devices that provide voice interfaces to users and networks. In order to achieve the same or higher levels of availability as the current PSTN, some protocols have implemented mechanisms to periodic...
a013481e544daf33cdc470586dede914
103 161-4
7.3.8.1 AuditEndPoint
The AuditEndPoint command can be used by the Call Agent to find out the status of a given endpoint. { ReturnCode [, EndPointIdList] [, NumEndPoints] } | { ReturnCode [, RequestedEvents] [, DigitMap] [, SignalRequests] [, RequestIdentifier] [, NotifiedEntity] [, ConnectionIdentifiers] [, DetectEvents] [, ObservedEvents]...
a013481e544daf33cdc470586dede914
103 161-4
7.3.8.2 AuditConnection
Auditing of individual connections on an endpoint can be achieved using the AuditConnection command. ReturnCode [, CallId] [, NotifiedEntity] [, LocalConnectionOptions] [, Mode] [, RemoteConnectionDescriptor] [, LocalConnectionDescriptor] [, ConnectionParameters] ← AuditConnection(EndpointId , ConnectionId [, Requested...
a013481e544daf33cdc470586dede914
103 161-4
7.3.9 Restart in Progress
The RestartInProgress command is used by the gateway to signal that an endpoint, or a group of endpoints, is taken out of service or is being placed back in service. ReturnCode [, NotifiedEntity] [, VersionSupported] ← RestartInProgress(EndpointId , RestartMethod [, RestartDelay] [, ReasonCode]) The EndpointId identifi...
a013481e544daf33cdc470586dede914
103 161-4
7.4 States, Failover and Race Conditions
In order to implement proper call signalling, the Call Agent must keep track of the state of the endpoint, and the gateway must make sure that events are properly notified to the call agent. Special conditions may exist when the gateway or the call agent are restarted: the gateway may need to be redirected to a new cal...
a013481e544daf33cdc470586dede914
103 161-4
7.4.1 Recaps and Highlights
As mentioned in clause 7.1.4, Call Agents are identified by their domain name, and each endpoint has one, and only one, "notified entity" associated with it at any given point in time. In this clause we recap and highlight the areas that are of special importance to reliability and failover in MGCP: • A Call Agent is i...
a013481e544daf33cdc470586dede914
103 161-4
7.4.2 Retransmission, and Detection of Lost Associations
The MGCP protocol is organized as a set of transactions, each of which is composed of a command and a response. The MGCP messages, being carried over UDP, may be subject to losses. In the absence of a timely response (see clause 8.5), commands are repeated. MGCP Entities shall keep in memory a list of the responses tha...
a013481e544daf33cdc470586dede914
103 161-4
7.4.3 Race Conditions
In this clause we describe how MGCP deals with race conditions. First of all, MGCP deals with race conditions through the notion of a "quarantine list" that quarantines events and through explicit detection of desynchronization, e.g. for mismatched hook-state due to glare for an endpoint. Secondly, MGCP does not assume...
a013481e544daf33cdc470586dede914
103 161-4
7.4.3.1 Quarantine list
MGCP controlled gateways will receive notification requests that ask them to watch for a list of events. The protocol elements that determine the handling of these events are the "Requested Events" list, the "Digit Map", the "Quarantine Handling", and the "Detect Events" list. When the endpoint is initialized, the requ...
a013481e544daf33cdc470586dede914
103 161-4
7.4.3.2 Explicit Detection
A key element of the state of several endpoints is the position of the hook. Although hook-state changing events are persistent in NCS, race conditions and state mismatch may still occur, for example when the user decides to go off-hook while the Call Agent is in the process of requesting the gateway to look for off-ho...
a013481e544daf33cdc470586dede914
103 161-4
7.4.3.3 Transactional Semantics
As the potential transaction completion times increases, e.g. due to external resource reservations, a careful definition of the transactional semantics becomes increasingly important. In particular the issue of race conditions, specifically as it relates to hook-state must be defined carefully. An important point to c...
a013481e544daf33cdc470586dede914
103 161-4
7.4.3.4 Ordering of Commands, and Treatment of Disorder
MGCP does not mandate that the underlying transport protocol guarantees the sequencing of commands sent to a gateway or an endpoint. This property tends to maximize the timeliness of actions, but it has a few drawbacks. For example: • Notify commands may be delayed and arrive to the call agent after the transmission of...
a013481e544daf33cdc470586dede914
103 161-4
7.4.3.5 Fighting the Restart Avalanche
Let us suppose that a large number of gateways are powered on simultaneously. If they were to all initiate a RestartInProgress transaction, the Call Agent would very likely be swamped, leading to message losses and network congestion during the critical period of service restoration. In order to prevent such avalanches...
a013481e544daf33cdc470586dede914
103 161-4
7.4.3.6 Disconnected Endpoints
In addition to the restart procedure, embedded clients also have a "disconnected" procedure, which is initiated when an endpoint becomes "disconnected" as described in clause 7.4.2. It should here be noted, that endpoints can only become disconnected when they attempt to communicate with the Call Agent. The following s...
a013481e544daf33cdc470586dede914
103 161-4
7.4.3.7 Call Agent Handling of Disconnected Endpoints
When an endpoint is in the "disconnected" state it may accumulate a large number of events in the quarantine buffer. Also, a "disconnected" endpoint may autonomously delete established connections (say the gateway reboots). Therefore, when connectivity between a "disconnected" endpoint and its Call Agent is subsequentl...
a013481e544daf33cdc470586dede914
103 161-4
7.5 Return Codes and Error Codes
All MGCP commands receive a response. The response carries a return code that indicates the status of the command. The return code is an integer number, for which five value ranges have been defined: • value 000 indicates a response acknowledgement, NOTE: Response acknowledgement is used for provisional responses (see ...
a013481e544daf33cdc470586dede914
103 161-4
7.6 Reason Codes
Reason codes are used by the gateway when deleting a connection to inform the Call Agent about the reason for deleting the connection. They may also be used in a RestartInProgress command, to inform the Call Agent of the reason for the restart. The reason code is an integer number. Defined values of the reason code are...
a013481e544daf33cdc470586dede914
103 161-4
7.7.1 RFC 2833 Negotiation
The internal list of supported codecs shall include the telephone-event codec with events 0-15. This will ensure that RFC 2833 [i.10] DTMF relay will be used for the connection when authorized by the LCO (via inclusion or an empty a: parameter) and allowed by the RCD. An example of an LCO that authorizes RFC 2833 [i.10...
a013481e544daf33cdc470586dede914
103 161-4
7.7.2 Selecting Codec Packetization Interval for T.38
The packetization interval for T.38 is selected using the same procedure that is used for audio codecs. See clause 7.7. Special DQoS considerations are required for T.38. When T.38 is allowed and DQoS is to be utilized the CMS should consider the bandwidth requirements for T.38 at a particular packetization period in i...
a013481e544daf33cdc470586dede914
103 161-4
7.7.3 Remote IP and Port Negotiation
The remote IP and port are provided via the Remote Connection Descriptor. Once obtained in a successful connection handling command (for example: a Modify Connection command), the endpoint shall continue to use them until either a new Remote Connection Descriptor is provided which specifies a new remote IP or port, or ...
a013481e544daf33cdc470586dede914
103 161-4
7.7.4 LCO Use with FXR Package
The following fxr/fx LCO formats may be used if FXR is used without VBD package (see clause A.5): 1) fxr/fx:gw This results in image/t38 via udptl t38 not being used on the call. Other ways for the CMS to request the same behaviour if the VBD package is not being used are: fxr/fx:off no fxr/fx in the LCO (this provides...
a013481e544daf33cdc470586dede914
103 161-4
7.7.5 LCO with FXR and VBD Being Used by CMS at Same Time
If FXR and VBD packages are used simultaneously, the LCO format used depends on whether T.38 or V.152 is the preferred method of handling fax. 1) If t38-loose is the preferred method of handling fax, then the LCO shall include fxr/fx as formatted in the following example: L:a:PCMU;red;PCMU, fxr/fx:t38-loose, gpmd/gpmd:...
a013481e544daf33cdc470586dede914
103 161-4
7.7.6 LCO format for V.152 and RFC 2198 Redundancy use
The CMS will specify in the LCO the payload to be used as V.152, the level of redundancy to be used with V.152 and the preference of the use of redundancy vs. non-redundant use of V.152. The CMS should map V.152 to PCMU. If the CMS wishes to authorize the use of PCMU as voice and as V.152, it shall map the second insta...
a013481e544daf33cdc470586dede914
103 161-4
8 Media Gateway Control Protocol
The MGCP implements the media gateway control interface as a set of transactions. The transactions are composed of a command and a mandatory response. There are eight types of commands: • CreateConnection • ModifyConnection • DeleteConnection • NotificationRequest • Notify ETSI ETSI TS 103 161-4 V1.1.1 (2011-10) 66 • A...
a013481e544daf33cdc470586dede914
103 161-4
8.1 General Description
All commands are composed of a Command header, which for some commands may be followed by a session description. All responses are composed of a Response header, which for some commands may be followed by a session description. Headers and session descriptions are encoded as a set of text lines, separated by a carriage...
a013481e544daf33cdc470586dede914
103 161-4
8.2 Command Header
The command header is composed of: • A command line identifying the requested action or verb, the transaction identifier, the endpoint toward which the action is requested, and the MGCP protocol version, • A set of parameter lines composed of a parameter name followed by a parameter value. Unless otherwise noted or dic...
a013481e544daf33cdc470586dede914
103 161-4
8.2.1 Command Line
The command line is composed of: • The name of the requested verb. • The identification of the transaction. • The name of the endpoint(s) that should execute the command (in notifications or restarts, the name of the endpoint(s) that is issuing the command). • The protocol version. These four items are encoded as strin...
a013481e544daf33cdc470586dede914
103 161-4
8.2.1.1 Requested Verb Coding
Requested verbs are encoded as four letter upper- and/or lower-case ASCII codes (comparisons shall be case insensitive) as defined in table 6. Table 6: Requested Verb Codings Verb Code CreateConnection CRCX ModifyConnection MDCX DeleteConnection DLCX NotificationRequest RQNT Notify NTFY AuditEndpoint AUEP AuditConnecti...
a013481e544daf33cdc470586dede914
103 161-4
8.2.1.2 Transaction Identifiers
Transaction identifiers are used to correlate commands and responses. An embedded client supports two separate transaction identifier name spaces: • a transaction identifier name space for sending transactions; and • a transaction identifier name space for receiving transactions. At a minimum, transaction identifiers f...
a013481e544daf33cdc470586dede914
103 161-4
8.2.1.3 Endpoint, Call Agent and NotifiedEntity Name Coding
The endpoint names and Call Agent names are encoded as e-mail addresses, as defined in [i.6]. In these addresses, the domain name identifies the system where the endpoint is attached, while the left side identifies a specific endpoint on that system. Both components shall be case insensitive. Examples of such names are...
a013481e544daf33cdc470586dede914
103 161-4
8.2.1.4 Protocol Version Coding
The protocol version is coded as the keyword "MGCP" followed by a white space and the version number, which again is followed by the profile name "NCS" and a profile version number. The version numbers are composed of a major version number, a dot, and a minor version number. The major and minor version numbers are cod...
a013481e544daf33cdc470586dede914
103 161-4
8.2.2 Parameter Lines
Parameter lines are composed of a parameter name, which in most cases is composed of a single upper-case character, followed by a colon, a white space, and the parameter value. Parameter names and values are still case-insensitive though. The parameters that can be present in commands are defined in table 8. ETSI ETSI ...
a013481e544daf33cdc470586dede914
103 161-4
8.2.2.1 Response Acknowledgement
The response acknowledgement parameter (see table 9) is used to support the three-way handshake described in clause 8.7. It contains a comma separated list of "confirmed transaction-id ranges". Each "confirmed transaction-id range" is composed of either one decimal number, when the range includes exactly one transactio...
a013481e544daf33cdc470586dede914
103 161-4
8.2.2.2 RequestIdentifier
The request identifier correlates a Notify command with the NotificationRequest that triggered it. A RequestIdentifier is a hexadecimal string; length shall not exceed 32 characters. RequestIdentifiers are compared as strings rather than numerical values. The string "0" is reserved for reporting of persistent events in...
a013481e544daf33cdc470586dede914
103 161-4
8.2.2.3 Local Connection Options
The local connection options describe the operational parameters that the Call Agents instructs the gateway to use for a connection. These parameters are: • The packetization period in milliseconds, encoded as the keyword "p" followed by a colon and a decimal number. • The multiple packetization period in milliseconds ...
a013481e544daf33cdc470586dede914
103 161-4
8.2.2.4 Capabilities
Capabilities inform the Call Agent about the endpoint's capabilities when audited. The encoding of capabilities is based on the Local Connection Options encoding for the parameters that are common to both. In addition, capabilities can also contain a list of supported packages, and a list of supported modes. The parame...