message stringlengths 13 484 | diff stringlengths 38 4.63k |
|---|---|
Clarified mutual exclusivity in of filters /_replicate
The filters are the fields `doc_ids`, `filter`, and `selector`. | :<json object create_target_params: An object that contains parameters
to be used when creating the target database. Can include the
standard ``q`` and ``n`` parameters.
- :<json array doc_ids: Array of document IDs to be synchronized
+ :<json array doc_ids: Array of document IDs to be synchronized.
+ ``doc_ids``, ``fi... |
Persist digests before emitting them in `fs_util`
Otherwise they will not have been written to the LMDB store (although they will have been uploaded to any configured remote stores via the `ensure_uploaded_to_remote`). | @@ -586,7 +586,10 @@ async fn execute(top_match: &clap::ArgMatches) -> Result<(), ExitError> {
)
.await?;
- let report = ensure_uploaded_to_remote(&store, store_has_remote, snapshot.digest).await?;
+ let ((), report) = futures::try_join!(
+ store.ensure_directory_digest_persisted(snapshot.clone().into()),
+ ensure_uplo... |
Fix the typo
Remove unnecessary 'if'. | @@ -258,7 +258,7 @@ reflected in the view indexes.
.. note::
View index rebuilds occur when one view from the same the view group (i.e.
all the views defined within a single a design document) has been
- determined as needing a rebuild. For example, if if you have a design
+ determined as needing a rebuild. For example... |
Update gef.py
Quick fix for restoring the compatibility with Fedora GDB package which adds `Fedora ` at the start of the `gdb.VERSION` string. This fix is quick'n dirty and distro specific, if some other distribs are found doing the same thing, a better approach would be to use regular expressions instead. | @@ -215,7 +215,7 @@ ___default_aliases___ = {
}
GDB_MIN_VERSION = (7, 7)
-GDB_VERSION_MAJOR, GDB_VERSION_MINOR = [int(_) for _ in gdb.VERSION.split(".")[:2]]
+GDB_VERSION_MAJOR, GDB_VERSION_MINOR = [int(_) for _ in gdb.VERSION.replace("Fedora ","").split(".")[:2]]
GDB_VERSION = (GDB_VERSION_MAJOR, GDB_VERSION_MINOR)
cu... |
Fix alert signup HTML
You can't have a FORM inside a P so browsers insert a bunch of extra
open/close P tags to try to make it valid which makes the vertical
spacing look odd. | {% load crispy_forms_tags %}
{% if not signed_up_for_alert %}
-<p>
<form method="post" action="{{ alert_preview_action }}">
{% csrf_token %}
+ <p>
{% if alert_type == 'analyse' %}
<input type="hidden" name="url" value="">
<input type="hidden" name="name" value="">
We offer a service which emails you about unusual or in... |
Docs: Fixed IndexTemplate example
Added 'template_name' for as_template method | @@ -452,7 +452,7 @@ Potential workflow for a set of time based indices governed by a single template
return super().save(**kwargs)
# once, as part of application setup, during deploy/migrations:
- logs = Log._index.as_template()
+ logs = Log._index.as_template('logs')
logs.save()
# to perform search across all logs:
|
django-reversion compatibility documentation
Fixes | @@ -20,6 +20,7 @@ Django REST Framework |lt| 3.7.0 |check|
Django Allauth |check|
Django Simple Captcha |check|
Django OAuth Toolkit |check|
+Django Reversion |check|
======================= ============= ============ ============ ==============
.. |check| unicode:: U+2713
@@ -249,3 +250,25 @@ validator classes to func... |
CompoundEditor : Persist Editors following a numeric bookmark in layouts
User facing changes :
- When saving a layout, any editors that are currently following a
numeric bookmark will continue to follow that bookmark when the layout
is restored. | @@ -290,6 +290,15 @@ class CompoundEditor( GafferUI.Editor ) :
"driver" : self.__pathToEditor(driver),
"driverMode" : mode
}
+ else :
+ nodeSet = n.getNodeSet()
+ # NumericBookmarkSet doesn't support repr as we don't want to
+ # couple the layout-centric serialisation that assumes 'scriptNode'
+ # is a global into Sets... |
Fix Eltex.MES5448.get_lldp_neighbors script
HG--
branch : feature/microservices | @@ -21,26 +21,28 @@ class Script(BaseScript):
interface = IGetLLDPNeighbors
rx_detail = re.compile(
- r"^Chassis ID Subtype: (?P<chassis_id_subtype>.+)\n"
- r"^Chassis ID: (?P<chassis_id>.+)\n"
- r"^Port ID Subtype: (?P<port_id_subtype>.+)\n"
- r"^Port ID: (?P<port_id>.+)\n"
- r"^System Name:(?P<system_name>.*)\n"
- r"... |
Workaround fix YOLOv2 training
Set need_grad=True in get_unlinked_variable to fix issue.
Still, it doesn't solve the issue because there is a bug in nnabla
itself. Workaround is just seting need_grad=True again. | @@ -142,8 +142,12 @@ def create_network(batchsize, imheight, imwidth, args):
nH = yolo_features.shape[2]
nW = yolo_features.shape[3]
- output = yolo_features.unlinked()
- output = output.reshape((nB, nA, (5+nC), nH, nW))
+ output = yolo_features.get_unlinked_variable(need_grad=True)
+ # TODO: Workaround until v1.0.2.
+... |
Test that the 2 created libraries are in `all_libraries`
...instead of just checking that `all_libraries` has at least 2 elements. | @@ -22,17 +22,16 @@ class TestGalaxyLibraries(GalaxyTestBase.GalaxyTestBase):
self.assertIsNotNone(self.library['id'])
def test_get_libraries(self):
+ library_data = self.gi.libraries.get_libraries(library_id=self.library['id'], deleted=False)[0]
+ self.assertTrue(library_data['name'] == self.name)
deleted_name = 'dele... |
[fix update env.Whereis docu [ci skip]
Apply the patch in the issue, and further tweak the wording. | @@ -3650,30 +3650,51 @@ SConscript(dirs='doc', variant_dir='build/doc', duplicate=0)
Searches for the specified executable
<varname>program</varname>,
returning the full path name to the program
-if it is found,
-and returning None if not.
-Searches the specified
-<varname>path</varname>,
-the value of the calling envi... |
Clarify TypeError message
* Clarify TypeError message
* typo
* Wrap tye() in repr()
so that the type-check stfu
* Even better message
incidentally speeds up the thing, since all() possibly checked all elements and we don't. | @@ -56,7 +56,12 @@ def make_grid(
"""
if not torch.jit.is_scripting() and not torch.jit.is_tracing():
_log_api_usage_once(make_grid)
- if not (torch.is_tensor(tensor) or (isinstance(tensor, list) and all(torch.is_tensor(t) for t in tensor))):
+ if not torch.is_tensor(tensor):
+ if isinstance(tensor, list):
+ for t in t... |
Viewport geometry corruption in Isometric view.
Hair not work correct in isometric view
Fixed by setting MAX_ORTHO_DEPTH=200 as much more suited.
Also, small improvement in tile export. | @@ -12,6 +12,12 @@ from rprblender.utils import logging
log = logging.Log(tag='export.camera')
+# Core has issues with drawing faces in orthographic camera view with big
+# ortho depth (far_clip_plane - near_clip_plane).
+# Experimentally found quite suited value = 200
+MAX_ORTHO_DEPTH = 200.0
+
+
@dataclass(init=False... |
Add Serverless Practitioners Summit 2020 Presentation
Add link to Youtube recording of "Serverless Machine Learning Inference with KFServing - Clive Cox, Seldon & Yuzhui Liu, Bloomberg" | @@ -14,4 +14,5 @@ This page contains a list of KFServing presentations and demos.If you'd like to
| [Anchor MLOps Podcast: Serving Models with KFServing](https://anchor.fm/mlops/episodes/MLOps-Coffee-Sessions-1-Serving-Models-with-Kubeflow-efbht0) | David Aponte, Demetrios Brinkmann|
| [Kubeflow 101: What is KFserving?... |
tests: allow defining arbitrary number of OSDs
Some tests might want to set this since number of devices will not
necessarily map to number of OSDs | @@ -91,6 +91,9 @@ def node(host, request):
num_devices = len(ansible_vars.get("devices", []))
if not num_devices:
num_devices = len(ansible_vars.get("lvm_volumes", []))
+ # If number of devices doesn't map to number of OSDs, allow tests to define
+ # that custom number, defaulting it to ``num_devices``
+ num_osds = ans... |
test_upload: Use assertLogs in upload tests to verify logs.
This will avoid spam in test-backend output. | @@ -343,7 +343,11 @@ class FileUploadTest(UploadSerializeMixin, ZulipTestCase):
# dummy_2 should not exist in database or the uploads folder
do_delete_old_unclaimed_attachments(2)
self.assertTrue(not Attachment.objects.filter(path_id = d2_path_id).exists())
+ with self.assertLogs(level='WARNING') as warn_log:
self.asse... |
tutorial updates
punctuation, stylistic issues | @@ -151,7 +151,7 @@ The following example demonstrates this computation in SciPy
>>> A.dot(linalg.inv(A)) #double check
array([[ 1.00000000e+00, -1.11022302e-16, -5.55111512e-17],
[ 3.05311332e-16, 1.00000000e+00, 1.87350135e-16],
- [ 2.22044605e-16, -1.11022302e-16, 1.00000000e+00]]).
+ [ 2.22044605e-16, -1.11022302e-... |
Add "is_diff" to the metric name in EvalResults.
Support default candidate model when no model_name is provided when loading eval_result. | @@ -121,6 +121,7 @@ def load_and_deserialize_metrics(
path: Text,
model_name: Optional[Text] = None) -> List[Tuple[slicer.SliceKeyType, Any]]:
"""Loads metrics from the given location and builds a metric map for it."""
+ # TODO(b/150413770): support metrics from multiple candidates.
result = []
for record in tf.compat.... |
Update alias command
added alias command for Windows | @@ -36,6 +36,9 @@ Check the GitHub releases for the most stable release versions.
> **IMPORTANT**: The core system relies on plugins (git submodules). If you are unfamiliar with this concept and want to run the bleeding-edge code, a "git pull" on this code will likely not be sufficient. You will also need to update the... |
Added geostationary orbit creation method.
The method is supposed to be called with
-An attractor and
-Attractor's rotational velocity or period
-Hill radius (optional)
Issue: | @@ -297,6 +297,46 @@ class Orbit(object):
attractor, a, ecc, inc, raan, argp, arglat, epoch, plane
)
+ @classmethod
+ @u.quantity_input(angular_velocity=u.rad / u.s, period=u.s, hill_radius=u.m)
+ def geostationary(
+ cls, attractor, angular_velocity=None, period=None, hill_radius=None
+ ):
+ """Return the geostationar... |
Use the library short name instead of "mdl" in the playground script
TN: | ## vim: filetype=makopython
import argparse
+
from IPython import embed
from IPython.terminal.ipapp import load_default_config
-import ${module_name} as mdl
+
+import ${module_name}
+import ${module_name} as ${ctx.short_name.lower if ctx.short_name else 'mdl'}
HEADER = """
--
@@ -18,7 +21,7 @@ there are multiple.
Enjoy... |
MAINT: attempt to fix a sporadic optimiser test failure
[CHANGED] testing max evaluations triggers exit fails rarely,
but still fails. All I've done in this patch is check whether
the evaluations done is greater than *or equal* to the set limit... | @@ -93,7 +93,7 @@ class OptimiserTestCase(TestCase):
f, last, evals = MakeF()
x, e = quiet(maximise, f, xinit=[1.0], bounds=([-10, 10]),
return_eval_count=True)
- self.assertTrue(e > 500)
+ self.assertGreaterEqual(e, 500)
def test_checkpointing(self):
filename = 'checkpoint.tmp.pickle'
|
RPM: Do not define unused variables on RHEL8
* It seems OBS recently started hating these, because they are not
defining concrete versions, and fails therefore, however these
variables are not used, so lets just guard their definition. | +%if 0%{?rhel} < 8
# detect python site-packages path, use get_python_lib(0) as nuitka using
%global python_sitearch %(%{__python} -c "import sys, distutils.sysconfig; sys.stdout.write(distutils.sysconfig.get_python_lib(0))")
-
%global python3_sitearch %(%{__python3} -c "import sys, distutils.sysconfig; sys.stdout.writ... |
Enable hub tests on MacOS
Summary:
fix
This was broken by a bad openssl release in conda. Should be fixed now. Testing...
Pull Request resolved: | @@ -14,7 +14,7 @@ from torch.utils.checkpoint import checkpoint, checkpoint_sequential
import torch.hub as hub
from torch.autograd._functions.utils import prepare_onnx_paddings
from torch.autograd._functions.utils import check_onnx_broadcast
-from common_utils import skipIfRocm, load_tests, IS_MACOS
+from common_utils ... |
[tests] Make tests run when env is passed to subprocess
fixes | @@ -75,7 +75,7 @@ class MockPopen(object):
self.mock.returncode = 0
def assert_call(self, cmd):
- self.mock.popen.assert_any_call(shlex.split(cmd), stdout=subprocess.PIPE, stderr=subprocess.STDOUT)
+ self.mock.popen.assert_any_call(shlex.split(cmd), env=mock.ANY, stdout=subprocess.PIPE, stderr=subprocess.STDOUT)
def cl... |
Add a diagnostic for missing dynvar bindings in Bind's conv_prop
TN: | @@ -7,8 +7,8 @@ from langkit.compiled_types import (
from langkit.diagnostics import check_multiple, check_source_language
from langkit.expressions.base import (
- AbstractExpression, CallExpr, ComputingExpr, LiteralExpr, PropertyDef,
- aggregate_expr, auto_attr, construct, render
+ AbstractExpression, CallExpr, Comput... |
Re-enable dataflow tests.
tfx-bsl 0.25.0 is released and we can run these tests again. | @@ -306,23 +306,22 @@ class TaxiTemplateKubeflowE2ETest(test_utils.BaseEndToEndTest):
self._update_pipeline()
self._run_pipeline()
- # TODO(b/170163019) Re-enable Dataflow tests after tfx-bsl 0.25.0 release.
- # # Enable Dataflow
- # self._comment('kubeflow_dag_runner.py', [
- # 'beam_pipeline_args=configs\n',
- # '.BI... |
Update response.py
fix status code not propagating from response.stream to response.StreamingHTTPResponse | @@ -331,7 +331,7 @@ def stream(
:param headers: Custom Headers.
"""
return StreamingHTTPResponse(
- streaming_fn, headers=headers, content_type=content_type, status=200)
+ streaming_fn, headers=headers, content_type=content_type, status=status)
def redirect(to, headers=None, status=302,
|
Mentioning minimum TF version for Tensorforce
The sampling_body method in replay.py uses tf.while_loop and is given a parameter named as maximum_iterations. This parameter is introduced in Tensorflow version 1.5. If Tensorflow 1.4 is used for DQN and similar agents, we get unknown args 'maximum_iteration' error | @@ -102,7 +102,7 @@ pip install -e .
```
TensorForce is built on [Google's Tensorflow](https://www.tensorflow.org/). The installation command assumes
-that you have `tensorflow` or `tensorflow-gpu` installed.
+that you have `tensorflow` or `tensorflow-gpu` installed. Tensorforce requires Tensorflow version 1.5 or later... |
changed logging method
PypeLogger is obsolete | import os
from enum import Enum
from abc import abstractmethod
-
import attr
from openpype.lib.path_tools import sha256sum
-from openpype.lib import PypeLogger
from openpype.lib.file_handler import RemoteFileHandler
-
-log = PypeLogger().get_logger(__name__)
+from openpype.lib import Logger
class UrlType(Enum):
@@ -28,... |
Replace some malloc+memset pairs with calloc.
Summary: Pull Request resolved: | @@ -33,8 +33,7 @@ THCCudaResourcesPerDevice* THCState_getDeviceResourcePtr(
THCState* THCState_alloc(void)
{
- THCState* state = (THCState*) malloc(sizeof(THCState));
- memset(state, 0, sizeof(THCState));
+ THCState* state = (THCState*) calloc(1, sizeof(THCState));
return state;
}
@@ -55,8 +54,7 @@ void THCudaInit(THCS... |
Fix center marker shifting
fixes | @@ -133,6 +133,6 @@ export default createComponent({
left: 0;
z-index: 2;
- transform: translate(calc(50vw - 12.5px), calc(50vh - 12.5px + 47px));
+ transform: translate(calc(50vw - 12.5px), calc(50vh - 12.5px + 47px - 25px));
}
</style>
|
Cannot execute sample code.
I tried to execute the sample code of parse() on python 2.7 and 3.0.
But It occured JSONDecodeError because the "pattern" value of this sample JSON are described as multi-line.
To ensure that the sample code works, this value shuld be single-line. | @@ -60,8 +60,7 @@ To parse a STIX JSON string into a Python STIX object, use
"malicious-activity"
],
"name": "File hash for malware variant",
- "pattern": "[file:hashes.md5 =
- 'd41d8cd98f00b204e9800998ecf8427e']",
+ "pattern": "[file:hashes.md5 ='d41d8cd98f00b204e9800998ecf8427e']",
"valid_from": "2017-09-26T23:33:39.... |
Use our stored version of the crowdin-cli
So it'll never change under our feet. | @@ -102,7 +102,7 @@ compilemessages:
syncmessages: ensurecrowdinclient uploadmessages downloadmessages distributefrontendmessages
ensurecrowdinclient:
- ls -l crowdin-cli.jar || wget https://crowdin.com/downloads/crowdin-cli.jar # make sure we have the official crowdin cli client
+ ls -l crowdin-cli.jar || wget https:/... |
Prevent incorrect tuple size on get_extra_info errors
According to
get_extra_info fails by returning None. This is an attempt in
normalization of the response in cases of AF_INET, AF_INET6 and
erroneous return values. | @@ -143,7 +143,7 @@ class Request(dict):
@property
def ip(self):
if not hasattr(self, '_ip'):
- self._ip = self.transport.get_extra_info('peername')
+ self._ip = self.transport.get_extra_info('peername') or (None, None)
return self._ip
@property
|
Update install docs to reflect new minimum dependencies
[ci skip] | @@ -34,42 +34,29 @@ Dependencies
Mandatory dependencies
^^^^^^^^^^^^^^^^^^^^^^
-- `numpy <http://www.numpy.org/>`__ (>= 1.9.3)
+- `numpy <http://www.numpy.org/>`__ (>= 1.10.4)
-- `scipy <https://www.scipy.org/>`__ (>= 0.14.0)
+- `scipy <https://www.scipy.org/>`__ (>= 0.17.1)
-- `matplotlib <https://matplotlib.org>`__ (... |
Updates for InvenTree serializer classes
Catch and re-throw errors correctly | @@ -167,6 +167,18 @@ class InvenTreeModelSerializer(serializers.ModelSerializer):
return self.instance
+ def update(self, instance, validated_data):
+ """
+ Catch any django ValidationError, and re-throw as a DRF ValidationError
+ """
+
+ try:
+ instance = super().update(instance, validated_data)
+ except (ValidationEr... |
installer pip changes
installer pip changes | @@ -82,7 +82,6 @@ case "$ID" in
PACKAGE_MGR=$(command -v apt-get)
PYTHON_PREIN="git patch"
PYTHON_DEPS="python3 python3-pip python3-dev python3-setuptools python3-zmq python3-tornado python3-cryptography python3-simplejson python3-requests gcc g++ libssl-dev swig python3-yaml wget"
- PYTHON_PIPS="m2crypto"
BUILD_TOOLS=... |
Update GitHub Action workflows to use micromamba
Replace conda setup with micromamba
Reduce fetch depth for checkout
Fetch tags for version inference
Install pvlib from source before testing
Closes | @@ -8,7 +8,6 @@ on:
jobs:
test:
-
strategy:
fail-fast: false # don't cancel other matrix jobs when one fails
matrix:
@@ -31,16 +30,23 @@ jobs:
runs-on: ${{ matrix.os }}
steps:
- - uses: actions/checkout@v3
+ # We check out only a limited depth and then pull tags to save time
+ - name: Checkout source
+ uses: actions/ch... |
External Schema/Services credential type rendering bug
When 'name.' + <value> not found in translation resources, displays as name.<value>, just display <value> | @@ -35,6 +35,7 @@ import { UtilModule } from './util/util.module';
import { environment } from '../environments/environment';
const ROUTE_PREFIX: string = 'ROUTES.';
+const NAME_PREFIX: string = 'name.';
export const appInitializerFn = (appConfig: AppConfigService) => {
return () => {
@@ -69,6 +70,11 @@ export class My... |
[otBase] Actually call conv.writeArray()
Huh. Somehow the writeArray() was never wired up. We lose the failing
array index in the exception, but is fine to me. | @@ -728,12 +728,11 @@ class BaseTable(object):
# conv.repeat is a propagated count
writer[conv.repeat].setValue(countValue)
values = value
- for i, value in enumerate(values):
try:
- conv.write(writer, font, table, value, i)
+ conv.writeArray(writer, font, table, values)
except Exception as e:
name = value.__class__.__... |
Bump docutils to 0.18.1
(Not 0.19, which is not compatible with sphinx-rtd-theme yet) | @@ -21,9 +21,9 @@ Babel==2.11.0 \
--hash=sha256:1ad3eca1c885218f6dce2ab67291178944f810a10a9b5f3cb8382a5a232b64fe \
--hash=sha256:5ef4b3226b0180dedded4229651c8b0e1a3a6a2837d45a073272f313e4cf97f6
# docutils is required by Sphinx
-docutils==0.17.1 \
- --hash=sha256:cf316c8370a737a022b72b56874f6602acf974a37a9fba42ec2876387... |
[DOC] clarifications in the Deseasonalizer docstring
Adds some clarifications in the docstring of `Deseasonalizer`. | @@ -20,10 +20,14 @@ from sktime.utils.validation.forecasting import check_sp
class Deseasonalizer(BaseTransformer):
"""Remove seasonal components from a time series.
- Fit computes :term:`seasonal components <Seasonality>` and
- stores them in `seasonal_`.
+ Applies `statsmodels.tsa.seasonal.seasonal_compose` and remov... |
TrivialFix: replace list comprehension with 'for'
Creation of list here is useless. As I understand such
'cycle' was added just to have less number of code.
But creation of this list allocates memory for it. | @@ -1266,7 +1266,8 @@ def numa_get_constraints(flavor, image_meta):
nodes, flavor, cpu_list, mem_list)
# We currently support same pagesize for all cells.
- [setattr(c, 'pagesize', pagesize) for c in numa_topology.cells]
+ for c in numa_topology.cells:
+ setattr(c, 'pagesize', pagesize)
cpu_policy = _get_cpu_policy_con... |
Make reason a required input to bb watch
Resolves | @@ -220,9 +220,14 @@ class BigBrother:
"""
Relay messages sent by the given `user` to the `#big-brother-logs` channel
- If a `reason` is specified, a note is added for `user`
+ A `reason` for watching is required, which is added for the user to be watched as a
+ note (aka: shadow warning)
"""
+ if not reason:
+ await c... |
Remove dead function
Summary:
Pull Request resolved:
This wasn't called from anywhere (confirmed by grep)
ghstack-source-id:
Test Plan: waitforsandcastle | @@ -913,30 +913,6 @@ def create_generic(top_env, declarations):
return broadcast_actuals
- def emit_nn_body(option):
- # type: (FunctionOption) -> Union[str, List[str]]
- # Concrete definition on Type.cpp for NN functions. Delegates to the
- # xxx_forward variant variant after creating any necessary buffers.
- actuals ... |
Add r in front of error message string to make this a raw string
and avoid 'anomalous backslash in string' codacy and travis errors. | @@ -184,7 +184,9 @@ class Test_correct_collapsed_coordinates(IrisTest):
new_cube.add_dim_coord(DimCoord([0, 1, 2], "forecast_period",
units="hours"), 0)
- message = "Require data with shape \(3,\), got \(2,\)\."
+ # r added in front of error message string to make this a raw string
+ # and avoid 'anomalous backslash in... |
Make aoc_name a keyword arguemnt to accept spaces
Makes `aoc_name` in the link command a keyword only argument.
This allows users to link accounts with spaces in the name without having to
use quotes. | @@ -183,7 +183,7 @@ class AdventOfCode(commands.Cog):
brief="Tie your Discord account with your Advent of Code name."
)
@whitelist_override(channels=AOC_WHITELIST)
- async def aoc_link_account(self, ctx: commands.Context, aoc_name: str = None) -> None:
+ async def aoc_link_account(self, ctx: commands.Context, *, aoc_na... |
Fix Error
make --csv and --input-column optional when running in interactive mode | -from argparse import ArgumentDefaultsHelpFormatter, ArgumentParser
+from argparse import ArgumentDefaultsHelpFormatter, ArgumentParser, ArgumentError
import csv
import os
import time
@@ -31,6 +31,8 @@ class AugmentCommand(TextAttackCommand):
if not args.interactive:
textattack.shared.utils.set_seed(args.random_seed)
s... |
Checksum the colors attribute of paths
Fixes | @@ -821,6 +821,9 @@ def geometry_hash(geometry):
if hasattr(geometry, 'visual'):
# if visual properties are defined
h += str(geometry.visual.crc())
+ elif hasattr(geometry, 'colors'):
+ # paths do not use the visual attribute
+ h += str(caching.crc32(geometry.colors.tobytes()))
return h
|
infra: update firewall rules, add cluster_network for osds
At the moment, all daemons accept connections from 0.0.0.0.
We should at least restrict to public_network and add
cluster_network for OSDs.
Closes: | firewalld:
service: ceph-mon
zone: "{{ ceph_mon_firewall_zone }}"
+ source: "{{ public_network }}"
permanent: true
immediate: false # if true then fails in case firewalld is stopped
state: enabled
firewalld:
service: ceph
zone: "{{ ceph_mgr_firewall_zone }}"
+ source: "{{ public_network }}"
permanent: true
immediate: f... |
bugfix: set eval_model_params.is_training to 1 to enable training
evaluate_model() references the model.cost, but
model.cost is only set if is_training is set to True. | @@ -131,7 +131,7 @@ def load_dataset(data_dir, model_params, inference_mode=False):
eval_model_params.use_input_dropout = 0
eval_model_params.use_recurrent_dropout = 0
eval_model_params.use_output_dropout = 0
- eval_model_params.is_training = 0
+ eval_model_params.is_training = 1
sample_model_params = sketch_rnn_model.... |
[fix]: updated the minor fix
Github Issue: | @@ -18,7 +18,7 @@ class GrowthTrackerExport(ExportableMixin, IcdsSqlData):
return data_dict[case_id][column] if case_id in data_dict.keys() else "N/A"
def _fetch_data(filters, order_by, case_by_grouping=False):
- query_set = ChildHealthMonthlyView.objects.filter(filters).order_by(order_by)
+ query_set = ChildHealthMont... |
Use uncompiled version of pep508checker
This ensures that it will work when running across different Python versions. | @@ -546,7 +546,7 @@ def check():
click.echo(crayons.yellow('Checking PEP 508 requirements...'))
# Run the PEP 508 checker in the virtualenv.
- c = delegator.run('{0} {1}'.format(which('python'), pep508checker.__file__))
+ c = delegator.run('{0} {1}'.format(which('python'), pep508checker.__file__.rstrip('cd')))
results ... |
Integ tests: do not add user_properties on retries
When retrying tests on failure user_properties were added twice
causing an inconsistency in the tests result count. | @@ -144,7 +144,7 @@ def _setup_custom_logger(log_file):
def _add_properties_to_report(item):
for dimension in DIMENSIONS_MARKER_ARGS:
value = item.funcargs.get(dimension)
- if value:
+ if value and (dimension, value) not in item.user_properties:
item.user_properties.append((dimension, value))
|
fix: handle ebook which returns no progress info
closes | @@ -584,7 +584,6 @@ class AlexaClient(MediaPlayerDevice):
)
if self._session.get("state"):
self._media_player_state = self._session["state"]
- self._media_pos = self._session.get("progress", {}).get("mediaProgress")
self._media_title = self._session.get("infoText", {}).get("title")
self._media_artist = self._session.ge... |
adding create_backup, get_backups, remove_backup(s)
Fixes | @@ -1279,11 +1279,17 @@ class Model:
"""
raise NotImplementedError()
- def get_backups(self):
+ async def get_backups(self):
"""Retrieve metadata for backups in this model.
+ :return [dict]: List of metadata for the stored backups
"""
- raise NotImplementedError()
+ backups_facade = client.BackupsFacade.from_connection... |
Update CONTRIBUTING.md
Fixed typo to resolve LICENSE link. | @@ -56,6 +56,6 @@ If you discover a potential security issue in this project we ask that you notif
## Licensing
-See the [LICENSE](https://github.com/aws/aws-parallelcluster/blob/develop/LICENSE) file for our project's licensing. We will ask you to confirm the licensing of your contribution.
+See the [LICENSE](https://... |
Fixed login/logout for Django 2.1.
In django.contrib.auth.views, the login and logout funcs are removed as of Django 2.1. Helpdesk's urls.py needs to be updated to use the LoginView and LogoutView classes instead, which were introduced in Django 1.11. | @@ -185,13 +185,14 @@ urlpatterns += [
urlpatterns += [
url(r'^login/$',
- auth_views.login,
- {'template_name': 'helpdesk/registration/login.html'},
+ auth_views.LoginView.as_view(
+ template_name='helpdesk/registration/login.html'),
name='login'),
url(r'^logout/$',
- auth_views.logout,
- {'template_name': 'helpdesk/r... |
ci: fix gha deprecations for setup-deps action
update actions/setup-go to v3
updates actions/setup-python to v4
remove usage of BSFishy/pip-action
install pip packages directly
remove usages of deprecated ::set-output | @@ -9,21 +9,15 @@ runs:
run: |
sudo apt-get update -y
sudo apt-get install -y libarchive-tools
- - name: "Install Python requirements with pip"
- uses: BSFishy/pip-action@v1
- with:
- packages: |
- awscli
- packaging
# Go: Do this first because `Makefile` checks that the `go` version is correct.
- name: "Get Go version... |
update PETScNonlinearSolver to return same status information as Newton
set manually the solution from the update in case the KSP did not converge | @@ -493,8 +493,21 @@ class PETScNonlinearSolver(NonlinearSolver):
from petsc4py import PETSc as petsc
+ converged_reasons = {}
+ for key, val in six.iteritems(petsc.SNES.ConvergedReason.__dict__):
+ if isinstance(val, int):
+ converged_reasons[val] = key
+
+ ksp_converged_reasons = {}
+ for key, val in six.iteritems(pe... |
Add IOBase.read() and write()
These methods are required on IOBase-derived classes, even if they
are not a formal part of the protocol. For more information, see
Closes: | @@ -34,12 +34,14 @@ class IOBase:
def flush(self) -> None: ...
def isatty(self) -> bool: ...
def readable(self) -> bool: ...
+ read: Callable[..., Any]
def readlines(self, __hint: int = ...) -> List[bytes]: ...
def seek(self, __offset: int, __whence: int = ...) -> int: ...
def seekable(self) -> bool: ...
def tell(self)... |
Devirtualize StorageImpl deconstructor
Summary:
Further align at::StorageImpl with caffe2::StorageImpl
Pull Request resolved: | @@ -21,7 +21,7 @@ struct Type;
struct AT_API StorageImpl : public c10::intrusive_ptr_target {
public:
StorageImpl() = delete;
- virtual ~StorageImpl() {};
+ ~StorageImpl() {};
StorageImpl(
at::DataType data_type,
ptrdiff_t size,
|
Fixing a few typos I induced by find-replacing "node_"
Now the StreamPower component also works. | @@ -159,7 +159,7 @@ class StreamPowerEroder(Component):
7. , 0. , 7. , 7. , 7. ])
>>> mg2 = RasterModelGrid((3, 7), 1.)
- >>> z = np.array(mg2.x**2.)
+ >>> z = np.array(mg2.node_x**2.)
>>> z = mg2.add_field('node', 'topographic__elevation', z)
>>> mg2.status_at_node[mg2.nodes_at_left_edge] = FIXED_VALUE_BOUNDARY
>>> mg... |
Update deprecation_warning.py
Users have the option to turn off the (deprecation ) warnings by setting 'params.verbose=False'. | import sys
from plantcv.plantcv import _version
-
+from plantcv.plantcv import params
def deprecation_warning(warning):
"""Print out deprecation warning
@@ -14,4 +14,5 @@ def deprecation_warning(warning):
"""
version = _version.get_versions()
warning_msg = f"DeprecationWarning: {warning} Current PlantCV version: {versi... |
Update CAIP Prediction compatibility table to use TF 2.9.
See for the full version list. | @@ -33,8 +33,8 @@ _TF_COMPATIBILITY_OVERRIDE = {
# CAIP pusher. See:
# https://cloud.google.com/ai-platform/prediction/docs/runtime-version-list
'2.0': '1.15',
- # TODO(b/168249383) Update this once CAIP model support TF 2.8 runtime.
- '2.8': '2.7',
+ # TODO(b/168249383) Update this once CAIP model support TF 2.9 runti... |
[IMPR] Revise GeneratorsMixin's search deprecation
Making the changes discussed in CR 693515 [1]...
* Deprecating any use of 'titles' in favor of 'title'. Previously its usage
was only deprecated when the CirrusSearch extension isn't present.
* Only deprecate CirrusSearch's where usage when our family is a
WikimediaFam... | @@ -1353,20 +1353,22 @@ class GeneratorsMixin:
if where not in where_types:
raise Error("search: unrecognized 'where' value: {}".format(where))
if where in ('title', 'titles'):
- if self.has_extension('CirrusSearch'):
+ if where == 'titles':
+ issue_deprecation_warning("where='titles'", "where='title'",
+ since='201602... |
Reactivate watcher dashboard plugin in devstack/local.conf.controller
Since watcher dashboard can be sucessfully installed now by devstack,
we should enable this again. Many of us are get the local.conf from
here,so this change is necessary, we can enable watch dashboard plugin
by default. | @@ -28,7 +28,7 @@ ENABLED_SERVICES+=,q-svc,q-dhcp,q-meta,q-agt,q-l3,neutron
enable_service n-cauth
# Enable the Watcher Dashboard plugin
-# enable_plugin watcher-dashboard git://git.openstack.org/openstack/watcher-dashboard
+enable_plugin watcher-dashboard git://git.openstack.org/openstack/watcher-dashboard
# Enable th... |
updating the file path for newer version of Windows
Filesystem.file_path!="C:\\Users\\*\\AppData\\Local\\Microsoft\\Outlook*" | @@ -35,7 +35,7 @@ detect:
search: '| tstats `security_content_summariesonly` count values(Filesystem.file_path) as file_path
min(_time) as firstTime max(_time) as lastTime from datamodel=Endpoint.Filesystem
where (Filesystem.file_name=*.dll OR Filesystem.file_name=*.ost) Filesystem.file_path
- != "C:\\Users\\*\\My Docu... |
fix: use file name for backups to Google Drive
Currently, backups to Google Drive are uploaded with the absolute path as the filenames. This fix changes that.
[skip ci] | @@ -169,7 +169,7 @@ def upload_system_backup_to_google_drive():
if not fileurl:
continue
- file_metadata = {"name": fileurl, "parents": [account.backup_folder_id]}
+ file_metadata = {"name": os.path.basename(fileurl), "parents": [account.backup_folder_id]}
try:
media = MediaFileUpload(
|
Added helper function `News.sync_maillists`
Function sync maillists listing with API, that hold IDs of message that have news. PEPs handling is over RSS, so this will added manually in this function. | @@ -2,12 +2,35 @@ from discord.ext.commands import Cog
from bot.bot import Bot
+MAIL_LISTS = [
+ "python-ideas",
+ "python-announce-list",
+ "pypi-announce"
+]
+
class News(Cog):
"""Post new PEPs and Python News to `#python-news`."""
def __init__(self, bot: Bot):
self.bot = bot
+ self.bot.loop.create_task(self.sync_mai... |
Disable warnings display
In case this is hiding something in travis | [pytest]
DJANGO_SETTINGS_MODULE = config.settings
python_files = tests.py test_*.py *_tests.py
-addopts = --strict -l -p no:cacheprovider
+addopts = --strict --showlocals -p no:cacheprovider --disable-warnings
markers =
integration: integration tests
|
Add documentation for Linux Bridge and OVS ingress QoS
Added documentation reference for ingress bandwith limit QoS rule
for Open vSwitch and Linux Bridge backends.
Closes-Bug:
Closes-Bug: | @@ -43,7 +43,7 @@ traffic directions (from the VM point of view).
==================== ================ ================ ================
Rule \ back end Open vSwitch SR-IOV Linux bridge
==================== ================ ================ ================
- Bandwidth limit Egress Egress (1) Egress
+ Bandwidth limit ... |
Bugfix: Avoid the use of `locals()` in the reminder plugin
It makes it less clear where variables are used and to follow the code. | @@ -15,7 +15,7 @@ class RemindPlugin(WillPlugin):
"reminder_text": reminder_text,
}
self.schedule_say(formatted_reminder_text, parsed_time, message=message)
- self.say("%(reminder_text)s %(natural_datetime)s. Got it." % locals(), message=message)
+ self.say("%s %s. Got it." % (reminder_text, natural_datetime), message=... |
STY: whitespace
Change whitespace to remove differences between old and new files. | import importlib
+
class Constellation(object):
"""Manage and analyze data from multiple pysat Instruments.
@@ -136,4 +137,3 @@ class Constellation(object):
for instrument in self.instruments:
instrument.load(*args, **kwargs)
-
|
Redirect sign out to current page
Closes | My Challenges</a>
<div class="dropdown-divider"></div>
<a class="dropdown-item"
- href="{% url 'userena_signout' %}?next=/">
+ href="{% url 'userena_signout' %}?next={{ subdomain_absolute_uri }}">
Sign out</a>
</div>
</li>
|
Fix typo
python-pixel -> python-pyxel | @@ -79,7 +79,7 @@ Install the required packages in a way appropriate for each distribution. [glfw]
**Arch:**
-Install [`python-pixel`](https://aur.archlinux.org/packages/python-pyxel/) by using your favorite AUR helper:
+Install [`python-pyxel`](https://aur.archlinux.org/packages/python-pyxel/) by using your favorite A... |
models: Rename 'Jitsi' to 'Jitsi Meet' in Realm model.
Fixes | @@ -292,7 +292,7 @@ class Realm(models.Model):
VIDEO_CHAT_PROVIDERS = {
'jitsi_meet': {
- 'name': u"Jitsi",
+ 'name': u"Jitsi Meet",
'id': 1
},
'google_hangouts': {
|
Replace more calls to get_repository_definition with get_external_repository
Summary: Simply getting rid of a few more calls to `get_repository_definition` where it is unecessary
Test Plan: unit
Reviewers: schrockn, alangenfeld | @@ -285,24 +285,24 @@ def resolve_attempts_count(self, graphene_info):
# https://github.com/dagster-io/dagster/issues/228
def resolve_logs_path(self, graphene_info):
instance = graphene_info.context.instance
- repository = graphene_info.context.get_repository_definition()
- return instance.log_path_for_schedule(reposit... |
[4.0] remove UnicodeType and Python 2 related code
Also use tempfile.mkstemp instead of tempfile.mktemp which is
deprecated since Python 2.3 | @@ -31,12 +31,10 @@ The following generators and filters are supported:
¶ms;
"""
#
-# (C) Pywikibot team, 2008-2019
+# (C) Pywikibot team, 2008-2020
#
# Distributed under the terms of the MIT license.
#
-from __future__ import absolute_import, division, unicode_literals
-
import os
import pipes
import tempfile
@@ -... |
AnimationEditor : Refactor away `__visiblePlugs` member data
It was never used outside of `__expansionChanged()`, and we weren't using it to carry state from one invocation to the next. | @@ -165,7 +165,6 @@ class AnimationEditor( GafferUI.NodeSetEditor ) :
self.__splitter.setSizes( betterSize )
# set initial state
- self.__visiblePlugs = None
self.__editablePlugs = None
self._updateFromSet()
self._updateFromContext( [ "frame" ] )
@@ -192,27 +191,24 @@ class AnimationEditor( GafferUI.NodeSetEditor ) :
p... |
conftest.py: Provide all individual columns to get
Instead of simply passing ['*'], get the list of individual colummns
and pass that instead. This is useful as a way to get suppressed fields
such as mackey, which we need to verify the written data. | @@ -72,11 +72,10 @@ def _get_table_data_cols(table: str, datadir: str, columns: List[str],
cfgfile = create_dummy_config_file(datadir=datadir)
- if columns is None:
- # the test_parsing rouiines were written without needing to specify
- # columns
- columns = ['*']
- df = get_sqobject(table)(config_file=cfgfile).get(col... |
Fix flake8 errors in viskit/frontend.py
These are blocking PRs in the CI. It's possible a flake8 update changed
the error behavior. | @@ -224,8 +224,10 @@ def summary_name(exp, selector=None):
# if len(rest_params) > 0:
# name = ""
# for k in rest_params:
- # name += "%s=%s;" % (k.split(".")[-1],
- # str(exp.flat_params.get(k, "")).split(".")[-1])
+ # name += "%s=%s;" % (
+ # k.split(".")[-1],
+ # str(exp.flat_params.get(k, "")).split(".")[-1]
+ # )
... |
Update permission_manager_help.html
translation tag | <li>{%= __("Permissions at level 0 are Document Level permissions, i.e. they are primary for access to the document.") %}</li>
<li>{%= __("If a Role does not have access at Level 0, then higher levels are meaningless.") %}</li>
<li>{%= __("Permissions at higher levels are Field Level permissions. All Fields have a Perm... |
BUG: fixed bad list
Fixed bad list formatting in installation dependencies. | @@ -35,16 +35,17 @@ pysat itself may be installed from a terminal command line via::
pip install pysat
There are a few packages that pysat depends on that will be installed as
-needed by the installer
-
- * dask
- * netCDF4
- * numpy
- * pandas
- * portalocker
- * scipy
- * toolz
- * xarray
+needed by the installer:
+
... |
DOC: special: Remove heaviside from "functions not in special" in the tutorial.
heaviside is now in numpy, so it is no longer of a good example of a simple
function that is not in scipy.special. | @@ -246,12 +246,7 @@ The `binary entropy function`_::
def binary_entropy(x):
return -(sc.xlogy(x, x) + sc.xlog1py(1 - x, -x))/np.log(2)
-The `Heaviside step function`_::
-
- def heaviside(x):
- return 0.5*(np.sign(x) + 1)
-
-A similar idea can also be used to get a step function on [0, 1]::
+A rectangular step function... |
Fix predictString output length
translate_back_locations and translate_back output lengths differed for
some reason. use translate_back_locations in predictString instead. | @@ -89,7 +89,7 @@ class ClstmSeqRecognizer(kraken.lib.lstm.SeqRecognizer):
self.rnn.inputs.aset(line.astype('float32'))
self.rnn.forward()
self.outputs = self.rnn.outputs.array().reshape(line.shape[0], self.rnn.noutput())
- codes = kraken.lib.lstm.translate_back(self.outputs)
+ codes = [x[0] for x in kraken.lib.lstm.tr... |
Add comments for the
'route' data | // These are all the anchors to show in the TOC.
// They are objects with the "hash" and "label" properties.
anchors: [],
+
+ // This will be auto-populated to the current route.
route: ''
};
},
|
DOC: fix indentation level in list
[skip azp] [skip actions] | @@ -32,9 +32,9 @@ def spdiags(data, diags, m, n, format=None):
Matrix diagonals stored row-wise
diags : sequence of int or an int
Diagonals to set:
- - k = 0 the main diagonal
- - k > 0 the kth upper diagonal
- - k < 0 the kth lower diagonal
+ * k = 0 the main diagonal
+ * k > 0 the kth upper diagonal
+ * k < 0 the kth... |
Fixed 'NameError: name 'adata' is not defined'
Fixed 'NameError: name 'adata' is not defined' line 768, in diffusion_conn
changed from all of 'data' to 'adata' in diffusion_conn() | @@ -741,7 +741,7 @@ def select_hvg(adata, select=True):
return adata
### diffusion for connectivites matrix extension
-def diffusion_conn(data, min_k=50, copy=True, max_iterations=20):
+def diffusion_conn(adata, min_k=50, copy=True, max_iterations=20):
'''
This function performs graph diffusion on the connectivities ma... |
Wildfire getReport bug fix
* getReport bug fix
getReport bug fix
* Added empty RN
* Improved implementation | @@ -155,11 +155,15 @@ script:
throw 'Invalid hash. Only SHA256 and MD5 are supported.';
}
var bodyXML = 'apikey='+TOKEN+'&format=xml&hash='+hash;
- var resXML = sendRequest(reportUrl, bodyXML, DEFAULT_HEADERS).Body;
+ var resXML = sendRequest(reportUrl, bodyXML, DEFAULT_HEADERS);
if(!resXML){
- return 'No results yet';... |
removing installs dups from requirements.txt
Clean up the Dockerfile to not reinstall the pip modules from requirements.txt | @@ -37,9 +37,6 @@ RUN apt-get update && \
COPY setup/requirements.txt /requirements.txt
RUN easy_install pip && \
pip install -r /requirements.txt && \
- pip install psycopg2==2.6.2 && \
- pip install gunicorn==19.6.0 && \
- pip install setproctitle && \
rm /requirements.txt && \
update-rc.d -f postgresql remove && \
u... |
Fix a exception error
For shrink, if not specified instance_id should throw
"Not instances specified for shrink operation." | @@ -307,7 +307,7 @@ class MongoDbCluster(models.Cluster):
"""
if not len(instances) > 0:
raise exception.TroveError(
- _('Not instances specified for grow operation.')
+ _('No instances specified for grow operation.')
)
self._prep_resize()
self._check_quotas(self.context, instances)
@@ -339,7 +339,7 @@ class MongoDbClu... |
Remove `_assert_computation_duration_of_dispatch_is_reasonable`
It should not happen in real life and highly depends on the host, the current cpu load, the number of workers, users and user classes.
If there are performance issues, people will probably raise issue anyway. Then, we can run profiling. | @@ -203,31 +203,11 @@ class UsersDispatcher(Iterator):
if user_count_in_current_dispatch == self._user_count_per_dispatch:
break
- self._assert_computation_duration_of_dispatch_is_reasonable(duration=time.perf_counter() - ts_dispatch)
-
return {
worker_node_id: dict(sorted(user_classes_count.items(), key=itemgetter(0))... |
Update README.rst
Remove repeated information in demo README, along with broken links to the archived toga-demo repo. | @@ -18,32 +18,10 @@ and then run it::
This will pop up a GUI window.
-If you have cloned the toga-demo repository, you can run the demo like this::
+If you have cloned the toga repository, navigate to the demo directory and run it like this::
$ pip install toga
$ python -m toga_demo
-Community
----------
-
-Toga Demo i... |
Temporarily disable pyright in BK
### Summary & Motivation
Pending fix to venv build with rust dependency.
### How I Tested These Changes
BK | @@ -28,7 +28,7 @@ def build_repo_wide_steps() -> List[BuildkiteStep]:
return [
*build_repo_wide_black_steps(),
*build_repo_wide_check_manifest_steps(),
- *build_repo_wide_pyright_steps(),
+ # *build_repo_wide_pyright_steps(),
*build_repo_wide_ruff_steps(),
]
|
Remove unnecessary code in BaseOutputHandler
Closes | @@ -105,7 +105,7 @@ class BaseOutputHandler(BaseHandler):
if not isinstance(output_dict, dict):
output_dict = {"output": output_dict}
- metrics_state_attrs.update({name: value for name, value in output_dict.items()})
+ metrics_state_attrs.update(output_dict)
if self.state_attributes is not None:
metrics_state_attrs.upd... |
[ideep] Add IDEEP fallbacks for Faster-RCNN ops
TSIA | #include <caffe2/ideep/operators/operator_fallback_ideep.h>
#include <caffe2/ideep/utils/ideep_operator.h>
+#include <caffe2/operators/bbox_transform_op.h>
+#include <caffe2/operators/box_with_nms_limit_op.h>
#include <caffe2/operators/channel_shuffle_op.h>
+#include <caffe2/operators/collect_and_distribute_fpn_rpn_pro... |
api/nxtdevices/ColorSensor: add rgb and light
also, remove detection of brown color, because this is not supported | @@ -38,6 +38,24 @@ NXT Light Sensor
NXT Color Sensor
^^^^^^^^^^^^^^^^
.. autoclass:: pybricks.nxtdevices.ColorSensor
+ :no-members:
+
+ .. automethod:: pybricks.nxtdevices.ColorSensor.color
+
+ .. automethod:: pybricks.nxtdevices.ColorSensor.ambient
+
+ .. automethod:: pybricks.nxtdevices.ColorSensor.reflection
+
+ .. ... |
Subsets and Splits
No community queries yet
The top public SQL queries from the community will appear here once available.