content
large_stringlengths
3
20.5k
url
large_stringlengths
54
193
branch
large_stringclasses
4 values
source
large_stringclasses
42 values
embeddings
listlengths
384
384
score
float64
-0.21
0.65
# Trace correlations You can use Grafana [correlations](/docs/grafana//administration/correlations/) to embed interactive correlation links in your trace view to jump from spans to related logs, metrics, profiles, or external systems. This guide explains how to configure and manage Trace correlations in Grafana. ## Wha...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/tempo/traces-in-grafana/trace-correlations.md
main
grafana
[ -0.08378759026527405, -0.10268835723400116, -0.057588864117860794, 0.04755132272839546, 0.02040797285735607, -0.011184163391590118, -0.017744408920407295, -0.04485193267464638, 0.007112960331141949, -0.04142601788043976, 0.004867492709308863, -0.07823072373867035, 0.034514252096414566, 0.0...
0.062608
you started. ### Example 1: Trace to logs by service name and trace identifier In this example, you configure trace to logs by service name and a trace identifier. 1. On step 1, add a new correlation with the label \*\*Logs for this service and trace\*\* and an optional description. {{< figure src="/media/docs/tempo/sc...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/tempo/traces-in-grafana/trace-correlations.md
main
grafana
[ -0.08871416002511978, -0.061042420566082, -0.03154624253511429, 0.04408896341919899, 0.03474246710538864, -0.04346270114183426, 0.04693351686000824, -0.03794781118631363, 0.011639847420156002, 0.02391335926949978, 0.03384365141391754, -0.055535804480314255, 0.10078614205121994, 0.060479328...
0.075289
# Link to a trace ID You can link to Tempo traces from logs or metrics. ## Link to a trace ID from logs You can link to Tempo traces from logs in Loki, Elasticsearch, Splunk, and other logs data sources by configuring an internal link. To configure this feature, refer to the [Derived fields](../../../loki#configure-der...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/tempo/traces-in-grafana/link-trace-id.md
main
grafana
[ -0.020873218774795532, -0.01296912133693695, -0.026903392747044563, 0.05729556083679199, 0.06772585213184357, 0.003336025634780526, -0.0021330167073756456, -0.008067763410508633, 0.037963107228279114, -0.00016225565923377872, -0.03431791439652443, -0.07418879121541977, -0.010561230592429638,...
0.183237
# Upload a JSON trace file You can upload a JSON file that contains a single trace and visualize it. If the file has multiple traces, Grafana visualizes the first trace. To upload a trace file: 1. Select \*\*Explore\*\* in Grafana. 1. Select \*\*Import trace\*\* in the right corner. 1. Upload your JSON trace file. ## D...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/tempo/traces-in-grafana/json-trace-file.md
main
grafana
[ -0.14251139760017395, -0.004651431925594807, -0.11118561029434204, 0.013230130076408386, -0.07495494186878204, -0.045648060739040375, -0.07958541810512543, -0.02501569502055645, -0.029985010623931885, 0.021048789843916893, 0.008574878796935081, -0.030668271705508232, -0.010000631213188171, ...
0.059216
# Use traces in Grafana Using traces, you can search for traces, generate metrics from spans, and link your tracing data with logs, metrics, and profiles. This page provides a summary of how you can use tracing data in Grafana. For general documentation on querying data sources in Grafana, refer to [Query and transform...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/tempo/traces-in-grafana/_index.md
main
grafana
[ -0.07681205123662949, -0.010030008852481842, -0.06842359900474548, 0.05336577072739601, -0.04731246456503868, 0.0020495536737143993, -0.03257443383336067, -0.044440776109695435, -0.021715177223086357, -0.014379747211933136, -0.034607499837875366, -0.068963922560215, 0.002088952111080289, -...
0.049075
# Investigate traces using Search query builder Inspired by PromQL and LogQL, TraceQL is a query language designed for selecting traces. TraceQL provides a method for formulating precise queries so you can zoom in to the data you need. Query results are returned faster because the queries limit what is searched. To lea...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/tempo/query-editor/traceql-search.md
main
grafana
[ -0.028741395100951195, 0.020275508984923363, -0.046650923788547516, 0.052482396364212036, -0.03180710971355438, -0.05341144651174545, 0.05628236010670662, -0.005950527265667915, -0.03153001889586449, 0.009350190870463848, 0.04207339882850647, -0.03170599788427353, 0.03451298549771309, -0.0...
0.093103
# Query tracing data The Tempo data source's query editor helps you query and display traces from Tempo in [Explore](ref:explore). The queries use [TraceQL](/docs/tempo/latest/traceql), the query language designed specifically for tracing. For general documentation on querying data sources in Grafana, refer to [Query a...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/tempo/query-editor/_index.md
main
grafana
[ -0.07672502845525742, -0.031773313879966736, -0.05927623435854912, 0.08914171904325485, -0.09013374894857407, -0.04111899435520172, 0.028305288404226303, -0.05602386221289635, -0.03524687886238098, -0.0008753478759899735, -0.012020300142467022, -0.11168916523456573, 0.01176877599209547, -0...
0.110367
Grafana dashboards, refer to the [Use dashboards documentation](/docs/grafana//dashboards/use-dashboards/). ## Set options for query builder and editor The following options are available for the \*\*Search\*\* and \*\*TraceQL\*\* query types. You can modify these settings in the \*\*Options\*\* section. ![Options sect...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/tempo/query-editor/_index.md
main
grafana
[ -0.08870582282543182, -0.018757658079266548, -0.031055312603712082, 0.05006886273622513, -0.07524111121892929, -0.04325112700462341, -0.05455634370446205, -0.0389079749584198, -0.0069885882548987865, 0.06893470883369446, -0.020547255873680115, -0.05178910493850708, 0.03842812031507492, -0....
0.02408
} ``` TraceQL evaluates a contiguously stored trace. If these two conditions are satisfied in separate tenants, then Tempo doesn't return the trace. Refer to [Set up a multi-stack Tempo data source in Grafana](https://grafana.com/docs/grafana-cloud/connect-externally-hosted/multi-stack-data-sources/#set-up-a-multi-stac...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/tempo/query-editor/_index.md
main
grafana
[ -0.03800887241959572, -0.06194731593132019, -0.08110980689525604, 0.07175709307193756, -0.08094856888055801, -0.05733432620763779, -0.04003604128956795, -0.09548243880271912, 0.0032282823231071234, -0.03483670577406883, 0.06114477664232254, -0.0885927751660347, 0.002546838019043207, -0.067...
0.023168
# MySQL data source Grafana ships with a built-in MySQL data source plugin that allows you to query and visualize data from a MySQL-compatible database like [MariaDB](https://mariadb.org/) or [Percona Server](https://www.percona.com/). You don't need to install a plugin in order to add the MySQL data source to your Gra...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mysql/_index.md
main
grafana
[ -0.03634440153837204, -0.0452892929315567, -0.08176538348197937, 0.0396345779299736, -0.11356044560670853, -0.010353568941354752, -0.02522285468876362, 0.045302633196115494, -0.029194040223956108, 0.03549202159047127, 0.0075255753472447395, -0.09424911439418793, 0.07187273353338242, -0.036...
0.069059
# Configure the MySQL data source This document provides instructions for configuring the MySQL data source and explains available configuration options. For general information on managing data sources refer to [Data source management](ref:data-source-management). ## Before you begin You must have the `Organization ad...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mysql/configuration/_index.md
main
grafana
[ -0.06648102402687073, -0.030002474784851074, -0.08438592404127121, 0.00008855936903273687, -0.10420481860637665, -0.08591742813587189, -0.0015064585022628307, -0.002757064066827297, -0.07636900991201401, 0.07184144854545593, 0.022182293236255646, -0.06479646265506744, 0.09123699367046356, ...
0.030787
issues, it is recommended that clients connect to a MySQL server using a secure method that protects the password. Options include [TLS/SSL](https://github.com/go-sql-driver/mysql#tls), IPsec, or a private network. ## Additional settings The following are additional MySQL settings. \*\*MySQL options:\*\* - \*\*Session ...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mysql/configuration/_index.md
main
grafana
[ -0.037214890122413635, -0.0064738052897155285, -0.11475861817598343, -0.038596972823143005, -0.13076508045196533, -0.07444195449352264, -0.02770351618528366, -0.014045746065676212, 0.026827625930309296, 0.034416310489177704, -0.05792265385389328, -0.03009004518389702, 0.07475779950618744, ...
-0.044214
100 maxIdleConnsAuto: true connMaxLifetime: 14400 secureJsonData: password: ${GRAFANA\_MYSQL\_PASSWORD} tlsClientCert: ${GRAFANA\_TLS\_CLIENT\_CERT} tlsCACert: ${GRAFANA\_TLS\_CA\_CERT} ``` \*\*Use TLS and skip certificate verification:\*\* ```yaml apiVersion: 1 datasources: - name: MySQL type: mysql url: localhost:330...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mysql/configuration/_index.md
main
grafana
[ -0.08358146250247955, 0.03379712253808975, -0.07776889950037003, -0.06273987889289856, -0.09021739661693573, -0.09032304584980011, 0.003251390065997839, -0.07233548164367676, 0.05451139062643051, 0.05515681207180023, 0.03964440897107124, -0.10571811348199844, 0.08559558540582657, 0.0363180...
-0.027262
# Troubleshoot common problems with the Grafana MySQL data source plugin This page lists common issues you might experience when setting up the Grafana MySQL data source plugin. ### My data source connection fails when using the Grafana MySQL data source plugin - Check if the MySQL server is up and running. - Make sure...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mysql/troubleshoot/index.md
main
grafana
[ -0.042058609426021576, -0.09228760749101639, -0.04175212234258652, -0.0024935647379606962, -0.11088726669549942, -0.08257433027029037, -0.061431486159563065, -0.06702616810798645, -0.042115602642297745, 0.07013554871082306, 0.031062670052051544, -0.06252475082874298, 0.04552706703543663, 0...
-0.061364
# MySQL query editor Grafana’s query editors are unique for each data source. For general information on Grafana query editors, refer to [Query editors](ref:query-editor). For general information on querying data sources in Grafana, refer to [Query and transform data](ref:query-transform-data). The MySQL query editor i...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mysql/query-editor/_index.md
main
grafana
[ -0.022476505488157272, -0.03739450126886368, -0.06493396311998367, 0.07513537257909775, -0.11147190630435944, -0.02039474807679653, -0.009615020826458931, 0.020001860335469246, -0.021441681310534477, 0.05542542040348053, -0.023993147537112236, -0.059152692556381226, 0.1098245158791542, -0....
0.039825
order by from the drop-down. Select ascending (`ASC`) or descending (`DESC`) order. - \*\*Limit\*\* - You can add an optional limit on the number of retrieved results. Default is 50. - \*\*Preview\*\* - Toggle for a preview of the SQL query generated by the query builder. Preview is toggled on by default. ## MySQL Code...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mysql/query-editor/_index.md
main
grafana
[ -0.051876094192266464, -0.0330432690680027, 0.011776570230722427, 0.06590595096349716, -0.053683310747146606, 0.020462458953261375, -0.03725437819957733, 0.032588422298431396, -0.004793700762093067, 0.13607290387153625, -0.012013896368443966, 0.030018623918294907, 0.05208837613463402, -0.0...
-0.067541
of the currently active time selection as a UNIX timestamp. Example: \_1494410783\_ | | `$\_\_unixEpochTo()` | Replaces the value with the end of the currently active time selection as UNIX timestamp. Example: \_1494497183\_ | | `$\_\_unixEpochNanoFilter(dateColumn)` | Replaces the value with a time range filter using ...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mysql/query-editor/_index.md
main
grafana
[ -0.012067546136677265, 0.03247833251953125, -0.035137712955474854, 0.051225267350673676, 0.07454970479011536, -0.017258603125810623, 0.04161183908581734, 0.01274014264345169, 0.017239749431610107, 0.015293734148144722, -0.01599651202559471, -0.09043905884027481, -0.015002697706222534, -0.0...
0.11101
returns the same result as the previous one, but adds support for filtering data using the Grafana time picker. \*\*Example with `$\_\_timeGroup(dateColumn,'5m')` Macro:\*\* ```sql SELECT $\_\_timeGroup(time\_date\_time, '5m') AS time, sum(value\_double) AS sum\_value FROM my\_data WHERE $\_\_timeFilter(time\_date\_tim...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mysql/query-editor/_index.md
main
grafana
[ -0.1242508664727211, 0.0266304612159729, 0.010345454327762127, 0.0593438483774662, -0.08042288571596146, -0.014436866156756878, 0.005807156674563885, -0.01917084865272045, 0.05930687487125397, -0.0051970998756587505, 0.017105044797062874, -0.1193549707531929, -0.006965097039937973, -0.0038...
-0.027918
values (if not, only the first value is used). This allows the drop-down options to display a text-friendly name as the text while using an ID as the value. For example, a query could use `hostname` as the text and `id` as the value: ```sql SELECT hostname AS \_\_text, id AS \_\_value FROM my\_host ``` You can also cre...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mysql/query-editor/_index.md
main
grafana
[ 0.10217024385929108, 0.054146382957696915, -0.03221871331334114, 0.027066396549344063, -0.02724703587591648, -0.041063662618398666, 0.09996062517166138, -0.06265060603618622, -0.004352982621639967, 0.0014616649132221937, -0.009008510038256645, -0.0970800369977951, 0.07518404722213745, -0.0...
0.009117
SQL date/time data type:\*\* ```sql SELECT native\_date\_time as time, metric1 as text, CONCAT(tag1, ',', tag2) as tags FROM public.test\_data WHERE $\_\_timeFilter(native\_date\_time) ``` | Name | Description | | --------- | ----------------------------------------------------------------------------------------------...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mysql/query-editor/_index.md
main
grafana
[ 0.030190669000148773, 0.03367810323834419, -0.027957286685705185, 0.02103094756603241, -0.04511753097176552, -0.061315108090639114, 0.07658534497022629, 0.020635969936847687, -0.015462336130440235, -0.020344877615571022, 0.03145631402730942, -0.14635337889194489, -0.02704460918903351, 0.00...
0.033878
# OpenTSDB data source Grafana ships with advanced support for OpenTSDB. This topic explains configuration, variables, querying, and other features specific to the OpenTSDB data source. For instructions on how to add a data source to Grafana, refer to the [administration documentation](ref:data-source-management). Only...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/opentsdb/_index.md
main
grafana
[ -0.04253742843866348, -0.042341675609350204, -0.08057038486003876, 0.03386900946497917, -0.06484804302453995, -0.05199273303151131, -0.049103688448667526, -0.02658897638320923, -0.0042417761869728565, 0.05641881003975868, -0.03230215236544609, -0.033540692180395126, 0.03171239420771599, -0...
-0.01625
variables. ### Query variable Grafana's OpenTSDB data source supports template variable queries. This means you can create template variables that fetch the values from OpenTSDB. For example, metric names, tag names, or tag values. When using OpenTSDB with a template variable of `query` type you can use following synta...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/opentsdb/_index.md
main
grafana
[ -0.0339960940182209, 0.05620724707841873, -0.0886630266904831, 0.0709151178598404, -0.08892974257469177, -0.039871469140052795, 0.03495496138930321, 0.037904541939496994, -0.011976899579167366, -0.029679076746106148, -0.04978814721107483, -0.07936492562294006, 0.030149079859256744, -0.0957...
0.023276
# Configure the Grafana Pyroscope data source The Pyroscope data source sets how Grafana connects to your Pyroscope database. You can configure the data source using either the data source interface in Grafana or using a configuration file. This page explains how to set up and enable the data source capabilities using ...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/pyroscope/configure-pyroscope-data-source.md
main
grafana
[ -0.044795647263526917, -0.04241427034139633, -0.11684012413024902, -0.07048589736223221, -0.08240970224142075, -0.03935522958636284, -0.028486786410212517, -0.027321545407176018, -0.06063306704163551, 0.06750000268220901, 0.009092919528484344, -0.04686611145734787, 0.00026307112420909107, ...
0.005315
layer of security when working with Pyroscope. For additional information on setting up TLS encryption with Pyroscope, refer to [Pyroscope configuration](https://grafana.com/docs/pyroscope//configure-server/reference-configuration-parameters/). {{< /admonition >}} [//]: # 'Shared content for authentication section proc...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/pyroscope/configure-pyroscope-data-source.md
main
grafana
[ -0.16005182266235352, 0.07272665202617645, -0.1277928203344345, -0.038688089698553085, -0.11663679778575897, -0.09903617203235626, -0.028214136138558388, -0.056159451603889465, -0.021144112572073936, 0.056641802191734314, -0.005138748791068792, -0.033593762665987015, -0.019322507083415985, ...
0.013617
https://grafana.com/docs/grafana-cloud/visualizations/panels-visualizations/visualizations/flame-graph/ # Query profile data You can query your profile data using the open source Grafana Profiles Drilldown app or the built-in Grafana Pyroscope data source query editor. - Profiles Drilldown provides a queryless experien...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/pyroscope/query-profile-data.md
main
grafana
[ -0.04659660533070564, 0.024624081328511238, -0.0933661162853241, 0.015727298334240913, -0.01726192981004715, -0.03145552799105644, -0.02929522469639778, -0.009793220087885857, -0.05233970284461975, -0.0030070366337895393, -0.04335642233490944, -0.040241021662950516, -0.0050925021059811115, ...
0.055153
can set a positive number in the \*\*Limit\*\* input to limit the maximum number of time series returned by the data source. The series returned are always ordered by descending value for the total aggregated data over the time period. ### Profiles query results Profiles can be visualized in a flame graph. Refer to the...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/pyroscope/query-profile-data.md
main
grafana
[ -0.05912896618247032, 0.016986047849059105, -0.055416956543922424, 0.025651704519987106, -0.02398407831788063, -0.037232618778944016, 0.018238266929984093, 0.034742552787065506, 0.012645700946450233, -0.036522045731544495, -0.032875556498765945, -0.009148916229605675, 0.03983563929796219, ...
0.05511
# Grafana Pyroscope data source Grafana Pyroscope is a horizontally scalable, highly available, multi-tenant, OSS, continuous profiling aggregation system. Add a Pyroscope data source to query your profiles in [Explore](ref:explore). Refer to [Introduction to Pyroscope](https://grafana.com/docs/pyroscope//introduction/...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/pyroscope/_index.md
main
grafana
[ -0.054850853979587555, -0.008842555806040764, -0.15772585570812225, -0.004391214810311794, -0.03641211614012718, -0.08155212551355362, -0.012032557278871536, 0.054035548120737076, -0.09521808475255966, -0.003921617288142443, -0.028210902586579323, -0.04724567010998726, -0.0023991516791284084...
0.094673
# Prometheus data source Prometheus is an open source database that uses a telemetry collector agent to scrape and store metrics used for monitoring and alerting. Grafana provides native support for Prometheus, so you don't need to install a plugin. The following documentation will help you get started working with Pro...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/_index.md
main
grafana
[ -0.10437048971652985, -0.0050768498331308365, -0.04534199833869934, 0.04538490250706673, -0.04486796259880066, -0.10515226423740387, 0.010075331665575504, 0.012278756126761436, -0.007439130451530218, 0.0032503982074558735, 0.010104534216225147, -0.09398999810218811, 0.001896400353871286, 0...
0.208872
# Connect to Amazon Managed Service for Prometheus 1. In the data source configuration page, locate the \*\*Auth\*\* section 2. Enable \*\*SigV4 auth\*\* 3. Configure the following settings: | Setting | Description | Example | | --------------------------- | ---------------------------------------------- | ------------...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/aws-authentication.md
main
grafana
[ -0.04027736932039261, 0.02801087126135826, -0.06411949545145035, 0.007629480212926865, 0.010695218108594418, -0.11299586296081543, -0.01575755886733532, -0.03277657926082611, 0.03747528791427612, 0.04395723342895508, -0.0073358286172151566, -0.0814725011587143, 0.06751835346221924, -0.0557...
0.029669
core Prometheus. To revert the migration: 1. Disable the `prometheusTypeMigration` feature toggle. For more information on feature toggles, refer to [Manage feature toggles](/docs/grafana//setup-grafana/configure-grafana/feature-toggles/#manage-feature-toggles). 2. Obtain a bearer token that has `read` and `write` perm...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/aws-authentication.md
main
grafana
[ -0.10102870315313339, 0.0015422675060108304, -0.030260104686021805, 0.02455645054578781, -0.03342871367931366, -0.0853147879242897, -0.06349202990531921, -0.08695236593484879, -0.056547973304986954, 0.07854712009429932, 0.004263914655894041, -0.07086688280105591, -0.018480664119124413, -0....
0.03394
fetched data sources" get\_summary\_stats "$response\_body" update\_data\_source\_type "$response\_body" log\_message "Migration process completed" else log\_message "error fetching data sources: HTTP $http\_code - $response\_body" fi } # Function to initialize log file initialize\_log() { echo "=== Grafana Azure Prome...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/aws-authentication.md
main
grafana
[ 0.02336116135120392, 0.0018389776814728975, -0.01590193808078766, 0.02098034881055355, 0.005103496368974447, -0.0384708009660244, 0.02493809163570404, -0.027936307713389397, 0.02903270162642002, 0.13571488857269287, 0.06528357416391373, -0.08432332426309586, 0.016137411817908287, -0.026558...
0.019086
# Connect to Azure Monitor Managed Service for Prometheus After creating a Azure Monitor Managed Service for Prometheus data source: 1. In the data source configuration page, locate the \*\*Authentication\*\* section 2. Select your authentication method: - \*\*Managed Identity\*\*: For Azure-hosted Grafana instances. T...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/azure-authentication.md
main
grafana
[ -0.10005442798137665, 0.04425051808357239, -0.10317042469978333, -0.012465803883969784, -0.05693591758608818, -0.09321647137403488, 0.0326719731092453, -0.061474647372961044, 0.03974558785557747, 0.12718600034713745, 0.00020416101324371994, -0.08009839802980423, 0.05778820067644119, 0.0313...
0.104391
support. ### Rollback self-hosted Grafana without a backup If you don’t have a backup of your Grafana instance before the migration, remove the `prometheusTypeMigration` feature toggle, and run the following script. It reverts all the Azure Monitor Managed Service data source instances back to core Prometheus. To rever...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/azure-authentication.md
main
grafana
[ -0.0771334320306778, -0.022688915953040123, -0.05260222777724266, 0.06645423173904419, -0.010370575822889805, -0.056145183742046356, -0.030295563861727715, -0.11091163754463196, -0.0247701033949852, 0.13992314040660858, -0.002888759598135948, -0.06838499754667282, 0.03253118693828583, 0.03...
0.051526
log\_message "Grafana URL: $GRAFANA\_URL" response=$(curl -s -w "\n%{http\_code}" -X GET \ -H "Content-Type: application/json" \ -H "Authorization: Bearer $BEARER\_TOKEN" \ "$GRAFANA\_URL/api/datasources/") http\_code=$(echo "$response" | tail -n1) response\_body=$(echo "$response" | sed '$d') if [[ "$http\_code" -ge 2...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/azure-authentication.md
main
grafana
[ -0.01965622790157795, 0.02652902714908123, -0.013400166295468807, -0.013517126441001892, -0.029414944350719452, -0.08580540120601654, -0.027093714103102684, -0.014507213607430458, 0.056055497378110886, 0.11189320683479309, 0.047497741878032684, -0.0905052050948143, -0.004830216057598591, -...
0.045193
# Configure the Prometheus data source This document provides instructions for configuring the Prometheus data source and explains the available configuration options. Grafana includes built-in support for Prometheus, so you don't need to install a plugin. For general information on adding a data source to Grafana, ref...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/_index.md
main
grafana
[ -0.08341033011674881, -0.00883945357054472, -0.05237589403986931, -0.005397032015025616, -0.07459712773561478, -0.09880906343460083, -0.02153605967760086, -0.04394754767417908, -0.05602061003446579, 0.03980613872408867, 0.006142799276858568, -0.0692506656050682, 0.025218388065695763, -0.00...
0.090436
- \*\*CA certificate\*\* - Add your certificate. - \*\*TLS client authentication\*\* - Check the box to enable TLS client authentication. - \*\*Server name\*\* - Add the server name, which is used to verify the hostname on the returned certificate. - \*\*Client certificate\*\* - The client certificate is generated from...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/_index.md
main
grafana
[ -0.06745541840791702, 0.07282137125730515, -0.051313385367393494, -0.03481651097536087, -0.0573817603290081, -0.024977199733257294, -0.021501697599887848, -0.003035095287486911, 0.0443035252392292, -0.026557017117738724, -0.0065426211804151535, -0.07916037738323212, 0.07961024343967438, 0....
-0.024589
type of your Prometheus-compatible database, such as Prometheus, Cortex, Mimir, or Thanos. Changing this setting will save your current configuration. Different database types support different APIs. For example, some allow `regex` matching for label queries to improve performance, while others provide a metadata API. ...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/_index.md
main
grafana
[ -0.041156213730573654, 0.0022534304298460484, -0.008349116891622543, 0.057750146836042404, -0.06811489909887314, -0.10469572246074677, -0.029481874778866768, -0.02560720033943653, 0.022621668875217438, -0.0025013661943376064, -0.035166364163160324, -0.022722342982888222, 0.010170184075832367...
0.121155
- \*\*URL label\*\* - Adds a custom display label to override the value of the `Label name` field. - \*\*Label name\*\* - The name of the field in the `labels` object used to obtain the traceID property. - \*\*Remove exemplar link\*\* - Click the \*\*X\*\* to remove existing links. You can add multiple exemplars. - \*\...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/_index.md
main
grafana
[ -0.1456368863582611, 0.04001673683524132, -0.12070703506469727, 0.029434995725750923, -0.06301179528236389, -0.010396848432719707, -0.02119772881269455, -0.0555102601647377, 0.05114448443055153, -0.02990618720650673, 0.038062822073698044, -0.05123871937394142, -0.0055369362235069275, -0.06...
0.062375
Explore, make sure you've selected the correct data source from the data source drop-down menu. When using `remote\_write` to send metrics to Grafana Cloud, the data source name follows the convention `grafanacloud-stackname-prom`.
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/_index.md
main
grafana
[ -0.06426963955163956, -0.07680952548980713, -0.040514372289180756, 0.020383022725582123, -0.09492675960063934, -0.06586234271526337, -0.06387109309434891, -0.06318588554859161, 0.06686613708734512, 0.09772402793169022, -0.02451741136610508, -0.08857917785644531, -0.003883477533236146, -0.0...
0.008232
# Prometheus template variables Instead of hard-coding details such as server, application, and sensor names in metric queries, you can use variables. Grafana refers to such variables as \*\*template\*\* variables. Grafana lists these variables in dropdown select boxes at the top of the dashboard to help you change the...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/template-variables/_index.md
main
grafana
[ -0.05295698344707489, 0.06109433248639107, -0.05127020925283432, 0.04437573254108429, -0.0797819271683693, -0.03781171888113022, 0.013032190501689911, 0.008148424327373505, -0.028477827087044716, -0.004103385377675295, -0.05138469114899635, -0.12337587028741837, 0.02316908910870552, 0.0035...
0.179361
sum(rate(http\_requests\_total[$\_\_range])) by (instance))) Regex: /"([^"]+)"/ ``` Populate a variable with the instances having a certain state over the time range shown in the dashboard, using `$\_\_range\_s`: ``` query\_result(max\_over\_time([${\_\_range\_s}s]) != ) Regex: ``` ## Use `$\_\_rate\_interval` Grafana ...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/template-variables/_index.md
main
grafana
[ -0.10029715299606323, 0.06341785937547684, -0.027138561010360718, 0.003406891133636236, -0.06105773523449898, -0.053758133202791214, -0.01247519999742508, 0.0016638250090181828, 0.0565987192094326, 0.03020843304693699, -0.001241640537045896, -0.12069470435380936, 0.03938068822026253, 0.028...
0.068293
# Prometheus query editor Grafana provides a query editor for the Prometheus data source to create queries in PromQL. For more information about PromQL, see [Querying Prometheus](http://prometheus.io/docs/querying/basics/). The Prometheus query editor is located on the [Explore page](ref:explore). You can also access t...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/query-editor/_index.md
main
grafana
[ -0.08155384659767151, 0.02597939409315586, -0.06055022031068802, 0.059644799679517746, -0.0713328942656517, -0.07085349410772324, -0.031215110793709755, -0.024340759962797165, -0.030409688130021095, 0.024695944041013718, -0.019762098789215088, -0.0361834354698658, 0.005494458135217428, -0....
0.164374
example, setting this to `1h` suggests that data is collected or displayed at hourly intervals. This setting supports the `$\_\_interval` and `$\_\_rate\_interval` macros. Note that the time range of the query is aligned to this step size, which may adjust the actual start and end times of the returned data. - \*\*Form...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/query-editor/_index.md
main
grafana
[ -0.05959764122962952, 0.046433642506599426, -0.055500563234090805, 0.022311685606837273, -0.08926980942487717, -0.0924639105796814, -0.020541423931717873, -0.005641444120556116, 0.006678336299955845, 0.00600868184119463, -0.02012602984905243, -0.12071159482002258, -0.0026034421753138304, -...
0.090016
in your instance. If you would like to explore your metrics in the query builder further, you can open the \*\*Metrics explorer\*\* by clicking the first option in the metric select component of the query builder. The Metrics explorer displays all metrics in a paginated table list. The list shows the total number of me...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/query-editor/_index.md
main
grafana
[ -0.03851129859685898, 0.0435694083571434, -0.01996435970067978, 0.10051685571670532, -0.04030948877334595, 0.009814150631427765, -0.008371563628315926, -0.01600128971040249, 0.010995166376233101, -0.020513206720352173, -0.014229255728423595, -0.11936403065919876, 0.06283044815063477, -0.00...
0.098645
Metrics browser, click the arrow next to \*\*Metrics browser\*\*. ### Metrics browser in Code mode The Metrics browser locates metrics and selects relevant labels to help you build basic queries. When you click \*\*Metrics browser\*\* in `Code` mode, it displays all available metrics and labels. If supported by your Pr...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/query-editor/_index.md
main
grafana
[ -0.028368251398205757, 0.008445147424936295, -0.02335439622402191, 0.058005012571811676, -0.0010961226653307676, -0.02587812952697277, 0.038950301706790924, 0.013075310736894608, 0.023356996476650238, -0.058652181178331375, -0.01031485479325056, -0.09369981288909912, 0.014357330277562141, ...
0.170625
# Graphite data source Grafana includes built-in support for Graphite. This topic explains options, variables, querying, and other features specific to the Graphite data source, which include its feature-rich query editor. For instructions on how to add a data source to Grafana, refer to the [administration documentati...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/graphite/_index.md
main
grafana
[ -0.05970947816967964, -0.021312197670340538, -0.04887085780501366, 0.05594269558787346, -0.05062296241521835, 0.00023858033819124103, -0.046421874314546585, 0.025388816371560097, -0.039888154715299606, 0.09627265483140945, -0.06551805138587952, -0.04137537628412247, 0.045986682176589966, -...
0.047346
# Configure the Graphite data source This document provides instructions for configuring the Graphite data source and explains available configuration options. For general information on managing data sources, refer to [Data source management](ref:data-source-management). ## Before you begin - You must have the `Organi...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/graphite/configure/index.md
main
grafana
[ -0.09397371113300323, -0.0026752641424536705, -0.056751661002635956, -0.0035561388358473778, -0.059159040451049805, -0.05144819617271423, -0.06959114968776703, -0.016399381682276726, -0.11030356585979462, 0.1254757195711136, 0.015794074162840843, -0.06333687901496887, 0.03938901051878929, ...
0.039389
or response. | \*\*Setting\*\* | \*\*Description\*\* | | ----------- | ---------------------------------------------------------------------------------------------------------- | | \*\*Header\*\* | Add a custom header. This allows custom headers to be passed based on the needs of your Graphite instance. | | \*\*Value\...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/graphite/configure/index.md
main
grafana
[ -0.07449842989444733, 0.15372967720031738, 0.024548621848225594, 0.04375164583325386, -0.0012409973423928022, 0.0009191411081701517, 0.002754021668806672, 0.061156176030635834, -0.05300544574856758, 0.028704103082418442, -0.05652574822306633, -0.15490499138832092, 0.02754049189388752, -0.0...
0.017126
# Graphite template variables Instead of hard-coding details such as server, application, and sensor names in metric queries, you can use variables. Grafana lists these variables in drop-down selection boxes at the top of the dashboard to help you change the data displayed in your dashboard. Grafana refers to such vari...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/graphite/template-variables/index.md
main
grafana
[ -0.07940470427274704, 0.024892909452319145, -0.06130518391728401, 0.02263275906443596, -0.09237847477197647, -0.02265758253633976, -0.024416537955403328, 0.03713492676615715, -0.05544821172952652, 0.07058708369731903, -0.029399698600172997, -0.10383235663175583, 0.017926152795553207, 0.029...
0.062513
values in $`{apps}`, formatted as a regular expression. `=~` is the regular expression operator Non-tag queries use the default `glob` formatting for multi-value variables. ## Use other query variables When writing queries, use the \*\*metric find\*\* query type to retrieve dynamic values. For example, the query `prod....
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/graphite/template-variables/index.md
main
grafana
[ -0.026721175760030746, 0.03414419665932655, -0.02956068143248558, 0.013979743234813213, -0.09116150438785553, -0.04056115448474884, 0.015292951837182045, 0.014388378709554672, 0.026776641607284546, 0.02929873578250408, -0.00782816857099533, -0.11368689686059952, 0.013263396918773651, 0.015...
0.029193
# Troubleshoot Graphite data source issues This document provides solutions for common issues you might encounter when using the Graphite data source. ## Connection issues Use the following troubleshooting steps to resolve connection problems between Grafana and your Graphite server. \*\*Data source test fails with "Un...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/graphite/troubleshooting/index.md
main
grafana
[ -0.09572494029998779, -0.010260825045406818, -0.003924969118088484, -0.011047124862670898, -0.07112634181976318, -0.10367880761623383, -0.13115428388118744, -0.056227024644613266, -0.06612584739923477, 0.11466490477323532, 0.011370702646672726, -0.03566011041402817, -0.01106704119592905, 0...
-0.037016
consistently time out: - Increase the \*\*Timeout\*\* setting in the data source configuration. - Reduce the time range of your query. - Use more specific metric paths instead of broad wildcards. - Consider using `summarize()` or `consolidateBy()` functions to reduce the amount of data returned. - Check your Graphite s...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/graphite/troubleshooting/index.md
main
grafana
[ 0.0034214649349451065, 0.0318107008934021, 0.02336522750556469, 0.06459685415029526, -0.006839536130428314, -0.015641512349247932, -0.06459397077560425, -0.016148578375577927, -0.06724260747432709, 0.05240266025066376, -0.017293699085712433, -0.04582357406616211, -0.013056744821369648, -0....
0.013628
# Graphite query editor Grafana includes a Graphite-specific query editor to help you build queries. The query editor helps you quickly navigate the metric space, add functions, and change function parameters. It supports a variety of Graphite queries, including complex nested queries, through the use of query referenc...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/graphite/query-editor/index.md
main
grafana
[ -0.11571194231510162, -0.006759548094123602, -0.020318757742643356, 0.038207050412893295, -0.11586442589759827, -0.04528123885393143, -0.043205007910728455, -0.00012739891826640815, -0.038132138550281525, 0.06382682174444199, -0.01571931131184101, -0.0764719545841217, 0.009082222357392311, ...
0.126251
series To combine time series, click \*\*Combine\*\* in the \*\*Functions\*\* list. ### Select and explore data with tags In Graphite, everything is a tag. When exploring data, previously selected tags filter the remaining result set. To select data, use the `seriesByTag` function, which takes tag expressions (`=`, `!=...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/graphite/query-editor/index.md
main
grafana
[ -0.09069329500198364, 0.03540029749274254, 0.007141962647438049, 0.04888142645359039, -0.0699978843331337, -0.060243867337703705, 0.011230964213609695, -0.02191442809998989, -0.024825097993016243, 0.014609987847507, -0.026583684608340263, -0.08014136552810669, -0.06772644072771072, 0.00978...
0.019498
# Azure Monitor data source The Azure Monitor data source plugin allows you to query and visualize data from Azure Monitor, the Azure service to maximize the availability and performance of applications and services in the Azure Cloud. ## Supported Azure clouds The Azure Monitor data source supports the following Azure...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/_index.md
main
grafana
[ 0.03724794089794159, -0.014872709289193153, -0.06219341978430748, 0.040566980838775635, 0.010517014190554619, 0.03850596398115158, 0.029441019520163536, -0.11711307615041733, 0.04819786921143532, 0.10156993567943573, 0.01894376613199711, -0.060477323830127716, 0.07947322726249695, 0.008540...
0.052686
# Azure Monitor alerting The Azure Monitor data source supports [Grafana Alerting](ref:alerting) and [Grafana-managed recording rules](ref:grafana-managed-recording-rules), allowing you to create alert rules based on Azure metrics, logs, traces, and resource data. You can monitor your Azure environment and receive noti...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/alerting/index.md
main
grafana
[ -0.032370902597904205, -0.011820451356470585, -0.09107980877161026, 0.03681459650397301, 0.013459344394505024, -0.044421300292015076, 0.08666809648275375, -0.10084749758243561, 0.06992355734109879, 0.09487209469079971, -0.012972524389624596, -0.09228836745023727, 0.07947838306427002, 0.070...
0.055841
- \*\*Resource\*\*: Select your virtual machine - \*\*Metric namespace\*\*: `Microsoft.Compute/virtualMachines` - \*\*Metric\*\*: `Percentage CPU` - \*\*Aggregation\*\*: `Average` 1. Add expressions: - \*\*Reduce\*\*: Last (to get the most recent data point) - \*\*Threshold\*\*: Is above 80 1. Set evaluation to run eve...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/alerting/index.md
main
grafana
[ 0.050159428268671036, 0.04880668595433235, -0.011191558092832565, 0.049432966858148575, -0.023399287834763527, -0.04430793598294258, 0.04473067447543144, -0.0034195438493043184, 0.049360863864421844, 0.09137938171625137, -0.04748130962252617, -0.15161721408367157, 0.07995015382766724, 0.02...
0.108351
authentication method. If using Current User authentication, ensure fallback service credentials are configured. - Check that the query returns numeric data in Explore. - Ensure the evaluation interval allows enough time for data to be available. - Review the alert rule's health and any error messages in the Alerting U...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/alerting/index.md
main
grafana
[ -0.005148403812199831, 0.040575962513685226, -0.05069456994533539, 0.05601939186453819, -0.0187354926019907, -0.0365375392138958, 0.055195387452840805, -0.06555479019880295, 0.07156451046466827, 0.07002418488264084, -0.018126964569091797, -0.08108876645565033, 0.09525378793478012, 0.056345...
0.018249
# Configure the Azure Monitor data source This document explains how to configure the Azure Monitor data source and the available configuration options. For general information about data sources, refer to [Grafana data sources](ref:data-sources) and [Data source management](ref:data-source-management). ## Before you b...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/configure/index.md
main
grafana
[ -0.04765494167804718, -0.02617117203772068, -0.0881267711520195, -0.0026193272788077593, -0.04221772402524948, -0.0385763980448246, -0.006219987757503986, -0.10972761362791061, 0.010526400990784168, 0.17004439234733582, 0.008835854008793831, -0.11334584653377533, 0.043859049677848816, 0.00...
0.040379
--------------------------- | ------------------------------------------------------------------------------------------------------------------------------------------ | | \*\*Authentication\*\* | Select \*\*App Registration\*\*. | | \*\*Azure Cloud\*\* | The Azure environment to connect to. Select \*\*Azure\*\* for t...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/configure/index.md
main
grafana
[ -0.0032353047281503677, 0.025591062381863594, -0.03939666599035263, -0.010094462893903255, -0.004975363612174988, 0.06791325658559799, 0.07977175712585449, -0.08250819146633148, 0.05870816484093666, 0.07463476806879044, 0.08344662189483643, -0.08874672651290894, 0.0797000601887703, -0.0124...
-0.04556
hidden. | | \*\*Default Subscription\*\* | Click \*\*Load Subscriptions\*\* to populate available subscriptions, then select your default. | {{< figure src="/media/docs/grafana/data-sources/screenshot-workload-identity.png" max-width="800px" class="docs-image--no-shadow" caption="Azure Monitor data source configured wi...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/configure/index.md
main
grafana
[ -0.12154185026884079, 0.04172036051750183, -0.07896272838115692, 0.032826028764247894, -0.01489437185227871, -0.034171249717473984, 0.014813757501542568, -0.0684972032904625, 0.04010837897658348, 0.12081082910299301, 0.03215334564447403, -0.0811757892370224, 0.07350346446037292, 0.03390277...
0.021287
Azure Monitor type: grafana-azure-monitor-datasource access: proxy jsonData: azureAuthType: currentuser oauthPassThru: true disableGrafanaCache: true subscriptionId: # Optional, default subscription version: 1 ``` ## Additional configuration options These settings apply to all authentication methods. ### General settin...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/configure/index.md
main
grafana
[ -0.07587513327598572, 0.016791148111224174, -0.11592352390289307, 0.03051498718559742, -0.057066284120082855, -0.008065776899456978, 0.05060162395238876, -0.07503417134284973, 0.05645108222961426, 0.14973118901252747, -0.003555925562977791, -0.05628996342420578, 0.062481120228767395, 0.022...
-0.014149
For Grafana Cloud provider "grafana" { url = "" auth = "" } # For self-hosted Grafana # provider "grafana" { # url = "http://localhost:3000" # auth = "" # } ``` ### Terraform examples The following examples show how to configure the Azure Monitor data source for each authentication method. \*\*App Registration (client ...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/configure/index.md
main
grafana
[ -0.0865459144115448, 0.027754854410886765, -0.09959284216165543, 0.025975054129958153, -0.05527621880173683, -0.022832263261079788, 0.0066259331069886684, -0.07541801035404205, 0.02699478715658188, 0.14525213837623596, 0.013625931926071644, -0.14984390139579773, 0.06241308152675629, 0.0192...
-0.021682
# Azure Monitor template variables Instead of hard-coding details such as resource group or resource name values in metric queries, you can use variables. This helps you create more interactive, dynamic, and reusable dashboards. Grafana refers to such variables as template variables. For an introduction to templating a...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/template-variables/index.md
main
grafana
[ -0.042244065552949905, 0.010557080619037151, -0.10485191643238068, 0.07713592797517776, -0.07050647586584091, 0.09169385582208633, 0.07618266344070435, -0.04595399647951126, 0.03242644667625427, 0.11291571706533432, -0.03612029552459717, -0.12185833603143692, 0.11128772795200348, 0.0709920...
0.029196
\*\*Subscription\*\* field, select `$subscription`. 1. In the \*\*Resource Group\*\* field, select `$resourceGroup`. 1. Select the appropriate \*\*Namespace\*\* for your resources (e.g., `Microsoft.Compute/virtualMachines`). Now when you change the subscription, the resource group dropdown updates automatically, and wh...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/template-variables/index.md
main
grafana
[ -0.04091627523303032, -0.006673948839306831, -0.03537238389253616, 0.07213592529296875, -0.04800999164581299, -0.03072460927069187, 0.108867347240448, -0.08887962996959686, 0.051530200988054276, 0.10835462808609009, -0.03509082645177841, -0.11737591028213501, 0.07396665960550308, 0.0139042...
0.08272
the variable dropdown to manually refresh. ### Multi-value selection not working in queries - Ensure the resources meet the requirements (same subscription, region, and type). - For Logs queries, use the `$\_\_contains()` macro to handle multi-value variables properly.
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/template-variables/index.md
main
grafana
[ 0.03878655284643173, -0.07254266738891602, 0.03685072436928749, 0.09193603694438934, 0.029491078108549118, -0.003883104771375656, 0.1062171682715416, -0.10688360780477524, 0.03059374913573265, 0.03563007712364197, 0.0019096527248620987, -0.06627819687128067, -0.006029440555721521, 0.002117...
0.020791
# Troubleshoot Azure Monitor data source issues This document provides solutions to common issues you may encounter when configuring or using the Azure Monitor data source. ## Configuration and authentication errors These errors typically occur when setting up the data source or when authentication credentials are inva...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/troubleshooting/index.md
main
grafana
[ -0.015533587895333767, 0.0334906131029129, -0.04520496726036072, 0.06252229958772659, -0.01564631797373295, 0.016468357294797897, 0.03982371836900711, -0.08121494203805923, 0.02058306522667408, 0.11762796342372894, -0.008806603029370308, -0.06785991042852402, 0.11399363726377487, 0.0392123...
-0.064494
the workload identity webhook is running in the cluster. ## Query errors These errors occur when executing queries against Azure Monitor services. ### "No data" or empty results \*\*Symptoms:\*\* - Query executes without error but returns no data - Charts show "No data" message \*\*Possible causes and solutions:\*\* | ...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/troubleshooting/index.md
main
grafana
[ -0.03314124420285225, 0.10144968330860138, -0.046532370150089264, 0.07407330721616745, 0.0033953203819692135, -0.06259513646364212, 0.020757557824254036, -0.07081786543130875, 0.0453052818775177, 0.06438339501619339, 0.02628420852124691, -0.16127333045005798, 0.0703730434179306, -0.0131458...
0.076105
expected resources appear in results - Results seem truncated \*\*Solutions:\*\* 1. ARG queries are paginated. The data source handles pagination automatically, but very large result sets may be limited. 2. Add filters to reduce result set size. 3. Verify you have access to all subscriptions containing the resources. #...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/troubleshooting/index.md
main
grafana
[ -0.06521562486886978, 0.004781923722475767, -0.010063713416457176, 0.08706650137901306, 0.014311250299215317, -0.06136328727006912, 0.07257223129272461, -0.020628897473216057, -0.008255227468907833, 0.0173873919993639, -0.025447549298405647, -0.05076812207698822, 0.043339990079402924, -0.0...
0.040643
# Azure Monitor query editor Grafana provides a query editor for the Azure Monitor data source, which is located on the [Explore page](ref:explore). You can also access the Azure Monitor query editor from a dashboard panel. Click the menu in the upper right of the panel and select \*\*Edit\*\*. This document explains q...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/query-editor/index.md
main
grafana
[ -0.005788086447864771, -0.01870596408843994, -0.10917159914970398, 0.07033714652061462, -0.015179382637143135, -0.02156744711101055, 0.05550798028707504, -0.08792176097631454, 0.04874107614159584, 0.12266838550567627, -0.021926399320364, -0.08993446081876755, 0.06957853585481644, 0.0159521...
0.051681
type="note" >}} Not all metrics returned by the Azure Monitor Metrics API have values. {{< /admonition >}} > The data source retrieves lists of supported metrics for each subscription and ignores metrics that never have values. 1. Select a metric from the \*\*Metric\*\* field. Optionally, you can apply further aggregat...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/query-editor/index.md
main
grafana
[ -0.07937827706336975, 0.015318111516535282, -0.05639062449336052, 0.059467863291502, -0.07649807631969452, -0.012740160338580608, 0.010413775220513344, -0.04203970730304718, 0.09706705063581467, 0.08448184281587601, -0.05808338522911072, -0.1306188702583313, 0.014218867756426334, 0.0686721...
0.010967
(public preview) {{< admonition type="note" >}} The Logs query builder is a [public preview feature](/docs/release-life-cycle/). It may not be enabled in all Grafana environments. {{< /admonition >}} The Logs query builder provides a visual interface for building Azure Monitor Logs queries without writing KQL. This is ...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/query-editor/index.md
main
grafana
[ -0.04046255350112915, 0.023964859545230865, -0.02961466647684574, 0.0819253996014595, -0.09936477243900299, 0.024401357397437096, -0.005078292451798916, -0.1271854192018509, 0.0513177216053009, 0.1584312915802002, -0.02080933004617691, -0.12153492867946625, 0.04066571220755577, 0.013731528...
0.035479
default Log Analytics time-range applies. For more details, refer to the [Azure Monitor Logs API documentation](https://learn.microsoft.com/en-us/rest/api/loganalytics/dataaccess/query/get?tabs=HTTP#uri-parameters). If you previously used the `Intersection` option, it has been migrated to `Dashboard`. {{< /admonition >...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/query-editor/index.md
main
grafana
[ 0.06973738223314285, -0.032664861530065536, -0.061886321753263474, 0.06419993937015533, 0.002925443695858121, -0.04968880116939545, 0.02378300577402115, -0.05081101506948471, 0.07661638408899307, 0.06933250278234482, -0.04256373643875122, -0.05764893442392349, 0.01078670285642147, 0.050497...
0.063052
so that you can more effectively govern an environment. By querying ARG, you can query resources with complex filtering, iteratively explore resources based on governance requirements, and assess the impact of applying policies in a vast cloud environment. {{< figure src="/static/img/docs/azure-monitor/query-editor-arg...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/query-editor/index.md
main
grafana
[ 0.010426807217299938, 0.04452184960246086, -0.0018425947055220604, 0.06432133167982101, -0.002181500429287553, 0.018122758716344833, 0.07715849578380585, -0.07696177810430527, 0.05354700982570648, 0.11731661856174469, -0.023087235167622566, -0.024006562307476997, 0.09787161648273468, 0.051...
0.08686
`'\\grafana-vm\Network(eth0)\Total','\\hello!'` as a string, this expands it to `@'\\grafana-vm\Network(eth0)\Total', @'\\hello!'`. If you use single-value variables, escape the variable inline instead: `@'\$myVar'`. | | `$\_\_contains(colName, $myVar)` | Expands multi-value template variables.
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/query-editor/index.md
main
grafana
[ 0.0368104986846447, 0.053695887327194214, 0.01482263021171093, 0.004638740327209234, -0.06293649971485138, 0.06323937326669693, 0.06279856711626053, 0.02028578147292137, -0.007169023156166077, 0.042602360248565674, 0.037030816078186035, -0.08703102171421051, -0.003427878487855196, -0.02524...
0.020402
# Azure Monitor annotations [Annotations](ref:annotate-visualizations) overlay rich event information on top of graphs. You can use Azure Monitor Log Analytics queries to create annotations that mark important events, deployments, alerts, or other significant occurrences on your dashboards. ## Before you begin - Ensure...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/annotations/index.md
main
grafana
[ 0.04351998120546341, 0.042765695601701736, -0.0198479313403368, 0.060826029628515244, 0.0934009775519371, 0.045333851128816605, 0.10978199541568756, -0.05267656594514847, 0.06646108627319336, 0.12762360274791718, -0.06585778295993805, -0.08354631066322327, 0.04945793002843857, 0.1064990907...
0.072215
| order by TimeGenerated desc ``` ### Autoscale events Show autoscale operations: ```kusto AzureActivity | where $\_\_timeFilter(TimeGenerated) | where OperationNameValue contains "autoscale" | project TimeGenerated, Text=strcat("Autoscale: ", OperationNameValue), Status=ActivityStatusValue, ResourceGroup | order by Ti...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/annotations/index.md
main
grafana
[ 0.043231427669525146, 0.07694016396999359, 0.045576442033052444, 0.045490704476833344, -0.07288052886724472, 0.06127328425645828, 0.09496385604143143, -0.0375814363360405, 0.0718412846326828, 0.021671663969755173, -0.01796298287808895, -0.11086934059858322, -0.020920315757393837, 0.0029776...
0.087659
# Microsoft SQL Server (MSSQL) data source Grafana ships with built-in support for Microsoft SQL Server (MSSQL). You can query and visualize data from any Microsoft SQL Server 2005 or newer, including Microsoft Azure SQL Database. Use this data source to create dashboards, explore SQL data, and monitor MSSQL-based work...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/_index.md
main
grafana
[ -0.024960309267044067, -0.1098371222615242, -0.07325384020805359, 0.04600747302174568, -0.0894697830080986, 0.011861435137689114, 0.039275530725717545, -0.08338531851768494, -0.03107008896768093, 0.1360916942358017, -0.027133474126458168, -0.020006248727440834, 0.05846137925982475, 0.01553...
0.065879
# Configure the Microsoft SQL Server data source This document provides instructions for configuring the Microsoft SQL Server data source and explains available configuration options. For general information on adding and managing data sources, refer to [Grafana data sources](ref:data-sources) and [Data source manageme...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/configure/index.md
main
grafana
[ -0.0468793548643589, -0.10957203805446625, -0.12440626323223114, 0.0020732199773192406, -0.12070611119270325, -0.023886604234576225, 0.0016432363772764802, -0.0900745689868927, -0.06334397941827774, 0.1123308464884758, 0.014417417347431183, -0.04649518057703972, 0.05444048345088959, -0.041...
0.003915
using an older version of Microsoft SQL Server like 2008 and 2008R2, you may need to disable encryption to be able to connect. {{< /admonition >}} \*\*Authentication:\*\* | Authentication Type | Description | Credentials / Fields | | ----------------------------------------------------- | ------------------------------...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/configure/index.md
main
grafana
[ 0.0018473131349310279, -0.0644054263830185, -0.052794598042964935, 0.05244462564587593, -0.12972845137119293, 0.03168577700853348, -0.009993401356041431, -0.042783670127391815, 0.028685150668025017, -0.039772264659404755, -0.018261251971125603, -0.05593673512339592, 0.04602052643895149, 0....
-0.076274
| Defines the maximum packet size (in bytes) that Kerberos libraries will attempt to send over UDP before retrying with TCP. A value of `1` forces all communication to use TCP. | `1` (always use TCP) | | \*\*DNS Lookup KDC\*\* | Controls whether DNS `SRV` records are used to locate [Key Distribution Centers (KDCs)](htt...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/configure/index.md
main
grafana
[ 0.027988558635115623, -0.014669137075543404, -0.04212364926934242, -0.09160996973514557, 0.019950775429606438, -0.020825810730457306, -0.0546891912817955, -0.05841980129480362, 0.025867706164717674, 0.08187778294086456, -0.029186224564909935, -0.019671691581606865, 0.029932236298918724, -0...
-0.027205
a permission\*\* and choose the following permissions. They must be added individually. Refer to the [Azure documentation](https://learn.microsoft.com/en-us/entra/identity-platform/quickstart-configure-app-access-web-apis) for more information. - Select \*\*APIs my organization uses\*\* > Search for \*\*Azure SQL\*\* a...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/configure/index.md
main
grafana
[ -0.09661579877138138, 0.021784629672765732, -0.09443562477827072, 0.008519266732037067, -0.021384982392191887, -0.0352286770939827, 0.04491160809993744, -0.05970706045627594, 0.02682526595890522, 0.11428312212228775, 0.025110283866524696, -0.07135914266109467, 0.05050007998943329, 0.057061...
-0.044246
Authentication type to \*\*Managed Identity\*\*. This hides the directory ID, application ID, and client secret fields, and the data source uses managed identity to authenticate to SQL Server. 3. You can set the `managed\_identity\_client\_id` field in the `[azure]` section of the [Grafana server configuration](ref:con...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/configure/index.md
main
grafana
[ -0.10724614560604095, -0.0070297373458743095, -0.15570344030857086, 0.001242429600097239, -0.0718887522816658, -0.0012716343626379967, 0.11267553269863129, -0.055236365646123886, 0.03472435846924782, 0.1152157261967659, 0.022882817313075066, -0.05467034503817558, 0.10819817334413528, 0.020...
0.05897
about provisioning, and for available configuration options, refer to [Provision Grafana](ref:provision-grafana). #### Provisioning example ```yaml apiVersion: 1 datasources: - name: MSSQL type: mssql url: localhost:1433 user: grafana jsonData: database: grafana maxOpenConns: 100 maxIdleConns: 100 maxIdleConnsAuto: tru...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/configure/index.md
main
grafana
[ -0.04694106802344322, -0.08301109075546265, -0.10220041871070862, 0.009900280274450779, -0.09416663646697998, -0.007310814224183559, -0.018526121973991394, -0.03435618057847023, -0.059779245406389236, 0.09115438163280487, -0.04706895723938942, -0.0690365582704544, 0.05407021567225456, 0.03...
-0.004739
# Microsoft SQL Server template variables Instead of hard-coding details such as server, application, and sensor names in metric queries, you can use variables. Grafana displays these variables in drop-down select boxes at the top of the dashboard to help you change the data displayed in your dashboard. Grafana refers ...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/template-variables/index.md
main
grafana
[ -0.04461842402815819, -0.008137873373925686, -0.09816351532936096, 0.061609894037246704, -0.13933783769607544, -0.022293534129858017, 0.0347476452589035, -0.027452165260910988, -0.074436716735363, 0.032127365469932556, -0.021713174879550934, -0.10345803946256638, 0.046575963497161865, -0.0...
0.073125
# Troubleshoot Microsoft SQL Server data source issues This document provides solutions to common issues you may encounter when configuring or using the Microsoft SQL Server (MSSQL) data source in Grafana. ## Connection errors These errors occur when Grafana cannot establish or maintain a connection to the Microsoft SQ...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/troubleshooting/index.md
main
grafana
[ -0.05932074785232544, -0.06269790977239609, -0.07328580319881439, -0.02400791272521019, -0.12121414393186569, -0.03942305967211723, -0.05288713425397873, -0.08377032727003098, -0.02430100552737713, 0.062292855232954025, 0.011350116692483425, -0.02101626805961132, 0.009124085307121277, 0.02...
-0.026123
permission to access the specified database. \*\*Solution:\*\* 1. Verify that the database name is correct in the data source configuration. 1. Ensure the user is mapped to the database with appropriate permissions. 1. Grant at least `SELECT` permission on the required tables: ```sql USE [your\_database] GRANT SELECT O...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/troubleshooting/index.md
main
grafana
[ 0.0052896831184625626, -0.04210267588496208, -0.06424421817064285, -0.0768444612622261, -0.13179579377174377, -0.012990648858249187, 0.040607236325740814, -0.043888628482818604, -0.06949236989021301, 0.08368779718875885, -0.0069788298569619656, -0.08484356850385666, 0.05131957307457924, 0....
-0.085967
avoid timezone issues. 1. Time macros (`$\_\_time`, `$\_\_timeFilter`, etc.) always expand to UTC values. 1. If your timestamps are stored in local time, convert them to UTC in your query: ```sql SELECT your\_datetime\_column AT TIME ZONE 'Your Local Timezone' AT TIME ZONE 'UTC' AS time, value FROM your\_table ``` 1. D...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/troubleshooting/index.md
main
grafana
[ 0.03421201929450035, -0.03487492352724075, -0.04588752239942551, 0.03515620529651642, -0.011854954995214939, -0.03855207562446594, 0.025610292330384254, 0.051025573164224625, -0.023877020925283432, -0.0003277095383964479, -0.00818279106169939, -0.08033289015293121, 0.04347597062587738, -0....
-0.024669
1. Use the `FILL` option in `$\_\_timeGroup()` macro to handle missing data points. ## Get additional help If you continue to experience issues after following this troubleshooting guide: 1. Check the [Grafana community forums](https://community.grafana.com/) for similar issues. 1. Review the [Grafana GitHub issues](ht...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/troubleshooting/index.md
main
grafana
[ -0.09756526350975037, -0.04124252498149872, -0.04531951621174812, 0.06795231997966766, -0.08708061277866364, -0.04177888482809067, -0.0610835887491703, -0.07712143659591675, -0.006614622659981251, 0.02388221025466919, 0.016349999234080315, -0.07769803702831268, -0.009198902174830437, -0.03...
-0.068249
# Microsoft SQL Server query editor Grafana provides a query editor for the Microsoft SQL Server data source, which is located on the [Explore page](ref:explore). You can also access the MSSQL query editor from a dashboard panel. Click the menu in the upper right of the panel and select \*\*Edit\*\*. This topic explain...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/query-editor/index.md
main
grafana
[ -0.042657215148210526, -0.030185241252183914, -0.047566697001457214, 0.06904502958059311, -0.13492846488952637, 0.02834669128060341, 0.03994815796613693, -0.0034463482443243265, -0.05618725344538689, 0.07391544431447983, -0.009580935351550579, -0.0208179522305727, 0.047169946134090424, -0....
0.071013
\*\*Enter\*\*. Remove an alias by clicking the \*\*X\*\*. - \*\*Filter\*\* - Toggle to add filters. - \*\*Filter by column value\*\* - \_Optional\_. If you toggle \*\*Filter\*\* you can add a column to filter by from the drop-down. To filter by additional columns, click the \*\*+ sign\*\* to the right of the condition ...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/query-editor/index.md
main
grafana
[ -0.028526142239570618, 0.061098236590623856, 0.00858979020267725, 0.06835407018661499, -0.020082084462046623, 0.00323662837035954, 0.09865949302911758, -0.05387309193611145, -0.026644062250852585, -0.009242451749742031, 0.006621852051466703, -0.11109475046396255, 0.021712278947234154, -0.0...
-0.0105
drop-down, choose a macro such as `$\\_\\_timeGroup` or `$\\_\\_timeGroupAlias`. Then, select a time column from the \*\*Column\*\* drop-down and a time interval from the \*\*Interval\*\* drop-down. This generates a time-series query based on your selected time grouping. {{< admonition type="warning" >}} Time macros (`...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/query-editor/index.md
main
grafana
[ 0.0018684986280277371, -0.039349865168333054, -0.016211695969104767, 0.09334521740674973, 0.03726252540946007, -0.0019365024054422975, 0.10768644511699677, -0.010256617330014706, -0.009166214615106583, -0.030520033091306686, -0.025594938546419144, -0.1645011305809021, -0.0026620966382324696,...
-0.052196
( time\_sec bigint, description nvarchar(100), tags nvarchar(100), ) ``` ```sql CREATE TABLE [mssql\_types] ( c\_bit bit, c\_tinyint tinyint, c\_smallint smallint, c\_int int, c\_bigint bigint, c\_money money, c\_smallmoney smallmoney, c\_numeric numeric(10,5), c\_real real, c\_decimal decimal(10,2), c\_float float, c\...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/query-editor/index.md
main
grafana
[ 0.023382123559713364, 0.017940234392881393, -0.03178347274661064, 0.06324446201324463, -0.05500127002596855, -0.013413095846772194, 0.07706323266029358, 0.06173669174313545, -0.06552077829837799, 0.062276482582092285, 0.017750881612300873, -0.11204805970191956, 0.02904600277543068, 0.00021...
0.047754
10.0.1.1\_ and \_value 10.0.1.2\_. To render the series with a name of \_10.0.1.1\_ and \_10.0.1.2\_ , use a [Standard options definitions](ref:configure-standard-options-display-name) display name value of `${\_\_field.labels.hostname}`. Data frame result: ```text +---------------------+---------------------------+---...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/query-editor/index.md
main
grafana
[ 0.012584161944687366, 0.033927273005247116, -0.015011145733296871, 0.03513937443494797, -0.009508267045021057, 0.022825120016932487, 0.06165290251374245, -0.0017586305039003491, 0.06372378021478653, -0.08179518580436707, -0.00787363387644291, -0.12356302887201309, -0.0985889807343483, 0.01...
-0.015204
metric\_values WHERE $\_\_timeFilter(time) GROUP BY $\_\_timeGroup(time, '5m'), measurement ORDER BY 1 ``` \*\*Second query:\*\* ```sql SELECT $\_\_timeGroup(time, '5m') as time, measurement + ' - value two' as metric, avg(valueTwo) as valueTwo FROM metric\_values GROUP BY $\_\_timeGroup(time, '5m'), measurement ORDER ...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/query-editor/index.md
main
grafana
[ -0.052490513771772385, -0.022827744483947754, -0.016030652448534966, 0.03446989133954048, -0.09415005147457123, -0.036792028695344925, 0.04789145290851593, -0.015312157571315765, 0.021588556468486786, -0.01469771470874548, 0.0026443421375006437, -0.11489090323448181, 0.010876062326133251, ...
0.045189
built-in macros to populate the time range dynamically: ```sql DECLARE @from datetime = $\_\_timeFrom(), @to datetime = $\_\_timeTo() EXEC dbo.sp\_test\_datetime @from, @to ```
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/query-editor/index.md
main
grafana
[ 0.021690713241696358, -0.04189268499612808, -0.06888718903064728, 0.07797989249229431, -0.04629818722605705, 0.038033757358789444, 0.06516573578119278, 0.07674642652273178, -0.05017799511551857, -0.02472042851150036, -0.006671000272035599, -0.06939372420310974, -0.004008884076029062, 0.019...
0.016167
# Elasticsearch data source Elasticsearch is a search and analytics engine used for a variety of use cases. You can create many types of queries to visualize logs or metrics stored in Elasticsearch, and annotate graphs with log events stored in Elasticsearch. The following resources will help you get started with Elast...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/_index.md
main
grafana
[ 0.0054580532014369965, 0.025658324360847473, -0.04997306689620018, 0.025827066972851753, -0.005702453665435314, -0.014143210835754871, -0.026389695703983307, 0.020460471510887146, 0.03555551916360855, 0.05894177407026291, -0.060774918645620346, -0.06293192505836487, 0.003488251008093357, 0...
0.197482
# Elasticsearch alerting You can use Grafana Alerting with Elasticsearch to create alerts based on your Elasticsearch data. This allows you to monitor metrics, detect anomalies, and receive notifications when specific conditions are met. For general information about Grafana Alerting, refer to [Grafana Alerting](ref:al...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/alerting/index.md
main
grafana
[ 0.013203371316194534, -0.006664426065981388, -0.03695762902498245, 0.05460529401898384, 0.0026218597777187824, -0.02718699723482132, 0.03740124776959419, -0.008252247236669064, 0.04345506429672241, 0.011240397579967976, -0.09641730040311813, -0.10532809793949127, 0.03822116553783417, 0.026...
0.132786
your query to use metric aggregations with a Date histogram instead. ### Query complexity Complex queries with many nested aggregations may timeout or fail to evaluate. Simplify queries for alerting by: - Reducing the number of bucket aggregations - Using appropriate time intervals - Adding filters to limit the data sc...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/alerting/index.md
main
grafana
[ 0.09742280840873718, 0.05276814475655556, 0.003897937247529626, 0.07390067726373672, 0.002350668655708432, -0.012000787071883678, 0.05375794321298599, 0.012482767924666405, 0.05404654145240784, -0.017501143738627434, -0.0793771743774414, -0.09084165841341019, 0.06742556393146515, -0.014016...
0.077909
# Configure the Elasticsearch data source Grafana ships with built-in support for Elasticsearch. You can create a variety of queries to visualize logs or metrics stored in Elasticsearch, and annotate graphs with log events stored in Elasticsearch. For instructions on how to add a data source to Grafana, refer to the [a...
https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/configure/index.md
main
grafana
[ -0.009214385412633419, 0.006008485797792673, -0.06199364736676216, 0.007474452257156372, -0.03750740736722946, -0.04438358172774315, -0.08570705354213715, -0.039059799164533615, 0.03771738335490227, 0.12690244615077972, -0.040803518146276474, -0.11275196820497513, -0.008096198551356792, 0....
0.085424