content large_string | url large_string | branch large_string | source large_string | embeddings list | score float64 |
|---|---|---|---|---|---|
# Prometheus data source Prometheus is an open source database that uses a telemetry collector agent to scrape and store metrics used for monitoring and alerting. Grafana provides native support for Prometheus, so you don't need to install a plugin. The following documentation will help you get started working with Pro... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/_index.md | main | grafana | [
-0.0937676727771759,
-0.00729954382404685,
-0.06521855294704437,
0.04641519486904144,
-0.04937686771154404,
-0.11861010640859604,
0.008888944052159786,
0.01840580627322197,
-0.023879528045654297,
0.0031645181588828564,
0.01868565008044243,
-0.08900178223848343,
0.005635329522192478,
-0.001... | 0.202402 |
# Connect to Amazon Managed Service for Prometheus 1. In the data source configuration page, locate the \*\*Auth\*\* section 2. Enable \*\*SigV4 auth\*\* 3. Configure the following settings: | Setting | Description | Example | | --------------------------- | ---------------------------------------------- | ------------... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/aws-authentication.md | main | grafana | [
-0.04027736932039261,
0.02801087126135826,
-0.06411949545145035,
0.007629480212926865,
0.010695218108594418,
-0.11299586296081543,
-0.01575755886733532,
-0.03277657926082611,
0.03747528791427612,
0.04395723342895508,
-0.0073358286172151566,
-0.0814725011587143,
0.06751835346221924,
-0.0557... | 0.029669 |
core Prometheus. To revert the migration: 1. Disable the `prometheusTypeMigration` feature toggle. For more information on feature toggles, refer to [Manage feature toggles](https://grafana.com/docs/grafana//setup-grafana/configure-grafana/feature-toggles/#manage-feature-toggles). 2. Obtain a bearer token that has `rea... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/aws-authentication.md | main | grafana | [
-0.09324994683265686,
-0.00045064144069328904,
-0.019719386473298073,
0.02079792693257332,
-0.024389972910284996,
-0.09818682074546814,
-0.07468713074922562,
-0.09555929154157639,
-0.05941268801689148,
0.06378600746393204,
0.00045946912723593414,
-0.056728821247816086,
-0.01776573434472084,
... | 0.036985 |
fetched data sources" get\_summary\_stats "$response\_body" update\_data\_source\_type "$response\_body" log\_message "Migration process completed" else log\_message "error fetching data sources: HTTP $http\_code - $response\_body" fi } # Function to initialize log file initialize\_log() { echo "=== Grafana Azure Prome... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/aws-authentication.md | main | grafana | [
0.02336116135120392,
0.0018389776814728975,
-0.01590193808078766,
0.02098034881055355,
0.005103496368974447,
-0.0384708009660244,
0.02493809163570404,
-0.027936307713389397,
0.02903270162642002,
0.13571488857269287,
0.06528357416391373,
-0.08432332426309586,
0.016137411817908287,
-0.026558... | 0.019086 |
# Connect to Azure Monitor Managed Service for Prometheus After creating a Azure Monitor Managed Service for Prometheus data source: 1. In the data source configuration page, locate the \*\*Authentication\*\* section 2. Select your authentication method: - \*\*Managed Identity\*\*: For Azure-hosted Grafana instances. T... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/azure-authentication.md | main | grafana | [
-0.0983966588973999,
0.050162460654973984,
-0.10088169574737549,
-0.007535874843597412,
-0.06472544372081757,
-0.09358443319797516,
0.02499125525355339,
-0.06367538869380951,
0.04167300835251808,
0.1304684430360794,
0.002736323280259967,
-0.0784793272614479,
0.05983717739582062,
0.03501077... | 0.083392 |
support. ### Rollback self-hosted Grafana without a backup If you don’t have a backup of your Grafana instance before the migration, remove the `prometheusTypeMigration` feature toggle, and run the following script. It reverts all the Azure Monitor Managed Service data source instances back to core Prometheus. To rever... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/azure-authentication.md | main | grafana | [
-0.07943649590015411,
-0.017711633816361427,
-0.061563726514577866,
0.06436744332313538,
-0.008942722342908382,
-0.044252894818782806,
-0.037695303559303284,
-0.11853224784135818,
-0.026677289977669716,
0.13855218887329102,
-0.009815819561481476,
-0.06859217584133148,
0.03514144942164421,
... | 0.040323 |
log\_message "Grafana URL: $GRAFANA\_URL" response=$(curl -s -w "\n%{http\_code}" -X GET \ -H "Content-Type: application/json" \ -H "Authorization: Bearer $BEARER\_TOKEN" \ "$GRAFANA\_URL/api/datasources/") http\_code=$(echo "$response" | tail -n1) response\_body=$(echo "$response" | sed '$d') if [[ "$http\_code" -ge 2... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/azure-authentication.md | main | grafana | [
-0.01965622790157795,
0.02652902714908123,
-0.013400166295468807,
-0.013517126441001892,
-0.029414944350719452,
-0.08580540120601654,
-0.027093714103102684,
-0.014507213607430458,
0.056055497378110886,
0.11189320683479309,
0.047497741878032684,
-0.0905052050948143,
-0.004830216057598591,
-... | 0.045193 |
# Configure the Prometheus data source This document provides instructions for configuring the Prometheus data source and explains the available configuration options. Grafana includes built-in support for Prometheus, so you don't need to install a plugin. For general information on adding a data source to Grafana, ref... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/_index.md | main | grafana | [
-0.08998322486877441,
-0.022379133850336075,
-0.06770006567239761,
-0.0055989534594118595,
-0.09359424561262131,
-0.11289068311452866,
-0.025982102379202843,
-0.051396697759628296,
-0.05818143114447594,
0.06717532128095627,
0.020273489877581596,
-0.09139209240674973,
0.0062237149104475975,
... | 0.153416 |
to authenticate with a CA certificate. Follow the instructions of the CA (Certificate Authority) to download the certificate file. Required for verifying self-signed TLS certificates. - \*\*CA certificate\*\* - Add your certificate. - \*\*TLS client authentication\*\* - Check the box to enable TLS client authentication... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/_index.md | main | grafana | [
-0.05537651479244232,
0.04917296767234802,
-0.05119448900222778,
-0.04181992635130882,
-0.06371504068374634,
-0.035102520138025284,
-0.014951149001717567,
0.017746999859809875,
0.058456387370824814,
-0.010903353802859783,
-0.005343096796423197,
-0.08158726245164871,
0.08021549880504608,
0.... | -0.011148 |
and metric and label support in the query field's autocomplete. This can improve performance for large Prometheus instances. \*\*Performance:\*\* - \*\*Prometheus type\*\* - Select the type of your Prometheus-compatible database, such as Prometheus, Cortex, Mimir, or Thanos. Changing this setting will save your current... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/_index.md | main | grafana | [
-0.031461577862501144,
0.004675932228565216,
-0.005186781287193298,
0.05849837139248848,
-0.03347456827759743,
-0.07333610951900482,
0.010019578970968723,
-0.017431266605854034,
0.03235355019569397,
-0.025486694648861885,
-0.032767780125141144,
-0.04277912154793739,
0.02444734238088131,
-0... | 0.149386 |
the [`${\_\_value.raw}` macro](https://grafana.com/docs/grafana//panels-visualizations/configure-data-links/#value-variables). - \*\*Data source\*\* - \_(Visible when`Internal link` is enabled.)\_ Select the data source that the exemplar will link to from the drop-down. - \*\*URL label\*\* - Adds a custom display label... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/_index.md | main | grafana | [
-0.14998312294483185,
0.05082719027996063,
-0.12822400033473969,
0.051751017570495605,
-0.05000746250152588,
-0.023188145831227303,
-0.004642467014491558,
-0.019163645803928375,
-0.012893653474748135,
-0.010137219913303852,
0.01050999853760004,
-0.05033337324857712,
-0.019802311435341835,
... | 0.029509 |
have successfully tested the connection to a Prometheus data source or are sending metrics to Grafana Cloud and there is no metric data appearing in Explore, make sure you've selected the correct data source from the data source drop-down menu. When using `remote\_write` to send metrics to Grafana Cloud, the data sourc... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/configure/_index.md | main | grafana | [
-0.048238012939691544,
-0.07235343009233475,
-0.018392052501440048,
0.033614546060562134,
-0.07810570299625397,
-0.09600875526666641,
-0.05533882603049278,
-0.07999657839536667,
0.053741101175546646,
0.06583206355571747,
-0.022708149626851082,
-0.08849823474884033,
-0.005986169446259737,
0... | 0.060047 |
# Prometheus template variables Instead of hard-coding details such as server, application, and sensor names in metric queries, you can use variables. Grafana refers to such variables as \*\*template\*\* variables. Grafana lists these variables in dropdown select boxes at the top of the dashboard to help you change the... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/template-variables/_index.md | main | grafana | [
-0.06929069757461548,
0.05694650113582611,
-0.06906264275312424,
0.04550518840551376,
-0.07849577814340591,
-0.038159362971782684,
0.003767076414078474,
0.00783382449299097,
-0.02532203495502472,
0.011345923878252506,
-0.038857560604810715,
-0.11828736215829849,
0.018122857436537743,
0.025... | 0.178251 |
sum(rate(http\_requests\_total[$\_\_range])) by (instance))) Regex: /"([^"]+)"/ ``` Populate a variable with the instances having a certain state over the time range shown in the dashboard, using `$\_\_range\_s`: ``` query\_result(max\_over\_time([${\_\_range\_s}s]) != ) Regex: ``` ## Use `$\_\_rate\_interval` Grafana ... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/template-variables/_index.md | main | grafana | [
-0.10029715299606323,
0.06341785937547684,
-0.027138561010360718,
0.003406891133636236,
-0.06105773523449898,
-0.053758133202791214,
-0.01247519999742508,
0.0016638250090181828,
0.0565987192094326,
0.03020843304693699,
-0.001241640537045896,
-0.12069470435380936,
0.03938068822026253,
0.028... | 0.068293 |
# Troubleshoot Prometheus data source issues This document provides troubleshooting information for common errors you may encounter when using the Prometheus data source in Grafana. ## Connection errors The following errors occur when Grafana cannot establish or maintain a connection to Prometheus. ### Failed to connec... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/troubleshooting/index.md | main | grafana | [
-0.08671896904706955,
0.04159832373261452,
-0.008763086050748825,
-0.016181331127882004,
-0.06448923051357269,
-0.128679096698761,
-0.06570091843605042,
-0.05728309974074364,
-0.03217511996626854,
0.05585860833525658,
0.007173698861151934,
-0.062284909188747406,
0.012749564833939075,
0.020... | 0.087675 |
between Grafana and Prometheus requires authentication. When proxy authentication fails, the proxy redirects the request to an HTML authentication page. Grafana cannot parse the HTML response, which results in a parse error. This appears to be a query issue but is actually a proxy authentication issue. \*\*Solution:\*\... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/troubleshooting/index.md | main | grafana | [
-0.08187686651945114,
0.032361190766096115,
0.020838025957345963,
0.01580309122800827,
-0.07148528844118118,
-0.12086664885282516,
-0.012081901542842388,
-0.05553710460662842,
-0.025908101350069046,
0.019836248829960823,
-0.010885559022426605,
-0.09444303065538406,
0.03804006800055504,
0.0... | 0.103245 |
database types support different APIs, so setting this incorrectly may cause unexpected behavior. ### Scrape interval mismatch \*\*Symptom:\*\* Data appears sparse, or `rate()` queries return no data or incomplete results. \*\*Cause:\*\* The \*\*Scrape interval\*\* setting in Grafana does not match the actual scrape in... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/troubleshooting/index.md | main | grafana | [
-0.07969997078180313,
-0.013111341744661331,
-0.021300002932548523,
0.04317537695169449,
-0.06277963519096375,
-0.14632545411586761,
-0.06487482786178589,
-0.06263318657875061,
0.02527741529047489,
0.026775889098644257,
0.02009608969092369,
-0.123897984623909,
0.01392384897917509,
-0.03623... | 0.054509 |
and similar functions, remember that they need at least two data points to calculate. ### Exemplars not showing \*\*Cause:\*\* Exemplar data is not appearing in visualizations. \*\*Solution:\*\* 1. Verify that exemplars are enabled in the data source configuration under \*\*Exemplars\*\*. 1. Check that your Prometheus ... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/troubleshooting/index.md | main | grafana | [
-0.06265236437320709,
0.04838467389345169,
-0.02724548801779747,
0.0347180999815464,
0.0007344092009589076,
-0.13264940679073334,
-0.008864582516252995,
-0.015123025514185429,
0.023123856633901596,
0.0053422534838318825,
0.02297975681722164,
-0.15351532399654388,
0.011605534702539444,
-0.0... | 0.141645 |
# Prometheus query editor Grafana provides a query editor for the Prometheus data source to create queries in PromQL. For more information about PromQL, see [Querying Prometheus](http://prometheus.io/docs/querying/basics/). The Prometheus query editor is located on the [Explore page](https://grafana.com/docs/grafana//e... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/query-editor/_index.md | main | grafana | [
-0.0672883465886116,
0.035988546907901764,
-0.05370749160647392,
0.060330506414175034,
-0.06362723559141159,
-0.052890025079250336,
-0.006300751585513353,
-0.035924822092056274,
-0.027236763387918472,
0.02236418053507805,
-0.027888907119631767,
-0.026317214593291283,
0.008053596131503582,
... | 0.145118 |
example, setting this to `1h` suggests that data is collected or displayed at hourly intervals. This setting supports the `$\_\_interval` and `$\_\_rate\_interval` macros. Note that the time range of the query is aligned to this step size, which may adjust the actual start and end times of the returned data. - \*\*Form... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/query-editor/_index.md | main | grafana | [
-0.08006052672863007,
0.040586162358522415,
-0.0595896914601326,
0.041699908673763275,
-0.09335453808307648,
-0.09620604664087296,
-0.0334196612238884,
-0.012591151520609856,
0.00895078293979168,
0.006533890496939421,
-0.014281888492405415,
-0.11036577075719833,
-0.008879312314093113,
-0.0... | 0.090943 |
in your instance. If you would like to explore your metrics in the query builder further, you can open the \*\*Metrics explorer\*\* by clicking the first option in the metric select component of the query builder. The Metrics explorer displays all metrics in a paginated table list. The list shows the total number of me... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/query-editor/_index.md | main | grafana | [
-0.03851129859685898,
0.0435694083571434,
-0.01996435970067978,
0.10051685571670532,
-0.04030948877334595,
0.009814150631427765,
-0.008371563628315926,
-0.01600128971040249,
0.010995166376233101,
-0.020513206720352173,
-0.014229255728423595,
-0.11936403065919876,
0.06283044815063477,
-0.00... | 0.098645 |
Metrics browser, click the arrow next to \*\*Metrics browser\*\*. ### Metrics browser in Code mode The Metrics browser locates metrics and selects relevant labels to help you build basic queries. When you click \*\*Metrics browser\*\* in `Code` mode, it displays all available metrics and labels. If supported by your Pr... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/prometheus/query-editor/_index.md | main | grafana | [
-0.028368251398205757,
0.008445147424936295,
-0.02335439622402191,
0.058005012571811676,
-0.0010961226653307676,
-0.02587812952697277,
0.038950301706790924,
0.013075310736894608,
0.023356996476650238,
-0.058652181178331375,
-0.01031485479325056,
-0.09369981288909912,
0.014357330277562141,
... | 0.170625 |
# Graphite data source Grafana includes built-in support for Graphite. This topic explains options, variables, querying, and other features specific to the Graphite data source, which include its feature-rich query editor. For instructions on how to add a data source to Grafana, refer to the [administration documentati... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/graphite/_index.md | main | grafana | [
-0.07446987926959991,
-0.02614281140267849,
-0.07645652443170547,
0.04466543719172478,
-0.06757094711065292,
0.0031412444077432156,
-0.044589001685380936,
0.004075709730386734,
-0.06021635979413986,
0.08669278770685196,
-0.04238724336028099,
-0.02556990087032318,
0.04504389315843582,
0.001... | 0.036911 |
# Configure the Graphite data source This document provides instructions for configuring the Graphite data source and explains available configuration options. For general information on managing data sources, refer to [Data source management](https://grafana.com/docs/grafana//administration/data-source-management/). #... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/graphite/configure/index.md | main | grafana | [
-0.11453882604837418,
0.0029672165401279926,
-0.08362504839897156,
0.0009744620183482766,
-0.07793597131967545,
-0.06716842949390411,
-0.08178049325942993,
-0.027957923710346222,
-0.09893307089805603,
0.11723408102989197,
0.017198851332068443,
-0.052258413285017014,
0.02643403597176075,
0.... | 0.054507 |
or response. | \*\*Setting\*\* | \*\*Description\*\* | | ----------- | ---------------------------------------------------------------------------------------------------------- | | \*\*Header\*\* | Add a custom header. This allows custom headers to be passed based on the needs of your Graphite instance. | | \*\*Value\... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/graphite/configure/index.md | main | grafana | [
-0.07449842989444733,
0.15372967720031738,
0.024548621848225594,
0.04375164583325386,
-0.0012409973423928022,
0.0009191411081701517,
0.002754021668806672,
0.061156176030635834,
-0.05300544574856758,
0.028704103082418442,
-0.05652574822306633,
-0.15490499138832092,
0.02754049189388752,
-0.0... | 0.017126 |
# Graphite template variables Instead of hard-coding details such as server, application, and sensor names in metric queries, you can use variables. Grafana lists these variables in drop-down selection boxes at the top of the dashboard to help you change the data displayed in your dashboard. Grafana refers to such vari... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/graphite/template-variables/index.md | main | grafana | [
-0.07758898288011551,
0.031970977783203125,
-0.05819042772054672,
0.04076221585273743,
-0.07713258266448975,
-0.020895686000585556,
-0.011285226792097092,
0.02074381709098816,
-0.055165305733680725,
0.06385325640439987,
-0.036727625876665115,
-0.0951947495341301,
0.02240588888525963,
0.025... | 0.069166 |
values in $`{apps}`, formatted as a regular expression. `=~` is the regular expression operator Non-tag queries use the default `glob` formatting for multi-value variables. ## Use other query variables When writing queries, use the \*\*metric find\*\* query type to retrieve dynamic values. For example, the query `prod.... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/graphite/template-variables/index.md | main | grafana | [
-0.026721175760030746,
0.03414419665932655,
-0.02956068143248558,
0.013979743234813213,
-0.09116150438785553,
-0.04056115448474884,
0.015292951837182045,
0.014388378709554672,
0.026776641607284546,
0.02929873578250408,
-0.00782816857099533,
-0.11368689686059952,
0.013263396918773651,
0.015... | 0.029193 |
# Troubleshoot Graphite data source issues This document provides solutions for common issues you might encounter when using the Graphite data source. ## Connection issues Use the following troubleshooting steps to resolve connection problems between Grafana and your Graphite server. \*\*Data source test fails with "Un... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/graphite/troubleshooting/index.md | main | grafana | [
-0.09572494029998779,
-0.010260825045406818,
-0.003924969118088484,
-0.011047124862670898,
-0.07112634181976318,
-0.10367880761623383,
-0.13115428388118744,
-0.056227024644613266,
-0.06612584739923477,
0.11466490477323532,
0.011370702646672726,
-0.03566011041402817,
-0.01106704119592905,
0... | -0.037016 |
consistently time out: - Increase the \*\*Timeout\*\* setting in the data source configuration. - Reduce the time range of your query. - Use more specific metric paths instead of broad wildcards. - Consider using `summarize()` or `consolidateBy()` functions to reduce the amount of data returned. - Check your Graphite s... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/graphite/troubleshooting/index.md | main | grafana | [
0.0034214649349451065,
0.0318107008934021,
0.02336522750556469,
0.06459685415029526,
-0.006839536130428314,
-0.015641512349247932,
-0.06459397077560425,
-0.016148578375577927,
-0.06724260747432709,
0.05240266025066376,
-0.017293699085712433,
-0.04582357406616211,
-0.013056744821369648,
-0.... | 0.013628 |
# Graphite query editor Grafana includes a Graphite-specific query editor to help you build queries. The query editor helps you quickly navigate the metric space, add functions, and change function parameters. It supports a variety of Graphite queries, including complex nested queries, through the use of query referenc... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/graphite/query-editor/index.md | main | grafana | [
-0.1155826672911644,
-0.012839069589972496,
-0.026362551376223564,
0.04589183256030083,
-0.11527730524539948,
-0.03994596377015114,
-0.04013517126441002,
-0.0049681817181408405,
-0.029341643676161766,
0.0623176246881485,
-0.01843870058655739,
-0.06861741840839386,
0.012168356217443943,
-0.... | 0.127197 |
series To combine time series, click \*\*Combine\*\* in the \*\*Functions\*\* list. ### Select and explore data with tags In Graphite, everything is a tag. When exploring data, previously selected tags filter the remaining result set. To select data, use the `seriesByTag` function, which takes tag expressions (`=`, `!=... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/graphite/query-editor/index.md | main | grafana | [
-0.09069329500198364,
0.03540029749274254,
0.007141962647438049,
0.04888142645359039,
-0.0699978843331337,
-0.060243867337703705,
0.011230964213609695,
-0.02191442809998989,
-0.024825097993016243,
0.014609987847507,
-0.026583684608340263,
-0.08014136552810669,
-0.06772644072771072,
0.00978... | 0.019498 |
# Azure Monitor data source The Azure Monitor data source plugin allows you to query and visualize data from Azure Monitor, the Azure service to maximize the availability and performance of applications and services in the Azure Cloud. ## Supported Azure clouds The Azure Monitor data source supports the following Azure... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/_index.md | main | grafana | [
0.03724794089794159,
-0.014872709289193153,
-0.06219341978430748,
0.040566980838775635,
0.010517014190554619,
0.03850596398115158,
0.029441019520163536,
-0.11711307615041733,
0.04819786921143532,
0.10156993567943573,
0.01894376613199711,
-0.060477323830127716,
0.07947322726249695,
0.008540... | 0.052686 |
# Azure Monitor alerting The Azure Monitor data source supports [Grafana Alerting](https://grafana.com/docs/grafana//alerting/) and [Grafana-managed recording rules](https://grafana.com/docs/grafana//alerting/alerting-rules/create-recording-rules/create-grafana-managed-recording-rules/), allowing you to create alert ru... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/alerting/index.md | main | grafana | [
-0.03487517684698105,
-0.032307229936122894,
-0.10049688816070557,
0.044344618916511536,
0.017441293224692345,
-0.05544978007674217,
0.07773534953594208,
-0.10658342391252518,
0.047326020896434784,
0.11545542627573013,
-0.02220861054956913,
-0.09397933632135391,
0.07644446939229965,
0.0812... | 0.072723 |
- \*\*Resource\*\*: Select your virtual machine - \*\*Metric namespace\*\*: `Microsoft.Compute/virtualMachines` - \*\*Metric\*\*: `Percentage CPU` - \*\*Aggregation\*\*: `Average` 1. Add expressions: - \*\*Reduce\*\*: Last (to get the most recent data point) - \*\*Threshold\*\*: Is above 80 1. Set evaluation to run eve... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/alerting/index.md | main | grafana | [
0.050159428268671036,
0.04880668595433235,
-0.011191558092832565,
0.049432966858148575,
-0.023399287834763527,
-0.04430793598294258,
0.04473067447543144,
-0.0034195438493043184,
0.049360863864421844,
0.09137938171625137,
-0.04748130962252617,
-0.15161721408367157,
0.07995015382766724,
0.02... | 0.108351 |
authentication method. If using Current User authentication, ensure fallback service credentials are configured. - Check that the query returns numeric data in Explore. - Ensure the evaluation interval allows enough time for data to be available. - Review the alert rule's health and any error messages in the Alerting U... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/alerting/index.md | main | grafana | [
-0.016141586005687714,
0.044761013239622116,
-0.05015972629189491,
0.053261999040842056,
-0.04564717784523964,
-0.03806416690349579,
0.03122853673994541,
-0.07029058039188385,
0.051348425447940826,
0.07537313550710678,
-0.019548870623111725,
-0.08137442171573639,
0.09064900875091553,
0.047... | 0.008859 |
# Configure the Azure Monitor data source This document explains how to configure the Azure Monitor data source and the available configuration options. For general information about data sources, refer to [Grafana data sources](https://grafana.com/docs/grafana//datasources/) and [Data source management](https://grafan... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/configure/index.md | main | grafana | [
-0.05254797637462616,
-0.0354175791144371,
-0.11320178955793381,
0.005178428255021572,
-0.05042661353945732,
-0.057538121938705444,
-0.023778175935149193,
-0.09747917950153351,
0.0004216131055727601,
0.15594008564949036,
0.01605188101530075,
-0.104168601334095,
0.03446691855788231,
0.01961... | 0.045991 |
you want to monitor. Refer to the [Azure documentation for role assignments](https://docs.microsoft.com/en-us/azure/role-based-access-control/role-assignments-portal?tabs=current). #### App Registration UI configuration | Setting | Description | | --------------------------- | ------------------------------------------... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/configure/index.md | main | grafana | [
0.033892348408699036,
0.02970682829618454,
-0.053651317954063416,
0.06550993770360947,
-0.029423018917441368,
0.04078741371631622,
0.1113511472940445,
-0.09483576565980911,
0.02860802784562111,
0.02690829709172249,
-0.008161406964063644,
-0.0991692990064621,
0.036998338997364044,
-0.005879... | -0.004347 |
Azure. - `certificate.b64` is the encrypted, encoded file added to Grafana (in the client certificate field). #### App Registration (client certificate) UI configuration | Setting | Description | | --------------------------- | --------------------------------------------------------------------------------------------... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/configure/index.md | main | grafana | [
-0.10946627706289291,
0.07971813529729843,
-0.08868952840566635,
-0.005117473192512989,
-0.07662425190210342,
-0.0021532527171075344,
0.023222975432872772,
-0.04648644104599953,
0.07412545382976532,
0.06588255614042282,
0.0055387672036886215,
-0.08328735083341599,
0.06765282899141312,
-0.0... | -0.013492 |
identity in the Grafana server configuration: ```ini [azure] workload\_identity\_enabled = true ``` Optional configuration variables: ```ini [azure] workload\_identity\_enabled = true workload\_identity\_tenant\_id = # Microsoft Entra ID tenant containing the managed identity workload\_identity\_client\_id = # Client I... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/configure/index.md | main | grafana | [
-0.12538447976112366,
0.0513782761991024,
-0.07648853212594986,
0.01986110396683216,
-0.07435034215450287,
-0.050842564553022385,
0.03358960896730423,
-0.06288104504346848,
0.057562801986932755,
0.07988892495632172,
0.013620341196656227,
-0.06616654992103577,
0.04650656133890152,
0.0410026... | 0.089417 |
\*\*Authentication\*\* | Select \*\*Current User\*\*. | | \*\*Default Subscription\*\* | Click \*\*Load Subscriptions\*\* to populate available subscriptions, then select your default. | | \*\*Fallback Service Credentials\*\* | Enable and configure credentials for backend features like alerting. | {{< figure src="/medi... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/configure/index.md | main | grafana | [
-0.1015535369515419,
0.05291096121072769,
-0.08088918030261993,
0.04686279222369194,
-0.005430412944406271,
-0.04259548336267471,
0.06633269786834717,
-0.06359537690877914,
0.04098222032189369,
0.09796854108572006,
0.017010318115353584,
-0.05785328522324562,
0.09998447448015213,
0.01883000... | -0.006768 |
true` | All methods support the optional `subscriptionId` field to set a default subscription. For complete YAML examples, see the [authentication method sections](#configure-authentication) above. ## Configure with Terraform You can configure the Azure Monitor data source using the [Grafana Terraform provider](https:/... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/configure/index.md | main | grafana | [
-0.0782734677195549,
-0.00479467585682869,
-0.07290945202112198,
-0.003548041917383671,
-0.07316131144762039,
-0.0022646691650152206,
-0.028064321726560593,
-0.10535451024770737,
0.03338351845741272,
0.13274940848350525,
-0.01224357821047306,
-0.07573097199201584,
0.06544888019561768,
0.03... | 0.022348 |
# Azure Monitor template variables Instead of hard-coding details such as resource group or resource name values in metric queries, you can use variables. This helps you create more interactive, dynamic, and reusable dashboards. Grafana refers to such variables as template variables. For an introduction to templating a... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/template-variables/index.md | main | grafana | [
-0.06404843926429749,
0.011161085218191147,
-0.1267065554857254,
0.06820140033960342,
-0.09640274196863174,
0.061340004205703735,
0.04089006409049034,
-0.050879672169685364,
0.03995787352323532,
0.11037646234035492,
-0.0304492749273777,
-0.1261356770992279,
0.07576974481344223,
0.077458105... | 0.043285 |
\*\*Subscription\*\* field, select `$subscription`. 1. In the \*\*Resource Group\*\* field, select `$resourceGroup`. 1. Select the appropriate \*\*Namespace\*\* for your resources (e.g., `Microsoft.Compute/virtualMachines`). Now when you change the subscription, the resource group dropdown updates automatically, and wh... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/template-variables/index.md | main | grafana | [
-0.04091627523303032,
-0.006673948839306831,
-0.03537238389253616,
0.07213592529296875,
-0.04800999164581299,
-0.03072460927069187,
0.108867347240448,
-0.08887962996959686,
0.051530200988054276,
0.10835462808609009,
-0.03509082645177841,
-0.11737591028213501,
0.07396665960550308,
0.0139042... | 0.08272 |
the variable dropdown to manually refresh. ### Multi-value selection not working in queries - Ensure the resources meet the requirements (same subscription, region, and type). - For Logs queries, use the `$\_\_contains()` macro to handle multi-value variables properly. | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/template-variables/index.md | main | grafana | [
0.03878655284643173,
-0.07254266738891602,
0.03685072436928749,
0.09193603694438934,
0.029491078108549118,
-0.003883104771375656,
0.1062171682715416,
-0.10688360780477524,
0.03059374913573265,
0.03563007712364197,
0.0019096527248620987,
-0.06627819687128067,
-0.006029440555721521,
0.002117... | 0.020791 |
# Troubleshoot Azure Monitor data source issues This document provides solutions to common issues you may encounter when configuring or using the Azure Monitor data source. ## Configuration and authentication errors These errors typically occur when setting up the data source or when authentication credentials are inva... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/troubleshooting/index.md | main | grafana | [
-0.015533587895333767,
0.0334906131029129,
-0.04520496726036072,
0.06252229958772659,
-0.01564631797373295,
0.016468357294797897,
0.03982371836900711,
-0.08121494203805923,
0.02058306522667408,
0.11762796342372894,
-0.008806603029370308,
-0.06785991042852402,
0.11399363726377487,
0.0392123... | -0.064494 |
the workload identity webhook is running in the cluster. ## Query errors These errors occur when executing queries against Azure Monitor services. ### "No data" or empty results \*\*Symptoms:\*\* - Query executes without error but returns no data - Charts show "No data" message \*\*Possible causes and solutions:\*\* | ... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/troubleshooting/index.md | main | grafana | [
-0.03314124420285225,
0.10144968330860138,
-0.046532370150089264,
0.07407330721616745,
0.0033953203819692135,
-0.06259513646364212,
0.020757557824254036,
-0.07081786543130875,
0.0453052818775177,
0.06438339501619339,
0.02628420852124691,
-0.16127333045005798,
0.0703730434179306,
-0.0131458... | 0.076105 |
expected resources appear in results - Results seem truncated \*\*Solutions:\*\* 1. ARG queries are paginated. The data source handles pagination automatically, but very large result sets may be limited. 2. Add filters to reduce result set size. 3. Verify you have access to all subscriptions containing the resources. #... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/troubleshooting/index.md | main | grafana | [
-0.06329861283302307,
0.026550911366939545,
-0.04025455564260483,
0.08592718094587326,
-0.02037332020699978,
-0.043134916573762894,
0.055065806955099106,
-0.06310652941465378,
0.021249515935778618,
0.0805976614356041,
-0.02186259627342224,
-0.06069570779800415,
0.058256324380636215,
0.0076... | 0.032518 |
# Azure Monitor query editor Grafana provides a query editor for the Azure Monitor data source, which is located on the [Explore page](https://grafana.com/docs/grafana//explore/). You can also access the Azure Monitor query editor from a dashboard panel. Click the menu in the upper right of the panel and select \*\*Edi... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/query-editor/index.md | main | grafana | [
-0.019076386466622353,
-0.019041739404201508,
-0.11842893064022064,
0.0722031518816948,
-0.023231061175465584,
-0.005327483639121056,
0.04729990288615227,
-0.08756557106971741,
0.04747676104307175,
0.12587226927280426,
-0.03354621306061745,
-0.05713674798607826,
0.0697718933224678,
0.02169... | 0.074142 |
type="note" >}} Not all metrics returned by the Azure Monitor Metrics API have values. {{< /admonition >}} > The data source retrieves lists of supported metrics for each subscription and ignores metrics that never have values. 1. Select a metric from the \*\*Metric\*\* field. Optionally, you can apply further aggregat... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/query-editor/index.md | main | grafana | [
-0.07937827706336975,
0.015318111516535282,
-0.05639062449336052,
0.059467863291502,
-0.07649807631969452,
-0.012740160338580608,
0.010413775220513344,
-0.04203970730304718,
0.09706705063581467,
0.08448184281587601,
-0.05808338522911072,
-0.1306188702583313,
0.014218867756426334,
0.0686721... | 0.010967 |
(public preview) {{< admonition type="note" >}} The Logs query builder is a [public preview feature](/docs/release-life-cycle/). It may not be enabled in all Grafana environments. {{< /admonition >}} The Logs query builder provides a visual interface for building Azure Monitor Logs queries without writing KQL. This is ... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/query-editor/index.md | main | grafana | [
-0.060741741210222244,
0.025739820674061775,
-0.04330877214670181,
0.07187429070472717,
-0.10083246976137161,
0.015360116958618164,
-0.03049837052822113,
-0.12698489427566528,
0.043739281594753265,
0.14850762486457825,
-0.01051531545817852,
-0.11684300005435944,
0.03387066349387169,
0.0184... | 0.036492 |
default Log Analytics time-range applies. For more details, refer to the [Azure Monitor Logs API documentation](https://learn.microsoft.com/en-us/rest/api/loganalytics/dataaccess/query/get?tabs=HTTP#uri-parameters). If you previously used the `Intersection` option, it has been migrated to `Dashboard`. {{< /admonition >... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/query-editor/index.md | main | grafana | [
0.06973738223314285,
-0.032664861530065536,
-0.061886321753263474,
0.06419993937015533,
0.002925443695858121,
-0.04968880116939545,
0.02378300577402115,
-0.05081101506948471,
0.07661638408899307,
0.06933250278234482,
-0.04256373643875122,
-0.05764893442392349,
0.01078670285642147,
0.050497... | 0.063052 |
so that you can more effectively govern an environment. By querying ARG, you can query resources with complex filtering, iteratively explore resources based on governance requirements, and assess the impact of applying policies in a vast cloud environment. {{< figure src="/static/img/docs/azure-monitor/query-editor-arg... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/query-editor/index.md | main | grafana | [
0.010426807217299938,
0.04452184960246086,
-0.0018425947055220604,
0.06432133167982101,
-0.002181500429287553,
0.018122758716344833,
0.07715849578380585,
-0.07696177810430527,
0.05354700982570648,
0.11731661856174469,
-0.023087235167622566,
-0.024006562307476997,
0.09787161648273468,
0.051... | 0.08686 |
`'\\grafana-vm\Network(eth0)\Total','\\hello!'` as a string, this expands it to `@'\\grafana-vm\Network(eth0)\Total', @'\\hello!'`. If you use single-value variables, escape the variable inline instead: `@'\$myVar'`. | | `$\_\_contains(colName, $myVar)` | Expands multi-value template variables. | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/query-editor/index.md | main | grafana | [
0.0368104986846447,
0.053695887327194214,
0.01482263021171093,
0.004638740327209234,
-0.06293649971485138,
0.06323937326669693,
0.06279856711626053,
0.02028578147292137,
-0.007169023156166077,
0.042602360248565674,
0.037030816078186035,
-0.08703102171421051,
-0.003427878487855196,
-0.02524... | 0.020402 |
# Azure Monitor annotations [Annotations](https://grafana.com/docs/grafana//dashboards/build-dashboards/annotate-visualizations/) overlay rich event information on top of graphs. You can use Azure Monitor Log Analytics queries to create annotations that mark important events, deployments, alerts, or other significant o... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/annotations/index.md | main | grafana | [
-0.04413977637887001,
0.04603328928351402,
-0.07335469871759415,
0.026838058605790138,
0.01600915938615799,
0.003255837131291628,
0.05365678295493126,
-0.07109273970127106,
0.06760913133621216,
0.13444769382476807,
-0.05538000166416168,
-0.12314442545175552,
0.028682218864560127,
0.0866823... | 0.097051 |
| order by TimeGenerated desc ``` ### Autoscale events Show autoscale operations: ```kusto AzureActivity | where $\_\_timeFilter(TimeGenerated) | where OperationNameValue contains "autoscale" | project TimeGenerated, Text=strcat("Autoscale: ", OperationNameValue), Status=ActivityStatusValue, ResourceGroup | order by Ti... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/azure-monitor/annotations/index.md | main | grafana | [
0.043231427669525146,
0.07694016396999359,
0.045576442033052444,
0.045490704476833344,
-0.07288052886724472,
0.06127328425645828,
0.09496385604143143,
-0.0375814363360405,
0.0718412846326828,
0.021671663969755173,
-0.01796298287808895,
-0.11086934059858322,
-0.020920315757393837,
0.0029776... | 0.087659 |
# Microsoft SQL Server (MSSQL) data source Grafana ships with built-in support for Microsoft SQL Server (MSSQL). You can query and visualize data from any Microsoft SQL Server 2005 or newer, including Microsoft Azure SQL Database. Use this data source to create dashboards, explore SQL data, and monitor MSSQL-based work... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/_index.md | main | grafana | [
0.02807425707578659,
-0.0727902427315712,
-0.10837545990943909,
0.08987267315387726,
-0.08749885112047195,
0.012988174334168434,
0.05451599508523941,
-0.04884742572903633,
-0.025842903181910515,
0.11125777661800385,
-0.05660746991634369,
-0.03534140810370445,
0.05888674035668373,
0.0109568... | 0.045948 |
# Configure the Microsoft SQL Server data source This document provides instructions for configuring the Microsoft SQL Server data source and explains available configuration options. For general information on adding and managing data sources, refer to [Grafana data sources](https://grafana.com/docs/grafana//datasourc... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/configure/index.md | main | grafana | [
-0.0506058968603611,
-0.1065625473856926,
-0.13347499072551727,
0.0013287656474858522,
-0.1188819408416748,
-0.04253891855478287,
-0.023329731076955795,
-0.08316115289926529,
-0.05591589957475662,
0.09829818457365036,
0.019551405683159828,
-0.03957017511129379,
0.025442220270633698,
-0.024... | 0.008458 |
using an older version of Microsoft SQL Server like 2008 and 2008R2, you may need to disable encryption to be able to connect. {{< /admonition >}} \*\*Authentication:\*\* | Authentication Type | Description | Credentials / Fields | | ----------------------------------------------------- | ------------------------------... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/configure/index.md | main | grafana | [
0.0018473131349310279,
-0.0644054263830185,
-0.052794598042964935,
0.05244462564587593,
-0.12972845137119293,
0.03168577700853348,
-0.009993401356041431,
-0.042783670127391815,
0.028685150668025017,
-0.039772264659404755,
-0.018261251971125603,
-0.05593673512339592,
0.04602052643895149,
0.... | -0.076274 |
| Defines the maximum packet size (in bytes) that Kerberos libraries will attempt to send over UDP before retrying with TCP. A value of `1` forces all communication to use TCP. | `1` (always use TCP) | | \*\*DNS Lookup KDC\*\* | Controls whether DNS `SRV` records are used to locate [Key Distribution Centers (KDCs)](htt... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/configure/index.md | main | grafana | [
0.027988558635115623,
-0.014669137075543404,
-0.04212364926934242,
-0.09160996973514557,
0.019950775429606438,
-0.020825810730457306,
-0.0546891912817955,
-0.05841980129480362,
0.025867706164717674,
0.08187778294086456,
-0.029186224564909935,
-0.019671691581606865,
0.029932236298918724,
-0... | -0.027205 |
a permission\*\* and choose the following permissions. They must be added individually. Refer to the [Azure documentation](https://learn.microsoft.com/en-us/entra/identity-platform/quickstart-configure-app-access-web-apis) for more information. - Select \*\*APIs my organization uses\*\* > Search for \*\*Azure SQL\*\* a... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/configure/index.md | main | grafana | [
-0.09661579877138138,
0.021784629672765732,
-0.09443562477827072,
0.008519266732037067,
-0.021384982392191887,
-0.0352286770939827,
0.04491160809993744,
-0.05970706045627594,
0.02682526595890522,
0.11428312212228775,
0.025110283866524696,
-0.07135914266109467,
0.05050007998943329,
0.057061... | -0.044246 |
Authentication type to \*\*Managed Identity\*\*. This hides the directory ID, application ID, and client secret fields, and the data source uses managed identity to authenticate to SQL Server. 3. You can set the `managed\_identity\_client\_id` field in the `[azure]` section of the [Grafana server configuration](https:/... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/configure/index.md | main | grafana | [
-0.10744570195674896,
0.007949096150696278,
-0.1393885761499405,
0.028726015239953995,
-0.0732976645231247,
-0.0017766091041266918,
0.08042208850383759,
-0.0564567893743515,
0.03689275309443474,
0.11918316781520844,
0.02023841254413128,
-0.06848040223121643,
0.11183717101812363,
0.02156639... | 0.049038 |
about provisioning, and for available configuration options, refer to [Provision Grafana](https://grafana.com/docs/grafana//administration/provisioning/). #### Provisioning example ```yaml apiVersion: 1 datasources: - name: MSSQL type: mssql url: localhost:1433 user: grafana jsonData: database: grafana maxOpenConns: 10... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/configure/index.md | main | grafana | [
-0.059794772416353226,
-0.07543301582336426,
-0.11267475038766861,
0.003072081133723259,
-0.09775812923908234,
-0.024350544437766075,
-0.017673999071121216,
-0.040300458669662476,
-0.060243163257837296,
0.09382343292236328,
-0.043807756155729294,
-0.06874848902225494,
0.04706215113401413,
... | -0.004051 |
# Microsoft SQL Server template variables Instead of hard-coding details such as server, application, and sensor names in metric queries, you can use variables. Grafana displays these variables in drop-down select boxes at the top of the dashboard to help you change the data displayed in your dashboard. Grafana refers ... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/template-variables/index.md | main | grafana | [
-0.06673099845647812,
0.015269534662365913,
-0.10652061551809311,
0.05791686475276947,
-0.12246325612068176,
-0.008475465700030327,
0.04370301961898804,
0.0022351823281496763,
-0.049516867846250534,
0.02278328873217106,
-0.02302507311105728,
-0.108911894261837,
0.04270850121974945,
-0.0131... | 0.077904 |
# Troubleshoot Microsoft SQL Server data source issues This document provides solutions to common issues you may encounter when configuring or using the Microsoft SQL Server (MSSQL) data source in Grafana. ## Connection errors These errors occur when Grafana cannot establish or maintain a connection to the Microsoft SQ... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/troubleshooting/index.md | main | grafana | [
-0.06656178832054138,
-0.05322887375950813,
-0.07626545429229736,
-0.027214305475354195,
-0.12590272724628448,
-0.04706477001309395,
-0.05349881574511528,
-0.07851435989141464,
-0.022570645436644554,
0.05957024544477463,
0.009285187348723412,
-0.022639933973550797,
0.009544290602207184,
0.... | -0.025168 |
permission to access the specified database. \*\*Solution:\*\* 1. Verify that the database name is correct in the data source configuration. 1. Ensure the user is mapped to the database with appropriate permissions. 1. Grant at least `SELECT` permission on the required tables: ```sql USE [your\_database] GRANT SELECT O... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/troubleshooting/index.md | main | grafana | [
0.0052896831184625626,
-0.04210267588496208,
-0.06424421817064285,
-0.0768444612622261,
-0.13179579377174377,
-0.012990648858249187,
0.040607236325740814,
-0.043888628482818604,
-0.06949236989021301,
0.08368779718875885,
-0.0069788298569619656,
-0.08484356850385666,
0.05131957307457924,
0.... | -0.085967 |
avoid timezone issues. 1. Time macros (`$\_\_time`, `$\_\_timeFilter`, etc.) always expand to UTC values. 1. If your timestamps are stored in local time, convert them to UTC in your query: ```sql SELECT your\_datetime\_column AT TIME ZONE 'Your Local Timezone' AT TIME ZONE 'UTC' AS time, value FROM your\_table ``` 1. D... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/troubleshooting/index.md | main | grafana | [
0.03421201929450035,
-0.03487492352724075,
-0.04588752239942551,
0.03515620529651642,
-0.011854954995214939,
-0.03855207562446594,
0.025610292330384254,
0.051025573164224625,
-0.023877020925283432,
-0.0003277095383964479,
-0.00818279106169939,
-0.08033289015293121,
0.04347597062587738,
-0.... | -0.024669 |
1. Use the `FILL` option in `$\_\_timeGroup()` macro to handle missing data points. ## Get additional help If you continue to experience issues after following this troubleshooting guide: 1. Check the [Grafana community forums](https://community.grafana.com/) for similar issues. 1. Review the [Grafana GitHub issues](ht... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/troubleshooting/index.md | main | grafana | [
-0.09461495280265808,
-0.040871959179639816,
-0.02986082062125206,
0.08389755338430405,
-0.07281912863254547,
-0.042534179985523224,
-0.033503834158182144,
-0.09090066701173782,
-0.007388480007648468,
0.01435428112745285,
0.019838780164718628,
-0.09583420306444168,
-0.004643312189728022,
-... | -0.070692 |
# Microsoft SQL Server query editor Grafana provides a query editor for the Microsoft SQL Server data source, which is located on the [Explore page](https://grafana.com/docs/grafana//explore/). You can also access the MSSQL query editor from a dashboard panel. Click the menu in the upper right of the panel and select \... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/query-editor/index.md | main | grafana | [
-0.03838614001870155,
-0.037849269807338715,
-0.0822441428899765,
0.08529208600521088,
-0.12429539114236832,
0.005675139836966991,
0.014236243441700935,
0.013689801096916199,
-0.04468059167265892,
0.0821552723646164,
-0.008999345824122429,
-0.013188228942453861,
0.03866049647331238,
-0.054... | 0.080896 |
\*\*Enter\*\*. Remove an alias by clicking the \*\*X\*\*. - \*\*Filter\*\* - Toggle to add filters. - \*\*Filter by column value\*\* - \_Optional\_. If you toggle \*\*Filter\*\* you can add a column to filter by from the drop-down. To filter by additional columns, click the \*\*+ sign\*\* to the right of the condition ... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/query-editor/index.md | main | grafana | [
-0.028526142239570618,
0.061098236590623856,
0.00858979020267725,
0.06835407018661499,
-0.020082084462046623,
0.00323662837035954,
0.09865949302911758,
-0.05387309193611145,
-0.026644062250852585,
-0.009242451749742031,
0.006621852051466703,
-0.11109475046396255,
0.021712278947234154,
-0.0... | -0.0105 |
drop-down, choose a macro such as `$\\_\\_timeGroup` or `$\\_\\_timeGroupAlias`. Then, select a time column from the \*\*Column\*\* drop-down and a time interval from the \*\*Interval\*\* drop-down. This generates a time-series query based on your selected time grouping. {{< admonition type="warning" >}} Time macros (`... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/query-editor/index.md | main | grafana | [
0.0018684986280277371,
-0.039349865168333054,
-0.016211695969104767,
0.09334521740674973,
0.03726252540946007,
-0.0019365024054422975,
0.10768644511699677,
-0.010256617330014706,
-0.009166214615106583,
-0.030520033091306686,
-0.025594938546419144,
-0.1645011305809021,
-0.0026620966382324696,... | -0.052196 |
( time\_sec bigint, description nvarchar(100), tags nvarchar(100), ) ``` ```sql CREATE TABLE [mssql\_types] ( c\_bit bit, c\_tinyint tinyint, c\_smallint smallint, c\_int int, c\_bigint bigint, c\_money money, c\_smallmoney smallmoney, c\_numeric numeric(10,5), c\_real real, c\_decimal decimal(10,2), c\_float float, c\... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/query-editor/index.md | main | grafana | [
0.023382123559713364,
0.017940234392881393,
-0.03178347274661064,
0.06324446201324463,
-0.05500127002596855,
-0.013413095846772194,
0.07706323266029358,
0.06173669174313545,
-0.06552077829837799,
0.062276482582092285,
0.017750881612300873,
-0.11204805970191956,
0.02904600277543068,
0.00021... | 0.047754 |
10.0.1.1\_ and \_value 10.0.1.2\_. To render the series with a name of \_10.0.1.1\_ and \_10.0.1.2\_ , use a [Standard options definitions](https://grafana.com/docs/grafana//panels-visualizations/configure-standard-options/#display-name) display name value of `${\_\_field.labels.hostname}`. Data frame result: ```text +... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/query-editor/index.md | main | grafana | [
-0.07681789994239807,
0.03869766369462013,
-0.070386603474617,
0.022192999720573425,
-0.09185749292373657,
0.023749716579914093,
0.022916339337825775,
-0.02015165239572525,
0.06705755740404129,
-0.05274040251970291,
-0.028286561369895935,
-0.09335826337337494,
-0.06923773139715195,
0.00953... | -0.029883 |
metric\_values WHERE $\_\_timeFilter(time) GROUP BY $\_\_timeGroup(time, '5m'), measurement ORDER BY 1 ``` \*\*Second query:\*\* ```sql SELECT $\_\_timeGroup(time, '5m') as time, measurement + ' - value two' as metric, avg(valueTwo) as valueTwo FROM metric\_values GROUP BY $\_\_timeGroup(time, '5m'), measurement ORDER ... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/query-editor/index.md | main | grafana | [
-0.052490513771772385,
-0.022827744483947754,
-0.016030652448534966,
0.03446989133954048,
-0.09415005147457123,
-0.036792028695344925,
0.04789145290851593,
-0.015312157571315765,
0.021588556468486786,
-0.01469771470874548,
0.0026443421375006437,
-0.11489090323448181,
0.010876062326133251,
... | 0.045189 |
built-in macros to populate the time range dynamically: ```sql DECLARE @from datetime = $\_\_timeFrom(), @to datetime = $\_\_timeTo() EXEC dbo.sp\_test\_datetime @from, @to ``` | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/mssql/query-editor/index.md | main | grafana | [
0.021690713241696358,
-0.04189268499612808,
-0.06888718903064728,
0.07797989249229431,
-0.04629818722605705,
0.038033757358789444,
0.06516573578119278,
0.07674642652273178,
-0.05017799511551857,
-0.02472042851150036,
-0.006671000272035599,
-0.06939372420310974,
-0.004008884076029062,
0.019... | 0.016167 |
# Elasticsearch data source [Elasticsearch](https://www.elastic.co/guide/en/elasticsearch/reference/current/elasticsearch-intro.html) is a search and analytics engine used for a variety of use cases. The built-in Elasticsearch data source lets you query and visualize logs or metrics stored in Elasticsearch, and annotat... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/_index.md | main | grafana | [
-0.02252359874546528,
0.03247425705194473,
-0.05181277543306351,
0.02913673408329487,
0.02205927111208439,
-0.02763938531279564,
-0.05752401798963547,
-0.03613557666540146,
0.07174941152334213,
0.0548214428126812,
-0.04270453751087189,
-0.08047553896903992,
-0.03792429342865944,
0.00811253... | 0.158393 |
# Elasticsearch alerting You can use Grafana Alerting with Elasticsearch to create alerts based on your Elasticsearch data. This allows you to monitor metrics, detect anomalies, and receive notifications when specific conditions are met. For general information about Grafana Alerting, refer to [Grafana Alerting](https:... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/alerting/index.md | main | grafana | [
0.01175651140511036,
-0.005884204991161823,
-0.034961581230163574,
0.05311472341418266,
-0.00660651596263051,
-0.02119608409702778,
0.02610342763364315,
-0.01084219105541706,
0.046705879271030426,
0.015353452414274216,
-0.10120190680027008,
-0.10883186757564545,
0.03549820929765701,
0.0316... | 0.131577 |
your query to use metric aggregations with a Date histogram instead. ### Query complexity Complex queries with many nested aggregations may timeout or fail to evaluate. Simplify queries for alerting by: - Reducing the number of bucket aggregations - Using appropriate time intervals - Adding filters to limit the data sc... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/alerting/index.md | main | grafana | [
0.09742280840873718,
0.05276814475655556,
0.003897937247529626,
0.07390067726373672,
0.002350668655708432,
-0.012000787071883678,
0.05375794321298599,
0.012482767924666405,
0.05404654145240784,
-0.017501143738627434,
-0.0793771743774414,
-0.09084165841341019,
0.06742556393146515,
-0.014016... | 0.077909 |
# Configure the Elasticsearch data source Grafana ships with built-in support for Elasticsearch. You can create a variety of queries to visualize logs or metrics stored in Elasticsearch, and annotate graphs with log events stored in Elasticsearch. For instructions on how to add a data source to Grafana, refer to the [a... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/configure/index.md | main | grafana | [
-0.009385278448462486,
-0.0036910162307322025,
-0.0592661052942276,
0.005308666732162237,
-0.04280300810933113,
-0.03985154256224632,
-0.08164355158805847,
-0.03382943570613861,
0.02783907949924469,
0.12001000344753265,
-0.046089380979537964,
-0.1000979021191597,
-0.005166611634194851,
0.0... | 0.09851 |
`` with your base64-encoded Elasticsearch API key. For information about creating API keys, refer to the [Elasticsearch API keys documentation](https://www.elastic.co/guide/en/elasticsearch/reference/current/security-api-create-api-key.html). ### Amazon Elasticsearch Service If you use Amazon Elasticsearch Service, you... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/configure/index.md | main | grafana | [
0.05785819888114929,
0.028454983606934547,
-0.05288759246468544,
-0.04769085347652435,
-0.018125034868717194,
-0.02592778019607067,
-0.08586744219064713,
0.0034013993572443724,
0.07152228057384491,
0.06470703333616257,
-0.08933880180120468,
-0.036206308752298355,
0.05890275537967682,
0.009... | 0.002021 |
pattern in your index name. Options include: - no pattern - hourly - daily - weekly - monthly - yearly Only select a pattern option if you have specified a time pattern in the Index name field. - \*\*Time field name\*\* - Name of the time field. The default value is `@timestamp`. You can enter a different name. - \*\*M... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/configure/index.md | main | grafana | [
0.03128839656710625,
0.017088906839489937,
0.06435465812683105,
0.05079132318496704,
-0.029716258868575096,
-0.032773394137620926,
-0.040425825864076614,
-0.07207877188920975,
0.0669863298535347,
-0.009818213060498238,
-0.036635540425777435,
-0.046095795929431915,
0.0037783710286021233,
0.... | 0.030772 |
data within a secure network without opening that network to inbound traffic from Grafana Cloud. Refer to [Private data source connect](https://grafana.com/docs/grafana-cloud/connect-externally-hosted/private-data-source-connect/) for more information on how PDC works and [Configure Grafana private data source connect ... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/configure/index.md | main | grafana | [
-0.03545835241675377,
0.03509124740958214,
-0.11323421448469162,
0.008200505748391151,
-0.06332983076572418,
-0.045559294521808624,
-0.08036234974861145,
-0.052362482994794846,
0.04854899272322655,
0.06555599719285965,
-0.021363064646720886,
-0.054810717701911926,
0.0056883711367845535,
-0... | -0.001914 |
# Elasticsearch template variables Instead of hard-coding details such as server, application, and sensor names in metric queries, you can use variables. Grafana lists these variables in drop-down select boxes at the top of the dashboard to help you change the data displayed in your dashboard. Grafana refers to such va... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/template-variables/index.md | main | grafana | [
-0.024022012948989868,
0.053754985332489014,
-0.039955008774995804,
0.017043210566043854,
-0.04716864600777626,
-0.008309818804264069,
0.0013261891435831785,
-0.015072868205606937,
0.008306010626256466,
0.04368489235639572,
-0.08793576806783676,
-0.09955073893070221,
0.011144447140395641,
... | 0.094935 |
names with the index type `keyword`. | | `{"find": "fields", "type": "number"}` | Returns a list of numeric field names (includes `float`, `double`, `integer`, `long`, `scaled\_float`). | | `{"find": "fields", "type": "date"}` | Returns a list of date field names. | | `{"find": "terms", "field": "hostname.keyword", "si... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/template-variables/index.md | main | grafana | [
-0.009406757541000843,
0.04732923582196236,
-0.04174081236124039,
0.08011355251073837,
-0.00618927925825119,
0.026865262538194656,
-0.011705363169312477,
0.03695186227560043,
0.02762126922607422,
0.0255673099309206,
-0.018940379843115807,
-0.015203814953565598,
-0.012277516536414623,
0.019... | 0.067838 |
# Troubleshoot issues with the Elasticsearch data source This document provides troubleshooting information for common errors you may encounter when using the Elasticsearch data source in Grafana. ## Connection errors The following errors occur when Grafana cannot establish or maintain a connection to Elasticsearch. ##... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/troubleshooting/index.md | main | grafana | [
-0.0341193862259388,
0.01000398863106966,
-0.03360611945390701,
-0.01208212785422802,
-0.06971734762191772,
-0.0569467730820179,
-0.1301523745059967,
-0.06502954661846161,
0.0002779524074867368,
0.11682949215173721,
-0.02335200645029545,
-0.06909993290901184,
-0.011950690299272537,
-0.0000... | 0.01341 |
source is not healthy. Status: 502 Bad Gateway" \*\*Cause:\*\* A proxy or load balancer between Grafana and Elasticsearch returned an error. \*\*Solution:\*\* 1. Check the health of any proxies or load balancers in the connection path. 1. Verify Elasticsearch is running and accepting connections. 1. Review proxy/load b... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/troubleshooting/index.md | main | grafana | [
-0.030316941440105438,
0.014816708862781525,
0.024320492520928383,
0.012028198689222336,
-0.03862401843070984,
-0.052388519048690796,
-0.11459240317344666,
-0.07950218766927719,
0.03713979572057724,
0.09104382991790771,
-0.06377826631069183,
-0.0705336257815361,
-0.006302854977548122,
-0.0... | 0.058347 |
following issues don't produce specific error messages but are commonly encountered. ### Empty query results \*\*Cause:\*\* The query returns no data. \*\*Solution:\*\* 1. Verify the time range includes data in your index. 1. Check the Lucene query syntax for errors. 1. Test the query directly in Elasticsearch using th... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/troubleshooting/index.md | main | grafana | [
0.09990577399730682,
0.048231154680252075,
0.04921018332242966,
0.07762777805328369,
0.012697039172053337,
-0.013341745361685753,
-0.07314051687717438,
-0.008872231468558311,
-0.020902089774608612,
0.030331624671816826,
-0.038874369114637375,
-0.08488017320632935,
0.03796064108610153,
-0.0... | 0.048742 |
# Elasticsearch query editor Grafana provides a query editor for Elasticsearch. Elasticsearch queries are in Lucene format. For more information about query syntax, refer to [Lucene query syntax](https://www.elastic.co/guide/en/kibana/current/lucene-query.html) and [Query string syntax](https://www.elastic.co/guide/en/... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/query-editor/index.md | main | grafana | [
0.02308056317269802,
0.04947539418935776,
0.067255899310112,
0.07860907912254333,
-0.03834975138306618,
0.022680027410387993,
-0.07707356661558151,
0.000554329133592546,
0.02735297568142414,
0.052978333085775375,
-0.04886254668235779,
-0.033668823540210724,
-0.010677856393158436,
0.0255007... | 0.061049 |
multiple group by options when constructing your Elasticsearch query. Date histogram is the default option. The following options are available in the drop-down menu: - terms - refer to [Terms aggregation](https://www.elastic.co/guide/en/elasticsearch/reference/current/search-aggregations-bucket-terms-aggregation.html)... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/query-editor/index.md | main | grafana | [
0.08916418254375458,
-0.00148339057341218,
-0.029371894896030426,
-0.0023021965753287077,
-0.021327674388885498,
0.05908295139670372,
-0.014673428609967232,
-0.03952982276678085,
0.04845167696475983,
0.01090613566339016,
-0.015542728826403618,
-0.07184351980686188,
0.009563947096467018,
-0... | 0.036939 |
default is `500`. ## Raw query editor {{< docs/experimental product="The raw query editor" featureFlag="elasticsearchRawDSLQuery" >}} The raw query editor allows you to write Elasticsearch queries using the native [Elasticsearch Query DSL](https://www.elastic.co/guide/en/elasticsearch/reference/current/query-dsl.html).... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/query-editor/index.md | main | grafana | [
-0.004188179038465023,
0.017894743010401726,
-0.009259424172341824,
0.0768192932009697,
-0.031504616141319275,
0.004297412000596523,
-0.13405488431453705,
0.04857482388615608,
0.015666311606764793,
0.04391172528266907,
-0.08145246654748917,
-0.02960728108882904,
0.011491022072732449,
-0.01... | 0.088236 |
minute) | SORT @timestamp ``` #### Search log messages Search for specific patterns in log data: ```esql FROM logs-\* | WHERE message LIKE "\*error\*" AND log.level == "ERROR" | KEEP @timestamp, message, host.name, log.level | SORT @timestamp DESC | LIMIT 100 ``` ### Learn more about ES|QL For more information about ES... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/query-editor/index.md | main | grafana | [
0.00833479966968298,
0.06196814775466919,
0.06221911311149597,
0.026869917288422585,
0.015831291675567627,
-0.00824166089296341,
-0.0057867132127285,
0.008913523517549038,
0.08264605700969696,
0.06678169965744019,
-0.03011881560087204,
0.004088012035936117,
0.02434011921286583,
0.045927744... | 0.132407 |
# Elasticsearch annotations Annotations overlay event data on your dashboard graphs, helping you correlate log events with metrics. You can use Elasticsearch as a data source for annotations to display events such as deployments, alerts, or other significant occurrences on your visualizations. For general information a... | https://github.com/grafana/grafana/blob/main//docs/sources/datasources/elasticsearch/annotations/index.md | main | grafana | [
0.023651836439967155,
0.05114509537816048,
-0.002006086055189371,
0.00451261829584837,
0.04579417034983635,
0.005478109698742628,
-0.012353107333183289,
0.0021456959657371044,
0.08212322741746902,
0.04740772396326065,
-0.09162601083517075,
-0.10221769660711288,
-0.003901333548128605,
0.053... | 0.12787 |
{{< docs/hero-simple key="hero" >}} --- ## Overview Monitor your incoming metrics data or log entries and set up your Grafana Alerting system to watch for specific events or circumstances. In this way, you eliminate the need for manual monitoring and provide a first line of defense against system outages or changes tha... | https://github.com/grafana/grafana/blob/main//docs/sources/alerting/_index.md | main | grafana | [
-0.0706867203116417,
0.08395326137542725,
-0.09784749150276184,
0.09147907048463821,
0.0007363749900832772,
-0.04316650331020355,
-0.0011250056559219956,
0.005046180449426174,
0.046781882643699646,
0.006917847320437431,
-0.05995098128914833,
-0.025339949876070023,
-0.008856370113790035,
0.... | 0.104841 |
# Templates Use templating to customize, format, and reuse alert notification messages. Create more flexible and informative alert notification messages by incorporating dynamic content, such as metric values, labels, and other contextual information. In Grafana, you have various options to template your alert notifica... | https://github.com/grafana/grafana/blob/main//docs/sources/alerting/fundamentals/templates.md | main | grafana | [
-0.07772788405418396,
0.05329272523522377,
-0.017122585326433182,
0.04226924106478691,
0.007525736000388861,
0.01161803025752306,
0.102500319480896,
-0.005197109188884497,
0.06904524564743042,
-0.03604179248213768,
-0.053223345428705215,
-0.10408223420381546,
0.047211095690727234,
0.016949... | 0.15285 |
exceeded 80% (81.2345) for the last 5 minutes. ``` Implement annotations that provide meaningful information to respond to your alerts. Annotations are displayed in the Grafana alert detail view and are included by default in notifications. For more details on how to template annotations, refer to [Template annotations... | https://github.com/grafana/grafana/blob/main//docs/sources/alerting/fundamentals/templates.md | main | grafana | [
-0.024381175637245178,
0.05111007019877434,
-0.03447239473462105,
0.06150869280099869,
0.03664860501885414,
-0.0376662015914917,
0.1155092641711235,
-0.0188443623483181,
0.046047259122133255,
-0.028851021081209183,
-0.029682202264666557,
-0.09985078871250153,
0.02098824642598629,
-0.007275... | 0.110827 |
# Introduction to Grafana Alerting Grafana Alerting lets you define alert rules across multiple data sources and manage notifications with flexible routing. Built on the Prometheus alerting model, it integrates with the Grafana stack to provide a scalable and effective alerting setup across a wide range of environments... | https://github.com/grafana/grafana/blob/main//docs/sources/alerting/fundamentals/_index.md | main | grafana | [
-0.09563244879245758,
-0.019577091559767723,
-0.03861311450600624,
0.04555033519864082,
0.03551936149597168,
-0.1351265162229538,
0.06609996408224106,
-0.025987282395362854,
0.032523803412914276,
-0.008844831958413124,
-0.025971882045269012,
-0.04418524354696274,
0.05579236522316933,
0.012... | 0.197961 |
send the notification (timing options). ### Notification grouping To reduce alert noise, Grafana Alerting [groups related firing alerts into a single notification](ref:group-alert-notifications) by default. You can customize this behavior in the alert rule or notification policy settings. ### Silences and mute timings ... | https://github.com/grafana/grafana/blob/main//docs/sources/alerting/fundamentals/_index.md | main | grafana | [
-0.05770585313439369,
-0.023374255746603012,
-0.01799304597079754,
0.03256242722272873,
0.013911566697061062,
-0.04069480672478676,
0.06420524418354034,
-0.09573876857757568,
0.050245676189661026,
-0.03263356164097786,
-0.05222104862332344,
-0.07883498072624207,
-0.01721065863966942,
0.002... | 0.065807 |
# How rules are evaluated within a group Each evaluation group contains an \*\*evaluation interval\*\* that determines how frequently the rule is evaluated. For instance, the evaluation may occur every `10s`, `30s`, `1m`, `10m`, etc. Rules in different evaluation groups can be evaluated simultaneously. Rules within the... | https://github.com/grafana/grafana/blob/main//docs/sources/alerting/fundamentals/alert-rule-evaluation/evaluation-within-a-group.md | main | grafana | [
-0.12171164900064468,
-0.0011523255379870534,
-0.08445115387439728,
0.013026402331888676,
-0.012993859127163887,
-0.09180314093828201,
-0.017449814826250076,
-0.05189661309123039,
-0.0042861769907176495,
0.036947138607501984,
0.03366892784833908,
-0.03757588192820549,
0.03511772304773331,
... | 0.13458 |
# No Data and Error states Grafana Alerting implements the \*\*No Data\*\* and \*\*Error\*\* states to handle common scenarios when evaluating alert rules, and you can modify their behavior. An alert instance can transition to these special states: - [No Data state](#no-data-state) occurs when the alert rule query runs... | https://github.com/grafana/grafana/blob/main//docs/sources/alerting/fundamentals/alert-rule-evaluation/nodata-and-error-states.md | main | grafana | [
-0.09173170477151871,
0.0639885663986206,
-0.031037764623761177,
0.08641742169857025,
0.01637294329702854,
-0.08182809501886368,
0.054074790328741074,
-0.07101314514875412,
0.013061766512691975,
0.00024986101198010147,
0.01888338103890419,
-0.07914547622203827,
0.037633586674928665,
0.0196... | 0.122244 |
max-width="500px" >}} {{< docs/shared lookup="alerts/table-configure-no-data-and-error.md" source="grafana" version="" >}} Note that when you configure the \*\*No Data\*\* or \*\*Error\*\* behavior to `Alerting` or `Normal`, Grafana attempts to keep a stable set of fields under notification `Values`. If your query retu... | https://github.com/grafana/grafana/blob/main//docs/sources/alerting/fundamentals/alert-rule-evaluation/nodata-and-error-states.md | main | grafana | [
-0.0692337304353714,
0.06766752898693085,
-0.042390983551740646,
0.06698064506053925,
-0.031600359827280045,
-0.08030650019645691,
-0.009333317168056965,
-0.028561001643538475,
-0.005678405053913593,
0.05433952063322067,
-0.02965538203716278,
-0.036778323352336884,
0.05072072148323059,
-0.... | 0.039322 |
an alert instance may be in a state that isn't immediately clear to everyone. For example: - If "no data" handling is configured to transition to a state other than `No Data`. - If "error" handling is configured to transition to a state other than `Error`. - If the alert rule is deleted, paused, or updated in some case... | https://github.com/grafana/grafana/blob/main//docs/sources/alerting/fundamentals/alert-rule-evaluation/nodata-and-error-states.md | main | grafana | [
-0.05429809167981148,
0.01566702127456665,
0.002496404107660055,
0.05760246142745018,
0.10349159687757492,
-0.08453866094350815,
0.09191039949655533,
-0.0819723829627037,
0.12789863348007202,
-0.04177428409457207,
-0.019229305908083916,
-0.051207590848207474,
-0.021099567413330078,
-0.0085... | 0.168282 |
Subsets and Splits
No community queries yet
The top public SQL queries from the community will appear here once available.