hash stringlengths 32 32 | doc_id stringlengths 7 13 | section stringlengths 3 121 | content stringlengths 0 2.2M |
|---|---|---|---|
d4b7455827b6f3224f1fd9945f742ae1 | 103 523-1 | 6.3 MSP Template Requirements - Transparency | The present clause defines the Transparency Template Requirements, based on the principle defined in Clause 5.3.2. Table 6.3: Transparency Template Requirements Ref Transparency Template Requirement Mandatory / Optional E.T.1 Endpoints shall receive suitable knowledge of all middlebox identities. Mandatory E.T.1.1 Both... |
d4b7455827b6f3224f1fd9945f742ae1 | 103 523-1 | 6.4 MSP Template Requirements - Access Control | The present clause defines the Access Control Template Requirements, based on the principle defined in Clause 5.3.3. Table 6.4: Access Control Template Requirements Ref Access Control Template Requirement Mandatory / Optional E.AC.1 Only endpoints shall grant or deny middlebox access and middlebox permissions. Mandator... |
d4b7455827b6f3224f1fd9945f742ae1 | 103 523-1 | 6.5 MSP Template Requirements - Good Citizen | The present clause defines the Good Citizen Template Requirements, based on the principle defined in Clause 5.3.4. Table 6.5: Good Citizen Template Requirements Ref Good Citizen Template Requirement Mandatory / Optional E.GC.1 Resource attacks that use an endpoint action or request shall have some attribution to the at... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 1 Scope | The present document presents the engineering and operational requirements for the application of the IPv6 transition technology DS-Lite as defined by ETSI TS 101 569-1 [1] (IPv6 Transition Requirements) implemented within an integrated broadband cable network end to end across its network domains. The present document... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 2 References | |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 2.1 Normative references | References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies. Referenced documents which a... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 2.2 Informative references | References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies. NOTE: While any hyperlinks i... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 3 Definitions and abbreviations | |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 3.1 Definitions | For the purposes of the present document, the following terms and definitions apply: 4in6: encapsulation of IPv4 packets within IPv6 packet format NAT44: network address translation from an IPv4 address to another IPv4 address P Router: label switching router acting as a transit router in the core network of an MPLS ne... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 3.2 Abbreviations | For the purposes of the present document, the following abbreviations apply: 6PE IPv6 Provider Edge 6VPE IPv6 Virtual Private Network Provider Edge A+P Address + Port AAA Authentication, Authorization and Accounting ACL Access Control List AF Address Family AFTR Address Family Transition Router ALG Application Layer Ga... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 4 Considerations | |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 4.1 Background | The present technical specification is part of a series of ETSI technical specifications specifying requirements to engineer and operate the DS-Lite transition technology end to end across a cable operator's network. Its implementation would ensure the network provider can continue to provide business continuity throug... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 4.2 General Overview | The present document covers the DS-Lite, AFTR and CPE functions required to be engineered and operated within the operator's network footprint. DS-Lite will allow customers to access services natively over IPv6 and through translation over IPv4. As IPv6 does not have "backward compatibility" to IPv4 and the two protoco... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 5 Gap Analysis | The engineering and operational requirements applying ETSI TS 101 569-1 [1] need to be specified with the following design objectives: • To define the logical and physical parameters to allow for customers to access the public IP Internet across an IPv6 network using DS-Lite. • To define the DS-Lite specific feature co... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 6 Domain Functionality | |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 6.1 End to End Network Domains | In order to operate the IPv6 transition technology it has to be engineered and verified end to end across the cable broadband network addressing each of the domains as illustrated in figure 3. ETSI ETSI TS 103 443-3 V1.1.1 (2016-08) 17 Figure 3: Illustration of the Cable Broadband Network Domains The tests described in... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 6.2 DS-Lite Domain Topologies | This clause explains the potential DS-Lite domain topologies. NOTE: At the time of writing the present document, two topologies are possible, the integrated topology and the hairpin topology; however, depending on future hardware and software developments, additional topologies may be introduced. The integrated topolog... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 6.3 CPE Home Network Domain | DS-Lite enables a customer's device that is V4 and V6 i.e. dual stack to be supported across the Cable network when communicating to a V4 service. Functionality to be engineered in the cable network: • The cable residential gateway device shall have the B4 function as specified by IETF RFC 6333 [17]. • IPv4 packet size... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 6.4 Access Network Domain | Functionality to be engineered in the cable network: • The cable headend CMTS shall be capable of IPv6 connectivity for customer traffic. • The DOCSIS management between the Cable Modem and CMTS may be IPv4 or IPv6 NOTE: There are no additional requirements on the HFC distribution network i.e. AMPS, taps, etc. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 6.5 Core Network Domain | Functionality to be engineered in the cable network: • The core network routers shall support IPv6 routing and forwarding capabilities. • The AFTR shall be implemented as specified by IETF RFC 6333 [17], for further information on its operation refer also to IETF RFC 6908 [19]. Operation: A v6 client communicating with... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 6.6 Data Centre Network Domain | Functionality to be engineered in the cable network: There are no changes to the network DNS functionality required. The DNS shall be IPv6 capable. The DHCP server is inherently IPv6 only and shall include DHCP option for DSLite as specified in IETF RFC 6334 [20]. Refer also to clause 11.2 for further information about... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 6.7 DMZ Service Domain | Functionality to be engineered in the cable network. There are no specific operational requirements for the DMZ however it is strongly recommended that all services within the DMZ are IPv6 capable either by dual stack configuration or the use of V6/V4 load balancing. V6/V4 load balancers allow V6 access to existing v4 ... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 6.8 Transit and Peering Service Domain | Functionality to be engineered in the cable network. There are no changes to be engineered when considering the transit and peering domain since the transmit and peering links are dual stack and support both IPv6 and IPv4 packets simultaneously and therefore no specific additional requirements are needed to be defined ... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 6.9 Management and Monitoring Domain | |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 6.9.1 General Considerations | Functionality to be engineered in the cable network. DOCSIS management between the CMTS and Cable Modem may remain deployed either using IPv4 or IPv6 addresses. There is the additional functionality to monitor and manage the Cable Modem B4 functionality. Similarly to manage the monitor the ATFR in order to provide suff... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 6.9.2 OSS | Operators may use Operations Support System (OSS) tools (e.g. Multi Router Traffic Grapher, RRDtool, OpenNMS, JFFNMS, etc.) to measure KPI's and SLA's and to collect interface data packet count information. An operator may prefer to separate the softwire function and NAT44 function on different interfaces for collectin... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 6.9.3 B4 Remote Management | The B4 shall be connected to the IPv6 access network to offer IPv4 services. When users experience IPv4 connectivity issues, operators shall engineer the capability be able to remotely access (e.g. BBF TR-069 [29], SNMP, telnet, etc.) the B4 to verify its configuration and status. Operators should access B4s using nati... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 6.9.4 IPv4 Connectivity Checks | As the DS-Lite framework provides IPv4 services over the IPv6 access network, the operations system shall be engineered to be able to check the IPv4 connectivity from the B4 to its AFTR using ping and IPv4 traceroute. The AFTR should be configured with an IPv4 address to enable a PING test and a Traceroute test. Operat... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 6.9.5 B4 Provisioning | A DS-Lite CPE is an IPv6-aware CPE with a B4 interface implemented in the WAN interface. To avoid probable error of operating in a double NAT environment, a DS-Lite CPE should not operate a NAT function between an internal interface and a B4 interface, since the NAT function will be performed by the AFTR in the service... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 6.9.6 AFTR Provisioning | The AFTR may be provisioned with different NAT pools. The address ranges in the pools may be disjoint but shall not be overlapped. Operators may implement policies in the AFTR to assign clients in different pools. For example, an AFTR can have two interfaces. Each interface will have a disjoint pool NAT assigned to it.... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 6.10 Security Domain | Functionality to be engineered in the cable network. The cable modem packet classifiers shall be updated to support IPv6 filtering. The continuity of the security of the end to end service shall be maintained when operating DSLite, however the operational implications from DS-Lite shall be minimized as specified in IET... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7 Engineering Requirements | |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.1 Key Requirements | |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.1.1 AFTR | AFTR implementation requirements are based on enabling seamless DS-Lite connections without degradation in service, access, functionality of speed. For requirements on CPE see the following clause. Engineer the AFTR as the LSN device placed in the edge of the network (IXPE) as the IPv4 gateway to perform de-capsulation... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.1.2 CPE Cable Gateway Device | CPE implementation requirements are based on enabling seamless DS-Lite connections without degradation in service, access, functionality of speed. For requirements on AFTR see the previous clause. Engineer the CPE cable gateway device in customer's home to encapsulate the traffic on egress from a pure IPv4 packet to a ... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.2 DS-Lite Technology Feature Requirements | The DS-Lite technology feature is summarized in table 1 and 2 detailing for each function the requirement as required or optional with a brief description of each of the named functions and the performance requirements. Table 1: DS-Lite Technology Feature Requirement Description Functional Name Description IETF RFC 633... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3 Detailed AFTR Engineering Requirements | |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.1 AFTR Hardware Feature/Topology | |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.1.1 Role/Location | In case the AFTR performs the role of a 6PE, the AFTR has to be placed at the network edge as close to the external peering points as possible. In case the network has multiple exit points, a balanced path should be implemented to all exit points (AFTR nodes should only be added based on capacity requirements). In case... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.1.2 Type | The type of the node has to be chassis-based to guarantee later scalability and hot-swap capability. Features and functionality should be distributed on blade or port level. Physical Ports: 10 Gb/s capable; may be depend on aggregation of node capacity. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.1.3 Memory | Memory has to be able to hold the full IPv6 and IPv4 BGP routing table; minimum 8 GB. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.1.4 Integrated forwarding and AFTR function | The IXCF and AFTR mechanisms has to be integrated on blade or ingress port. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.1.5 Forwarding Architecture | Forwarding has to be done in hardware with a minimum number of 4 million sessions per blade. Node latency has to be below 1 ms. ETSI ETSI TS 103 443-3 V1.1.1 (2016-08) 29 |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.2 AFTR DS-Lite specific engineering requirements | |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.2.1 Tunnel Identifiers/Client-Customer ID | For data retention purposes, tunnel identifiers has to be uniquely associated with a single CPE. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.2.2 MTU Sizing/TCP MSS | TCP MSS support is mandatory for the AFTR. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.2.3 Load balancing | Load balancing across aggregated interfaces has to be supported. This includes IP and port allocation ECMP, PVST LB, LDP hashing, etc. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.2.4 IPv4 Private Subnet Segmentation | The AFTR has to be able to segment the IP blocks into smaller blocks for the local interfaces. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.2.5 Non-ALG Deployment | The AFTR has to have a non-ALG approach for decapsulation. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.2.6 Traffic Prioritization | Traffic prioritization has to be possible to e.g. support B2B customers running video or voice to the translation interface. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.2.7 Data retention (DR) | For DR purposes two potential methodologies exist, NAT Caching with filters or Netflow. The requirement is to hold, for each flow, the following entries: • Source IPv4 address • Source IPv6 address • Source port (internal IPv4) • Remote destination port (external IPv4) • Time stamp • Remote IPv4 address • Remote IPv6 a... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.2.8 UPnP/Port forwarding/PCP | The AFTR has to allow uPnP forwarding and port mapping through the tunnel. ETSI ETSI TS 103 443-3 V1.1.1 (2016-08) 30 |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.3 AFTR General software engineering requirements | |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.3.1 Topology dependency | The AFTR general software engineering requirements depend on the deployment topology. In general two topologies are possible, one where the AFTR functions as a full MPLS 6PE router, the "integrated topology" and one where the AFTR functions as a L3 router, hairpinning connections through an external 6PE router, the "ha... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.3.2 Integrated topology engineering requirements | List of features required for both IPv4 and IPv6/L2 and L3 for an integrated topology solution: • MP BGP (as well 6PE and 6VPE) • BGP Community/32 bit AS • MPLS LDP (potentially only v4 native but the requirement for v6 native MPLS may become an absolute) • ECMP • QoS (v4/v6) - classification, priority queuing, etc. • ... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.3.3 Hairpin topology engineering requirements | List of features required for both IPv4 and IPv6/L2 and L3 for a "hairpin topology" solution: • SNMP (transport over v4 and v6) v1/v2/v3 ETSI ETSI TS 103 443-3 V1.1.1 (2016-08) 32 • ACLs/Prefix Listing (both v4/v6) • TACACS/RADIUS (v4/v6) • Syslog (event reporting for v4 and v6 as well as transporting over both protoco... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.4 Scalability | The AFTR has to be engineered to be able to hold a minimum of 20 million sessions at one time. The AFTR has to be engineered to support future increase of throughput per blade, e.g. by having processing done through a feature card. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.5 AFTR Performance | |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.5.1 General considerations | The AFTR performance is based on lowest acceptable benchmarks and the actual delivery of throughput, convergence, failover and latency for all aspects and features within the chassis interoperable on the network. All performance requirements are to be operated based on peak capacity and average throughput. Both are to ... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.5.2 Throughput interfaces | All interfaces have to be engineered to be 10 Gb/s and work at line rate. The interface has to be operated so that it is compatible with the local cable P/PE router connectivity. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.5.3 Node latency | The required node latency has to be engineered to be 100 microseconds. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.5.4 Flow throughput | The flow throughput shall be established as defined by three main performance figures: • CPE initialization: This is the initialization of the port allocation per subscriber (i.e. when a CPE comes up for the first time) with a single external IP per CPE. • Primary flow initialization: Primary flow initialization is if ... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.5.5 Convergence | Convergence of routing and link failure shall be engineered to be well within 10 ms. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 7.3.6 AFTR Application proxy | Table 3 shows the DS-Lite "proxy" requirements. As the actual DS-Lite flow is based on a 4-4 NAT encapsulated in an IPv6 tunnel, there is no true ALG translation. However the AFTR requires knowledge of protocol requirements and therefore "proxy" functionality (as with standard NAT44). Table 3 lists the protocols that c... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 8 General Considerations | |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 8.1 Hardware Considerations | A carrier grade NAT solution is to be engineered with a max capacity of 120 gigabytes, 130 000 IP SI-ed connections and 4 million flows allowing for 32 flows per customer at max capacity. The customer end point, based on max flows per IPv4 private address, will need to be limited to allow for max 2 000 flows per client... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 8.2 DS-Lite Scalability | The details of the scalability are structured below showing the engineering requirements for delivery in any single local cable network scenario. The scalability requirements to be engineered are: 1) Min of 4-6 million flows per NPU. 2) 132 k customer IP sources per NPU. 3) 20-gigabytes throughput, 10 gigabytes in, 10 ... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 8.3 PCP Considerations | The present document specifies the engineering and operational requirements for DS-Lite as an IPv6 transition technology such that it is implementable across the cable network domains to provide a seamless experience to users accessing IPv4 network services through new IPv6 only networks and that enables current and ne... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 8.4 NDP Considerations | As there is no direct IPv6 connectivity, 6PE configuration will be used. The NDP timer configuration should not be touched; however these are the defaults for the design in case the hair-pinned topology is used: • min-advertisement-interval 200 • max-advertisement-interval 600 • router-lifetime 1 800 • no reachable-tim... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 9 Support Systems | |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 9.1 Testing | The conformance tests shall be carried out to validate the implementation of DS-Lite in accordance with ETSI TS 101 569-1 [1]. Each of the validation tests listed in table 4 should be performed in the environments with the laboratory topologies, network integration and standalone. ETSI ETSI TS 103 443-3 V1.1.1 (2016-08... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10 CPE Specifications for IPv6 | |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1 Summary | |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.1 Reference Architecture | The reference architecture is given in the figure 7. The functional description and for further details refer also to IETF RFC 6333 [17], however where there may be differences with the requirements in IETF RFC 6333 [17] and the present document then the requirements of the present document take precedence. ETSI ETSI T... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2 CPE Requirements | |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.1 General | The CPE shall support the following RFC's: • IETF RFC 2460 [21], Internet Protocol v6 (IPv6) Specification. • IETF RFC 4861 [22], Neighbor Discovery for IPv6. • IETF RFC 4862 [23], IPv6 Stateless Address Auto-configuration. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.2 Cable Modem | |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.2.1 DOCSIS 2.0 + IPv6 Cable Modem | The DOCSIS 2.0 + IPv6 cable modem shall support the following: • DOCSIS 2.0+IPv6 Cable Modem Specification [24]. • IPv6 management as defined in the OSSIv3.0 Specification [25]. • Provisioning Mode Override, as defined in [24] and [25]. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.2.2 DOCSIS 3.0 Cable Modem | The DOCSIS 3.0 cable modem shall support the following: • MAC and Upper Layer Protocols Interface Specification (MULPI) [26]. • Upstream Drop Classifiers. IPv6 network HFC AFTR/ CGN/ LSN IPv6 network IPv4 network CM IPv4 Pc IPv6 Pc B4/ DS-Lite CPE/ Home Gateway IPv4/IPv6 Pc B4 / DS-Lite CPE / Home Gateway – ‘Basic Brid... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.3 eRouter/Home Gateway | The following engineering requirements for the eRouter/Home gateway shall be supported: • IPv6 provisioning of CPE devices as specified in [27]. • IPv6 address assignment, as specified in [27]. • IETF RFC 4361 [28] to make the DHCPv4 client identifier identical to the DHCPv6 DUID. • Support BBF TR-069 [29] via native I... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.4 LAN-side Interface | The following requirements are to be supported as given below: • has to support SLAAC; • should support IETF RFC 6106 [39] DNS resolver information; • should support stateless DHCPv6 (INFORM) server on LAN side; • may support stateful DHCPv6 server (IA_NA) on LAN side; this may be needed to identify a single customer i... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.5 Software Features | |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.5.1 Static Configuration | The router has be able to hold a static configuration. The configuration control has to be split between customer and network cable operator. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.5.2 Tunnel Bindings | The tunnel bindings should have a lifetime around 5 to 10 minutes. To avoid double assignment of active bindings in case of delegated prefix change, prefixes have to be quarantined for longer than the binding lifetime. ETSI ETSI TS 103 443-3 V1.1.1 (2016-08) 41 |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.5.3 P2P | The Cable Gateway CPE has to be able to initiate and hold point-to-point DS-Lite tunnels. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.5.4 Gi-DS-Lite | The Cable Gateway CPE has to be able to setup and use a non-directly connected IPv6 tunnel to external AFTRs. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.5.5 Tunnel Identifiers/Client-Customer ID (flow label identifier) | To avoid problems with depletion of IPv4 private address space per AFTR, the Cable Gateway CPE has to be able to identify by not solely using the IPv4 address as Client ID. The CPE should use either the flow label or the IPv6 address; both methodologies should be supported. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.5.6 MTU Sizing/TCP MSS | TCP MSS is not required; MTU size and MSS clamping functionality has to be supported. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.5.7 Non-ALG Deployment | The DS-Lite encapsulation methodology should solely encapsulate the IPv4 packet within the IPv6 with no modification of the packet itself; no ALGs should be used. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.5.8 DNS over IPv6 | DNS has to be able to be transported over both IPv4 and IPv6. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.5.9 Port Forwarding | Port forwarding should be possible before encapsulation of the IPv4 packet and therefore logil reside on the dual stack internal LAN interface. Future support for uPnP and PCP is required. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.5.10 SI | Softwire initiation has to be engineered so that it is guarantying end to end last resort for traffic needed to be tunnel. The mechanisms differ from vendor to vendor, but it should be based on the internal interface and configurable due to the potential of IPv4 management, especially with the integrated solution as ma... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.5.11 DHCPv4 Internal | DHCPv4 internal to the customer LAN has to be driven from the CPE and be private addressing either 10.x or 192.168.x originations. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.5.12 DHCPv6 - PD Internal and external | DHCPv6 for the external interface has to be generated so DHCPv6-PD has to be featured in the CPE. This has to able to distribute an EUI-64 allocation. This should be extended following industry adoption of EUI-112 RFCs. The adopted use of DHCPv6 specifications, IETF RFC 3646 [30] would be preferable to allocate statefu... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.5.13 Non-ALG Deployment | The DS-Lite encapsulation methodology should not have any ALG necessity or functionality, solely the encapsulation of the IPv4 packet within the IPv6 with NO modification of the packet itself. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.5.14 Customer Management (Access and Reporting) | Customer management has to be limited to port forwarding potential on the ingress interface customer facing. HTTP access for management and a close system preventing any changes to the "static" IP configuration for the cable operator's corporate control. Web-UI is the only method allowed. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.5.15 Cable Operators Corporate Management (IPv6 or IPv4) | Management should be in-band and out-of-band (depending on the out-of-band technical feature set) on the IPv4 or IPv6. However it is most likely that if non-integrated, the management of the CPE routers will be over IPv6, to avoid having to further increase the path and having to add another private address scheme whic... |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.5.16 Port Forwarding | Port forwarding should be capable before the encapsulation of the IPv6 packet and therefore should sit on the dual stack internal interface internally facing the customer LAN. NAT_PMP functionality as part of or a further deployment of port forwarding should be a considered feature. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.5.17 UPnP | UPnP functionality has to be engineered. |
3c4eaa0df36fcc7906df2e1cc795abea | 103 443-3 | 10.1.2.5.18 Firewall | The CPE cable router should have an integrated firewall with full Rulebase functionality for both the cable operator's corporate and customer management. Corporate encoding should be hardcoded for the most part and customer soft coded. |
Subsets and Splits
No community queries yet
The top public SQL queries from the community will appear here once available.