sentence stringlengths 1 13.5k | labels listlengths 0 15 | doc_title stringclasses 84
values |
|---|---|---|
The backdoor After the extensive validation described above, the backdoor enters its main execution stage. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
At its core, the backdoor is a very standard one that receives instructions from the C2 server, executes those instructions, and sends back information. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
The type of commands that can be executed range from manipulating of registry keys, to creating processes, and deleting files, etc., effectively providing the attackers with full access to the device, especially since it’s executing from a trusted, signed binary. | [
"T1070.004",
"T1112"
] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
In its first step, the backdoor initiates a connection to a predefined C2 server to report some basic information about the compromised system and receive the first commands. | [
"T1005"
] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
The C2 domain is composed of four different parts: three come from strings that are hardcoded in the backdoor, and one component is generated dynamically based on some unique information extracted from the device. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
This means that every affected device generates a different subdomain to contact (and possibly more than one). | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Here’s an example of a generated domain: Figure 6: Dynamically generated C2 domain The dynamically generated portion of the domain is the interesting part. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
It is computed by hashing the following data: The physical address of the network interface The domain name of the device The content of the MachineGuid registry value from the key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography The backdoor also generates a pseudo-random URI that is requested on the C2 domain. | [
"T1012",
"T1082"
] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Like the domain, the URI is composed using a set of hardcoded keywords and paths, which are chosen partly at random and partly based on the type of HTTP request that is being sent out. | [
"T1071.001"
] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Possible URIs that can be generated follow these formats: pki/crl/<random components>.crl, where <random components> can be numbers and one of the following strings: “-root” “-cert” “-universal_ca” “-ca” “-primary_ca” “-timestamp” “-global” “-secureca” fonts/ | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
woff/<random components>-webfont<random component>.woff2 or fonts/woff/<random components>.woff2, where the <random components> can be numbers and one or more of the following strings: “Bold” “BoldItalic” “ExtraBold” “ExtraBoldItalic” “Italic”, “Light” “LightItalic” “Regular” “SemiBold” “SemiBoldItalic” “opensans” “not... | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
It then sends this JSON document to the C2 server. Figure 7: Example of data generated by the malware If the communication is successful, the C2 responds with an encoded, compressed buffer of data containing commands for the backdoor to execute. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
The C2 might also respond with information about an additional C2 address to report to. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
The backdoor accepts the following commands: Idle Exit SetTime CollectSystemDescription UploadSystemDescription RunTask GetProcessByDescription KillTask GetFileSystemEntries WriteFile FileExists DeleteFile GetFileHash ReadRegistryValue SetRegistryValue DeleteRegistryValue GetRegistrySubKeyAndValueNames Reboot None In a... | [
"T1005",
"T1012",
"T1057",
"T1070.004",
"T1112"
] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
The command CollectSystemDescription retrieves the following information: Local Computer Domain name Administrator Account SID HostName Username OS Version System Directory Device uptime Information about the network interfaces Resulting hands-on-keyboard attack Once backdoor access is obtained, the attackers follow th... | [
"T1033",
"T1082",
"T1083"
] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
To avoid detection, attackers renamed Windows administrative tools like adfind.exe which were then used for domain enumeration. | [
"T1036.005",
"T1059.003"
] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
csrss.exe -h breached.contoso.com -f | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
(name=”Domain Admins”) member -list | csrss.exe -h breached.contoso.com -f | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
objectcategory=* > .\Mod\mod1.log Lateral movement was observed via PowerShell remote task creation, as detailed by FireEye and Volexity: $scheduler = New-Object -ComObject (“Schedule. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Service”);$scheduler. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Connect($env: | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
COMPUTERNAME);$folder = $scheduler. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
GetFolder(“\Microsoft\Windows\SoftwareProtectionPlatform”);$task = $folder. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
GetTask(“EventCacheManager”);$definition = $task. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Definition;$definition. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Settings. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
ExecutionTimeLimit = “PT0S”;$folder. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
RegisterTaskDefinition($task. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Name,$definition,6,”System”,$null,5);echo “Done” C:\Windows\system32\cmd.exe /C schtasks /create /F | [
"T1053.005",
"T1059.003"
] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
/tn “\Microsoft\Windows\SoftwareProtectionPlatform\EventCacheManager” /tr | [
"T1053.005"
] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
“C:\Windows\SoftwareDistribution\EventCacheManager.exe” /sc ONSTART /ru system /S | [
"T1053.005"
] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
[machine_name] Persistence is achieved via backdoors deployed via various techniques: | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
PowerShell: Powershell -nop -exec bypass -EncodedCommand The –EncodedCommand, once decoded, would resemble: Invoke-WMIMethod win32_process -name create -argumentlist ‘rundll32 c:\windows\idmu\common\ypprop.dll _XInitImageFuncPtrs’ -ComputerName | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
WORKSTATION Rundll32: C:\Windows\System32\rundll32.exe C:\Windows\Microsoft. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
NET\Framework64\[malicious .dll | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
file], [various exports] With Rundll32, each compromised device receives a unique binary hash, unique local filesystem path, pseudo-unique export, and unique C2 domain. | [
"T1218.011"
] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
The backdoor also allows the attackers to deliver second-stage payloads, which are part of the Cobalt Strike software suite. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
We continue to investigate these payloads, which are detected as Trojan:Win32/Solorigate.A!dha, as the situation continues to unfold. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Microsoft Defender for Endpoint product and hardening guidance Supply chain compromise continues to be a growing concern in the security industry. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
The Solorigate incident is a grave reminder that these kinds of attacks can achieve the harmful combination of widespread impact and deep consequences for successfully compromised networks. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
We continue to urge customers to: Isolate and investigate devices where these malicious binaries have been detected Identify accounts that have been used on the affected device and consider them compromised Investigate how those endpoints might have been compromised Investigate the timeline of device compromise for ind... | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
On top of that, comprehensive visibility into system and network activities drive the early detection of anomalous behaviors and potential signs of compromise. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
More importantly, the ability to correlate signals through AI could surface more evasive attacker activity. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Microsoft Defender for Endpoint has comprehensive detection coverage across the Solorigate attack chain. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
These detections raise alerts that inform security operations teams about the presence of activities and artifacts related to this incident. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Given that this attack involves the compromise of legitimate software, automatic remediation is not enabled to prevent service interruption. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
The detections, however, provide visibility into the attack activity. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Analysts can then use investigation and remediation tools in Microsoft Defender Endpoint to perform deep investigation and additional hunting. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Microsoft 365 Defender provides visibility beyond endpoints by consolidating threat data from across domains – identities, data, cloud apps, as well as endpoints – delivering coordinated defense against this threat. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
This cross-domain visibility allows Microsoft 365 Defender to correlate signals and comprehensively resolve whole attack chains. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Security operations teams can then hunt using this rich threat data and gain insights for hardening networks from compromise. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Microsoft Defender for Endpoint detections across the Solorigate attack chain Several Microsoft Defender for Endpoint capabilities are relevant to the Solorigate attack: Next generation protection Microsoft Defender Antivirus, the default antimalware solution on Windows 10, detects and blocks the malicious DLL and its ... | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
It quarantines malware, even if the process is running. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Detection for backdoored SolarWinds.Orion.Core.BusinessLayer.dll files: Trojan:MSIL/Solorigate. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
BR!dha Detection for Cobalt Strike fragments in process memory and stops the process: Trojan:Win32/Solorigate.A!dha Behavior:Win32/Solorigate.A!dha Detection for the second-stage payload, a cobalt strike beacon that might connect to infinitysoftwares[.]com. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Trojan:Win64/Solorigate. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
SA!dha Detection for the PowerShell payload that grabs hashes and SolarWinds passwords from the database along with machine information: Trojan:PowerShell/Solorigate. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
H!dha Figure 9. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Microsoft Defender for Endpoint prevented malicious binaries Endpoint detection and response (EDR) | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Alerts with the following titles in the Microsoft Defender Security Center and Microsoft 365 security center can indicate threat activity on your network: SolarWinds Malicious binaries associated with a supply chain attack SolarWinds Compromised binaries associated with a supply chain attack Network traffic to domains ... | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
These alerts can also be associated with other malicious threats. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
ADFS private key extraction attempt Masquerading Active Directory exploration tool Suspicious mailbox export or access modification Possible attempt to access ADFS key material Suspicious ADFS adapter process created Figure 10. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Microsoft Defender for Endpoint detections of suspicious LDAP query being launched and attempted ADFS private key extraction Figure 11. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Microsoft Defender for Endpoint alert description and recommended actions for possible attempt to access ADFS key material Our ability to deliver these protections through our security technologies is backed by our security experts who immediately investigated this attack and continue to look into the incident as it de... | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Careful monitoring by experts is critical in this case because we’re dealing with a highly motivated and highly sophisticated threat actor. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
In the same way that our products integrate with each other to consolidate and correlate signals, security experts and threat researchers across Microsoft are working together to address this advanced attack and ensure our customers are protected. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Threat analytics report We published a comprehensive threat analytics report on this incident. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Threat analytics reports provide technical information, detection details, and recommended mitigations designed to empower defenders to understand attacks, assess its impact, and review defenses. Figure 12. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Threat analytics report on the Solorigate attack Advanced hunting Microsoft 365 Defender and Microsoft Defender for Endpoint customers can run advanced hunting queries to hunt for similar TTPs used in this attack. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Malicious DLLs loaded into memory To locate the presence or distribution of malicious DLLs loaded into memory, run the following query DeviceImageLoadEvents | where SHA1 in (“d130bd75645c2433f88ac03e73395fba172ef676″,”1acf3108bf1e376c8848fbb25dc87424f2c2a39c”,”e257236206e99f5a5c62035c9c59c57206728b28″,”6fdd82b7ca1c1f0e... | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
4)| extend base64_decoded = replace(@’\0′, ”, make_string(base64_decode_toarray(base64_extracted)))//| where notempty(base64_extracted) and base64_extracted matches regex ‘[A-Z]’ and base64_extracted matches regex ‘[0-9]’ SolarWinds processes launching CMD with echo To locate SolarWinds processes launching CMD with ech... | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Query Responseand AdditionalFields has “.avsvmcloud” To locate DNS lookups to a malicious actor’s domain, run the following query DeviceNetworkEvents| where RemoteUrl contains ‘avsvmcloud.com’| where InitiatingProcessFileName ! | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
= “chrome.exe”| where InitiatingProcessFileName ! | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
= “msedge.exe”| where InitiatingProcessFileName ! | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
= “iexplore.exe”| where InitiatingProcessFileName ! | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
= “firefox.exe”| where InitiatingProcessFileName ! | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
= “opera.exe” Find SolarWinds Orion software in your enterprise To search for Threat and Vulnerability Management data to find SolarWinds Orion software organized by product name and ordered by how many devices the software is installed on, run the following query DeviceTvmSoftwareInventoryVulnerabilities| where Softwa... | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
IdentityServer. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
ServiceHost.exe”| where FileName in~(“werfault.exe”, “csc.exe”)| where ProcessCommandLine !contains (“nameId”) Appendix MITRE ATT&CK techniques observed This threat makes use of attacker techniques documented in the MITRE ATT&CK framework. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Initial Access T1195.001 Supply Chain Compromise Execution T1072 Software Deployment Tools Command and Control T1071.004 Application Layer Protocol: DNS T1017.001 Application Layer Protocol: Web Protocols T1568.002 | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Dynamic Resolution: Domain Generation Algorithms T1132 Data Encoding Persistence T1078 | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Valid Accounts Defense Evasion T1480.001 Execution Guardrails: Environmental Keying T1562.001 Impair Defenses: Disable or Modify Tools Collection T1005 Data From Local System Additional malware discovered | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
In an interesting turn of events, the investigation of the whole SolarWinds compromise led to the discovery of an additional malware that also affects the SolarWinds Orion product but has been determined to be likely unrelated to this compromise and used by a different threat actor. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
The malware consists of a small persistence backdoor in the form of a DLL file named App_Web_logoimagehandler.ashx.b6031896.dll, which is programmed to allow remote code execution through SolarWinds web application server when installed in the folder “inetpub\SolarWinds\bin\”. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Unlike Solorigate, this malicious DLL does not have a digital signature, which suggests that this may be unrelated to the supply chain compromise. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Nonetheless, the infected DLL contains just one method (named DynamicRun), that can receive a C# script from a web request, compile it on the fly, and execute it. Figure 13: Original DLL Figure 14: The malicious addition that calls the DynamicRun method This code provides an attacker the ability to send and execute any... | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Microsoft Defender Antivirus detects this compromised DLL as Trojan:MSIL/Solorigate. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
G!dha. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Talk to us Questions, concerns, or insights on this story? | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Join discussions at the Microsoft 365 Defender tech community. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Read all Microsoft security intelligence blog posts. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Follow us on Twitter @MsftSecIntel. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
The post Analyzing Solorigate, the compromised DLL file that started a sophisticated cyberattack, and how Microsoft Defender helps protect customers appeared first on Microsoft Security. | [] | Analyzing Solorigate the compromised DLL file that started a sophisticated cyberattack and how Microsoft Defender helps protect customers |
Security researchers have issued a warning over a sophisticated malware botnet that has flown under the radar for more than two years. | [] | Horabot campaign targeted businesses for more than two years before finally being discovered |
Analysis by security firm Cisco Talos also found that organisations across “several business verticals” have been targeted by the botnet since November 2020.Dubbed ‘Horabot’, the botnet was spotted infecting devices with a banking trojan and spam tools to steal sensitive financial information and assume control of user... | [] | Horabot campaign targeted businesses for more than two years before finally being discovered |
Users of email services such as Gmail, Yahoo, and Outlook, have been impacted by the botnet, with their accounts used to send malicious emails to contacts. | [] | Horabot campaign targeted businesses for more than two years before finally being discovered |
“Horabot enables the threat actor to control the victim’s Outlook mailbox, exfiltrate contacts’ email addresses, and send phishing emails with malicious HTML attachments to all addresses in the victim’s mailbox,” researchers said. | [
"T1566.001"
] | Horabot campaign targeted businesses for more than two years before finally being discovered |
”According | [] | Horabot campaign targeted businesses for more than two years before finally being discovered |
to Talos, the botnet has specifically targeted Spanish-speaking users in the Americas, and could be based in Brazil. | [] | Horabot campaign targeted businesses for more than two years before finally being discovered |
Companies operating in the accounting, construction, engineering, and investment sectors are thought to have been particularly targeted by the botnet. | [] | Horabot campaign targeted businesses for more than two years before finally being discovered |
Subsets and Splits
No community queries yet
The top public SQL queries from the community will appear here once available.